WRT54GS RTS Threshold issue

Discussion in 'Cisco/Linksys Wireless Routers' started by dugr, Mar 22, 2006.

  1. dugr

    dugr Network Guru Member

    I have 2 WRT54GS's, one for G only and one for B only environments. The B only router is used as an access point for 3 Netgear MP101's with erratic results, i.e. dropped streaming connections. The B only router is the issue. I've tried Firmware Versions v4.70.6 and v4.70.8 Hyperwrt 2.1b1 + Thibor14 with the same results.

    I have a BefW11S4 that I’m running EU Firmware Version:1.51.2 that I've gone back to using as an access point for the B environment that works almost flawlessly with the MP101's, in reality, the MP101’s are the real dirt bags, but that’s another story unto it self. The Befw11S4 has a number of limiting issues, so I'm trying to get the WRT54GS to take its place with marginal results.

    The only thing that is different in the wireless configs is the BefW11S4 (and Netgear Routers) RTS Threshold is 2432 by default and maximum, the WRT54GS default and maximum RTS Threshold on the is 2347.

    Does anyone know of a firmware that will allow you to increase the RTS Threshold to 2432, or any other ideas?
  2. dvaskelis

    dvaskelis Network Guru Member

    I'm not sure you're barking up the right tree here. Are you assuming that the WRT54GS is going into RTS/CTS handshaking mode, and that the Netgear does not support it correctly? You can disable CTS on the WRT54GS and then ensure it doesn't go there, that's usually the default on small networks anyway.

    But, I would not think that would result in a dropped connection even if that's the case. If anything, enabling RTS/CTS might help with dropped connections!

    Besides "B-Only", try the 1-2Mbps basic rate. That doesn't disallow 11Mbps, but it's the basic rate that old 802.11b APs use before going up to 5 or 11Mbps. If that doesn't help, ensure it's set for a long preamble, as not all 802.11b devices understand short preamble. If that doesn't help, ensure the SSID is broadcast. As a last ditch if you're still dropping, try turning off frame burst, although I only saw one ancient 802.11b NIC that didn't like that. Those are all things that some older 802.11b devices don't always work well with.
  3. dugr

    dugr Network Guru Member

    I've tried all those things also and this was the last resort before I started hacking the MP101, it so sensitive to everything.

    You are correct, I am barking up the wrong tree, I just found a MP101 forum that has some mods for a fix.

    We'll see!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice