WRT54GS v1.0 Problems (Faulty Unit?)

Discussion in 'Cisco/Linksys Wireless Routers' started by Maxx, Mar 8, 2005.

  1. Maxx

    Maxx Network Guru Member

    This time I will try to be as "concise" as possible. Everything will be expalined below. The two NICs I have connected via WiFi to the Router negotiate a connection @ 125mbps, over time they throttle down (which is normal) to 54mbps, 48mbps, 24mbps, 11mbps,... and (this I no longer see as normal) every other day or so... down to 2mbps and finally 1mbps at which point the connection stalls or is lost. Here, the Router often dissapears from the Wireless Network Monitor Site Survey (refreshing does not bring it back) and only a hard reboot restores (default) connectivity. Meanwhile, as all of this takes place the LEDs on the router never indicate any problems, no resets, no nothing. Other times, the router configuration screens and internet browsing shows extreme lag (even with a negotiated setting of 125mbps) and strangely enough to fix the problem all I need to do is change the channel (from 1 to 11, from 11 to 6, from 6 to 13, etc.)... within a day the same problem occurs on that "new" channel and switching back to the one that initially caused problems brings back the speedy response.

    I've tried using the latest HyperWRT build (HyperWRT 2.1b1 @ 50%, 67%, even 84%, etc.) with similar settings but it too did not solve the problem (albeit the setup seems a little more stable for longer periods of time using HyperWRT) but soon enough everything goes haywire.

    Both NICs use the Linksys Wireless Networking Monitor v1.1 (I have v4.0 installer but for different hardware and I'm not sure if it is a good idea to use it in place of these speedbooster v1.1s). I've modified the "default" profile to reflect my settings. If connected, under advanced link information I can see:

    For the WPC54GS:
    Noise Level: -67dBm (sometimes -45dBm)
    Signal Strength: -63dBm (sometimes -10dBm)

    For the WMP54GS:
    Noise Level: -143dBm
    Signal Strength: -61dBm (sometimes -53dBm and/or -56dBm)

    I hope someone can help me or at least lead me in the right direction when it comes to diagnosing the source or sources of these problems. Any suggestions? Can I assume the router is faulty? Could it be something external (previously with 802.11b hardware there were NO problems)?
    My current setup consists of 2 clients (one notebook, one desktop - both P4s with 1GB DDR RAM) running XP SP2 (plus all the latest patches, hardware firmwares/drivers, chipset drivers, no hardware conflicts, no adware, no spyware, no trojans, no viruses) Fully optimized BIOS settings, tweaked XP settings, very few running services (but I'm sure I haven't disabled anything critical or such that could be causing these problems - note that Wireless Zero Configuration Windows Firewall/IPS and IPSEC are disabled, I've also disabled DNS client and DHCP client when not using the DHCP server on the AP), defragmented NTFS volumes, Mozilla Firefox 1.01 and 15 second boot-times, bla bla bla. Anyhow, the network consists of:

    0. TOSHIBA PCX2500 Cable Modem - TWC Roadrunner @ 5000/384
    1. LINKSYS WRT54GS "US v1.0" @ Firmware "EU v3.37.2"
    2. LINKSYS WPC54GS "US" @ Driver "EU v3.50.21.11"
    3. LINKSYS WMP54GS "US" @ Driver "EU v3.50.21.11"

    Wireless Network Mode: G-only(tried Mixed-Mode - didn't help - why woudl it?)
    Wireless Network Name (SSID): radiowa, domowa, linksys (no apparent difference)
    Wireless Channel: 1, 6, 11, 13 (no apparent difference - note that most APs in my area are on 6 with a single AP on 1)
    DHCP Server: Enabled, Disabled (no apparent difference - when enabled I limit the Maximum Number of DHCP Users to 2)
    Static DNS: hardcoded or obtained via DHCP (no apparent difference)
    Security Mode: disabled
    Wireless MAC Filter: enabled
    Permit only: Permit only PCs listed to access the wireless network
    (hardcoded my two clients and saved settings)
    Authentication Type: auto
    Basic Rate: all
    Transmission Rate: all
    CTS Protection Mode: disabled
    Frame Burst: enabled
    Beacon Interval: 50, 100
    (at 50 problems occur less often but are not eliminated)
    DTIM Interval: 1
    Fragmentation Threshold: 2346, 2304
    (no apparent difference)
    RTS Threshold: 2347, 2304 (no apparent difference)
    AP Isolation: on, off (at on problems occur less often but are not eliminated)
    Block Anonymous Internet Requests: checked
    Filter Multicast: checked
    Filter Internet NAT Redirection: unchecked
    Filter IDENT(Port 113): checked
    IPSec Passthrough: disabled
    PPTP Passthrough: disabled
    L2TP Passthrough: disabled
    UPnP: disabled

    PS - In the past I've used the WZC and found it provided limited success with the 802.11g hardware (not so with my old 802.11b where it performed flawlessly). I decided to try the Linksys Wireless Network Monitor to specify my networks exact (more or less) settings and prevent the NICs from associating with other APs or dropping connections to/from my AP. I guess this did not help.
  2. Maxx

    Maxx Network Guru Member

    As an update, I've removed the Linksys Network Monitor (config utility) off of the desktop client (WMP54GS), uninstalled the NIC drivers, cleaned the registry, etc., restarted the computer and reinstalled just the drivers (via the device manager) as well as re-enabled the WZC, DNS and DHCP services (currently all @ automatic). The NIC connnects to the router but will not do so at speeds greater than 54mbps (Afterburned is enabled and so are all the other options that allowed for a 125mbps using the Linksys Network Monitor and previously also WZC. For now (less than 24 hours) the connection between the desktop NIC and the router was stable. I will try the same stategy with the notebook NIC when I get back from work.

    PS - Anyone care to comment on the signal and noise dBm values?
  3. Maxx

    Maxx Network Guru Member

    Having gone back to WZC... the WMP54GS-based client started connecting @ 125mbps with what XP2's WZC dubs an "excellent" signal strength. For now (24+ hours) there have been no connectivity issues except for occassional lag when 1. accessing the web-based built-in setup of the WRT54GS router 2. opening websites. Regardless, I would really appreciate some thoughts on my settings and those dBm values I've posted above. I think I was clear and yet thurough enough to "derserve" some replies. LI.ORG gurus, addicts, etc., anyone?
  4. Julez

    Julez Guest

    I get this dropout problem as well. I use a Linksys wireless G PCI card, Linksys wireless G PCMCIA, a Belkin wireless g in the clients.

    I use a Linksys BFDSR41W as a DSL router
    I use a WRT54GS as a wireless AP

    The internet connection and connection to both routers is flawless when wired to 2 of my other computers. However, signal from all wireless PCs sinks and is eventually lost. DHCP is not set up on any PCs and they work perfectly well (albeit only at 54 or lower) with the configuration I have given the 'AP' and 'Router'.

    The problem is signal ranges from excellent to very weak in the space of 30minutes and drops off. Eventually it always comes back on.

    pretty annoyed - all cards and aps/routers run latest firmware. No IP conflicts. Just pure annoyance considering the WRT54GS is a hell of a lot more unstable than my previous belkin B standard AP.
  5. Maxx

    Maxx Network Guru Member

    Thanks for your reply. I noticed your thread and many others which seem to hint at this and other similar WRT54G (the new revisions) and WRT54GS problems. What else might I add - I can run DHCP and turn it off (hardcode all NIC settings) - this makes no difference. My router exhibits the same problems as yours - no logical reason and indeed it is far less stable than my previous Linksys 802.11b AP.
  6. Niteflight

    Niteflight Network Guru Member

    Got the same...

    Hi Maxx,

    Just found this forum and your message. It looks like you've got EXACTLY the same problem I've been having with my WRT54GS/WPC54GS combination. Me too bought this set to upgrade from an old 11b set, but until now I've been having the same throttling back and losing the connection. I also have been using a Wifi enabled PocketPC and the strange thing is that this PPC did get a connection with the WRT54GS even though the Network Monitor on my notebook did not detect any networks.

    Maybe we can upgrade the firmware on the client network card?

    Hope you update the info on your problem!

    Good luck!
  7. Maxx

    Maxx Network Guru Member

    WMP54GSv1.0 (0 walls and less than 2m away, directly beneath the router)
    old reported Noise Level: -88dBm
    new reported Noise Level: -143dBm
    old reported Signal Strength: -53dBm
    new reported Signal Strength: -39dBm

    WPC54v1.0 (about 2 walls and 15m away, directly ahead of the router)
    old reported Noise Level: -88dBm
    new reported Noise Level: -92dBm
    old reported Signal Strength: -72dBm
    new reported Signal Strength: -67dBm

    PS - I've had an RMA on this (v1.0) particular GS router and received the new one (also v1.0 WRT54GS) that is why I report "old" and "new" noise and signal specs.

    Linksys Wireless Networking Monitor v4.0 disabled the Speedbooster (or at least I've never seen any machine negotiate a connection at +54mbps - where WZC and v1.1 of the Monitor for Speedbooster cards connects at 125mbps) but allows for a stable connection. Is there any work around ao that v4.0 of the "regular" Network Monitor can be used? Is Linksys aware of these XP SP2 + Speedbooster problems? WRT54GSv1.x/v2,x problems? I think I'm not alone as I've seen many similar threads concerning WRTxxxx products and Niteflight just confirmed that he has the EXACT same problems. Terrible.

    UPDATE - I've found a semi-solution. With the new router, I've flashed to HyperWRT and installed EU drivers for all NICs, enabled only the Wireless Networking Monitor, set Static IPs for the clients and most importantly of all set the Router's channel to 13! I don't care that is it "illegal" in the US - I'm constantly connected @ 125mbps, line specs look like this:

    WMP54GSv1.0 (0 walls and less than 2m away, directly beneath the router)
    new reported Noise Level: -1438dBm
    new reported Signal Strength: -54dBm

    Stranegly enough the only drops that occur (and this started happening once I went back to the Wireless Networking Monitor v1.1 with Speedbooster - never happened with the v4.0 for non-Speedbooster NICs) happen for a split second if 1. I start using WMPC, JETAUDIO, 2. plug-in and power-on my HP printer. Strange isn't it? I'm further sure there are no PCI or PnP conflicts and the NIC has an IRQ all to itself and share very little memory space with other devices (Certainly not the printer, usb hub or the audio card).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice