WRT54GS v1.1 locks up when using print server

Discussion in 'Cisco/Linksys Wireless Routers' started by nefaste, Mar 27, 2005.

  1. nefaste

    nefaste Network Guru Member

    I've got a funny feeling this may be related to the large file transfer disconnects, as the behavior is similar.

    I've got a recently purchased WRT54GS v1.1 and flashed to the Linksys v3.37.6 firmware (though it had this problem with the firmware revision before as well). I also have a Airlink Plus APSUSB1 print server. I have two computers, connected by 802.11g to the router (using WPA-PSK TKIP). The print server connects by ethernet cable directly into the router, and I've manually assigned it to port . The printer port on the computers connects by TCP/IP. The printer is an EPSON C82 (which is specifically listed as compatible with this print server).

    The problem is as follows, I will attempt to print a document (say 10 pages long). The printer will begin printing, everything looks good, text & graphics are printing as they should, then the printer will get to about the 3rd or 4th page (sometimes as far as the 7th or 8th page) and then suddenly, BOTH computers (including the one that had nothing to do with the printing) get disconnected from the wireless network, and the printer stops printing. After a few moments the computers will reconnect to the wireless network, and the computer that was printing will automatically attempt to continue the print, about HALF a page will print again, then both computers are AGAIN disconnected from the network, the print will error again, and the process will repeat itself over and over (attempt to print, disconnect, re-connect, attempt to print, disconnect, re-connect, etc.).

    Now the funny thing is, I have an old 802.11g router here (poor range and crappy firmware, I replaced it to get a better signal, which the Linksys did very nicely), when this print configuration used to be hooked up to it, everything worked great.

    I've been tweaking settings for a week now, tried different cabling, router settings, even separated the two as far as possible to reduce interference. Any ideas?
  2. jagboy

    jagboy Network Guru Member

    maybe itcould be a mtu setting or could be encyption. try to enable or disable encyption.
  3. Toxic

    Toxic Administrator Staff Member

    only a suggestion bt tryt he QoS page. assign a LOW priority to the Port the print is on. and set High priorities to the two wireless PCs using there PCs Mac addresses.

    Dunno if it will help but it might.

    I dont know the Printing Port TCP/UDP but if you find out you could also set this to LOW priorites and see if that helps.

    Port 92: Network Printing Protocol (TCP/UDP)
    Port 515: printer spooler (TCP/UDP)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice