WRT54GS v1.1 setup/subnet

Discussion in 'Sveasoft Firmware' started by OutKa5t, Jan 9, 2006.

  1. OutKa5t

    OutKa5t Network Guru Member


    I am running a WRT54GS with the sveasoft firmware upgrade. I am doing this so that the WRT54GS can operate as a bridge to my Netgear wireless modem/router.

    Everything works but I have a Windows MCE PC connected to the Linksys and an Xbox 360 connected to the Netgear. When I set the Linksys up the instructions I followed stated that I had to use a different subnet than my Netgear, so I do. However, this means the xbox doesnt see the MCE.

    Is there a work around for this? Can I run the Linksys on the same subnet with a new firmware?

  2. vincentfox

    vincentfox Network Guru Member

    Which firmware? Satori? Alchemy? Talisman?
  3. OutKa5t

    OutKa5t Network Guru Member

    Alchemy - sorry
  4. OutKa5t

    OutKa5t Network Guru Member

    Ok basically here is my problem. I have a Netgear DG834GT and a Linksys WRT54GS 1.1. The linksys is running Alchemy version 3.01.8sv and is operating in client mode. This is great but means I had to set it up on a different subnet to the netgear. This in-turn means my pc's connected to the linksys don't see the pc's connected to the netgear.

    I would like to run my Linksys in 'bridge' mode but I don't know if there is a firmware to do this. In bridge mode I am hoping the linksys and all pc's connected to it will pull ip details from the dhcp running on the netgear.

    Can anyone point me in teh right direction?
  5. vincentfox

    vincentfox Network Guru Member

    Your question is still not terribly clear. Is the Linksys the client unit, or is it the NetGear? Who has the modem connection wired to it?

    You say you have the WRT currently in AP-client mode. In that mode you can only have a single attached client and it will end up being in the same subnet with the main LAN. Not sure what directions you are talking abou that said for client to work you had to have different subnets? Perhaps you mean different IP's?

    You want bridging, you will have to learn about WDS. But for that you will need units on each side capable of WDS bridging. YOU will have to look up the NetGear and see if it will support being a WDS peer, I have no idea.
  6. OutKa5t

    OutKa5t Network Guru Member

  7. vincentfox

    vincentfox Network Guru Member

    The guy in the start of the thread is, In My Humble Opinion, a bit mixed up.

    He may understand a bit about networking, and have stumbed on a solution that worked for them, and assumed that the fact that it worked, was because their theory was valid. The solution worked in spite of the mistaken assumption, because the part that they got wrong is totally ignored in AP-client config.

    AP-client mode in Alchemy and similar does not do routing. Hence all the business about setting different netmasks etc. is a complete waste of time. At best, it's harmless. It's a layer-2 device in this mode so the only thing it cares about is passing packets back and forth based on MAC address, nothing is examined for IP address.

    So the real question is, why is your X-Box on one side, unable to see the PC on the Netgear. Does the X-Box work otherwise? See it in what sense? Is there a status page on the X-Box that tells you what IP it has grabbed off the network? I would venture to guess it grabbed a number in the range handed out by the Netgear device. Need to debug what the MCE and X-Box device think is their network configuration first.

    [edit] forgot to mention, if you have DHCP server running on the Linksys turn it off. See if the X-Box picks up an address from the NetGear when rebooted.
  8. OutKa5t

    OutKa5t Network Guru Member

    Thanks for the help, even if a little concerning about the advice I originally followed.

    My network is

    Main Router/Modem (Netgear)
    Runs DHCP and Wireless
    My xbox is connected to this as are two wireless laptops

    Client (Linksys) Picks up a WAN ip from the netgear
    local ip =
    Also runs DHCP
    Two wired PC's and a WMCE are connected to this

    All devices have connection to the internet.

    I have the necerssary ports open on the Netgear for the Xbox but I can not ping the xbox from my MCE. I have the firewall turned off on the Linksys.

    I have tried putting the xbox on a dmz and turning windows firewall off but to no avail.
    Below is a diag of my network now and at the bottom is what I would like the Network to do.

  9. OutKa5t

    OutKa5t Network Guru Member

    I have now sorted this. I can have the functionality described above by using the dhcp forward option on the DD_WRT .23 firmware.

    I have found a few bugs but the firmware is working great. Just checking the xbox functionality now.
  10. vincentfox

    vincentfox Network Guru Member

    Sounds like you are heading towards one big happy LAN. Great!

    One question, what did you use to make those diagrams? Need to do something similar....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice