WRT54GS v1.1 SLOOOOW surfing

Discussion in 'Cisco/Linksys Wireless Routers' started by dingdong, Nov 17, 2005.

  1. dingdong

    dingdong Network Guru Member

    Just got a WRT54GS v1.1, I often get some pretty good speeds for file downloads (what I would expect from my cable connection) but web surfing is very slow even with NO file sharing/transfer running.

    Often pages timeout and I have to reload several times, what's going on? Surfing the web is a nightmare, but if I fire up ftp or something it zips along quite happily???

    I tried upgrading to the latest firmware on Linksys site for the v1.1 but got "upgrade are failed" or something, luckily after a reset the thing still works as well or badly as it did before.

    What should I do? I am a little scared of trying to update the firmware again in case it really screws things up, considering the official upgrade .bin didn't even work?!
  2. dingdong

    dingdong Network Guru Member

    OK I think I solved my own problem, woo!

    The bin file I got from the Linksys website was US version, but I'm in UK. I guess this is why it refused to flash.

    Trouble is, the UK site only links to the old firmware which was already installed when I purchased the WRT54GS v1.1.

    So I went to FTP site and finally found this .bin file:


    I couldn't find any docs but I tried it anyway and it worked! No more http timeouts, web now nice and fast!

    So if anyone is having a similar problem, you could try this firmware..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice