wrt54gs v1.1 w/hyperwrt -> Airport express (WDS)

Discussion in 'HyperWRT Firmware' started by larhan, Jul 3, 2005.

  1. larhan

    larhan Network Guru Member

    I'm about to go nuts, I've spent the entire weekend trying to figure my wrt54gs out.

    I want to use my airport express to work as a client to my wrt54gs. The goal is to connect my xbox through the
    ethernet on the airport express.

    In order to achieve my goal it looks like I'll have to set up a WDS link between the wrt54gs and my Airport Express.

    Since I have a v1.1 of the wrt I've installed hyperwrt in order to try and set up the WDS link.
    After reading through a couple of tutorials I ended up executing the following two commands:
    wl lazywds 0
    wl wds BB:BB:BB:BB:BB:BB #Original MAC address removed

    it always returns:
    eth1: Invalid argument
    wds Set or get the list of WDS member MAC addresses.
    Set using a space separated list of MAC addresses.
    wl wds xx:xx:xx:xx:xx:xx [xx:xx:xx:xx:xx:xx ...]

    I have tried using no security, WEP and WPA with the same results.

    The airport Express have been set up using the same channel and WPA passwd and it's green like it's supposed to be,
    but it can not see the wrt and the other way around.

    Any ideas wil be appreciated

  2. namky

    namky Guest


    The Apple's Airport Express ethernet port is the WAN port. That means you can only connect an ADSL or Cable modem to it.
    If you want to connect your Xbox to join your network, use instead an AP such as a WAP54g and configure it as a bridge.
    I did this and is working fine.
  3. eponymous

    eponymous Network Guru Member

    This is simply not true. It *is* true the the AX's ethernet port is the WAN port by default, but it is very simple to make a change through AirPort Admin to make it a LAN port.

    I have established a WDS link between my WRT54GS (HyperWRT 2.1b1) and my AX but it took a lot of trial and error and I am not at all sure I could walk anyone through it. I experienced the same error the original poster did many MANY times. I would recommend trying to get it working WITH lazywds set to 1 first, as once you have that you at least know both the AX and WRT are configured correctly for WDS.

    To this day I occasionally have to do a quick lazywds 1 to reestablish connectivity and then a lazywds 0 after.
  4. stencil

    stencil Network Guru Member

    I have been trying to get this to work for the better part of two days now. I have DD-WRT prefinal 3.2 installed on the WRT54G. I also have the Airport Express set up as a WDS properly, to my knowledge.

    In fact, I can get on the Airport Express extension of the network and use the Internet even.

    The one thing that doesn't seem to be working is the ethernet port on the Express. While I can get on it wirelessly, when I try to connect to it using an ethernet cable, no go.

    I've tried various combinations of DMZ'ing the device connecting to it (Xbox, then a PowerBook), etc. I've also tried setting the Xbox up with a static IP address. Nothing.

    Here's how I have things configured:

    1) Wireless mode: AP
    2) WEP 128-bit
    3) Wireless MAC filter disabled
    4) Lazy WDS off
    5) WDS Subnet disabled
    6) Wireless WDS mac list, first slot is the MAC address of the Airport Express

    Airport Express:
    1) Set to Create a Wireless Network
    2) WEP 128 bit with same password preceded by a "$"
    3) Same channel as WRT
    4) Ethernet port enabled
    5) Internet: WDS Host MAC address set to WRT's MAC address
    6) Also allow wireless clients checked
    7) Configure using DHCP
    8) Connect using AirPort (WDS)
    9) Network: Distribute IP addresses not checked
    10) WDS: Enable this base station as a WDS remote base station selected
    11) Allow wireless clients on this base station selected

    This is all according to several reports that this should work. And, in fact, I can stream music to my stereo as well as connect to the Airport as a WDS wirelessly.

    The one thing I can't do is get on it via its LAN port.

    I can't figure out what the deal is - is the DHCP conflicting since I have everything set to do DHCP? According to all the guides this shouldn't be an issue, but...? Any help? I know some people have gotten this working.

    EDIT: I should also note that I have the WRT connecting to DSL via PPPOE, into a DSL modem.
  5. will792

    will792 Network Guru Member

    Check Apple forum for Airport Express. There are some postings on WDS configuration with Linksys routers. Cannot recall any postings describing use of Ethernet port for a client connection.
  6. stencil

    stencil Network Guru Member

    Thanks Will - Looked quite a bit in there to no avail.

    As for Apple's documentation, the gyst is that if I have the thing working as a WDS remote base station, the Ethernet port should be active.

    The strange thing is that when I try to reset the APE and plug it into the router, I get a message saying that no Ethernet cable is detected. I wonder if the ethernet port on this thing just went bad?
  7. bigrig

    bigrig Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice