Wrt54gs v1 Stops talking to Cable modem

Discussion in 'DD-WRT Firmware' started by jimbronie, Jan 18, 2008.

  1. jimbronie

    jimbronie Network Guru Member

    Hey guys,
    I have been having some issues as of late. I have the version 1 of the 54gs with dd-wrt v23 sp2. It ran for 81 days rock solid, but now from time to time the router does not pass info to and back from the cable modem. I have been on endless calls with my cable company and they have my modem being monitored and it is not dropping any packets. It must be something with my router.

    I have stopped all apps including torrents but it still happens. I listen to the sirius stream with a mac gui app and it will work for a while then drop the stream because of the above problem.

    I looked into the DD-WRT faqs and did all the adjustments back months ago. I just can't pin point the issue. (beyond it being the router).

    Now, have the v1 and v1.1 54gs' have this issue for anyone else?????

    I think probably, I will replace the router but money is tight right now and I really would like to find a workaround until I get a new router.

    Any assistance appreciated.


    P.S. What is the best router (that can do wds with Apple Airport extreme boxes) on the market now?
  2. szfong

    szfong Network Guru Member

    You may have a dying router. WDS is very picky sometimes... should use same firmware on all.. a couple of my older routers are showing instability, signs of flakyness.. try changing to a different firmware and see if it improves, if not junk it and spend some on a new one when you have some more cash
  3. mstombs

    mstombs Network Guru Member

    Cable modems can do this because of a glitch in connection and just need a "dhcp-renew" request to reopen comms. There is a monitoring script (dd-wrt wiki) you can run which regularly pings a gateway or dns server and if it fails it tries a "dhcp-renew" - might not be the router. Similar problem with tomato:-

  4. jimbronie

    jimbronie Network Guru Member

    Thanks guys. The router is pretty old so I am thinking it might be breaking down.

    I did try one of the v24 releases, but those worked even less. So I put 23sp2 back on.

    I am at best a novice when it comes to this stuff, but, if I ran that script would there be a loss of connectivity while the script runs?

    Again, thanks for the advice!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice