WRT54GS v4 and DD-WRT

Discussion in 'DD-WRT Firmware' started by jim37, Sep 4, 2006.

  1. jim37

    jim37 LI Guru Member

    I got a WRT54GS v4 so that I could upgrade the firmware to DD-WRT.

    I've followed all the tips that I've been able to find:
    • Direct wired connection to computer
    • Only one port being used on the router
    • Internet (arrrgh!) Explorer and not Firefox
    • No password
    • No internet connection
    • Go into admin and update firmware and point it at the one I want

    Every time it moves along for a while and then gives that "Upgrade are failed" message. I've tried doing the micro first, the mini first, ah - just do the standard. Nothing seems to work... except reflashing with the stock Linksys firmware to bring the thing back to life. That seems to work in about 30 seconds.

    Heck, I've even tried using the Linksys reflashing utility to push the DD-WRT into the router.

    Anybody got anything I can try that will make my life fulfilled and the rest of my days content, sunny and happy?

  2. anectine17

    anectine17 Network Guru Member

    Sounds like you may need JTAG. Some questions first. With the Linksys firmware installed, did you do a manual reset to factory defaults before attempting to flash the DD-WRT? The reset can be done one of 2 ways...a)hold the reset button on the back of the router for 30 seconds, or b)from the GUI, Administration>Factory Defaults, select Restore Factory Defaults. It is a MUST that you do a hard reset before and after each flash.

    Does it function properly with the Linksys firmware installed? If so, there's still hope. Do the hard reset, flash the mini generic version of DD-WRT v.23, WAIT about 10 minutes after it's successfully flashed, do another hard reset. You should be good to go at that point. You'll want to flash the standard generic version now, do the hard reset, and you're done. If it varies from that, come back and tell us exactly what it's doing.....any error messages, what lights on the router are doing what, etc. Good luck!!

    **You don't need to use the "micro" version. Start with "mini" then "standard".
  3. n9lya

    n9lya LI Guru Member

    wrt54gs V4

    I just got my new in the box V4 off ebay Nice .. I flashed mine with no problems... The Default settings and waittimes that are mentioned above are imperitive..

    do let us know what yours does...
  4. jim37

    jim37 LI Guru Member

    What's JTAG?

    I don't remember doing the hard reset. I'll add that and see what happens.

    I've never tried actually using the router. I've got my main computer and the household network running on a WRT54G. I got this WRT54GS for two reasons - my old WRT54G was getting flakey sometimes and I wanted to try extending the current range I was getting. Figured that I would attach the new router to my spare computer to do the firmware upgrade before doing anything else. I can certainly try putting the WRT54GS online.

    Thanks for the tips, and I'll give it a shot.

  5. jim37

    jim37 LI Guru Member

    OK, I tried the hard reset using the GUI and it showed the screen that said "Successful" and to wait a few seconds to get back to the GUI. I gave up on that after waiting for about 5 minutes. I tried going back to and it wouldn't work. I killed power to the router waited a few seconds and restored power. It cycled itself back up, and then I could get into the GUI.

    Tried the button reset and again, it locked up until I did the power trick.

    So it appears that there is something amiss before trying to perform the upgrade.

    What should I do now?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice