WRT54GS v4 Bricked :(

Discussion in 'Cisco/Linksys Wireless Routers' started by kop48, Feb 16, 2006.

  1. kop48

    kop48 Network Guru Member


    I was uploading the new Tofu 13d firmware to my GS when it failed mid-way through and when I rebooted the router (not knowing it'd corrupted the firmware), the router was bricked. The power light just flashes continuously now and the router.
    The router responds to pings and I have tried to follow the HyperWRT recovery guide to de-brick it, but no luck. The file appears to TFTP fine to the router (this is official GSv4 firmware from Linksys) and it still does not work.

    Any help would be really appreciated as I would really like to get this router back up and running as it is one of the best routers I have ever used.

  2. gaster

    gaster Network Guru Member

    You need to tell us again what you really did.
    there is no tofu 13d, only Thibor 13d.
    there are other recovery guides, here for example, that are good too
  3. kop48

    kop48 Network Guru Member

    Oops, I DID mean Thibor.

    OK - had Thibor 13c - was up for over a week and doing lots of P2P. Saw Thibor 13d was out, so went to upgrade. Upgrade failed about 2/3s of the way through the bar. Tried again after that - failed almost instantly. Tried the GSv4 one just in case - that failed too. Read in the forums that Thibor said to reboot before flashing, so I rebooted before I realised the firmware was probably corrupt.

    After that, I tried the HyperWRT guide to re-flash some new firmware on there (official Linksys GS v4). Did a long reset, used TFTP and uploaded the firmware. It seemed to upload fine, but, it doesn't reboot by itself and on forced reboot it still keeps flashing the power light, but responds to pings.

    So, there's the story of my little GS - I'd really appreciate any help with this....

  4. kop48

    kop48 Network Guru Member

    *bump* Anyone able to help me? :(
  5. kop48

    kop48 Network Guru Member

    ok I was able to fix it by using verbose tftp output. Basically, it wouldn't accept any firmware except for DDWRT23MINI GSv4. So, if anyone else has problems, go get that image and flash it using TFTP. You need to reset the router if you fail to flash, as for some reason the router won't accept any more attempts past one.
  6. StephN666

    StephN666 Guest

    Hello, I'm Stephane and i'm my english is not very good :sad: and i'm not understand all topic.

    test http://stephn666.free.fr/WRT54GSV4_1.05.2_US_code.exe

    I'm not tested but my linksys router is an WRT54G 3.1.

    For all, in my web page http://stephn666.free.fr/ all firmware (not WRT54GSV4_1.05.2_US_code.exe) work into my WRT54G 3.1.

    The .exe is a WRT54GV4.0_4.20.7_US_CODE.exe Official to modifie by "Resource hacker".

    that should go even on a bricked router.

    Bye ;)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice