WRT54GS v4 impossible to debrick??

Discussion in 'HyperWRT Firmware' started by shames, Dec 24, 2005.

  1. shames

    shames Network Guru Member

    I have a wrt54gs v4 and tried to upgrade firmware as per instructions on the forums
    i long reset the route rwith the button onthe back.. success
    i got the ddr-wrt v23b1 mini generic and flashed it from web config ... success
    i loaded the hyper-wrt thibor11 firmware.. success
    i did another long reset from back button on the router.. success??
    after i plugged it back in all the lights flashed
    the power led wont' stop blinking and it couldn't connect at all to any wireless or wired connections
    i was able to make some progress using the 16 pin > earth trick and was finally able to ping the machine
    i set the settings to static ip in windows and tried tftping the firmware on to the route ragain and no luck
    i try the web config utility, no luck
    all i can do is ping the router through dos
    i tried the linksys tftp client and set it to 900 tries in hopes that it would fix the timing issue
    still does nothing
    the power led still blinks but only the wired lan led shows up now
    i am really stuck and would really appreciated some help
    thanks in advance
  2. zaphod

    zaphod Network Guru Member

    hi shames,

    if your wrt54gs answers to ping than you are not far away of getting new firm on it again..

    the tftp thing is the only one which will work for you.

    1. set your wired-pc ip to /

    its just a matter of timing to get the new firmware on it...

    try it this way:

    - unplug power from wrt54gs
    - open cmd window
    - enter "tftp -i PUT c:\tmp\firmwarefile.bin" dont hit return
    - plug in power in wrt54gs
    - fast hit return in cmd window

    see what happens...

    if this dont work try the same procedure with the linksys-tftp-tool...

    hope that helps...

    greets and merry XMas

  3. shames

    shames Network Guru Member


    tried that method for about an hour or 2 today with no luck
    as soon as i plug the router back in windows goes thru that 2 or 3 second acquiring network address thing cuz it shows the cable disconnected when i unplug the router
    it seems resetting it does nothing to it at this point
    any specifics on the timing?
    as soon as i plug it in all the lights flash but die out
    and the pwoer led flashes constantly and the 1 wired connection lights up blinking every so often
    any idea hwen in this sequence i should hit the enter key?
    every time i get time out
    or server error something
  4. zaphod

    zaphod Network Guru Member

    right after plugging in power to the router hit the return button in the cmd window

    the "mini-os" your router is on just ask a few times if there is any firmware for it..

    maybe this could help:

    start your router, ping it..., after you get answer execute "arp -a"

    you will see something like this: 00-12-17-xx-xx-xx dynamisch

    then put "arp -d" (deleting arp entry)

    then "arp -s 00-12-17-xx-xx-xx" (static arp entry for your routers mac-adress"

    now try the ftp-procedure again....
  5. skumaru

    skumaru Network Guru Member

    shames: Assign a static IP to your computer and try the tftp method.
  6. Sumi

    Sumi Network Guru Member

    yes, above is correct, but LOAD UP THE DEFAULT LINKSYS FIRMWARE with tftp!!! i just did the same thing yesturday (flashed whit hyperwrt, than powerled blinkin, flashchip hack, and tftp), and it works again..
  7. Sumi

    Sumi Network Guru Member

    oh.. and always use static ip, and 10MEGABIT/half duplex, for flashin':)
  8. marno

    marno Guest

    after throwing away my first wrt54g because I couldn't bring it back to life---an hour after the shrink wrap was off my new wrt54gl---I had another brick!!!! pulled my hair out trying to revive this thing---AND---it came back to life!!!! The most important thing I learned was the importance of a STATIC IP ADDRESS on your computer in order to communicate with this thing. You can ground pin 16 on the flash chip, short out pins 15 and 16 all night long (been there, done that) without a static IP-----there is no hope of revival. By the way----this thing is ALWAYS at I checked it with Etereal (shows packet activity on the network) hang in there.
  9. shames

    shames Network Guru Member


    Ok I've done pretty much all this that everyone's said but thanks for the great advice
    i have alaywas had it on a static ip for thewired lan or somethin and subnet
    i've tried the tftp as soon as i plug it in
    and nothin
    like it siad it goes thru that second or two of acquiring network address icon in the system tray and seems to ignore any network related commands
    i'll try those commands tho zaphod and keep at it
    any other advice would be great
  10. shames

    shames Network Guru Member

    Ok update all!
    i did as vaphod said and cleared the mac address stuff
    i tried flashin back to stock linksys firmware thru dos and hit enter as soon as i plugged it in
    and without me knowing it ran the tftp linksys .exe and it installed the firmware ok!!
    thanks everyone
    now the question is do i risk trying this all again to get the hyperwrt drivers working?
    possibly since i know how to debrick a little better
    but i'm still scared
    will see what i can do without it and if it works ok
    besides that thanks for the help
    i'll be back on the forums as soon as i stop being so chicken about flashing again
  11. Hylian

    Hylian Network Guru Member

    Im having the same damn problem.... thing is though, I was pinging it, shit I even transfered over the firmware from the .exe from... well after it finaly transfered, it still flashed the power light and I go ziltch for connection. tired to ping it again, it wouldnt ping anymore..... WTF

    I did everything that Shames did, When I was pinging too, now it will once in a while give me a ping, but otherwise Its a dead LAN port light and a flashing power LED
  12. zaphod

    zaphod Network Guru Member

    read the post above again.. do the same mentioned above... read about timing and tftp and arp....
  13. Hylian

    Hylian Network Guru Member

    Aight now im getting this when I try to TFTP it

    C:\Documents and Settings\Hylian>tftp -i PUT c:\tmp\firm.bin
    tftp: tftp/udp: unknown service

    gah, im about to go back to using my v5 cuz at least I can get online with that piece

    Zaphod, you GOTTA have MSN or something, please bro?
  14. zaphod

    zaphod Network Guru Member

  15. Hylian

    Hylian Network Guru Member

    that site costs money to get into...
  16. Hylian

    Hylian Network Guru Member

    Fuck, i dont have the GS, i have WRT54G v4. shit
  17. Hylian

    Hylian Network Guru Member

    well I FINALY Got it Debricked, I did the whole, pop it open touch the antenna to the 16th area
    then booted it up.

    It seemed to work after fidling with it enough

    hopfully that will work everytime
  18. lallous

    lallous Network Guru Member


    I was able to get ping responses by joining pin 15-16 with a screewdriver , I also did the arp procedure of adding the router's mac address (static) but when i try to install the linksys firmware here is what happens:

    C:\>tftp -i put c:\code.bin
    Transfer successful: 2884608 bytes in 8 seconds, 360576 bytes/s
    (I also tried using the original filename instead of code.bin and still the same problem)

    Reply from bytes=32 time=1ms TTL=100
    Reply from bytes=32 time<1ms TTL=100
    Reply from bytes=32 time=1ms TTL=100
    Reply from bytes=32 time=2ms TTL=100
    Reply from bytes=32 time=2ms TTL=100
    Reply from bytes=32 time=1ms TTL=100
    Reply from bytes=32 time=1ms TTL=100
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    And i never get a ping again even after the router reboots after installing the new firmware

    My linksys firmware is the following:WRT54GSV4_1.05.2_US_code.bin
    My router is a WRT54GS V.4

    Any suggestions on what firmware to install other than linksys's firmware. Am i doing anything wrong?
  19. slicknick1

    slicknick1 Guest


    " enter "tftp -i PUT c:\tmp\firmwarefile.bin" dont hit return "

    How do you insert a password using this method through the command console? Thanks.

  20. Thibor

    Thibor Super Moderator Staff Member Member

    you don't need a password when you tftp from the command line to recover from a brick
  21. tstrike2000

    tstrike2000 Network Guru Member

    That is how I got my old WRT54G to debrick. That did the trick after I couldn't get it working touching the pins 15 and 16 together.
  22. Alex Kwong

    Alex Kwong LI Guru Member


    One of my unit is WRT54G V.4 had been bricked for few months.
    First time see this post about deleting the MAC...
    Now problem is on the dynamic IP to static, I guess...

    I set the pc tcp/ip to / subnet mask
    Lan card configured to 10Mbps/half duplex

    in DOS window
    arp -a
    Interface: --- 0x2
    Internet Adress Physical Address Type 00-16-b6-a6-xx-xx dynamic

    arp -d

    arp -s 00-16-b6-a6-xx-xx

    arp -a

    Interface: --- 0x2
    Internet Adress Physical Address Type 00-16-b6-a6-xx-xx static

    unplug power from WRT54G
    open dos window
    ready for "tftp -i PUT c:\code.bin" dont hit Enter
    plug in power in WRT54G with connect pin 16 to antenna
    before one of the LAN light back on, fast hit Enter in dos window
    it show
    Error on server : code pattern incorrect

    check the arp -a the status back to dynamic again??
    use the Firmware Upgrade Utility v.4.30.5 the response also is code pattern incorrect.

    Before I trying arp -d (delete MAC) the response usually is Timeout occurred

    Anyone know whats wrong?

    Please help!

  23. mstombs

    mstombs Network Guru Member

    If you have a WRT54G (not GS or GL) I suggest you try with the latest firmware specifically for that router which I believe was Firmware 4.21.1 (available on US site).

    I also recommend you use a hub/switch between PC and Router, and I'm not a fan of flash pin shorting unless its a real last resort!
  24. Alex Kwong

    Alex Kwong LI Guru Member

    Hello mstombs,

    Thanks for the response.

    I use one of my old Black Box 9-port personal MiniHub connected in between PC and WRT54G router. It does help keep the router IP status in static, even re-power on and shorting pin 16.
    But tftp result still the same. If hit enter during all LAN LED turn off after shorting pin & power on. The DOS screen quickly responded Error on server : code pattern incorrect. If hit enter when first ping-able line come up after shorting pin and power on. The DOS screen responded Timeout occurred after 50 seconds.

    Any other advice?

  25. mstombs

    mstombs Network Guru Member

    Other advice - only thing I can think is to check-out dd-wrt forums, they often recommend a very small basic dd-wrt firmware to start with. Failing that it is JTAG time, apparently erasing the nvram partition is often enough to reset these routers.
  26. Alex Kwong

    Alex Kwong LI Guru Member

    Hello mstombs,

    I waste a lot of time on pin shorting and tftp
    Actually I already made a JTAG cable and solder header on the PCB two days ago. But due to can't get the driver loaded... so keep trying on tftp... and thinking where gone wrong.
    Today just found out that I put giveio.sys file in to the wrong location C:\windows\system32 It should be in c:\windows\system32\drivers

    few hours ago I got it loaded successfully and use the tjtagv2.exe fix the problem.
    In my case, only erase the nvram still can't tftp. After erase the nvram need to flash the WRT54 V4 cfe.bin then erase kernel. After that reset the router and the DD-WRT mini can be tftp in. After that I upgraded it to std.

  27. mstombs

    mstombs Network Guru Member

    Result! Well done.
  28. TxDot

    TxDot Guest

    Can someone clarify for me which row of pins to short? On my WRT54GS (v2), one side of the Flash chip there are 2 rows of pins and on the other side there is 1 row. One the side with 2 rows the second row is about 3/16 of an inch away from the chip. So which row do I short pins 15 & 16 (or pin 16 if I have to go that route) on? I've checked out the pictures in the WRT54 Revival Guide thread but the router in the picture is different enough from mine that I want to double check things.
  29. mrdude

    mrdude Network Guru Member

    I dumped the full TSOP of my wrt54gsv4 using a USB Jtag and will post the dump here if anyone needs it - you'll need a USB jtag to flash it back onto the router though, or another way is to lift the TSOP and flash it using a willem programmer or simliar prgramming device if you can't fathom out how to debrick normally.

    The USB jtag only takes around 30 seconds to write the full flash - loads of time faster than using a serial port based jtag, and lifting the tsop is not recommended if you don't already have a programmer or excellent soldering skills.
  30. ecker567

    ecker567 Addicted to LI Member

    I'd love to get a usb jtag cable and software - the parallel jtag cable I have with hairydairymaid program takes ~3 hours to do a complete flash. Can anyone recommend a usb jtag and software? I have several bricked routers I need to try and revive...

    Thanks guys.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice