WRT54GS v4 incompatible with Intel 2200/BG chipset?

Discussion in 'Cisco/Linksys Wireless Routers' started by komUnec8, Jan 11, 2006.

  1. komUnec8

    komUnec8 Network Guru Member

    Hi all

    I'm about to turn the brand new WRT54GS-v4 I bought last week into a brick, not by flashing it badly, but by throwing it hard against a wall and stomping on it.

    I had a WAG54G v2 until I passed it on to my daughter. Replaced it with a WRT coz I'd heard all about their ability to be re-flashed with other open source firmwware etc.

    My ASUS W3H00A laptop used to work no problems at all with the WAG54G. Now, I cannot get a reliable connection at all. I can associate but usually can't get a DHCP address, and no receive traffic to the PC.

    Funny thing is the Secure Easy set up worked fine, and I even had it going for a short while, and I though everything was looking good, but now, nothing I do will make it work.

    I started on 1.05.00 code that the box came loaded with. When that stopped working, I re-flashed with 1.05.2 code, and that also worked initially, but now does not.

    Is anyone else having any issues with WRT54GS-V4? Is it just my ASUS' Intel 2200/BG chipset that is incompatible with the WRT but not the WAG54G?(Before anyone asks, I have the latest drivers loaded from ASUS, but I notice they are not the latest Intel generic drivers (which don't work on the ASUS when I loaded them)?

    (Nope, don't think so. I tried a D-Link DWL-G650+ cardbus card in the laptop to see if it was my radio, and it did the same thing! Worked once, now doesn't). Also, I get the same issues when I run a USB wireless adaptor on my desktop machine, just in case anyone thinks its the laptop itself).

    Conclusion: Either I have been supplied a dud, or the WRT54GS v4 with Speedbooster is not really that backward compatible with a lot of radios!?

    I used to think the WAG54G had issues, but now I think I might have been better off than I know?

    If this isn't resolved/resolvable, I'll go back to the WAG54G. :thumbdown:
  2. vincentfox

    vincentfox Network Guru Member

    You *might* have some configuration issue on the WRT54GS unit. Like for example what settings? Encryption? Preamble long or short? Things like that. Lots that you didn't mention about your setup....

    I have 2 WRT54GS-v4 units that seem to work just fine with a variety of client cards from old Orinoco 802.11b up through Hawking 802.11g. It is possible you got a dud unit, it happens. Does a wired connection exhibit same behaviour as WiFi?

    More importantly, the Intel 2200BG is a known problem child. Over at DSLreports.com Wireless Networking forum, there's a thread that is *13* PAGES long about people having issues with it. Having to mess around with driver versions, and other contortions to make it compatible. You usually think of Intel as being very reliable, but their name in WiFi is mud lately. Best advice I can give you, is there is a version 10.x of the drivers out now, try those.
  3. komUnec8

    komUnec8 Network Guru Member

    Thanks for your comments Vincentfox.

    Sorry I didn't go into too much detail on settings I have already tried. (I tried too many to write about :( ). I think I eliminated any issues to do with encryption settings by trying everything from no encryption at all, through WEP to WPA-PSK with TKIP. Even with no encryption at all, I can't get the data to flow.

    Also tried adjusting long preamble, power settings etc. any suggestion I could find on the newsgroups, but no luck on any of them

    Wired connections are no problem at all.

    I agree with you about the intel 2200 chipset being sus, but I can't do much about it short of changing my laptop. (I suppose I could try and find a better mini pCI card and swap out the existing one, but I guess there would be warranty issues on the laptop).

    Also, if it's just the Intel chipset in my laptop, that doesn't explain why I have the same issues with the D-Link adapter, or why I can use the same Intel wireless with the WAG54G with no problems?!?

    I did wonder if it's possibly linked to a Mixed mode issue due to the presence of 802.11b signals in the area, given I am trying to run this in g mode? Or, looking for things that changed from the WAG54G situation, perhaps the Speedbooster capability changes things for the cards that aren't Speedbooster compatible (how does that work?).

    Does anyone know if the radio behaviour would change if I loaded DD-WRT or any other non-Linksys firmware? (I expect not, given I understand it's based on the original code, up to a point). My basic approach was going to be to get things working using the Linksys original code first, then go DD-WRT, so the sooner I sort this, the sooner the real fun can begin (unless anyone wants to convince me to go straight to DD-WRT for a good reason?)

    Any other ideas people have to sort this out would be much appreciated.

  4. madhatter

    madhatter Network Guru Member

    Hi i have a wrt54gs ver 4 with the 1.05.03 stock linksys firmware and a sony laptop (VGN-FS315M) using the intel 2200bg wireless. have no problems with wireless and are using WPA.
  5. vincentfox

    vincentfox Network Guru Member

    I haven't used stock Linksys firmware in a while, but in my DD-WRT firmware at least there's an Advanced Settings tab under Wireless. Under there I can disable Afterburner which is what they call SpeedBooster. Worth a try.
  6. komUnec8

    komUnec8 Network Guru Member

    Okay, here's an update that brings some hope to the situation.

    The good news is I can connect! (I'm actually lodging this post over my wireless connection, from my Asus laptop running the Intel 2200 chipset and everything is running as it should! :cheering: )

    What is different?

    1) I'm only 10 feet from the WRT!!! If I go any further, I lose the connection! In fact, I can tip my laptop over so that the screen is flat on the table and the line of sight between laptop and AP is through a solid wooden table, and the link will drop. Even with clear LoS in the same room, if I move more than 4 metres from the AP the ping times jump from 2ms to way up just before I lose the connection.

    Possible conclusions. 1) My laptop has a bad radio card or antenna problem. Not likely since it worked fine with the WAG54G over a distance of 10 m through several walls)

    2) The Intel chipset doesn't work very well over much distance/obstruction with the WRT's Broadcom?

    3) The WRT I received is dodgy.

    4) The freespace RF path in my house isn't very 'free' (probably very dense from all the fuming I've been doing trying to get this working! :sad:)

    Anyway, tomorrow I will hopefully have a WAG54G to check my laptop against and to compare directly with the WRT. Then I will probably ask for a replacement WRT (so I don't think I will flash this one with DD-WRT even tho I understand I'll be able to play with the power levels, which might improve things?).

    Oh, and the other piece of good news is that, in eliminating problems, I fired up my laptop using Xandros Linux and that works lwith the Intel chipset and the WRT just fine! Once I worked out it was a distance related issue, I went back to Windows to prove it works under XP too, (when close by) and it did. So, it's not the OS. Could still be the laptop radio, but most likely a dud WRT out of the box. Just my luck!

    Thanks to all those who offered suggestions and a shoulder to lean on!

    I'll update again once I have finally cracked it.
  7. Tubisten

    Tubisten Network Guru Member

    I just had the same problem the other day. A reset of the settings to factory defaults took care of it.

    WRT45GS with 1.05.02

    At the time I was using an old Netgear MA521 (802.11b) wireless card.
  8. komUnec8

    komUnec8 Network Guru Member

    And a final update to advise that I have had the original WRT54GS replaced under Warranty and the new one works just fine straight out of the box, as it should have done the first time. ! Interestingly, the new box came with the latest firmware already installed, (the last one I had to upgrade myself).

    I now have both a WAG54Gv2 running 1.00.25 AU firmware and the new WRT54GS v4 running 1.05.2 firmware working with my ASUS W3H00A notebook using Intel 2200 BG chipset on v9.x drivers and a Linksys WUSB54G. WPA-PSK works fine with everything too!

    I did notice tho that the connected rate changes quite dynamically with the Intel chipset, tho I'm wondering if this is by design, as it seems to do this when the Notebook is not doing much. As soon as I start to use it again, the data rate climbs back up. By comparison the WUSB54G adaptor I am now running on the Desktop PC just sits there at 54M all the time (works through 2 interior walls no sweat at 54Mbps!)

    So, life returns to normal for a while until I have gathered enough courage to flash the WRT54GS box to DD-WRT!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice