WRT54GS v5.0 FW 1.50.8

Discussion in 'Cisco/Linksys Wireless Routers' started by JPBOSS, Oct 13, 2006.


    JPBOSS LI Guru Member

    Help. Does anyone have the 1.50.8 Firmware BIN file they can send me? I downloaded the 1.50.9 last night and upgraded my router like a dumba$$ and now it is talking continuously with my Cable Modem and affecting my upload performance cutting it in half. I spoke with Linksys's Customer-NO-Service and they told me that the 1.50.8 is no longer available. Total BS. What pain in the a$$ they are. :mad:
  2. Toxic

    Toxic Administrator Staff Member

    I have 1.50.7 available. do you want this one? i'll see if my source at linksys can get 1.50.8 maybe a few days for a reply though.

    JPBOSS LI Guru Member

    Thanks Simon, yes I'll wait for you to see if you can get the 1.50.8 from your contact. The 1.50.8 ran pretty well for me. Why does Linksys remove previous versions?

    Thanks again for your help. JP
  4. Toxic

    Toxic Administrator Staff Member

    I can't comeent on what linksys does about removal of firmwares. I dont work for them.

    If I did work for them there would be changes :thumbup: :biggrin:
  5. heyyahblah

    heyyahblah LI Guru Member

    I upgraded to 1.50.9 and have had no problems. Why don't you reset the cable modem (unplug from wall), then reset the router. If that doesn't work contact your ISP and get a better cable modem.

    What you said makes no sense. It has nothing to do with the firmware and router(s) always talk to the modem. Its their job.

    JPBOSS LI Guru Member

    You obviously don't know what you are talking about. Do you seriously think I didn't try all of that? That's elementary Linksys Support Tech's fix for every problem they encounter. Pull the Plug, plug back in, hold reset for 30-seconds, etc etc. For my upload speed to cut in half going from 1.50.8 to 1.50.9, is a problem. I also have the latest Motorola Cable modem so I know that's not the problem. Linksys pulling older versions of FW off their site and not even allowing their Support Tech's access to them is the most stupid thing they could do. If you are going to roll out new code, the basic common-sense approach in Software Development is to allow fallback to previously proven code in case of problems. Obviously Linksys just thinks this approach is silly.
  7. Toxic

    Toxic Administrator Staff Member

    when you reset the router what is the MTU setting at? Auto? try setting it to manual 1500

    JPBOSS LI Guru Member

    It was set to Auto, just tried manual set to 1500 but it didn't improve upload speed any. Let me know if you get your hands on the 1.50.8 from your Linksys contact. Thanks, JP
  9. Keav

    Keav LI Guru Member


    I am also looking for ver 1.50.8 to roll back to.

    After updating to 1.50.9 my Nokia N80 mobile phone will no longer connect wirelessly to the router, I get the error "No gateway reply".

    My laptop and PC are fine.

    The phone will pick up the router, but constantly flicks back and forth between Active and Inactive.

    I have tried all the obvious, re-set, re-flash, factory default, turn off security etc etc.

    Any help or the 1.50.8 bin file would be greatly appreciated!
  10. johnnyvomit

    johnnyvomit Guest

    I too updated my WRT54GS and it's *boned*. So I figure "no way is this a linksys problem" and flash a second one.... so now I have 2 routers that don't work at all :/ (wireless may connect but no internet, eventually I can't join the wireless net with macs)

    I subbed a question to linksys to see if they know what's going on....
  11. JPBOSS

    JPBOSS LI Guru Member

    Simon, any update from your contact on getting the 1.50.8 yet? Sorry to bug you. JP
  12. micken

    micken LI Guru Member

    Hi, I have the WRT54GSv5_v6_v1_50_8_US_code version that I used on the UK model before upgrading to the current firmware. No problems with either on my system, 3 wired pc's and 1 wifi laptop.
  13. frankphelps

    frankphelps Guest

    I'm not very knowledgeable about this stuff but I'm running 1.50.8 on my WRTS54GSv5. I have saved in My Documents a folder called "WRT54GSv5_v6_v1_50_8_US_code.0". It's 1.5 MB , consists of 3 files, a Read Me text, a BIN file of the same name, and another Text Document.
    Is it of any value to you and if so, how would I get it to you? I have High Speed Cable access, so file size is not a problem.

  14. Sporg

    Sporg LI Guru Member


    I just talked to Linksys support in Denmark, and within 5 mins, I had the 1.50.8 firmware. Appears they are more professional here :wink:

    I have uploaded it here for you: http://www.sendspace.com/file/fh6st1

    It says US code, but it works perfectly, and since its from Dk support I must assume it must be right even for EU versions.

    Hope this solves your problem.

    I experienced performance problems also,here it was difficulty finding/loading webpages.

    Interestingly enough, the support guy told me that they already know that the 1.50.9 is a buggy version. Hopefully that means they will work on a straigthened out version now.
  15. Sporg

    Sporg LI Guru Member

    A little follow-up on reverting to 1.50.8:

    It seemed this firmware had become flaky too, after my upgrade to 1.50.9.
    it seemed it still lacked the performance it had before.

    So, I looked at some advice posted earlier in this forum, about resetting before reflashing. I ended up doing like this:
    Hard reset (button on the back), power cycle, then set to factory settings in the web interface, power cycle, reflash, power cycle, then set it up like it was before.

    Now finally I have the smooth performance of 1.50.8 working again.

    I dont know if above operation would help on the new firmware also, but I must admit, I'm not in the mood for trying that for a while...
  16. Keav

    Keav LI Guru Member

    Hey Sporg, nice one, thanks very much :)

    I actually spoke to Linksys yesterday and they tried rolling me back to 1.50.7.

    This did fix my Nokia phone connectivity problem, but wireless security stopped working!

    Flashing back to 1.50.9 once again stopped my phone working and didn't fix the security issue, at which point tech support decided that my router must be faulty and to exchange it under warrenty.

    Now with a replacement v5.1 router, running 1.50.5 everything works but speed is barely 20% of what I had with 1.50.8 so I'm going to try your firmware version now - wish me luck :)
  17. JPBOSS

    JPBOSS LI Guru Member

    Thanks for the file Sporg. It helped me get back up to speed. Thanks again,

  18. Keav

    Keav LI Guru Member

    Yep, 1.50.8 works great for me too :)

  19. Sporg

    Sporg LI Guru Member

    You're welcome both of you.

    Glad that it helped you also :)
  20. DickyS

    DickyS Guest

    Just to add a little more evidence. I got myself a (very spanky) NetGear SPH101 Skype phone (http://www.netgear.com/Products/CommunicationsVoIP/Skype/SPH101.aspx) and all was working well at v1.50.5, as well as a couple of PCs and a printer.

    I "upgraded" to v1.50.9, the phone no longer connected.

    I downgraded to v1.50.8 (found from this thread TVM!) and the phone connected.

    Repeating the exercise caused the same behaviour. So I'll be sticking with v1.50.8 for the time being.
  21. dacull

    dacull LI Guru Member

    Im glad I didn't bother upgrading to 1.50.9

    Although i remember the first upgrade from default to 1.50.8 did similar things to what you guys are describing because I didnt do a full settings reset before the flash. I complained to support that the readme or onscreen instructions never suggested this...

    Still I think I will wait for a better FW. My router is stable but i noticed after a couple of months in use it was somewhat slower, so there is no doubt some memory leaks somewhere.
  22. Sporg

    Sporg LI Guru Member

    Well, I decided to take the plunge, and convert to the DD-WRT micro firmware.
    I can only say wow!
    Now this is a router: Tough, fast, reliable.
    With the VxWorks, I had to reboot every damn time I wanted to Voice/Video-chat with my gf, or the sound would be choppy.

    Now, with DD-WRT everything works every time.
    And it has _loads_ of extra features, compared to VxWorks.

    Try it, try it :)
  23. JPBOSS

    JPBOSS LI Guru Member

    Which model and version of router do you have

    I am running the WRT54GS v5
  24. Sporg

    Sporg LI Guru Member

    Well, I have the WRT54GS v5.1 :)

    It can be done as shown in this guide:

    Just be sure to be _very_ particular in following the instructions, then all should go well. Look at the Step-by-step guide.
    I personally chose the option where you can put the right MAC address into the router. (Its on the label at the bottom of the router.)

    I am very happy I did it, I've got a whole other router now, so much better.
    Both smoother, speedier, and more reliable.

    And on the GS, the 16 MB RAM is enabled by default when using the files from that page :wink:
  25. lencuff

    lencuff LI Guru Member

    Sounds like I might give this one a try! I don't suppose the saved settings can be reloaded from the original linksys setup?
  26. lencuff

    lencuff LI Guru Member

    Tried this on a V5.1 and a V6 last night. Both running fine now and what a difference! Very stable and loads more options to tweak.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice