WRT54GS(ver.2) suddenly quit working...

Discussion in 'Cisco/Linksys Wireless Routers' started by helpless old guy, Feb 23, 2009.

  1. helpless old guy

    helpless old guy Addicted to LI Member

    My trusty WRTGSv2 suddenly quit after nearly 5 years of flawless service.
    I had a fairly powerful voltage surge last month from a nearby lightning strike that selectively fried a lot of my electronics (Cable telephone modem, home theater components, usb hub, telephone system, etc).

    Most "expensive stuff" in the house is protected with numerous UPS's, but this surge apparently entered via the phone line or cable system.

    My problem is I'm a bit of an "old guy" entirely self taught through Google searches, and have become much more knowledgeable than most "average" users (even built my own killer Media Center computer using various web help), but I have a very hard time wrapping my mind around anything to do with software, firmware, and settings changes...

    It took me over a week to install my WRT54 and getting it operational, and that was after over 15 hours on the phone with Linksys "customer support"... ....after many days, I somehow ended up with a guy in India who took pity on me and walked me through the setup, step-by-step. It has worked perfectly and flawlessly ever since for 4 or 5 years.

    I have two desktops connect via ethernet cables and a laptop (wireless), all XP-based machines.

    The first thing I need to know is if my Router is "bricked", or if it has the potential to be fixed with a firmware upgrade and re-installation or maybe proper settings.

    All of my computers seem to recognize that I'm connected to the router (even my laptop), but are unable to make an internet connection through the cable modem.
    (the cable modem works fine; I can plug the cable from any computer directly to the cable modem and get instant, quality internet access... ...just cannot connect through the router.)

    I called Linksys "customer service" and got absolutely nowhere, other than to inform me that my router was out of waranty, and no free support was available. The third person I talked to told me that a firmware update would "fix it", but that I would have to pay $50 for any assistance in installing it, with no guarantees)

    I went looking for firmware updates myself, and ended up successfully installing Tomato (I found a well-written tutorial Link on how to do that). The problem is (maybe) that I don't know what to do with settings or setup (I had hoped that the thing would just take off and connect; I may have screwed something up by trying to insert/change IP addresses.)

    I'm obviously way over my head; been messing with this on and off for nearly a month. I'm lost without my router to do file-sharing, since I've only got one set of monitors for both desktops (both have dual-monitor support), and have relied on file-sharing for several years; I desperately need to be able to have two computers on and working to function efficiently without having to unhook, reconnect, reset the computer modem, etc.

    I have no problem with having to buy a new router if necessary, but I'm on a small fixed income and hate to do that if my Linksys is actually still serviceable.

    Can anyone help?

    I simply (to start) want to find out if its "fried" or not.

    Thanks in advance for any help.

  2. irootsk

    irootsk Addicted to LI Member

    As you said, you can connect to internet if you plug modem directly to PC. Also you can access the web interface on the router. That's good. Now you need to connect modem to router, and router to PC where you had internet connection. To get internet connection on router, you need to clone MAC address of your PC to router.
    So go to webinterface ( and go to Advanced>MAC Address. There should be an option Clone MAC.
    Any progress?
  3. booyoo

    booyoo Network Guru Member

    As you say you installed tomato successfully, it means in general that the box is alive. It could be though that the broadband port side is physically defective or that there is a software configuration error. Please read the following and reply with your results:
    1. Hook up the broadband port to the modem with a tested network cable. Does the light on router indicated 'internet' light up? Does the link indicator on the modem light up? If yes that would indicate a physical link is active. If no there may be a problem there already.
    2. I assume you are hooked up to the router's one of the 4 switch ports with a tested working network cable, and your pc was allocated an IP address automatically. If not, please make sure your test pc is set up to use an automatically assigned IP address.
    3. Login to the box and navigate to the 'Administration' then 'Configuration' page. Select 'Restore Default Configuration' with the option 'Erase all data in NVRAM (thorough) and press OK. Answer OK to the popup confirmation window and wait for the router to reboot.
    4. If rebooted successfully and you see that windows was assigned an IP address in the 192.168.x.x range then login again to the router at Remember its now using default user name and password. (I think its 'admin' for both)
    5. Navigate to the 'Status' then 'Overview' page and review the information on the WAN section. Is there an IP address, Subnet Mask and Gateway addresses there? If yes those should be the ones allocated by your ISP? If no then there lays the problem.


    Edit: proof read
  4. helpless old guy

    helpless old guy Addicted to LI Member

    First, I want to thank both of you for the responses and help...

    I woke up in "the middle of the night" last night (early this morning) (not unusual) and went to the computer to check for responses to my post...

    Since I was up anyway, I proceeded to spend a couple of hours slowly following the suggestions posted...

    I've followed the instructions to the letter and have gotten some rather strange (and for now, unexplainable) results:

    First, I followed the steps provided by "booyou"...

    1. The "internet" light did not light up"; however the link light corresponding to the port that I plugged into the router did light up, indicating a connection.
    2. I don't know how to check on the "automatically assigned IP address, but assume that it is, since addresses did appear in the overview page (but not in the WAN section, which was blank). It did assign addresses, both MAC and IP, and subnet mask, in another heading.
    3, 4, and 5. "Restore Default Config" and "Erase all data" worked successfully, and the router rebooted... ..."after rebooting, a "continue" button appeared, and pressing that took me to the "overview" page... ...but as mentioned above, no addresses appeared in the WAN section (but did elsewhere).

    I copied the info in the overview to my clipboard and pasted it into an extensive reply to this thread (but didn't post since I was no longer connected to the internet, but still had that window to the thread open).

    I then followed "irootsk"'s directions and cloned the MAC address...
    That was followed by an instruction to reboot the computer, which I did (knowing I was going to lose the the info that I had spent over an hour typing into my reply, but willing to do that over again)...

    That's when disaster struck! I have no explanation why, and have not been able to figure it out...

    ...but the normal restart process resulted in a "dead" computer:confused:

    My Media Center Computer, which has performed reliably and flawlessly for over four years, will not boot up (in spite of over a dozen attempts). I've tried disconnecting the router, modem, and all usb accessories; checked all internal connections, checked all the boards and hard drives for connections... ...killed the power, let it set and plugged in again... ...everything I can think of... ...and no success.

    I can't imagine how anything I did following the instructions provided had any effect on the restart process; it has to be some type of cruel co-incidence... ...but nothing I can come up with can get the computer to progress beyond the "motherboard" page that always flashes on the monitor at startup.

    The computer attempts to start, the "motherboard" page flashes (just as it always has); the cooling fans start, the processor light flashes showing cpu activity... ...then the processor light stops (it always paused for a moment while Windows loads)... ...but now it just freezes on the "motherboard" page, and won't continue.

    I've even tried rebooting from a rescue cd, which has worked flawlessly in the past, but it doesn't recognise that there's a disk in the drive (I'm assuming that's what's happening).

    I built the computer myself several years ago, but did that by reading tutorials; it was basically "plug and play", with various software mods... It's been rock-stable up to this point; I'm bumfuzzled!

    The computer is normally used for video editing and as a high-definition dvr. It has three tv tuner cards; two dual monitor video cards; five hard drives totalling 2.08 TB of storage for media files (I keep adding larger hard drives; HDTV is a tremendous space hog; the operating system is on a separate 80gb Raptor hard drive).

    I haven't made any changes in the past couple of months; every time I do I clone the C drive to a Maxtor One Touch 4 before adding any new components or software. (That's where the "rescue disk" comes in; it boots the computer into Linux and formats and restores the C drive to it's last saved restore point or a previous point of your choice, but I can't get that to work either.
    Right now, I've obviously got bigger problems than my router failure... ...I've got to figure out how to get the computer running. I guess we have to put this thread on hold.

    Thank you, irootsk and booyoo for the help.

    If you have any comment on the results I've described, I'd appreciate it).

    (I'm on my older desktop, which I normally use for non-media functions; I was trying to "fix" the router with the "new" computer due to it's extra speed, stability, and reliability... ...guess the joke's on me:frown:)
  5. irootsk

    irootsk Addicted to LI Member

    ooh man. that's really sad. i feel sorry for that.
    do you get any beeps while you trying to boot up PC? can you access the BIOS?
    is you network card build in on motherboard or it's in PCI slot?
    to determine where is problem will take some time.
    if you've got onboard LAN card, try to dissable it in BIOS.
    also try to find on internet the error codes for your BIOS.
    i hope we can find the way how to bring the life back to your PC.
    anyway i'd recommend to unplug all hardware which is not necessary for now (additional HDD, video/tv cards, etc....)
    fingers crossed :thumbup:
  6. helpless old guy

    helpless old guy Addicted to LI Member

    I get the initial beep when I first start the computer, and the processor light (indicating processor activity) flashes normally (just like it always has at boot-up).

    One of my monitors (DVI input/output) immediately shows the ASUS start page (identifies the motherboard as A8N5X) (so far just like it always has)...

    From that point, nothing progresses. The processor light goes out (that's normal, but only for a few seconds while Windows loads; it normally starts flashing again and loads the operating system).

    The computer will now stay in that state indefinitely: all fans running, dvd drives open and close (and seem to recognize when a cd is inserted, but don't attempt to read).

    The bottom of the "start" page notes: "Press DEL to enter setup" (that's how I would normally access the bios), but will not respond to keystrokes on the keyboard.

    I normally use a wireless keyboard and mouse (usb), but thinking that the usb drivers may not have loaded (the wireless keyboard has always interfaced at that stage before), but tried a known good standard plug-in keyboard with no change in results.

    I believe the network card is on the motherboard, only because I have not installed anything like that in a pci slot. (just checked the manual; LAN: NVIDIA nForce built-in MAC... ...that's the network card, isn't it?

    as mentioned previously, I can't (so far) get to the bios...

    Intuitively (since I don't really know what I'm doing), I have already disconnected the external drives and several other usb-plugged accessories.

    I've also unplugged all the internal hard drives; even removed the Raptor c-drive and replaced it with a blank SATA drive, hoping to possibly re-install the operating system from the rescue disk/Maxtor One-Touch 4 Plus that contains the backup clones of previous configurations... ...no luck there either; the computer is unresponsive and won't boot from the rescue disk.
    (I've done this many time successfully in the past for various reasons when things have not gone well with changes or viruses, etc; it simply formats the drive and restores the previous selected version).

    I've been up much of the night "playing" with things... ...the only thing I've observed so far that seems a little out-of-the-ordinary is that the cooling fans seem somewhat lethargic (I've got lots of and bigger fans, since the 3800 Athlon dual-core does generate a lot of heat when its run hard (like video processing or recording more than one High-Definition TV program at a time; the think will keep the house warm on a cold night).

    I haven't removed any pci cards yet, but don't see the advantage; I could do that if it would help to resolve anything.

    The "lethargic" fans make me suspect a failing power supply, but I don't know how to check that without being able to access the bios (430 watt Antek)

    One odd thing I noticed on one of the latest attempts to restart (explaining "lethargic" fans) was that two fans failed to start on their own; I do keep a visual check on the fans since I'm worried about heat; and they have always started on their own in the past. On the latest restart (the only time I've observed this) one of the case fans wasn't turning, and the small fan on the on-board nvidia graphics chip was stalled... ...I bumped each fan with the eraser end of a wood pencil, and they immediately "took off" and have been running since.

    The on-board graphics chip, I believe, is only really used during startup, since I have dual high-performance Nvidia graphics cards installed in the pci express slots (capable of supporting four monitors, HDTV, etc in any combination).

    The on-board chip is what, I believe, is putting the image on my single monitor now; since the second monitor doesn't become functional normally untill the operating system boots.

    That's all the info I can think of right now that might be helpful... ...any other questions or suggestions?

  7. irootsk

    irootsk Addicted to LI Member

    Well. It's look like you said - failing power supply.
    Here is nice step-by-step guide how to check power supply.
    Also you can try to swap power supply from your second PC.
    Hope it will somehow help you.
  8. booyoo

    booyoo Network Guru Member

    Sorry to hear about the pc, an unfortunate coincidence...

    As for the network problem, I tend to think that the first assumption is right and the broadband port on the router got fried during the storm. When you connect an ethernet cable to electrically 'live' ports the link indicator should light up on both devices, as said the 'internet' light on the router and another on the modem.

    As a background why both together only indicate a good connection: the link is made of 2 pairs of wires for transmit & receive accordingly. If you have only one light out of the two on, it means either the cable is damaged or one of the port's electronics. In other words one or two out of the four conductors fail to transfer the required voltages.

    Aside from that, I wanted to ask you something else. Could it be that to hook up the modem and router you were asked to use an ethernet 'cross-over' cable and you may have forgotten? Older modems didn't know how to automatically negotiate uplink vs. standard device. I doubt its the case though because you would have remembered but if you tell us the brand and model of the modem I can check it out to confirm.

    If we don't satisfy this very first step, no doubt you won't see any information on WAN section of the router's web manager.

    As for the pc, did you try to start windows in safe mode? Clearly only if the power supply is working that is..

    let us know.

    Edit: sorry, I just realized you are not passing the POST of the BIOS yet...just disregard the windows comment. I guess the best thing will be to remove all cards and have a minimal hookup of motherboard/cpu/memory to a working power supply and on board video to see a regular response of entering the BIOS with Del button etc..at that stage if the pc is still beeping on POST, then it could also be a fried memory module..
  9. irootsk

    irootsk Addicted to LI Member

    booyoo - but his keyboard doesn't respond at all.

    helpless old guy - have you managed to measure voltage output on PSU?
  10. helpless old guy

    helpless old guy Addicted to LI Member

    I'm sorry for the slow response; I'm in the middle of an all-consuming project right now trying to survive a financial setback (regarding financing, of course), and really haven't done anything since my last post. I hopefully will be able to get back to the computer tonight.

    irootsk: I followed the "tree" you sent, and it led me back to the motherboard...
    No, I haven't had an opportunity to check the voltage output (I'm not even sure I know how), but I'm leaning less in that direction since I haven't been able to duplicate the "lethargic fan" situation in a dozen subsequent restarts. The fans now all kick right off and will remain running until I shut down the power (for over an hour in one instance).

    booyoo: I hadn't seen your edit until just now (since I didn't get an alert on an edit).

    Thanks for that POST term; I didn't know what to call that next step that it won't take.
    I think you're on to something with the memory comment.
    I've got four "sticks" to play with; if one is bad I'll find it.

    I'll try tonight to finish "stripping" the computer to its bare essentials as you suggest and using one memory stick.
    I was thinking along those lines when you mentioned a fried memory module...
    The computer I'm using now is much slower starting and gives me the opportunity to actually see and read what it's doing in the startup process. I recall that the first thing it does is perform a memory check; that could possibly be the answer (I hope, I hope).

    As for the router/cable hook-up question:
    The modem is a Scientific Atlanta, DPC2100 series, P/N 4010995. I can very vaguely remember the term "crossover cable", but cannot remember purchasing one.

    When the router first "failed", the possibility of a bad cable was one of the first things that occurred to me... ...I tested every cable I own by connecting each one directly between the computer and cable modem; each time, I could instantly connect to the internet. If one of those cables had been a "crossover", would the standard direct hook-up have been successful? (that was the limit of my cable testing; after that I assumed that all cables and connectors were good; could that be a poor assumption?)

    Again, thank both of you for sticking with me on this; I'll try to respond more promptly to further posts.

  11. booyoo

    booyoo Network Guru Member

    I looked up the modem manual, it says the ethernet cable is provided in the box but nowhere it is mentioned to be a cross-over one. As you say multiple different cables worked when hooked up directly to a pc, then the port is in fact an auto-sensing one and there's no need for a cross-over cable.

    So for the network problem, its a physical link failure. If you don't have both the 'internet' light on the router and the 'PC' light on the modem lit up - and they should be on even by the mere booting up of the devices - its a no go and can say for sure the internet port of the router is dead (knowing the modem side does work with other devices/pc's).

    About the fans, typically the brushless ones found in pc's simply collect dust with the years around the bearing and what you describe as helping them start-up with a stick is the symptom indicator.

    As for the motherboard, the POST is responsible for initializing all hardware and starting the boot process. If a critical hardware test/initialization fails it will halt. Usually there are different beep sequences that represent different problems, the idea historically to help identify the culprit hardware even if there's no video or basic component like memory or cpu installed.

    Once you strip it all down to the bare motherboard, you can even try to start it up without memory modules at all to hear the beeping which represent 'no functioning memory modules identified' (I know what you're thinking...and no, it won't fry the board :).

    So good luck and let us know how it goes.
  12. helpless old guy

    helpless old guy Addicted to LI Member

    Well... ...I'm making some progress! ...but I don't know how to interpret the results:frown:

    (Please excuse my newbie terminology)

    First, being fixated on the "memory" thing, I removed the two 1gb sticks of memory that I'd installed as an upgrade last year (leaving the original two Kingston 500gb dual channel originally installed originally)...

    I didn't remove any of the pci cards for the first attempt, wanting to see what effect the memory reduction had...

    I had removed all the hard drives, so I ran SATA cables to my original 74gb WD Raptor that carries all of my software (only); connected to "sata1" on the motherboard, and letting the drive set externally on the desktop so that I could check if it would spin up (I haven't been able to tell in the case).

    I powered up the 'puter; got the usual single "beep"... ...and it progressed to the next step! (first time since my disaster that it's gone beyond the "motherboard screen".

    I don't know what you call the (white on black) page that used to flash across the screen for a nanosecond, but now I have info!

    The most significant thing I learned is that it didn't recognize any hard drives... ...no primary master disk; no primary slave disk.

    It did, however, recognise my two dvd drives as Secondary Master and Slave disks (these are IDE instead of SATA)

    It also recognized all 8 of my PCI devices and my still-attached USB storage device (the 750gb Maxtor one-touch I've referred to earlier with the image backups).

    Also, I have a message at the bottom of that page: "MTLDR is missing (press Ctry Alt Del to restart)"

    So, now, I either have a "dead" hard drive or dead cables, or bad controller, etc...

    I replaced the Raptor with a spare SATA drive I have and restarted... ...identical result and messages...
    (either bad cables or?)

    So, I used a different set of SATA cables, and back to the WD Raptor... ...same result. (maybe no power?)...

    I next powered the hard drive with an adapter (my power supply has both SATA and ATA power cables; I have an adaptor to change a ATA power cable to a SATA connector that I had bought in a missguided attempt to install a 5th SATA device before realizing that I only had 4 SATA "info" connectors).

    Next restart, it found the hard drive! So, I'm evidently not getting power from the "SATA side" of the power supply?

    Now, it's recognizing the the hard drive (with the operating system installed), but still won't progress past that point due to the missing NTLDR.

    If I'm doing this right, here's a photo of my current screen:

    I looked up "NTLDR' on Google... ...I believe the next thing I should do is see if I can access the bios on the next restart?

    One of the possibilities I've found is that the bios is corrupted and not looking in the right place on the drive for the OS?

    Several thoughts are going through my mind at this point...

    So many things are "wrong" and so suddenly... ...could it have been anything I did while trying to get my (now apparently fried) router working? (Incidently, I've ordered a new router; should be here tomorrow).

    Or, could this just be a coincidence?
    I mentioned in my first post the voltage surge and lightning strike... ...although my computers are protected by ups's, I did get component damage (like a usb hub on this computer, and my router... ...is it possible that some of that voltage "backed into" my now-malfunctioning computer and did some damage (maybe weakening components?) for a future failure a month later? It now seems like so many things have suddenly "gone wrong"...

    I'm going to post this now; would appreciate thoughts and the best next step; I'm going to try to access the bios, but won't change anything yet unless I find something very obvious that I'm confident I can change properly without compounding my problems.

    Thanks again,

  13. helpless old guy

    helpless old guy Addicted to LI Member

    Wow! Stop the presses!

    With my luck this is probably very premature... ...but my computer's booted up and running!

    More to follow...
  14. helpless old guy

    helpless old guy Addicted to LI Member

    I just wanted to post the above as quickly as possible to forestall anyone typing a lengthy post without the latest information...

    I was able to access the bios once I did everything in the previous post...

    I'm always uncomfortable when I get into the bios out of fear of my knowledge level about that kind of thing; I'm usually very careful not to change anything without explicit instructions, but this time I somehow got an extra dose of bravery.

    I navigated to the "boot" section and explored a bit...

    it looked to me that somehow the "boot priority" had somehow been changed from what I remembered as the previous/usual settings. (and I swear, I haven't been in there for many, many months; how do bios settings get changed?)

    It looked like the boot priority for hard drives had been changed to booting from the one-touch (it had always been "first sata master")...

    Hesitantly, I moved the "master" up to first priority, saved and exited, and the computer booted right up! It appears so far that everything loaded.

    I've really made a "mess" of my computer; It's going to take me hours to put it back together, checking every step for success.

    Now, of course, I have to reinstall the hard drives, one by one, and try to make sure I get them assigned to the right drive letters (I have 5 drives installed at present) or I won't be able to find anything... ...and of course, I need to try out the power cables; possibly the "SATA" power is now operative (I hope, I hope), but it seems at least that the motherboard is working (at least the part I've checked so far).

    I don't have the slightest clue yet what caused all of this.
    I guess I should re-install my memory sticks and see if they work now, but I feel that I'm way ahead of where I was 12 hours ago.

    ...I feel so much better now... ...at least I have hope:)

    Any thoughts?
  15. booyoo

    booyoo Network Guru Member

    NTLDR is missing would be a message you see when the pc is trying to boot from a formatted but empty partition. In your case probably because the boot sequence was altered and didn't start from the drive that actually has the OS installed.
    It can be that a power surge resets the BIOS, not corrupting it per se, just loading all the defaults instead. Maybe that happened. If your electrics are not all grounded a situation called 'ground loop' might happen and cause data errors like this even while plugging an ethernet cable...

    Anyway, sounds like good progress and a good learning curve ;-)
  16. helpless old guy

    helpless old guy Addicted to LI Member

    I had to take some time off from the computer to do some "productive" stuff... ...but what can be more important than having my computers working?

    I'm going slow and carefully, and double-checking every step.

    I've put the "c" drive back in the case where it belongs... ...found out that my (what I thought was) meticulous marking of the cables and locations wasn't as thorough as I thought it was...
    I'm going to have a real challenge getting all the drives back in the same order with proper drive letters to match my directories, but I've run into that problem in the past with 5 drives and constant expansion and upgrading to larger drives, so I'll figure that out.

    One thing has happened that mystifies me...

    The "magic bullet" that finally allowed the computer to advance to/past the post stage was when I removed two sticks of memory. Before that, with literally dozens of restarts, it would not advance.

    So that I could identify which stick was bad, I just re-installed those two sticks, one at a time...

    Neither stick prevented or slowed the process down, so I once again filled up all four memory slots as it has been running all year (same memory). The computer just boots faster (and flawlessly so far). Now, the post page (is that the proper term?) just flashes across the screen, but I was able to see that it's now recognising all 3 gb of memory.

    Does that make any sense? (removing the memory "fixed" it, but putting it back in didn't "unfix" it. (the memory was firmly in the slots and solidly locked; that was the first thing I checked nearly a week ago when I was looking for loose connections, etc.

    I'm going to be working on my other hard drives next; will keep you updated.
  17. helpless old guy

    helpless old guy Addicted to LI Member

    I built this house myself... ...I'm a "nut" about grounding and polarity... ...at least, as of thirty years ago when I built it, every outlet (checked and double checked) had the proper polarity and a good ground (to both a 20 ft ground rod and a 100 ft well casing).

    I do have a lot of surge-protector strips along this wall, and three APC ups's plugged in (one for each computer and accessories and one for the home theater), and I possibly should check those in case something could be awry there.

    The router and cable modem are probably not grounded, though, since they are powered by "wall warts"; the only ground would be through the cable shield, which the cable company insists is grounded to the ground rod.

    I sure have been plugging/unplugging the ethernet cables... ...probably hundreds of times since last Dec 27th when the lightning struck, but without trauma.

    The incident that seemed to trigger the disabling of my computer was the requested restart after cloning my MAC address in Tomato. That was one of the few times that I hadn't touched the ethernet cable --- simply restarted:confused:

    As to the bios resetting to default... ...wouldn't default normally be the primary or "C" drive? (at least in the drive sequence?) ...those were the settings that had been changed in the bios (the hard drive priority had been changed to try to boot from the external usb drive; that seems to be such an unlikely situation that I could hardly conceive of that as a default.

    Equally puzzling is the screwy situation where the computer wasn't even getting to the post page... ...and that removing memory was what finally allowed it to get that far.

    ...and the "beep speaker" on the motherboard never has and still doesn't sound anything more than the initial single beep (no alarms of any kind).

    I know it does have alarm modes since it sporadically sets off that series of beeps at startup with a message that the "fan is operating too slowly" (with an option to ignore the message, which I do since I'm using the AMD "quiet cool" technology that controls fan speed according to temperature of an load on the processor; the fans run extremely slowly at startup but increase in speed as things get warm; when things get hot in the case, you can hear the fans speed up).

    I'm going to work on getting my other hard drives installed; I'll keep you posted on my progress.

    (I suspect we may never determine what caused thing to act the way they (hopefully) were.
  18. irootsk

    irootsk Addicted to LI Member

    woow. congratulations. i've been away for few days but i am really surprised about progress you've done. :wink:
    I am really glad that your system is alive again.
    Just don't understand what exactly happend.
  19. helpless old guy

    helpless old guy Addicted to LI Member

    Nothing about my saga makes the slightest bit of sense to me...

    I couldn't get back to it yesterday, fell asleep exhausted, but woke up about 11:30 and ended up working all night on it, putting things back together.

    I worked slowly and deliberately, and restarted to check the success of each addition to make sure I could identify any step that caused a problem. It also took me a long time since I'm rather ham-fisted, and even though I originally bought a "roomy" Cooler-Master Centurion Mid Tower, when you fill it up with everything I have installed it's darn-near to find room for all the cables no matter how you try to tie or route them. It's common to unplug something while trying to plug in something else; every bit of space that isn't taken up with components is taken up with cables.

    Anyway, I've finally got everything back together; the computer successfully restarted every time; and everything works just like it should with the exception of one hard drive (the "4th" SATA) drive. (I'm still trying to figure that one out.)

    It could possible be a dead drive; I've checked and replaced the cables; my next step is going to be replacing it with a known-good spare drive.

    I finally had to give it up and get a little sleep about 6:30 am.

    I haven't tried connecting to the internet yet, but can't see any reason that won't work.

    The thing that's still totally mystifying to me is that the two "problems" that I had to "fix" to get the thing running the first time (get to the post step) are no longer problems. Recall that I had to remove two memory sticks to get to the post page, and then had to change cables and the power source to get my "c" drive active (the motherboard wouldn't recognize it)...

    I reinstalled the drives in order (SATA 1, Sata 2, etc). I had used the cable set from "SATA 3" to get things active. Out of curiosity I used the original "bad" cables and power source on the SATA 3 drive when it came time to install it, and the darn thing kicked right off with no hesitation!

    So, nothing that I "found bad" during my diagosis steps has proven to be bad. The memory works flawlessly (so far), and the cables and power source is fine.

    I have to keep shaking my head...
    I simply can't come up with any event that could have corrupted my bios settings (which, it turns out, is the only thing that was causing all my problems)

    The computer had been performing flawlessly through dozens of restarts while I was "fooling" with the router and software...

    The particular time it failed, there was no plugging/unplugging of anything; the case was on the computer; I was simply following the suggestions step-by-step.

    I performed the last steps on list; Tomato asked for a restart, and the roof fell in.

    Is there any way that changing the settings within the router could conceivably affect bios settings? ...aren't those totally independent things?
  20. booyoo

    booyoo Network Guru Member

    The mysteries of electrons...

    All's well?
  21. helpless old guy

    helpless old guy Addicted to LI Member

    Thanks for asking...

    The unfortunate truth is that I haven't had a chance to get back to any further steps since my last post, in spite of "best intentions".

    I really haven't had a spare minute for the computer (other than using them) for the past month; to do what I have so far I was stealing time from the normal 5-7 hours of sleep that I usually manage to get.

    My "all-nighters" worked for a few days and that's how I got as far as I did, but after a week of that I ran out of steam (literally). I keep promising myself that I'm going to get back to it the minute I can find the time, but it's no longer keeping me from sleeping (I guess the old body's demands for a little sleep once in a while have assumed control).

    I'm still where I was at with the last post, with covers and parts spread all over the room (and getting misplaced; I somehow "lost" one of my hard drives; it's in this mess somewhere but I haven't had time to find it).

    I have a new ASUS 520GU Router, but haven't had time to do more than open the box. (I'm going to need some help with software choice since all the glowing reviews suggest that the router is great but the OEM software is near-worthless.) Before getting into the router issue I want to assure myself that the computer's back fully to its previous state before the original router went bad so that I can hopefully address only one issue at a time.

    What's preventing me from putting the covers back on is the dead-or-unrecognized hard drive issue I mentioned earlier.

    Other than that, the computer has been re-starting flawlessly; I'm still manually switching the cables back and forth to the cable modem, but have gotten pretty good at it... ...it's a huge hassle, but I'm living with it while I address other "more urgent" issues concerning my financial survival.

    Thanks for sticking with me; I'll somehow figure out how to get back to it in the next few days and report back.

  22. helpless old guy

    helpless old guy Addicted to LI Member

    I finally decided to let the bankers wait a day and try to "finish" my computer.
    I found that my only remaining problem was evidently a result of my own confusion when stripping out the hard drives. I had somehow mixed up the notes on my drives and re-installed a "dead" Maxtor drive instead of a good one.

    I now have all six drives working, the covers back on, and have gone through over a dozen smooth restarts.

    (I haven't gone through my extensive files yet; may have screwed up the directory, but will be able to resolve it if/when I detect a problem by re-assigning drive letters to the drives.)

    So, now I'm ready to tackle the installation of the new router!

    As mentioned earlier, I've purchased a ASUS WL-520GU due to the great reviews, attractive price, rebate, and the most attractive feature: a usb port to network my printers, scanner, and camera through use of a usb hub. (all those devices at this time are usb1, but handle my needs so far; for years, I've had powered usb hubs on the two desktops, and have had those four items plugged into a third. To print documents or upload pics, I've been manually swapping that combo hub to the appropriate computer hub, which has been a huge hassle; and I had no way to print anything from the laptop other than to copy the file to a usb drive and use one of the desktops... ...all a hassle, and it seemed like the printers, etc. were always plugged into the wrong computer. Anyway, the idea of being to network those devices through the router appealed to me tremendously.
    I also have to admit I still bear some ill-will toward Linksys customer service, although lousy customer service seem to be the increasing norm with just about everybody these days.)

    In case you're not familiar with this ASUS router, read some of these Reviews and I think you'll understand why I decided to give it a try.

    My original thought was to immediately flash it with Tomato, but I'm beginning to doubt my competence and knowledge when it comes to making required changes to the settings or adding whatever software changes are needed to get usb support.

    I noticed in those reviews that ASUS has issued a firmware update that's supposed to be vastly superior to their old horrible firmware. I thought it might be wise to try it before I open a new can of worms and screw something else up.

    Any comments or suggestions?


  23. booyoo

    booyoo Network Guru Member

    All I can say about the ASUS is that you probably don't need any third party features as its quite extensive out of the box now - two years since launch they keep supporting it with updates which is nice nowadays. Just go with the original updates and keep it simple.
  24. helpless old guy

    helpless old guy Addicted to LI Member

    I must have a mental block when it comes to understanding software/firmware:confused:
    Either that, or since I crashed my computer I simply don't have the nerve to go playing with things I don't understand.

    I scoured the ASUS website; downloaded their latest manual on the router, downloaded the latest firmware and utilities... ...read nearly a hundred posts on their message boards... ...but just couldn't wrap my mind around what to do next or in what order.

    I finally decided to (in spite of the dozens of posts bashing their "horrible, non-existent customer service") decided to invest a phone call anyway...

    I was on hold for a good half-hour until I got a live rep; the phone connection was awful and he talked way too fast in some unknown version of the English language, but he had the patience of a saint in walking me through the steps needed to install the latest firmware. For some reason, my downloads wouldn't work and my computer was having problems connecting to their website. He stayed with me through a lengthy restart and countless times asking him to repeat instructions that I couldn't decipher, but after again downloading the latest firmware and a little struggle with unzipping, we got that loaded to the router. Then, nothing worked like it should; the router wouldn't connect to or recognize my cable modem. I finally on my own decided to replace their brand-new (included) ethernet cable with one of my older (tested) ones, and things kicked right off! (after a hard reset?).

    From there on, it was really slick:)

    The router found the modem, acquired all necessary info on it's own, and presto! I was on line through the router!
    ...simply turned on my second desktop after connecting the second ethernet cable and it immediately connected too!
    (I haven't tried the laptop yet, but expect it to be just as easy.)

    After keeping him on the phone through all the hassles and communication difficulties, I didn't have the heart to ask him about the printer setup (I made the mistake of thinking I could handle that myself, since the new manual I'd downloaded seemed to have pretty clear instructions in that regard.)

    Stupid me!

    I downloaded and installed the latest utilities since the version on the included cd had no printer support... ...haven't been able to get past that. I'm hung up on how to proceed from there.

    I can address the router through my browser, and it found and recognizes my printer on it's own, but the interface at the usb logo notes "no connection" which doesn't make any sense at all to me.

    I'm at least a little lost at this point, but I'm thrilled to have a router working for the first time in two and a half months.

    All in all, I'd call that a good day:thumbup:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice