WRT54GS WPA issues - Thinkpad works on OLD WRT54GS but not NEW WRT54GS

Discussion in 'Cisco/Linksys Wireless Routers' started by nerdmeier, Jan 17, 2007.

  1. nerdmeier

    nerdmeier Network Guru Member

    I have had a WRT54GS successfully running on a home network for a few years. I can’t find a version number on it and I seem to recall that I bought it shortly after they were introduced. I have two old wired pc’s and one old wireless Sony Viao successfully running on the router. The WRT54GS is set up to use WPA-PSK with TKIP and no SSID broadcast.

    My friend was given a new Thinkpad for his new job and told to set up a high-speed connection at his house. Before the cable connection was set up at his house he brought the Thinkpad to my house and we quickly set him up to access my wireless router using WPA-PSK. He returned a few more times to access the router with no problems.

    He was authorized by his employer to purchase a router and I recommended a WRT54GS. The new router (WRT54GS Version 6) was in place when the Comcast tech came out to set up his cable connection.

    The installation went flawlessly and he was able to access the Internet both in a wired mode through the router and in a wireless mode as well – thus proving the wired and wireless functions were working on the router.

    After the Comcast tech left we attempted to set up WPA-PSK. I have done this set-up on a few systems besides my own and it has always been successful. This time it has been a complete failure. The Thinkpad is able to connect to the WPA-PSK set up at my house on the OLD router but unable to connect using WPA-PSK at my friend’s house on the NEW router. If we shut off the WPA at my friend’s house the router connects just fine. We’ve also used the Thinkpad to connect to a few other unsecured wireless routers.

    The Thinkpad seems to be working just fine – it has no issues on my wireless WPA-PSK set-up. The problem seems to be with the BRAND NEW WRT54GS Version 6 router (firmware v1.50.6, Feb 17, 2006). By the way, both routers are unmodified except for the required set up as recommended by Linksys.

    I see that a number of others have had WPA issues but I can’t find any success stories on how to resolve them - just a lot of suggestions - mostly for using 3rd party software which I would prefer to avoid. Anyone have any success solving this issue?
  2. crawdaddy

    crawdaddy Network Guru Member

    personally, I don't use WPA in any form because it's still too much of a pain in the rear to set up. I just use WEP. If someone wants to break into my network THAT bad, then they'll get in no matter how much security I slap on it.
  3. nerdmeier

    nerdmeier Network Guru Member

    I've set up or helped others set up about 6 different systems using linksys and WPA with no problems up to now. I agree that the networks are never REALLY that secure. But my issue is why the Thinkpad has no trouble logging into my WPA wireless but can't log into the NEWER WRT54GS using WPA.
  4. Esquire

    Esquire Mesquire Staff Member Member

    Do you have another client with which you can test out the WPA issue? The newer router supports WAP2 as well so try (if you haven't done so) or make sure you have selected WPA-PSK Personal to match that on the ThinkPad and not the WPA/WPA2 mix.

    As a side note: I much prefer WPA; it's simpler to setup - WEP is even more of a pain to connect to, especially when folks start mixing ASCII keys (which Linksys doesn't support) with HEX keys and try to connect using Passphrase instead of the network key when the former is not supported by the client. More to the point: WPA is more secure than WEP.
  5. nerdmeier

    nerdmeier Network Guru Member

    Interesting that you should suggest another client - I thought about doing that just before I received an email telling me that you had posted a response - do you have psychic powers?

    I received an answer from Linksys today telling me that "it is necessary that 'we' upgrade to the latest version which is version 1.51.0" followed by a page and a half of instructions - which point to an additional 11 pages of instructions in their knowledge base (that's 11 pages if you print them out). I wonder who 'we' is. Do you suppose they're gonna send somebody to my house? LOL!

    My friend is unavailable until Monday so I won't get to the upgrade until then. I'll post our results after I complete the upgrade. Wish me luck!
  6. nerdmeier

    nerdmeier Network Guru Member

    I was successfully able to upgrade the firmware this past Sunday. Unfortunately, the upgrade did not solve the problem. I've emailed the Linksys tech that was helping me. We'll see what she has to say. By the way, the Thinkpad is a model T60.
  7. Esquire

    Esquire Mesquire Staff Member Member

    It's probably logical to say by now it's a faulty unit. I would request a RMA and return it.
  8. nerdmeier

    nerdmeier Network Guru Member

    Acting on Esquire's advice, I took MY Sony Viao w/ a Linksys plug-in wireless adapter to my friend's house to try to connect to the router I THOUGHT I was having trouble with. My Sony connected using WPA without a hitch! I'm writing this using the wireless connection! So, I'm back to the drawing board - apparently there's some issue with the Thinkpad T60 and the 'ThinkVantage' connection to the new router. What would make the Thinkpad connect to my old router and NOT my friend's new router? Anyone with any ideas?

    Scratchin' my bald head
  9. Toink

    Toink Network Guru Member

    Would it help if I share my experiences on the same wrt54gs v6 model with f/w version 1.51.0 our office has. My supplier's macbook wont even connect to it. NO WEP or WAP at all. But it's the only laptop that wont connect to the router...

    have you tried changing the channel of your router, and see if it helps?

    I did that to our router but no luck so far with the MacBook.
  10. doru31

    doru31 LI Guru Member

    T60p not working with WRT54G

    I recently upgraded from a T41p to a T60p and the new model can't associate with the Linksys WRT54G (Firmware Version: v4.21.1) router. I don't know what the problem is because it connects to other routers in the neighborhood but not to my WRT54G. This is a very strange problem and I would like to know if anyone has found a solution.
  11. doru31

    doru31 LI Guru Member

    T60p and WRT54G Associating... FAILS

    I have a thinkpad T60p, running WinXP Pro SP2, that I am trying to connect to the router wirelessly. I even changed the wireless security to disabled and I still can't associate to the router. I am able to see my router hotspot using my T60p and when I try to connect to it, it just keeps saying: Associating ... but then it fails to connect. I've tried connecting to other hotspots and it seems to connect just fine. Is there an incompatibility between T60p and WRT54G router (Firmware Version: v4.21.1)? The reason I'm asking is because I aslo have a T41p which has no problem connecting to my WRT54G router.

    My T60p Network adapter:
    Atheros AR5001 11a/b/g Wireless LAN Mini PIC Express Adapter (Driver Version:

    Thaks for any help you can provide.
  12. nerdmeier

    nerdmeier Network Guru Member

    I've had a few emails back and forth with Linksys on this issue. The latest reply from Linksys told me, "I am placing an inquiry with our product engineers" so they can look into this issue. That was about a week ago so I'm gonna bug them again this coming week. I'll post again when (and if) I get an answer. Are you using the 'ThinkVantage' button to gain access? - or are you using Windows to gain access?
  13. doru31

    doru31 LI Guru Member

    I am using 'ThinkVantage', but I've also tried Windows to connect to the router and it didn't work either.
  14. nerdmeier

    nerdmeier Network Guru Member

    Thanks, that's an interesting piece of information. I was going to try Windows but my friend's computer was provided by and set up by a small university in New Jersey - and it works wirelessly via ThinkVantage when he's on campus - so I didn't want to have to mess with the settings in case it would cause an issue with his connectivity on campus. I'm waiting to see what Linksys to say.
  15. cnsdave

    cnsdave Guest

    Lenovo ThinkVantage Problem using Linksys WRT54G

    I have two WRT54G routers, one at my house and one at a beach vacation home. My Thinkpad T60 works at the beach but does not associate with my home WRT54G. When I set these two wireless routers up I created them with the same SSID, same WPA-PSK security with TKIP encryption using identical passkeys in each router. A couple weeks ago my laptop quit working with my home wireless but continued to work at the beach home. I also have another HP laptop that works fine at both homes. I believe there is something messed up with the Thinkvantage software application. The ThinkPad can only connect to the Linksys router at home if I use unsecured adhoc mode. I can't even get WEP to work. WPA-PSK and WPA2-PSK of course don't work either. Beats me. With AC I don't even see Green bars indicating signal strength when attempting to connect. However if I select the find networks function I see the SSID and signal strength is 100%. The error AC finally presents in the Help Me Fix This Window is to check the security settings (WPA-PSK, etc.) or to make sure an "Administrator" has not blocked the radio channels being used. I've tried channels 1, 6, and 11. I am using AC Version 4.21.
  16. nerdmeier

    nerdmeier Network Guru Member

    Known issues w/ thinkpad wireless

    Hi cnsdave,

    I kinda gave up on this issue some time ago. The Thinkpad I was having the issues with belongs to a friend and we just left it hooked up in a 'wired' mode.

    But I do have some info. When I was still working on the issue I noodled around in the ibm.com website and found out there was a known problem with the Thinkpad's wireless stuff. I kinda remember a three step process to upgrade the firmware/software to fix the problem(s). My friend is VERY computer illiterate and gets quite jittery about technical things - the computer is provided by his employer who is 1,600 miles away and I didn't want to get into a 'middle-man' role if I botched the upgrade or it caused some other functions to stop working - so we left it hooked up to the router in a wired mode.

    I suspect you will find some answers if you noodle around in the support section on the ibm website.

    Good Luck!
  17. DKJohan

    DKJohan Guest


    It seems it's never to late to apply new information :)

    nerdmeier, thanks for pointing me in the rigth direction.

    Here is what i found out from the Lenovo Access Connections (AC) support site :

    Use Your Thinkvantage Update (TU) from the ThinkVantage Productivity Center an You will get the latest version (4.42 /june 2008).

    If You do not use TU go to Lenovo website for support of AC. Use link :

    My TP is a T60 with Intel Wireless, and AC version was 4.12. After the upgrade to 4.42 every things works fine.

    Best regards
  18. nerdmeier

    nerdmeier Network Guru Member

    Muchas Gracias My Friend!

    Thanks a bunch! I hadn't even thought of this for some time now. When I first looked into it on the Lenovo site it entailed a three step process that I was unwilling to do because I didn't want to 'mess up' my friends computer in some way. But if it is now a simple upgrade to fix things I'll have to look back into things.

    Thanks again!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice