WRT54GSUK - Help - connection problems :(

Discussion in 'Cisco/Linksys Wireless Routers' started by nashienet, Dec 19, 2005.

  1. nashienet

    nashienet Network Guru Member

    I am a wireless networking newbie and I have the WRT54GSUK router and the WUSB54GS USB network cards to connect to it. I have gotten to a point with it now where I am completely lost and fear I may simply have to return it to amazon and opt for another wireless router :(

    Hopefully one of you clever people will spot something that I should be doing with it to fix my wireless woes.

    Ok, after several installations and various attempts at configuring my network I have settled on the following settings (after some advice from Linksys tech support):

    I am using windows wireless configuration not the linksys monitor which I have turned off (linksys advised me to do this).

    I am using WPA encryption, MAC address filtering and I have changed the default admin password for the router.

    It's version 1.1 of the router and uses 3.17 firmware.

    Ok now then - heres the problem:

    Quite regularly I lose my wireless connection, the signal strength doesn't drop, the connection simply ends. I have found that the only way to restore it is to take the AC adaptor out of the router and put it back in, windows then reconnects to the router. I have to do this a hell of a lot. Sometimes I have noticed that the first sign of the dropped connection is actually lack of access to the router configuration web panel ( - I recall that being the address offhand), but web access remains for a few minutes before that goes too.

    I thought that maybe I should update the firmware and I tried that but initially the instalklation hung for about 15 minutes (it says it should take no more than 5 minutes) before I had no other choice but to turn it off. The firmware remained at 3.17, I tried again, but was told that the 'upgrade failed'. Also in the download I took from linksys the readme said that I should install the .RMT file, however no such file was included, only a .bin.

    Does anybody think they understand what would be causing the wireless connection to die like that. It has to be the router thats getting in a muddle somewhere, otherwise turning it off and on wouldn't fix the problem would it...?

    Any advice and suggestions will be greatly appreciated.
  2. Thibor

    Thibor Super Moderator Staff Member Member

    firstly you should upgrade the firmware, get it from the downloads section of this website, any for the GS v4.70.6 based like Hyperwrt_GS_Thibor-171205 or dd-wrt v23.
    make sure you upgrade from a WIRED connection and not wireless. after that reset your router to defaults, either by holding the reset button for 30 seconds or from within the GUI. the wireless connection could be due to your machine causing the usb ports to turn off to save power(it has been known to happen), or could be due to the router. i'd upgrade the fw first, then you have a known good starting point.
    by the way, the firmware images are bin files, just go to Administration>Firmware Upgrade and then browse for the upgrade bin file and then proceed with the upgrade, but make sure you don't navigate away from the page or cancel it or do anything with it for 2 minutes or until it tells you "Upgrade Success" and reboots itself
  3. nashienet

    nashienet Network Guru Member

    I tried using the official linksys firmware upgrade but it 'failed'. I'll try using the one you suggest. If its a USB power thing, how can this be rectified?

    Also is it ok for me to upgrade straight from my current firmware (this may sound strange...) in other words, I don't have to upgrade to one firmware first and then the one you suggest, also will that firmware you mention work on WRT54GS version 1.1 (I just wanted to make absolutely sure before I potentially make a mistake)?

    Thanks for your advice :)
  4. nashienet

    nashienet Network Guru Member

    Yet again I have attempted to upgrade the firmware and after a few minutes I was told in unreassuringly broken english "Upgrade are failed!", suffice to say that if Linksys cannot even get a JavaScript popup error message correct its fairly indicative of the quality of the router. I am absolutely gutted that this saga has drained so much of my time.

    It simply doesn't work and I won't ever be choosing Linksys for anything again (including your own device drivers and auto-installation from cd but the less than useful 4 page booklet rec, I only hope my linksys WUSB cards will at the very least play nicely with the Belkin Pre-N MIMO I am about to order from amazon.

    Thanks for your help and I hope nobody has all the problems I experienced :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice