WRT54Gv3 won't get WAN IP from Comcast.

Discussion in 'Networking Issues' started by googlymoogly, Oct 17, 2007.

  1. googlymoogly

    googlymoogly LI Guru Member

    I've tried everything from cloning mac's of original pc and current router, to powering down my whole network overnight. I asked a neighbor what router/isp he has he said a WRT54Gx with Comcast hassle free (forget if it was L or S).

    I should also note that it works fine if plugged in directly to a pc or to my other netgear router, but I'd really like to take advantage of this dd-wrt firmware on my linksys...

    Did I just get uber unlucky? I've heard that mac cloning is the answer but I disagree as I can freely move the internet from my current netgear to 2 different laptops and they both pick up an address fine...

    I've heard that comcast may be up to some trickery in how they hand out their dhcp but I'd like to leave that out for now if possible...

    Help! What am I missing?!
  2. Mastec

    Mastec Network Guru Member

    I have a WRT54Gv3 and everything works fine so I can say Comcast is not up to something. I see you tried the power down method, that should have done it. On the Basic Setup tab do you have the Connection type set to anything other than Automatic Configuration? STP disabled?
  3. googlymoogly

    googlymoogly LI Guru Member

    What cable modem do you have?

    I have tried with both the default linksys v3 firmware, and tried their latest firmware.

    I have also tried several variants of dd-wrt firmware. with STP disabled.

    I don't think disabling STP is an option in the default linksys firmware but will double check.

    DO you have the SB5100 Modem mastec?
  4. Mastec

    Mastec Network Guru Member

    No, Comcast gave me an Arris Touchstone Telephony modem, have not used the SB5100. You say you powered down you entire network.... Did you power off the modem as well?

    I had the same issue years ago. I shut everything down and let it sit for a minute. Powered on in this order... 1) modem wait 45 seconds 2) router wait 45 seconds 3) computer
  5. ifican

    ifican Network Guru Member

    Most cable modems when you change devices just need to be powered off, then on then plug in the device you want to recevice an address, if that is not working then something else is going on. At this point i would use a packet sniffer to view what is happening, you will need a hub to view what you need to see, but if you can get to that point you will know exactly what is going on. Might be the router not accepting what its sent, might be the dhcp server not offering but you will not know for sure until you can see it first hand.
  6. googlymoogly

    googlymoogly LI Guru Member

    Have not sniffed between modem and said router yet...

    I have done the power down of the whole network including cable modem for over 8 hours (overnight) and brought it back up in this order:

    1- modem power
    2- router wan cable to modem
    3 - router power
    4 - pc power on

    I'm just wondering what could be that different from a netgear and a linksys in terms of receiving a wan ip via dhcp..

    I have tested the router at my school and it will pick up a private ip from our network (on the 10.10.x.x net) then in turn hands out ip's on it's dhcp on my own 192.168.x.x net, so it is not malfunctioning...

    Have found this forum (http://www.cable-modems.org/forum/read.php?2,21614,21614#msg-21614)
    but it is quite old so I'm not sure how accurate it is today, and their solution seemed to be cloning the mac, which is not the issue as I've tried switching between my router that works to multiple pc's and then back without cloning.

    Anyways there are a few posts on there about how a dhcp request from a router is different from an xp client, so that's why I thought it might be relevant.

    Being a networking student I find this problem really aggravating since I've never had a problem with DHCP and I would hope that it wouldn't make a difference what brand of router you use, which I thought is why we have standards.

    Anyways, enough with my ranting-

    I went and ordered a new LINKSYS BEFCMU10 Cable Modem off newegg.com in haste, so I am hoping that this solves the problem, being that they are both from the same manufacturer. (Although it will create a new problem of waiting for 30 mins on hold for Comcast to register my new MAC, or is this not necessary?)

    Any other ideas and comments are appreciated and welcomed... I'm really hoping that it's just this rented modem's problem... hope with me!
  7. googlymoogly

    googlymoogly LI Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice