WRT54GX-EU v2 won't upgrade

Discussion in 'Linksys Official Firmware' started by carltabet, Dec 26, 2005.

  1. carltabet

    carltabet Network Guru Member

    Hi there,

    I just got a WRT54GX-EU v2 with factory installed firmware 2.00.05 and I have tried to upgrade it with EU firmwares 2.00.10 and 2.00.12 but it just won't work.

    When I get into the router's setup menu and select firmware upgrade, I then select the BIX file and it starts out well. I can see the process bars filling up but suddenly at about 25% of the upgrade, the whole thing stops and I get a blank page that lasts forever. The router sort of gets stuck on the following link:

    I waited a good 5 mins but it just stalls on that link with a frustrating blank page. After that, the router won't respond anymore so I have to reset it. Back to factory firmware 2.00.05.

    Could it be that the router is in fact a US version packed in an EU box, so therefore would need a US firmware? That sounds pretty strange even for a newbie like me.

    Any help is much appreciated.
  2. NateHoy

    NateHoy Network Guru Member

    I'd start with doing a factory reset, then turning off everything you can find to turn off (to free up memory). It may not work, but heck - it's worth a try.

    I had that happen on a Vonage-supplied Linksys router once. I could not get it to update firmware until I turned off wireless, then it worked like a charm.
  3. carltabet

    carltabet Network Guru Member

    OK, I tried doing a hard reset by pressing Reset for about 30 sec or so, and I also tried to install EU firmwares 2.00.10 and 2.00.12 as well as US firmware 2.00.08. All of them are .bix files which is correct, cause at one time I was wondering if something was wrong with the extension and whether I should have .bin files instead.

    But it just won't upgrade. The router is simply connected to a single computer on LAN port 1 and I even disabled everything that could eat the memory including wireless as NateHoy instructed.

    The process bars fill up to about 25% and then I get stuck on a blank page with the url
    I don't even get a message saying the upgrade has failed.

    Now I'm thinking maybe the firmware filenames are too long like WRT54GX-v2_EU_2.00.10.bix and WRT54GX_V2_EU_2.00.12.bix and should be renamed to something shorter but it just doesn't make sense cause these are official filenames.

    Next thing I'm doing is to contact official Linksys support. How are these guys, can they be counted on?
  4. dt9394

    dt9394 Network Guru Member

    EU and US firmware

    Both firmware are 99% same. It should'nt b a problem to flash the firmware. I had my EU wrt54gx v2 and flashed US firmware version. No problem at all. No need hard reset or anything....
  5. carltabet

    carltabet Network Guru Member

    Re: EU and US firmware

    Yes I know that the only change is the US firmware not having channels 12 and 13 for wireless. But I did try to upgrade to US firmware 2.00.08 as well and it didn't work, I got the same problem I have with EU firmware. The upgrade process never seems to reach 100%.

    I emailed Linksys support about my weird issue and they should respond within 24 hours hopefully.

    I'll post whatever solution they'll have for me.
  6. Pastasaus

    Pastasaus Guest

    I actualy had the same problem a ouple of days ago. Since I got a new linksys router for cristmas and tryed to get it to go with my Norwegian ADSL connection (witch it didnt and I assumed it was the long username I have), after trying to upgrade all firmwares I could find (from homepage/ftp/links from here and some US vertions) It allways stopped at 25% and I got a blank page.

    I finaly got it to work (installed ver 12 EU now) by doing a hard factory restore (30 sec btn-crunsh) then having it only connected to the PC I had the upgrade on, it patched wo any problems what so ever

    It managed to upgrade the firmware, but it did not solve the problem with the connection.

    If you wont be able to upgrade yourfirmware with these steps, try shutting off all the wireless recivers in the house as well (doubt it will do anythnig but it just might)
  7. chcant

    chcant Guest

    I have solved this problem by erasing cookies and cache of the browser!
  8. carltabet

    carltabet Network Guru Member

    Problem solved!

    Problem solved gents!

    I was finally able to upgrade my router to EU firmware 2.00.12 using your advice, Linksys support and my own common sense.

    Here is what Linksys told me to do:

    "Try upgrading the firmware immediately after a hard reset. To reset the router, hold the reset button down for 10 seconds. Disable any firewalls. You may also try assigning a static IP on the computer when upgrading the firmware. If you have another computer, try upgrading from there so we can isolate the problem."

    It only worked when I moved the router to another computer and I assigned IP I had to do a hard reset for the router and it still didn't work. Somehow I figured that if my Windows firewall was disabled why not also disable the antivirus, I thought maybe Trend Micro Pc-cillin 2005 is interfering with the upgrade, although its firewall feature was never installed, only the antivirus.

    I guess that was the source of the problem because after disabling it the upgrade worked!

    I can now stop pulling my hair and I know what to expect now for future upgrades.

    Thank you all. :cheer:
  9. xedion

    xedion Guest

    after hardware reset and deactivating firewall AND antivirus(avast) ALL OK :cheering:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice