WRT54GX hassles

Discussion in 'Cisco/Linksys Wireless Routers' started by gdi2k, Mar 16, 2006.

  1. gdi2k

    gdi2k Network Guru Member

    Yesterday I bought a Linksys WRT54GX ver. 2. Being a Linux user, I assumed that it would work fine with Firefox, but apparently not.

    I talked to tech support, who told me that a firmware upgrade would correct the issue, so I borrowed a Windows machine, tried to upgrade the firmware via the web interface but it failed (after the ninth black line on the progress bar, the screen goes blank. Setup page only becomes accessible again after a reset, but old firmware remains).

    So I was told to try the Linksys' tftp.exe upgrade program (which is also only available for Windows), but that too failed (it wouldn't connect the first 2 tries, then it consistently fails at the "Erasing flash"stage).

    The support staff then admitted that the setup pages wouldn't work with Firefox, even after the firmware upgrade - only Internet Explorer or Netscape Navigator (6.0 or higher) were supported.

    So I downloaded the latest version of Netscape (which is available for Linux), but that (predictably) had the same problems as Firefox.

    What's the deal here? Linksys use Linux on most of their routers, but their customers have to use Windows?

    If I install a third party firmware, will it work with Firefox? And if so, can I upgrade the firmware to a third party flavour if I can't even upgrade it normally?

    Any help appreciated before this junk goes back to the store...


  2. sebastiang

    sebastiang Network Guru Member

    In my case, upgrade to newer version helped. After that, it is possible to upload an image from firefox on linux. The version of the firmware was 2.00.10 EU (as I remember). If you have problems with upgrading on windows then check any firewalls, antivirus and such software that can mess. Try to go on the router's diagnostic page and check if you can ping your workstation - if you do not have connection then something blocks it. I had also problem when upgrade could not be done even from windows (and on 2.00.10 EU firmware), but helped me long reset (for about 90 seconds or so :) ) during power on. I do not know if there is any connection, but when something happened with aniSdkTool (you can check it in the system log whether it fails and so on...) the upload could not be done (or I just messed to much ;-) )...
    The tftp program from Linksys also does not work with my router so I wonder why do the support tells something like that ;-)
    About third party firmwares.... I think it should not be a problem. I have tested images based on 2.00.14 Linksys GPL sources and the web interface looks quite fine on firefox and the upgrade is possible from linux - at least it works in my case.

  3. Tom0819

    Tom0819 Network Guru Member

    Temporarily change the speed of your ethernet card from whatever it is (probably Auto or 100 MB full duplex) to 10 MB half duplex. Once you make this adjustment, you will be able to upgrade the firmware via the web interface using IE. The latest firmware is compatible with Firefox.
  4. gdi2k

    gdi2k Network Guru Member

    Thanks for the responses! This does sound promising! Ill give this a try in the coming days and let you know if it works...


  5. Astronut

    Astronut Network Guru Member

    Altering the ethernet card speed to 10Mbps half-duplex does get past this annoying problem - I tried it myself when I got a WRT54GX v2 in January.

    Make sure you've got the correct firmware.
    If you're in Europe the correct latest firmware v2.00.10 is linked here:
    This was given to me by Linksys support.
    I believe there's a later version for Europe v2.00.12 kicking around somewhere but I've not been able to find it. It's definately not on Linksys's ftp site.

    If you're in the States or Canada then you can download an even later version v2.00.15 (released a few days ago) from Linksys's main download web page.

    I wish Linksys would get their act together and make this latest version available for the UK and the rest of Europe. :thumbdown:
    I'm reluctant to install the v2.00.15 version from the USA or Canada download pages because of possible incompatibility issues and the fact that USA wireless channels are 1-11 whereas Europe wireless channels are 1-13.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice