WRT54GX v.2 - what firmware for Europe?

Discussion in 'Cisco/Linksys Wireless Routers' started by The_Real_Mastiff, Dec 2, 2005.

  1. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    I downloaded the 06 firmware for my brand new WRT54GX v.2, but I see that it has "USA" in the name, and I can't find any firmware without that, with Europe or something. Should I use this firmware on my european WRT54GX v.2 as well? It's now on firmware 05, which is what it was delivered with.

    What I'm worried about is that USA, like France may have limitations imposed on the wireless part that we don't need to follow here in Norway.

    Thanks in advance!
  2. Nalle

    Nalle Network Guru Member

    There is limitations in USA as well but the difference between EU (excluding france) is that USA is using only 11 different channels instead of 13. this is probably managed in the firmware so you'll probably loose 2 channels if you use this firmware.

    check ftp://ftp.linksys.com/international/firmware/, and see if you find the EU version there.
  3. stefansundh

    stefansundh Network Guru Member

  4. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    Thanks! I found the file WRT54GX-EU_v2_2_00_10.zip, and I assume that it's the correct one. Do you have any idea why this is up to version 10, while the US version on the Linksys page is only 6? Is this perhaps a Beta? The annoying thing is that there are no release notes in it.

    There is a file called WRT54GX_EU_1_02_06.zip there as well, but that seems to be for the version 1 router. Should I just install the US version, or can I take the chance on installing the possible Beta version 10?
  5. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    Sorry if I'm nagging, but I would appreciate to know what I should install since I won't set up the router before it has the latest firmware.
  6. stefansundh

    stefansundh Network Guru Member

    Sorry about the delay...
    ...but I'm not logged on every day.

    I'm running the v2_2_00_10 on my router. I run a security scan (nessus) on the router with the delivered firmware (2.00.06). The scan resulted with a reported issue and thats my reason for upgrading. After upgrading the scan don't report any issues.

    I downloaded the 2.00.10 (eu) from linksys at ftp://ftp.linksys.com/international/firmware/WRT54GX-EU_v2_2_00_10.zip. They don't state that it should be a beta version. On the other side there is no documentation available at all about this firmwareversion. I have struggled with Linksys support about release notes and older firmware versions to be able to perform a rollback. I have not got anything at all, but a bunch of emails telling that they have not got any response from me. The strange thing is that I'm the one waiting for their response. The sum of it from me would be that Linksys support sucks...

    Since I could not wait forever to upgrade I upgraded anyway, without relasenotes and possibility to perform a rollback. I new that the "dyndns" did not work in 2.00.10 since i foud the information on linkstsinfo.org. I have reported this to Linksys support, but I don't get anywhere with them.

    If I were you I would not install the US version on your EU-model. I would go for EU-2.00.10.

  7. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    Thanks! I had given up on this thread, but now I'm gonna try that firmware! :cheer:
  8. vibe666

    vibe666 Network Guru Member

    i used the US firmware when I couldn't find an EU one for my v1 GX, but I'm having some problems.

    for one, I lost channels 12 & 13 on the wifi (as expected) which was a shame because 13 gives me the best performance generally.

    and for two, I'm getting disconnects every few minutes, and with a 20-30 sec reconnect it's killing my downloads constantly.

    oh, and for three, there is a problem with using P2P apps on linksys routers that causes them to jam up after a couple of hours of heavy downloading. something to do with the routers tracking tcp connections for a whole week, and only being able to track so many without falling over. obviously, when using P2P apps, this becomes an issue after only a couple of hours on a 2mbps connection, forcing a reboot. I got around this on my old wrt54g by using hyperwrt with a startup script, but that eventually died, and it seems like the gx's don't have any custom 3rd party firmwares out yet, so for now at least i'm stuck, unless i want to sell it and go back to a wrt54g.
  9. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    Thanks! I won't try the US firmware. I tried to download the firmware mentioned by Stefan, but that link's dead. It's probably been pulled.
  10. ruivinho

    ruivinho Network Guru Member

    Acctually the last firmware for the V2 is 2.000.12
  11. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    Interesting! Are you talking about US or beta EU firmware?
  12. ruivinho

    ruivinho Network Guru Member

    Its not a beta version but a release. This one is EU release but you need to contact the support most likely to get it. Dont think they have it on there ftp server.
  13. The_Real_Mastiff

    The_Real_Mastiff Network Guru Member

    That may not be the stupidest thing I've ever heard, but it's damn close! :thumbdown: When there's new firmware it should be in Linksys' interest as well to get it out there since any bugs in the current firmware will give them a bad rep.
  14. ruivinho

    ruivinho Network Guru Member

    A lot of times Linksys have newer firmware that never sees the market. Take for eksample the wrt54g v5. That one also has v 1.00.3 but wasnt released. If you try to call support or send a mail to them you can find out yourself.
  15. dannyp

    dannyp Network Guru Member

    Linksys Live Tech Support insisted last night that latest WRT54GX v2 EU Firmware version was v2.00.10 :(

    However, I found a download link on here to v2.00.12 EU, upgraded and running it now. :thumb:

    Worth noting however that v2.00.05 -> v2.00.10 retained router config, whereas v2.00.10 -> v2.00.12 reset to factory defaults. now shows:-

    FW_ID = RT3105W-D40(EU)
    Firmware Version = 2.00.12
    Boot Version = 1.00.03
  16. carltabet

    carltabet Network Guru Member

    Can't upgrade firmware

    Hi there,

    I just got the 2.00.10 firmware for my new wrt54gx-eu v2 router that is currently using the factory default 2.00.5.

    When I get in the setup menu and pick the BIX file, the process starts with a few bars completing, I'd say about 25% and then the page becomes completely blank and it sort of gets stuck on the address

    I waited for about 5 minutes cause maybe that's the way it works (newbie here) but nothing happens after that.

    Although I know I shouldn't do it, I just pulled out the power because the router wouldn't respond anymore. Then it's back to the default 2.00.5 firmware.

    Any ideas? I'll try with 2.00.12 and see what happens.

    EDIT: Same problem with 2.00.12... Could it be that my router is a US version and thus can only use US firmware? I highly doubt it because it came in an EU box.

    A firmware that won't upgrade. Sigh. I'm lost! :cry:
  17. spurv

    spurv Network Guru Member

    Where did you find that version?
  18. Tom0819

    Tom0819 Network Guru Member

    Hi cartabelt,

    I have also experienced this. In fact, I returned the router to the store for another one thinking it was defective but I was wrong (since both behaved exactly as you described).

    Here's the fix:

    Temporarily change the speed of your ethernet card from whatever it is (probably Auto or 100 MB full duplex) to 10 MB half duplex. Once you make this adjustment, you will be able to upgrade the firmware. Obviously, don't forget change your NIC back to its original settings after you are done. Good luck!!!
  19. ruivinho

    ruivinho Network Guru Member

    Newer firmware

    Comed out a newer firmware for the wrt54gx v2, now the newest are 2.00.14 but at the moment i think its just in a us version. Not any notes on what that one fixes yet.
  20. Rein

    Rein Network Guru Member

    Re: Newer firmware

    Where can I find this new 2.00.14 firmware?
  21. ruivinho

    ruivinho Network Guru Member

    Know the support for most of Europe have it at.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice