WRT54GX2 Power Light Goes Off

Discussion in 'Cisco/Linksys Wireless Routers' started by losangeles, Mar 18, 2006.

  1. losangeles

    losangeles Network Guru Member

    I bought a brand new WRT54GX2 from Staples and it worked great ... the first day. :rofl:

    The second day the power light goes off regularly and so does the wireless light (the port 1 light where the dsl modem is and internet light stay on).

    Of course I loose the connection to the network and I have to unplug the power from the router and plug it back in.

    I am using the latest firmware 1.0.14. And I am looking my WRT54GS which worked flawlessly for 2 years and I am saying sorry to it. (It replies I told you so!) :sad:

    Does this sound like a lemon device guys?

    Thanks in advance.
  2. Randy

    Randy Network Guru Member

    Serveral of us have had problems with this unit. It overheats and shuts down :sad: I'm am waiting for my 4th one (in 3 months) to returned from linksys and I'm selling it!!!!! Good luck with your
  3. losangeles

    losangeles Network Guru Member

    WOW. That's good news .... :thumbdown: Damn.

    Today it seems to be working fine. Let's see how it will keep up.

    Thanks Randy.
  4. losangeles

    losangeles Network Guru Member

    Firmware reload fails

    i am trying to re-upgrade the firmware as linksys live support suggested but when the bar reaches almost in the middle the page 'page not found' page comes up in the browser and it seems that the firmware upgrade cannot be completed.

    tried numerous times.

    i'm taking it back for sure. i am very dissapointed by this investment. (or disinvestment to be more accurate)
  5. howardp6

    howardp6 Network Guru Member

    Before you take it back, did you do the firmware update from a wired connection between the router and the computer?
  6. losangeles

    losangeles Network Guru Member

    Got a new one with.. new problems

    yes i did it through a wired connection.

    i took it back and got a new one. the new one has other problems. when trying to upgrade, firmware progress bar fills up but before reaching the end the page times out . no message for successful completion.

    when i go to status to see firmware version it reports that it has the latest. so does this mean that it was upgraded succesfully?

    i tried once more but now the page times out even sooner - around the middle of the upgrade progress bar. the power light though continues to flash like it still upgrades the firmware and then reboots and reports that it has the latest version.

    Next problem: this one does not seem to turn itself off like the previous one but the wireless connection suck! i cant get more than 72 mbps connection in all channels and transfer rates top at 600 kbps with extreme fluctuations. The previous one was reporting 108mbps connection and transfer speeds were steady at 1600+ kpbs . :sad:

    I am really pissed off guys + Very bad experiece + huge amounts of time wasted = Starting to change my mind about Linksys latest products. :thumbdown:
  7. howardp6

    howardp6 Network Guru Member

    Try resetting the router to factory defaults and power cycling it and then resetting it up.
  8. losangeles

    losangeles Network Guru Member

    ok. i got my 3rd!!!! router today and I just didn't upgrade the firmware to see how it works with the shipped one.

    till now there are no mulfunctions. except one issue that I am just concerned with but it doesn't have to do with the router:

    The notebook adapter Power light (WRC54GX) is countinuously blinking rapidly when I am connected wirelessly. Is that normal? Shouldn't both lights 'power and link' stay on without blinking?

    Needless to say that you should probably stay away from this router. Especially now that Linksys came up in such a short time with the WRT54GX4 I don't see too much support for the GX2 (firmware wise). Probably go directly for the GX4.
  9. howardp6

    howardp6 Network Guru Member

    It is normal for the LEDs to blink, they indicate transmission and receiption of signal.
  10. Randy

    Randy Network Guru Member

    Well.....They recieved my unit 2 weeks ago and the status is still Back Ordered. Come on linksys....return the unit so I can get rid it. :thumbdown: :thumbdown: :thumbdown: :thumbdown:
  11. SBTRS

    SBTRS Network Guru Member

    So Losangeles, are you saying the ver1 "out of the box" firmware is the best so far? The wireless connectivity,throughput, etc does not exist with that version? I know there were several "fixes" since then . It is possible to downgrade to Ver 1.0?
  12. Astronut

    Astronut Network Guru Member

    When you're updating firmware on this router you have to temporarily set your ethernet card's speed from 100Mbps full-duplex to 10Mbps half-duplex.
    It's the only way to prevent the process hanging before completion.

    I don't know if this is a problem for this router only or if the same thing happens when updating firmware on other router models but that solution does work.
  13. losangeles

    losangeles Network Guru Member


    the firmware version that is shipped with the router (at least for the three units I got was 1.01.06) seems to be working fine at least for my configuration. I didn't try to upgrade the firmware on the 3rd router as it would possibly fail as in the previous routers.

    Maybe if there is a reason in the future to upgrade I will try the method suggested by Astronut to see if it works that way but for the time being I dont even think about it!

    I've had enough with this router and at least now that it is working I 'll leave it as is.

    Now concerning your question of downgrading the firmware: I searched everywhere on the net when I had the problems with the second router to find the original firmware but I didn't have any luck. Linksys does not have it in their site and extensive web search did not return any results. I even tried to find posts talking about "downgrading" but I didnt find anything. So I dont know if it is possible to go back... if you are able to fing the original firmware that is.

    This is one more reason that I dont try to upgrade the firmware to the new router. If there is a problem with it too then i dont know how to go back.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice