WRT54GX2 WAP broken and other issues...

Discussion in 'Cisco/Linksys Wireless Routers' started by Shrink0823, Aug 13, 2006.

  1. Shrink0823

    Shrink0823 Network Guru Member

    I think that I must have gotten a lemon. My previous router was a linksys wrt54g rev.2 and it worked faithfully for the past 4 years. I replaced with the the WRT54GX2 after going through a couple of other routers (D-link 624 which dropped wireless connection repeatedly and a WRT54GS which spontaneously rebooted every day or so). I have noticed 3 problems with the GX2:

    1. WAP encryption is broken - I can connect using any of my wireless computers using WEP or no encryption, but when WAP encryption is selected (AES or TSK) with a key selected which is 8 characters long, none of the wireless clients can connect using that particular password (no any other password) and the clients keep responding as though WEP encryption is being used (complaining about illegal password having to be 5 or 8 characters long).

    2. Frequent lockups on the WAN side - this is happening numerous times daily: the connection to my cable modem locks up in spite of the fact that it still has a WAN IP. None of the clients can connect to the internet and the only way I can solve the problem is by releasing and renewing the WAN IP.

    3. System Up Time and Current Time missing on the status page: neither of these times have been evident on that status page.

    I have searched the forums here and at dslreports but haven't seen any of these errors frequently cropping up with this router. I have used the January firmware as well as the latest beta firmware posted on this site but still the problem persists. I've tried resetting to factory settings hoping that would clear the problems but to no avail. Any suggestions? Thanks!
  2. kingvj

    kingvj Network Guru Member

    To me, the router itself is a PKI..:D

    BTW, did a clone-MAC and disabled Wireless QoS?
  3. Shrink0823

    Shrink0823 Network Guru Member

    I wound up returning the router today and got a replacement. I had cloned one of my PC's MAC addresses but took the router back before I could see whether it did any good. What I have noticed with the new one:

    1. WAP works now where it didn't before - the old router was sending out WAP encryption as though it was WEP.

    2. I still don't have current time and system up time in the status page. That just might take awhile for it to sync to the time server.

    3. When I make changes to the primary settings page (the one where you specify dhcp ip ranges, etc...) the router does not reboot as the original one did.

    Now the main issue is whether or not the WAN side craps out frequently. I'll report back. For now, I am not cloning one of the MAC addresses from the computers on the network but am going to disable wireless qos (I doubt it had any impact on the last router but there's no reason for it to be on in the first place <g>).

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice