WRT54GX4 and XBOX 360 Problem

Discussion in 'Networking Issues' started by fillyfrantic, Feb 2, 2006.

  1. roverrhubarb

    roverrhubarb LI Guru Member

    I have the channel selected manually, but I DO have adaptive Channel on (11, 7)
    Without that I won't get the full benefit of my srx400 laptop card. Why should I switch it off? Is it buggy?

    Where's the QoS setting? Do you mean in the TCPIP settings on my client PC? Or is it there in the admin pages somewhere? And why will turning it off help?

    Yep I do have a 2.4 GHz phone, but in times when my router isnt working, I turn that off (for days at a time) and it doesnt really help.
  2. beware_tootsie

    beware_tootsie LI Guru Member

    With regards the WRT54GX4 beta firmware release version 1.00.19, if you're having problems requesting for it thru their chat or email support, you may call their technical support hotline [it's on the WRT54GX4 box]. Just request for the beta firmware to be sent to you. Provide 2 email addresses to be sure you get it.

    I believe their support engineers did a great job on fixing the issue between the aweseome Xbox 360 and the fine WRT54GX4 router.
  3. nunyabiziz

    nunyabiziz Network Guru Member

    thanx guys for the heads up on the beta firmware for the wrt54gx2 and the xbox 360 issue. i had requested the firmware for tech support and sure enough my 9 month long problem has been resolved. this is also after 2 replacements by linksys because tech support sent me a corrupted firmware, twice.
  4. HaloXgamer

    HaloXgamer Network Guru Member

    I can connect with wireless, but online is laggy, and downloads are at a crawl. any settings I should try?
  5. acejacker

    acejacker LI Guru Member

    can someone send me the link beside the one posted?

    When I upgrade , it says bad image.

    please help.........
  6. rakeshjmd

    rakeshjmd LI Guru Member

    after updating firmware on router change mtu to 350 on setup page & power cycle whole network
  7. rakeshjmd

    rakeshjmd LI Guru Member


    at the time of upgrade ***** please check the file you r trying to upgrade is a zip file please unzip it first
  8. rakeshjmd

    rakeshjmd LI Guru Member


    change advanced wireless setting ** becon interval to 50 * change mtu 1350 & please try to upgrade firmware
  9. acejacker

    acejacker LI Guru Member

    Ok . Got the firmware installed and it shows with my srx 400.

    Tried to connect cold turkey to my official 360 wireless adaptor and it didn't work. I'm slowly losing faith and my mind.

    I 'm going to try your other suggestions now. Any other tips would be greatly appreciated.
  10. acejacker

    acejacker LI Guru Member

    Btw , it tells me the mtu value is out of range. 576 to 1500.

    edit. Saw you put 1350 in a later post. nevermind............
  11. acejacker

    acejacker LI Guru Member

    ok. I got it to connect once ( yeah once ) but it quit before ICMP. Any ideas why?

    Now it just stops on wireless network not connected everytime.........
  12. lamabile

    lamabile Network Guru Member

    I had the same exact problem until I disabled WPA2 in the Wireless Security Settings.
  13. peternorth

    peternorth Guest

    Just buy a router and bridge them.

    Cable the xbox up via cat5 to the new router.
    I will work better than that xbox crap anyway.

  14. acejacker

    acejacker LI Guru Member

    I had mine disabled from before. I only use mac filtering. Oh well , back to the drawing board.
  15. acejacker

    acejacker LI Guru Member

    I just don't know what is different in my setup . The firmware works for others and not me and I have no Idea why.

    I upgraded and even restored factory options. I then disabled security and still a no go.

    I need just a little push over this hump.........
  16. TheFreakingPope

    TheFreakingPope Network Guru Member

    Helpful Hand


    Step 1. Verify that the top right corner now reads WRT54GX4 v. 1.00.19.
    Step 2. Reset Factory Defaults.
    Step 3. Make sure that everything is set to default or automatic in the XBOX configuration.

    Let me know what error you get after you've done these things and we'll try to get you through this.

  17. acejacker

    acejacker LI Guru Member

    step 1. Checked and yes it is.

    step 2. done! again!

    step 3 , not quite too sure what you mean...........
  18. acejacker

    acejacker LI Guru Member

    If you're talking about on the 360 itself then yes I did put everything as automatic or default.
  19. TheFreakingPope

    TheFreakingPope Network Guru Member

    Man, I don't know what to tell you.

    When I got it working I had to reset everything because of the crazy sh*t I had tried in my previous efforts.

    Have you tested this with another router? At this point it could be something with the card. Just a thought.

    I know the thing works like a champ with the WRT54G. Do you know anyone with one you could borrow?
  20. FastKatt

    FastKatt Addicted to LI Member

    About to buy a WiFi NIC for my son's Xbox360...
    Reading her is starting to scare me! I hope I don't have to replace the router!

    Anyone know if there's a fix? 3rd party firmware? Any thoughts?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice