WRT54GX4 Is there any HOPE?

Discussion in 'Cisco/Linksys Wireless Routers' started by roverrhubarb, Aug 2, 2006.

  1. roverrhubarb

    roverrhubarb LI Guru Member

    WRT54GX4 SRX 400

    (Apologies for the cross post from network issues - if that's bad form - I only saw this subforum just now)

    I went well out of my way to buy this piece of junk on my last trip to the US.

    Now I have all the same problems as the other reviewers I see in those comments on CNET etc. Actually, looking around, reviews come in two flavours:
    1. Early Days: 5 out of 5 stars - they love the router - soooo fast - wait till next week
    2. Had it a while: 1 out of 5 stars - works great when it works, but constant reboots, dropped connections etc.

    I'm at stage 2 of course. What's more, its incompatible with all my old linksys B pc cards, so I've had to buy G cards for the other machines (I have one srx400 pc card).

    I use this damn thing for work to share my desktop - and I'm having to hold up meetings for 5 mins while I reboot my router. Some days I need to reboot every 1/2 hour - other days it works fine all day.

    It has never worked with my WPC11 WIFI B cards - even though it shows a strong signal it won't connect.

    I have the latest firmware (minor vers 17) and I've downgraded to 13 and 15 and upgraded again.

    I can't be bothered sending it in under warranty since I know any new one will have the same issues.
    Its too far to take it back to the shop.
    I just sit and wait and check the firmware update site in the hopes they'll fix it.

    Does any one have any inside info on whether linksys is actually working on a fix?

    Is anyone working on alternative firmware for these things?

    Is anyone actually sure firmware will fix it and it's not a hardware issue?

    Is there any forum where this is discussed more frequently?

    Is there a class action law suit I can join - I'm pissed off!
  2. Toxic

    Toxic Administrator Staff Member

    Thanks for the rant and rave, that really helps this forum.

    So......your having connection problems with class 11b, and you need a different firmware.

    i'll see what i can do. I take it you have hard reset the router after any firmware upgrade?

    you have also tried tweaking the wireless settings yes? http://www.linksysinfo.org/portal/forums/showthread.php?t=47284
  3. roverrhubarb

    roverrhubarb LI Guru Member

    It's not just a question of the old cards not working with it. I read somewhere that they are based on Prism chipsets and are generally incompatible - with no hope for firmware upgrades since Prism is out of business.

    So I've resolved myself to that.

    I don't think its related to interference or specific frequencies either.

    The thing is the signal strength is great - its always 4/5 bars minimum. When it connects the connection speed is 240mbps and the actual throughput is around least 40mbps. It's just that it periodically stops working altogether and needs a reboot.

    Just about everyone who's had one of these for more than a week has reported the same issue. I'm just hoping that firmware will fix it.

    There was some interest it seems, in porting OpenWRT to it back in January - but that looks like it's fizzled due to a different Linux being used by the GX.

    I guess we'll just have to hold on and hope.

  4. kingvj

    kingvj Network Guru Member

    Hv u tried changing the mode to Mixed? Disabled Wireless QoS? Change the RTS/Fragmentation threshold values? Tranmission rate to 11Mbps (since th cards are B)? Basic rate set to 1-2 Mpbs?
  5. grcore

    grcore Network Guru Member

    Many prism based wlan nics dont support WPA (depending on firmware version and driver). What encryption are you using?

    Many prism wlan nics have upgradeable firmware flash, and many that cant be upgraded can use ram dl firmware with certain drivers. Then there are those that you cant do a dam thing with.

    What sort of nics are these?
  6. jgutz20

    jgutz20 Network Guru Member

    you could always buy a timer, so the router will turn off and back on on its own. :)

    i've always had good luck with the gx4 and not so good of luck with 300n series. not that my experience fixes your problem but on the path that kingvj was taking, have you tried disabling as many of the routers features as you possibly can? How many devices total are running on this router? wired and wireless
  7. gphoton

    gphoton LI Guru Member

    Using a timer to reboot daily works for me


    I feel your pain. There is a memory leak in the firmware. When the router starts to get flakey the number of bytes transferred on the status page often shows as a negative number. I purchased a $9 digital wall plug timer at Walmart that shuts the router off at 5:30AM and back on at 5:31AM every day. I did this several months ago and it has solidly worked for me. The router is solid until some number of bytes get transferred then some counter in the internals writes over something important and "HAL won't open the pod-bay doors" anymore. The daily reboot clears the counters and all is well. It is a drag if you need 24/7 for some monitoring, server or control system, but I can lose 1 minute out of 144.

    Best of luck,
  8. roverrhubarb

    roverrhubarb LI Guru Member

    Thanks for this very useful reply gphoton.
    I have an old timer switch around somewhere, so I'll look for that.
    I wonder if there's some way through software to cause the thing to reboot from a pc on the network.

    If the only issue is indeed buggy firmware, then I guess at least there is hope - as long as linksys doesn't drop it altogether.

    On the other hand, I'm not sure if a daily reboot will fix it.
    The behaviour I'm seeing is more erratic: It's been working fine for the last 2 weeks, yet before that there was a day where I had to reboot it every half hour. And similar days like that.

    The every-half-hour problem came while I was sharing my desktop with a team across the world - so it could be that I was producing an unusual amout of outbound traffic - perhaps this is where the memory leak occurs. I rebooted twice in 1.5 hrs.

    On the other hand, I had a similar session the day before that ran for over an hour with no issue.

    I'll try the timer and hope for a firmware upgrade.
    It seems the source for the firmware has been released (its based on some distro called "Clinux") so there's also hope that someone else will fix the leak, or port OpenWRT to it.

    thanks again,
  9. gphoton

    gphoton LI Guru Member

    happy to help, you could try an X10 switch for PC based reboot

    Hi roverrhubarb,

    The instability does seem to track the amount of data transferred. If you wanted a PC to reboot the router (it needs a hard power reboot, not just a software reset) you could attach the router to an X10 switch and use the PC to send X10 commands with an appropriate adapter. The other nice feature with this is that you could remotely reboot the router if it starts to act up, without climbing several floors of stairs etc...


    The are several PC based home control programs such as "homeseer" that can add timer functionality to the x10 control.

  10. roverrhubarb

    roverrhubarb LI Guru Member

    Thanks again for the tip.
    I guess if it can't be done easily with telnet, I might as well dig up that old timer switch.

    BTW, is this bug present in the old firmwares too (1.00.13,15 as well as 17)?

    You'd think this would be high on their bug database.

    I just wish now that early reviewers would test the thing for a week before posting a review - the negative reviews this would generate would be a nice wakeup call.

    I hope the next firmware is soon and fixes the problem.
  11. roverrhubarb

    roverrhubarb LI Guru Member

    I had about 3 weeks there where even my machine with the old B card was connecting (not the linksys B cards - they never connect).

    All of a sudden in the last few days I can't keep up a stable connection.

    Cycling the power doesnt help. Nor does even hard resetting the wap.

    How can this be? If it were purely a firmware bug, cylcing the power should fix it, no?
  12. tkelley

    tkelley Guest

    Having a similar problem which seems to have popped up when a non-linksys NIC was entered into the equation. Router is set up with WEP 128, and MAC filtering, ver of firmware is 1.0.13. Did ping testing -n 1000 (several times) and found that when the non-linksys system is connected the router fails about every 10 - 15 minutes. Turned radio off on the non-linksys and router held up fine! Planning on replacing non-linksys wireless NIC with linksys wireless NIC!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice