WRT54GX4 (SRX400) Problems

Discussion in 'Cisco/Linksys Wireless Routers' started by pinterested, Feb 1, 2006.

  1. pinterested

    pinterested Network Guru Member

    I'm glad this site and forum is back up and available; i wanted to ask these questions as i have been fighting with a new SRX400 for several days.

    I had several major issues that I am hoping to get feedback on:

    Background: I have a very stable wired/wireless network with a linksys WTG54GS running HyperWRT 2.0. It is connected to by a wireless notebook running an Intel B/G internal card as well as a Belkin Extender/access point (running as a bridge). The Belkin access point has a Xbox 360 and other items behind it. This setup works extremely well, but i wanted more speed by getting a stronger signal to my access point.

    I puchased the SRX400 and proceeded to configure the SSID, keys, IPs, etc the same as my WRT54GS. I unplugged the 54GS and replaced it with the SRX400. The wired connections worked ok, but the wireless immediately had trouble.

    I got an IP on my notebook but within a minute lost it, and couldn't regain it. The wirless bridge never could connect. I continued troubleshooting with the notebook only. I upgraded to the latest firmware from the Linksys site (.10) and reset the configuration to factory. I could connect, but once i began to reconfigure to my network settings (WEP, IP range, etc) the wireless connectivity would become flakey and just stop working. My notebook would always show it was connected , but the was "limited or no connectivity" .

    I contacted linksys support, and they suggested turning off security on the router. If i reset the router to default, and left WEP etc off it worked fine, but i won't run that configuration perminently. I saw posts elsewhere about changing the MTU from Auto and that did little to nothing...

    The final straw was that a VPN client on a wired connection died religously every 10 minutes or so when using this router. I saw posts elsewhere about this issue, but no resolution.

    I switched back to the WRT54GS and everything works fine.

    I'm willing to buy a Pre-N device if it works correctly, but this wasn't what i expected from Linksys. The original Linksys tech support guy dropped my call and i was frustrated enough to return the entire thing to Best Buy.

    So, my questions:

    1) Has anyone heard of a compatibility issue with the SRX device and a G device access point or bridge?
    2) Have other people have overcome similar issue with VPN? Changing/upgrading my VPN software isn't an option.

    I would go repurchase the router if I felt i could overcome these issues.

  2. Chuck_IV

    Chuck_IV Network Guru Member

    A few things to try...

    1. Make sure you laptop's network drivers are up to date.

    2. Try disabling the Firewall(SPI). The firewall(SPI) seems to think too many things are a DOS attack, when they aren't and it will purposely drop packets. This may help both your wireless and VPN issue. Also, who's VPN are you using?

    3. Change the channel the WRT54GX4 is using for wireless. If it's using auto, try forcing it to the same channel your old GS was on.

    4. Try using WPA instead of WEP(if you can) and see if that is more stable.

    If none of that works, you may want to do the online chat with Linksys and ask for the beta firmware, they have been emailing people. It's version 1.00.12 and is supposed to fix several bugs, including Skype issues, as well as QOS issues(although it doesn't fix my firewall/Vonage issue). A few people have said this version makes all the difference for them, so it may just help.

    NOTE: Disabling the firewall isn't as bad as it sounds. You are still adequately protected by the inherent security of NAT.
  3. pinterested

    pinterested Network Guru Member

    Good suggestions!

    It's the Nortel Networks client, and i'm running the lastest supported by my work admins.

    I didn't do anything with the SPI firewall, so if it defaults on it was on the entire time.

    I did update the laptop drivers fairly recently, but thats a good call and i will update.

    I did try the channel config changes(went from Auto to 6).

    Again, thanks.
  4. howardp6

    howardp6 Network Guru Member

    The WRT54GX4 does not support bridging and or repeating so your Belkin will never work as a bridge.
    The VPN client may a be a packet loss problem, but that should not be as issue since you are wired. Look into any connection problems with the internet.
    If you have the WPA2 Microsoft hotfix installed it causes problems with WEP encryption. If you are using WEP remove it from the client. As for WPA, make certain you have SSID broadcast on and make certain you have the WPA2 hotfix installed on your computer. If your laptop NIC only has WPA not WPA2 set the router to WPA only.
  5. fillyfrantic

    fillyfrantic Network Guru Member

    I connected my Linksys WET54G Wireless bridge and had not problems (after I upgraded the firmware to the bridge). Actually, this bridge is the only way my XBOX 360 will connect to the WRT54GX4 (since the Microsoft Wireless adapter doesn't). Also I upgraded the WRT54GX4 firmware as previously posted (version 1.00.12) and although beta firmware, seems to stabalize my 11b and 11g connections. Hope this helps.
  6. flyguy42

    flyguy42 Network Guru Member

    Yea.. I just purchased the GX4 as well... even my wired connections were terrible. I forget what I ended up doing... but disabling SPI along with adjusting some other settings got it up and running fine. The damn thing just woulnt work right out of the box though... thought I was going crazy. To be fair... I tried the Netgear version of the gx4 and had the same problem....
  7. pcar1947

    pcar1947 Network Guru Member

    I have also purchased the 54GX400 in hopes of maximizing my wireless signal. It has been a headache out of the box. I upgraded from a stable 54gs router.

    Specifically 54GX 4 frequently goes down requiring that I reset it . Yesterday It stayed up for 1day 5 hours. That is the most it has stayed up.

    I have 2 computers with 54GS PCI cards, 2 TIVO’s w/TIVO wireless G Adapter and a HP Intel wireless Notebook. And a IOGear Powerline network device. I have unplugged this device and that does not help.

    I have changed the channel from 11 to 6 and other channels.

    I do run WEP security ( because of the TIVO’s) and change the passphase frequently.

    I have discussed this Linksys Support and they have not been able to help.

    I am ready to return it.

    Can FLYGUY2 remember the settings?

    Paul in the ATL
  8. pcar1947

    pcar1947 Network Guru Member

    Update to previous post

    I disabled SPI, which is also called QoS, because according to Linksys it will improve performance on a mixed network.

    So far I have been connected 17 hours. Previously every 1 to 2 hours it would disconnect or brick.

    What is Qos ?

    Paul C

    "802.11e/QoS QoS will be enbabled by default to provide the best performance for your wireless connection. Select Disable to improve performance for a mixed wireless network."
  9. howardp6

    howardp6 Network Guru Member

    QOS lets you prioritize internet bandwidth by MAC address, Port Range by defined application to Low, Medium or High.
  10. pcar1947

    pcar1947 Network Guru Member

    Re: Update to previous post

    Thanks for the response
  11. pcar1947

    pcar1947 Network Guru Member

    I found this review on Amazon.com ( After I bought the router) and I am experiencing the Time problem referenced. A call to Linksys support did know good (Check the box for daylight savings and reboot was there response).

    Does anybody have suggestion on how to fix it?

    "Don't buy this product if you have any desire to control Internet access. The firmware on this device is buggy and is on par with a first beta software from a new company. If you live in the Eastern time zone, you'll get a GMT-4 instead of the correct GMT-5 time displayed. Don't check Automatically Adjust for Daylight Savings time. It won't automatically adjust, it simply adds an hour making Eastern Time GMT-3 when it really should still be GMT-5. This is important if you want to restrict Internet Access to certain times during the day. But then again, this is another bug in the firmware - you can't properly control access times. The Allow feature is totally inoperative. The only thing you can do is to deny access, but controlling access is not easily accomplished. The unit continually access the time server. This is fine since it keeps time up to date (well, it keeps the incorrect time up to date). Unfortunately, it tends to reset the time to 1200am and holds it for a good half second until it displays the correct time. This creates havoc if you have 1200am set anywhere as denial of internet access. Because it would continually deny access. Frequent disconnects of wireles devices also occur. "
  12. dryheat

    dryheat Network Guru Member

    WRT54GX4 Problems With VPN - Uncheck "Block WAN Pings&q

    Router was shipped with 1.00.09 firmware and I upgraded to 1.00.10.

    Used all default settings except:

    1. SSID name
    2. administrator password
    3. enabled WPA security
    4. unchecked "Block WAN pings" under security settings ( this fixed my very slow VPN connections) not sure why but I would guess that this setting caused all ICMP packets to get blocked, not just ping and this would goof up the handskake between downstream devices and the sender when message size greater than the MTU was sent

    Linksys level 3 tech support suggested unchecking the "Block WAN pings"

    Wireless download speed is as good as hardwired download speed with or without VPN.

    I did not notice any decrease in download speed after enabling WPA security.
  13. dryheat

    dryheat Network Guru Member

    SPI and QoS for the Record

    SPI and QoS are two different animals.

    Stateful Packet Inspection - SPI is a feature where the router inspects TCP packets and can make a determination as to what to do with the packet, either pass it or drop it if it is a harmful packet, SPI is basically a firewall architecture that gaurds against harmful packets.

    Quality of Service - 802.11e defines a set of QoS enhancements for network applications that are time-delay sensitive such as Voice over Wireless IP and streaming multimedia, the prioritization of voice, data, and video are also addressed in 802.11e
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice