WRT54GX4 won't pull IP from Cable modem...

Discussion in 'Cisco/Linksys Wireless Routers' started by Chuck_IV, Aug 4, 2006.

  1. Chuck_IV

    Chuck_IV Network Guru Member

    For some reason, my WRT54GX4 won't pull an ip addy from my cable modem anymore. Looking at the status page, i get across the board and no amount of releasing and renewing changes it(internal webpage release/renew as ipconfig /release and renew will pickup the router). I can see the little light, on the router, for the connection, blinking, so it recongnizes that much. I cannot even get to the cable modem itself(using, however, once in a while, if I try, while the modem is rebooting, I CAN actually get to the initial status page, but that's it. Trying to goto another page, within the router, leads to a timeout.

    If I plug in my old WRT54GS(v3), it picks the ip just fine.

    I'm thinking something was toasted on the router(maybe internet port, on the router) because my cable modem also lost connectivity(wouldn't sync) and replacing it(with identical model), fixed the problem. I just find it strange than EVERYTHING else on the modem works just fine, including wireless(I even bounced around, loading different versions of the firmware). It just will not pickup the ip from the cable modem.

    Anything thoughts?

  2. dead_p00l

    dead_p00l Guest

    Have you tried hooking the cable modem directly to a computer to make sure it is working. if the you can get online with the cable modem connected directly to a computer then Id say it's the router.
  3. Chuck_IV

    Chuck_IV Network Guru Member

    Oh, it's definitely the router. A straight connection(without any router) works fine, as well as connecting thru my my old Linksys WRT54GS(as I'm doing now). I'm just a bit miffed as to why everything else works flawlessly, expect pulling the ip from the cable modem. Strange, to say the least.

    I need the range I get with that router(that's why I don't use my WRT54GS anymore). It's still under warranty(I think), but I CRINGE at the hoops I'll probably have to jump thru, with Linksys, in order to get them to replace it. I don't know if I'll have the patience for it.
  4. Chuck_IV

    Chuck_IV Network Guru Member


    Got it to work again. I had to clone my PC's MAC ID, within the router, in order for it to pick up the ip from the cable modem. I have no idea why I need to do this NOW, as I never had to do this, in the past and I also don't need to do this with my WRT54GS, as it worked without MAC cloning.

    Hmm... Oh well, it works now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice