wrt55ag / ssh problems!!

Discussion in 'Cisco/Linksys Wireless Routers' started by tootipz, Jun 30, 2005.

  1. tootipz

    tootipz Network Guru Member

    I know this is a site primarily for wrt54g routers but hey, I think there are a lot of similarities between it and a wrt55ag version 2 router, which I have!

    The problem I have is with SSHD running on a none typically port on my xp system

    If I tweak it and say run SSHD on my xp box to anything but the standard default (port22), let's say for example SSHD, run on port 3256 (this is on my xp box). Then on my router (wrt55ag) set up SSHD to forward any incoming SSH packs to that port (3256) which in turn is forwarded to my xp box...NO, nodda, doesn't work, period.

    However if I open up DMZ I can ssh from an outside box, through my router/firewall (wrt55ag) and it connect (on port 3256) and works on that arbitrary port (again port 3256). VERY VERY WEIRD!

    WHY!! why can't I run sshd on my xp box on any port I want and set the router to route those ports to my xp IP address? Why does only 22 forward correctly?

    Well I've asked linksys tech support and they can't figure it out either, in fact it's supposedly gone before their lab and up the chain. I've stumped them! I think this is BS and needs to be in the next firmware revision?

    Open for thoughts or ideas on this! Thanks! Tootipz
  2. fizze

    fizze Network Guru Member

    thats not port forwarding.

    you can set up a RAW socket on your WRT54ag (if the firmware is capable of that)
    that takes input on port 22 and outputs it to your ARBITRARY port to your designated sshd machine's IP.

    afaik ssh or sshd on linux is capable of that.
  3. tootipz

    tootipz Network Guru Member

    fizze, I would strongly disagree with you. This feature is under the "Port Range Forwarding" tab. Under this tab is where I setup these forwarding rules...an incoming packet on port 3256 should be forwarded on to this system 192.168.1.X.

    If it's not port forwarding then what is it called?

    Then typically the xp system @ 192.168.1.X says, port 3256 is running sshd, is up and running this sshd application, hand shakes and establishes a socket...but no, the packet gets dropped in the bit bucket at the firewall

    My previous wrt55ag router version 1 performed the above flawlessly, however I had some electric problems with it and had it replaced with version 2, ever since the new version 2 router...no workie!!

    Like I said, it's a weird thing...I definitely a glitch in linksys firmware!

    regarding your comment:
    "set up a RAW socket" - I haven't seen any ability in the firmware to set up a RAW socket? Is that under the "Application & Gaming" section?
  4. jagboy

    jagboy Network Guru Member

    did u try with the router firewall off
  5. tootipz

    tootipz Network Guru Member

    Yeah, I tried enabling dmz (which turned off the firewall)...was able to connect from the outside via ssh directly to this arbitrary port 3256 right away...no issues! Some serious glitches with this routers firmware version 1.10 (release date 11/11/2004). I even tried re-flashing the firmware, still same issues.

    Why is it that linksys/cisco would even release such a inflexible firmware that doesn't even function correctly???

    I guess I need to download the open source and compile my own version? Is there such a thing?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice