wrt56G and the INTEL PRO 2200bg wireless card

Discussion in 'Cisco/Linksys Wireless Routers' started by flowerGuy, Mar 16, 2005.

  1. flowerGuy

    flowerGuy Network Guru Member

    yes I am having incredable headaches with my wrt56G and an intel PRO 2200bg wireless card that my gateway tablet PC uses. Every time i try to connect wirelessly my wrt is hosed so bad that my entire net connection for all my machines is hoses and i need to do a power cycle.

    When i called support two weeks ago they told me that the PRO 2200 might have issues with the WRT56G (talk about bad luck!) and that i was to disable G access on my card (bummer!) and set power to maximun...i did this and it seemed to help for awhile but now it is at the point that if i even turn on the damn tablet my net connection dies instantly.

    can anyone help with this??

    - mark
  2. howardp6

    howardp6 Network Guru Member

    My daughters DELL D600 has a Intel Proset 2200B/G card installed in it and it can access a WRT54v1 running as an access point with WPA-PSK TKIP. The WRT54G v1 is connected to a WRT54GX. The WRT54G is running HyperWRT 21b1. Other than the lack of support for WPA-PSK AES under WZC service and the requirement the you must use a full length key for the Intel WLAN client I have had no problems. I did upgrade the driver for the Intel Proset 2200b/g before I attempted to setup the minicard and access my network. You have to identify the version of the Intel Proset 2200 B/G with the identifier which is available on the Intel website and download the correct client and driver. I would suggest you do this at this time. Since you have a tablet make certain that you down load the tablet version.
  3. flowerGuy

    flowerGuy Network Guru Member

    very good your reply is most helpful..i am upgrading the 2200bg driver as i type and will try the hyperWRT upgrade afterward. It is reassuring to hear that someone out there has got this combo working!!

    i'll keep you posted...

  4. Siem

    Siem Network Guru Member

    Head over to this thread Link

    I managed to solve my problem with an older 2200BG driver version ( ).

    Some other guys in this thread (Link) solved it by installing the newest 2200BG driver (

    I am running HyperWRT 2.1b1 on my WRT54G v1.0

    Greetz, Siem
  5. flowerGuy

    flowerGuy Network Guru Member

    well ok...i installed the v9.xxx version and so far so good. i am not so much concerned about the connection speeds at this time, just the connection.

    The other part of this riddle is that my WRT56g is connected to the 'net through a Bellsouth WESTELL DSL router/modem. Since this modem uses 192.168.1.x by default I have set my WRT to and DCHP start at This connection seems flaky at best...i am trying to get more info on configuring my WESTELL with my WRT56g.

    - mark
  6. t4thfavor

    t4thfavor Network Guru Member

    since your ip 192.168.0.xxx is a private ip i can (safely) assume that it probibly has routing capabilities because that ip block can not be used on the internet you are issued another ip.
    this is probibly not a problem becuase the wrt will get its ip from the modem and then give it out to other machines nothing really flaky about it.

    it should serve you well
    although if you need to map ports you may have to open them in the modem also.
  7. howardp6

    howardp6 Network Guru Member

    Are you using the Westell DSL route/modem as a bridge or a router and DHCPserver. I have a Westell Versalink 327 and it is setup as a bridge. My WRT54GX handles the PPOE to Verizon DSL. The default address of the Versalink is Since the Versalink has its DHCP server and fireware shutoff and is setup to bridge its WAN connection to the first port. My WRT54GX has an IP Address of and is athe DHCP server and gives out addresses in the range. Everything is on the same subnet and there is no conflicts in IP addresses.
  8. flowerGuy

    flowerGuy Network Guru Member

    all problems solved!!!

    FINALLY! the intel pro 2200bg upgrade fixed the wireless issues and the change of the router to PPPoE and the modem to bridge ethernet has fixed that flaky net connection that seemed to stop working whenever i needed it the most <g>...

    thank to ALL that helped with these issues!

    - mark
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice