WRTbwlog v0.81 released

Discussion in 'Sveasoft Firmware' started by littlewhoo, Jun 13, 2005.

  1. littlewhoo

    littlewhoo Network Guru Member


    WRTbwlog v0.81 is available.

    Bugfix release 0.81
    Bugfix: WLAN logging should now be working correctly again.
    Bugfix: DD-WRT users should not see an error message on the status page anymore.
    Layout Selection added.

    Changelog for v0.8:
    Configuration page added.
    Rewrote most scripts to make them more modular an easier to maintain.
    Improved web interface.
    Display of down/upload speed added.
    More WLAN information on status page.
    Added option on WLAN Scan page, which channels to scan.

  2. XCOM7

    XCOM7 Network Guru Member

    Nice thanks a lot!
    Looks awesome grate new features but can you change it back to the blue please? :)
    The white and gray are to hard for my eyes and I can bearly see the menu.
    Thanks man! Just a small request :)
    Also I keep getting in the status page the following error:
    could not open input file: No such file or directory
    Any ideas?
  3. littlewhoo

    littlewhoo Network Guru Member

    In the next version I'll most likely make the color/layout configurable or at least provide more than one predefined layout. This is easy to do, as with v0.8 I moved the whole layout to CSS2.
    In the meantime you can change the colors for yourself. It's really easy, as all layout defninitions are in the file default.css. So you just have to edit this file.
    There you'll find many entries like this
    html, body {
    	margin: 0;
    	background: #FFFFFF;
    	color: #000000;
    where #xxxxxx is the background or foreground color for this element. For example #000000 means black, #FFFFFF white, #EEEEEE light grey, #BBBBBB darker grey...
    For more details please see http://www.w3schools.com/css/css_colors.asp

    Where exactly on the status page are you getting this error? Is nothing displayed on this page except this error, or is this error displayed at a certain subsection (which one)?

  4. littlewhoo

    littlewhoo Network Guru Member

    Whoever doesn't like the default layout/colors of WRTbwlog, feel free to modify the CSS stylesheet /tmp/bwlog/default.css according to your liking, send it to webmaster@hetos.de and I will include it in the next version of WRTbwlog (if it isnt' too ugly :D or browser specific and if it doesn't break the page layout).

    To customize the stylesheet, no whichcraft is required. Just a little bit CSS knowledge.

  5. XCOM7

    XCOM7 Network Guru Member

    Thanks for the pointer.
    As for the error it will only come up at the top of the page before.
    Here is how it looks:
    could not open input file: No such file or directory
    @root I.T.
    Linux version
    And of course you can see the rest of the datat but didnt feal like posting it all :)

    If I copy the default.css from the previous wrtbwlog to the new one would it still work?
    I really like that lay out so I want to use that one...
    Thanks for all the help.
  6. littlewhoo

    littlewhoo Network Guru Member

    This seems to be caused by an error in one of the numerous commands/queries on this page. Which firmware version are you using? Presumably the page is trying to read a file, which is present on the firmware I'm running (Alchemy 1.0), but which is not present on your router.

    Is there any subsection on this page, where only the header is being displayed without any additional information?

    No. default.css form the previous version doesn't contain layout information for most elements in v0.8. But the css file I have sent you the link for, should do the trick. If there are still some differences, you could tweak some of the color vlaues in this css file.
  7. XCOM7

    XCOM7 Network Guru Member

    Thanks a lot the style looks better :)
    Now for the error I only get it on the header of the page and I use DD-WRT pre5.
  8. naitkris

    naitkris Network Guru Member

    nice work - v0.8 working great!
  9. littlewhoo

    littlewhoo Network Guru Member

    Well, not exactly. :) I mistyped a letter in a parameter name, which disabled WLAN logging completely. But the bugfix release 0.81 is fixing this.

    Is the error on the status page gone with 0.81? I can't check this for myself, because I have no router running DD-WRT.

  10. naitkris

    naitkris Network Guru Member

    looks like i got version v0.81 just as you uploaded it :) working fine anyway!

    can't wait for the "Traffic by IP or MAC (Rflow?)" feature if and when it gets added!
  11. jagboy

    jagboy Network Guru Member

    it looks good :D

    good work littlewoo
  12. XCOM7

    XCOM7 Network Guru Member

    Works grate with the new release :)
  13. techspy

    techspy Network Guru Member

    Thanks for the great tool!
    I dont have any pc's on my local network that are always on, so I am backing up the file to my remote ftp server. I also have the rc_startup script modified to start WRTbwlog whenever the router reboots. Here is a question...Can I modify WRTbwlog so that it points to my ftp server by default, for the location to retrieve the backup when starting? By modify I mean change it (the install file/package) so when its installed it will automatically point to that location instead of I need this because if the router reboots and it downloads WRTbwlog from the original website (@hetos.de), then it will have the default setting of to try to download the backup file. If I can change this, and host it on my own webserver, I will change the rc_startup script to point to my server for the location to download WRTbwlog with the changed default ftp location already coded in.
    Also, I would like to change the default username, password, ftp upload location for the backup etc. Can anyone give me some advice on how to do this?

    Thanks, John

    EDIT: I have located the values I want to change in the config.cgi file. I have changed them in Word and saved. Can I just zip it back up and change the extension back to .tgz and .gz?
  14. littlewhoo

    littlewhoo Network Guru Member

    Don't change config.cgi. The values in config.cgi are just fallback values, if no configuraiton file can be found. The real configuration file is /tmp/bwlog/data/config.
    And it's not recommended using Windows to change any WRTbwlog files. Windows has different line breaks than Linux and editing a file with a Windows based text editor will completely screw up this file in most cases (there are a few text editors for Windows though, which can handle Linux style linebreaks).
    Another problem on Windows is, that most (all?) Windows file compression software like Winzip, Winrar... cannot handle the Linux file permissions. And without the proper file permissions WRTbwlog will not work an longer.

    The best way to get an own WRTbwlog version with different default values is:

    1.) Reboot you router and install WRTbwlog

    1.) Change all values (URL of FTP server, FTP password...) according to your preferences on and save the changes

    3.) login to the router and stop WRTbwlog

    cd /tmp/bwlog

    4.) go to the directory /tmp/bwlog/data and delete all files except the file 'config'

    5.) Now you can repack WRTbwlog and upload it to your own server

    cd /tmp
    tar -czvf mywrtbwlog.tgz ./bwlog/
    ftpput -u myftpusername -p myftppassword myftpserver /myftpdirectory mywrtbwlog.tgz
    rm mywrtbwlog.tgz

    (of course you'll have to adjust the ftpput line above according to the settings of your FTP server)
  15. techspy

    techspy Network Guru Member

    Thanlks, I will try it when I get home.

  16. techspy

    techspy Network Guru Member

    OK, I made the changes and saved it on my webserver. It is downloading correctly and starting but it isnt attempting to download the backup file. If I click the "restore last backup", it works. So I tried starting wrtbwlog from hyperterminal by having it download from my webserver etc. It worked but still didnt try to download the backup file. It even started faster than normal. I mean once I hit return after start.sh, it showed "please wait" for about 5 seconds then went back to "/tmp/bwlog #" and it was running.
    I remember before it was taking longer and showed the info that it tried to download the backup file from Any ideas on this?

    Thanks, John

    ps: I watch my ftp server at startup of wrtbwlog and no account rrys to log in.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice