WRTG54G internet connection problem

Discussion in 'Cisco/Linksys Wireless Routers' started by Metalbolt, Mar 4, 2006.

  1. Metalbolt

    Metalbolt Guest

    Howdy all,

    I've had my router since the begining of December, and up until this point I've had no problems. Then last week after a reinstalled Windows Xp my router takes a dump. Well, a half dump. No internet, but it was still connected to both of my computers, one wireless, one hard-wired, as I can still access the management screen by typing in the routers IP. It is also still connected within my home network just fine, as I can still send files between my computers. I tried rebooting the router, it didn't work. When I noticed the new firmware, I upgraded, "BAM!" worked like a charm!

    That is, until this evening. I'm a heavy user, I use my cable connection for work and play, I'm on it at least 8 hours a day. So I know for a fact that it has been working flawlessly this past week. So, tonight it crapped out again. Same problem. I tried reflashing the firmware, tried doing it in management mode, I looked at every setting that i could make sense of, but to no avail. I know that it is the router, because when I plug straight into my modem, as I currently am, I have no problems. After I flashed it the last time, my connection to the net stayed live for maybe 5 minutes, then it went dead again. That is the longest all night that I have managed to get it working.

    I would appreciate any help you all can give me. If you need more info than I have given, let me know what.

    Much thanks,

    Also, I have yet to contact linksys, since as I've read on here, they seem to be less than helpfull. And, you know, if it can be avoided, I like to avoid such things.
  2. MarcJoli

    MarcJoli Guest

    This sounds very familiar. I have the same problem I think.

    I had my WRT54G v5 working great since December, and then a couple of weeks ago, the internet side of the router stops working.

    I can ping it, get to the router's menus, and the LAN seems to be working between the connected computers.

    I flashed the firmware and reset multiple times. The flash looks successful, but still no internet.

    I was wondering if maybe this went down because of some kind of a virus or other kind or attack? I did notice that when the router started failing, my kids were on AIM on one computer when browsing on another computer was failing to get out.

    I am a networking newbie, so please any help or tips would be appreciated.
  3. johann316

    johann316 Guest


    I have the same problem....worked fine until 12 noon thursday and BAM. Nothing. NO internet....I unplugged my router, and connected directly through the modem with no issues. I can't figure it out...HELP.
  4. columbians

    columbians Network Guru Member

    I have a wrt54gs v5 router with v. 1.50.5 firmware. I was battling connection issues until making the following adjustments:

    On router look under Setup -- Basic Setup
    1) Change MTU setting on your router to "Manual"
    2) Now change MTU size to 1200 (recommended for accessing secure sites)
    Save Settings

    On router look under Administration -- Management
    1) Find and Disable UPnP.
    Save Settings

    I have had consistent connectivity after implementing these changes, after being very frustrated initially. I know this does not address the gaming issues that the move from Linux has created for some (can't load 3rd party firmware on this router, due in large part to the reduction in memory on these version 5 routers). Still, maybe some will find this post helpful. :thumb:
  5. bodydoc

    bodydoc Guest

    Connection Issues

    I had the same issue. The internet connection just stops working. You can access the router web page and release then renew wan IP and reboot your PC. This should temp fix the problem. But it will go down again. I have been on the phone with Linksys for 4 hours in the last 5 days!!! There is a major problem with V5 routers. I finally got a level 2 person to issue a RMA, unfortunatley this did not fix the problem. Now the RMA dept is going to ship me a V3 router, which I think is the best.
  6. Boc_est1986

    Boc_est1986 Network Guru Member

    having a simnilar problem. I am running the WRTG54g V5 with the latest Linksys firmware, flashed today. Was working fine until about a week ago when all of a sudden the internet just dies. Reboot the modem and the router and its back up but them bam it goes down again. I stop downloading and just browse the internet, everything is fine so i try downloading but bam 5 mins later all is dead. Looks like a downloading problem for the router almost as if it has had a donload limit placed on it and it just dies when it reaches its limit
  7. NateHoy

    NateHoy Network Guru Member

    A similar problem has plagued the Linksys (and many other consumer model) routers for some time now. This is especially troublesome for P2P (BitTorrent, Kazaa, Limewire, eMule, etc) users.

    Any router with NAT generally has to maintain a NAT table, which keeps track of the active connections from client computers on the router to servers on the Internet. No entry in that table, no connection.

    Entries can only be deleted from that table when the connection is disconnected, which happens due to a specific disconnect (usually) or a connection timing out (frequent), or an active connection "idling out" (when the connection has not been used in a long time).

    The first problem is that most P2P clients do not disconnect any connections, they depend on the network driver to time out connections when they are done (sorta within the nature of an ad-hoc network of that type).

    The second problem is that the WRT54G's native firmware usually only allows 2,048 connections in the connections table ("iptable").

    The third, and silliest, problem is Linksys' chosen default for turning "active" connections into "idle" (and therefore recyclable) connections. FIVE DAYS.

    The symptoms of a full iptables are:

    1. Any connections made BEFORE the table filled up, that have not been disconnected, work perfectly fine.
    2. No new connections can be made to any server.

    Eventually, P2P will eat up all of the connections available in the router, and as your well-behaved applications release their connections like good little network clients, P2P will gobble those up, too.

    The ONLY real fix in V4 and earlier hardware is to load aftermarket firmware that allows you to adjust the number of maximum connections up, and the idle timeout value down.

    Sadly, since Linksys has castrated the V5 hardware, aftermarket firmware is not an option.

    IF this is your problem, your options are:

    1. Reduce the number of simultaneous connections in your P2P clients. Your global maximum # of connections should be under 100, and you'll have to experiment with the right setting, which will change based on your specific circumstances. In other words, dumb down your P2P client.

    2. Call Linksys and give 'em hell until they finally change these silly defaults to something useful. Good luck, you'll need it.

    3. (what I recommend). Take that castrated handicapped POS back to the store and return it, and get a WRT54GL or WRTSL54GS, both of which are Linux based routers and quite excellent, then load up some aftermarket firmware (HyperWRT Thibor, DD-WRT, or another one).

    note - in some cases, Linksys has agreed to replace the V5 crap with one of the older models in a pure shipping-costs-only swap. If you can get them to agree to this, GO FOR IT.
  8. Boc_est1986

    Boc_est1986 Network Guru Member

    have been running P2P and Bittorrents since i've had the router and no problems only been in the last week that its become a problem. Tried messing around with max connection settings and still no joy. the problem isn't just with P2P bittorrent etc i can be downloading form normal internet sites and the problem still persits
  9. olinger69

    olinger69 Guest


    I have a wrt54gs v2 (I think) and was using p2p software, then yesterday when I get home from work, connected to the router, but no internet. I also had an issue with windows firewall (which I wasn't using). Dont know if any of this is coincedence or related, but I have a direct connection to the modem and its fine. Linksys site is down now.
  10. Boc01

    Boc01 Guest

    Same as me widows firewall has problems and the router is usueless. Have been getting email support from Linksys but so far no good i've performed a hard reset thinking it may be the settings but still no joy. Have just emailed them saying its still under warrenty so i'd like a replacement. See what they have to say about that
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice