WRTG54S Firmwear problem.

Discussion in 'Cisco/Linksys Wireless Routers' started by Picard102, Mar 10, 2005.

  1. Picard102

    Picard102 Network Guru Member

    I did an update on the firmwear on my router and everything went smothly. It said Update Compleate and then I "clicked to procced" and the router stoped responding, and the power light was flashing.
    I constulted the Knowlage Bank at Linksys and used Answer 175 to try and reinstall the new firmwear. I did as instructed and I was able to ping the router. I tried to run the install from the CD but it couldnt connect to the router, and I tried to use the WRT54G to flash the firmwear but it failed to connect too, even though I could still ping my router.

    Is there any way to reset the router to a good version of the firwear manualy, or has my router been fried?
  2. howardp6

    howardp6 Network Guru Member

    Hopely when you did your firmware upgrade, you did through a wired connection and will do so in the future. Did you run the firmware upgrade exe after identfying the ip address of the router that is connected directly to your PC nd entering the password? If you know the ip address of the router you can tftp the firmware bin file to the ip address of your router, you must specify that the the file is in bin format with the -i switch. If the firmware successfuly upgrases your router. I would leave it on for a short period of time to make certain the firmware upgrade is completed. If the power light is not flashing I would do a hard reset on the router to return it to factory defaults and try to reconfigure the router.
  3. Picard102

    Picard102 Network Guru Member

    I did.
    I did, and got a response when I pinged the router. But the update either says Unable to connect, or inocrrect code system.

    -i switch?
    I tried tftp 'ing the firmwear to the router, though I dont know if it was -i switched, and it said unable to connect still. Even though I can ping it still.
  4. Picard102

    Picard102 Network Guru Member

    It seems leaving it unpluged over night did something to it. I tried to flash it with TFTP again and it worked. The light stoped blinking, so I hit reset on the back to defualt the settings. The light started flashing again. So I tried to flash it again, but couldnt connect. So I reset my tcip configeration to normal, and was able to reflash it, and was able to enter the admin interface.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice