WRTSL54GS and Vista compatibility

Discussion in 'HyperWRT Firmware' started by bigclaw, Jan 31, 2007.

  1. bigclaw

    bigclaw Network Guru Member

  2. Thibor

    Thibor Super Moderator Staff Member Member

    that claim refers to the network component only, and not the storage link features. i am in contact with Cisco regarding this issue and i'm sure they will release a compatible firmware soon. have you tried their release version to see if it is compatible?
  3. bigclaw

    bigclaw Network Guru Member

    I see.

    I don't have a copy of Windows Vista yet. One of the factors that determine when I upgrade to Vista is the SL support.
  4. Thibor

    Thibor Super Moderator Staff Member Member

    it WILL have full vista support, it's being worked on right now.
  5. zerosc

    zerosc LI Guru Member

    I can't seem to connect to my USB HDD, which is connected to the WRTSL54GS, via My Network in Vista. Is this a know problem as mentioned above? Is there a way around it? The FTP function works, both through a client (CoreFTP Lite) and through Vista's "explorer" (My Computer, etc).
  6. Thibor

    Thibor Super Moderator Staff Member Member

    that is what this thread is about: VISTA compatibility. we not it's not compatible right now, but it WILL be.
  7. zerosc

    zerosc LI Guru Member

    thank you, just wanted to clarify. I guess I should just wait until Linksys release the next GPL code then.
  8. Thibor

    Thibor Super Moderator Staff Member Member

    unless you don't want to wait, and can rewrite samba yourself. whichever suits you more i guess
  9. zerosc

    zerosc LI Guru Member

    Just curious, since I have little experience in programming, what would I need to do to get this to work? A simple breakdown of the tasks would suffice.

    I started doing some reading and found out that a new version of Samba that is compatible with Vista has been released.

    Just want to see if this is something that I might be able to try.
  10. Thibor

    Thibor Super Moderator Staff Member Member

    go for it mate.
  11. zerosc

    zerosc LI Guru Member

    So I googled "samba vista" and found this.


    I tried doing option 1, changing the security policy on my Vista. Sad to say, it didn't work. Anyone gotten it to work? Anyone got any idea why it didnt for me?
  12. Thibor

    Thibor Super Moderator Staff Member Member

    it didn't work when i tried it either. I'm sure Linksys will have a beta available that fixes this very very soon. very soon :)
  13. setaylor

    setaylor Network Guru Member

    Meanwhile, if you use secpol to change your LAN authenitication method (or modify the registry key:


    from 3 to 1

    you CAN connect IF you map the samba share as a network drive. Files can be read, written and listed this way. If you just browse to the share, you can not write files to the share.
  14. zerosc

    zerosc LI Guru Member

    Ditto, see my post above. Mind if I ask how your extern HDD is set up? Also, what version of the firmware are you running? What version of Vista are you running? How is your network/sharing policy setup?
  15. setaylor

    setaylor Network Guru Member

    As I mentioned, it ONLY seems to work if you MAP the share to a network drive.

    If you just BROWSE to the share, it shows, but fails.

    I have reproduced this behavior on 3 Vista machines. I should mention that my share username and password is a Vista username password and the workgroup is the same, but I have not tried to break this.
  16. zerosc

    zerosc LI Guru Member

    Yea, I think it's working, the key is, like you said, to set the user name and password the same as the one on my Vista box. I basically had to create another user in the admin group (in storage/administration). I wonder if you have to do that for all people who want access. Anyhow, prior to this, I had already set the security policy as well as tried mapping the shared storage, BUT i only had "admin" and "guest" users. Thanks, this just made my day.
  17. c4mil0

    c4mil0 Guest


    The solution to access the samba and then the router and the device connected to the router its quite simple just follow this simple instructions:

    Make sure you enabled the run button on the start menu to do this
    (most vista configurations have this disabled)

    1.right click start menu
    2. Settings
    3.Start Menu
    5.Go to the run button and enable it

    On run write

    Console Root
    Local Computer Policy
    Computer Configuration
    Windows Settings
    Security Settings
    Local Policies
    Security Options

    there we change the following politics

    x1) Microsoft network client: Send unencrypted password to third-party SMB server: set to "Enabled".

    x2) Network security: LAN Manager authentication level: select the option: Send LM & NTLM - use NTLMv2 session security if negotiated.

    And thats it folks, it will work just fine like xp, without needing to change the login or password anywere, wich its the right solution for me cause i got diferent rights on accesing files to the diferent clients in my own network,

    Greetings from colombia


    Got the following problems though , i can now see it but then in some pcs it will see the folders and the folders will be empity, this is as far as i can make it work, anybody got a solving for this??
  18. dutchman71

    dutchman71 LI Guru Member

    I can see my files on my drive, I can copy them, delete them, but when I try to play an MP3 file with Windows Media Player it can't open the file, saying the file can't be found. (I double clicked on the file to get it to play).

    Works fine from my Xp laptop....

    Any progress on updates from Linksys Thibor?
  19. Thibor

    Thibor Super Moderator Staff Member Member

    there is a beta version 2.07.2 that i have confirmed as being compatible with Vista. when it's released i'll update with the new Samba.
  20. dutchman71

    dutchman71 LI Guru Member

    Excellent, I can't wait for the update.
  21. bigclaw

    bigclaw Network Guru Member

    I guess it's taking a long time for Linksys to push this out. I e-mailed their customer support to see if I could get a hold of the beta firmware. They said they would verify there was such firmware and get back to me later. That was three weeks ago. :)
  22. ka9yhd

    ka9yhd LI Guru Member

    Oh boy there is an echo here. :)

    ........... Just commenting on Carl double posting. hehehehe
  23. Thibor

    Thibor Super Moderator Staff Member Member

    What double post?
    i don't see any :)
  24. ka9yhd

    ka9yhd LI Guru Member

    I guess I should clean my glasses more often. :)
  25. mw1001

    mw1001 Network Guru Member

    I tried this way to access the file using Vista on two computers, but fail in both.

    The only method that I can access files thru Vista still mapping a network drive (with several limitations).
    How much time Linksys will need to release a firmware to solve this insure? We are waiting for 6 months… In the beginning this wasn’t a problem, because I was able to delay an upgrade. But I change two notebooks and the new ones are Vista based :(



    Hi everybody,
    After almost a hour chatting with Linksys support, I receive the following feedback:
    So, I must say: I’m not very optimist with the future of WRTSL….. Looks like they forgot about this model.

  26. mw1001

    mw1001 Network Guru Member

    Any news???

    Hi Everybody!

    Several months has passed since Vista’s launch and we (users) still without a solution. Linksys’s support doesn’t help anything and don’t know about the beta firmware or any attempt to solve the compatibility problem.

    Of course we can use some work around to mount a network drive and see/write files, but with a lot of limitations. Isn’t possible execute anything directly from the network driver, and this include the impossibility to run mp3 or videos with WMP (already mentioned in others replies to this thread).

    Anyone have any updated news about the WRTSL54GS and Vista compatibility?

  27. Toxic

    Toxic Administrator Staff Member

    there has been very little info on WRTSL54GS from linksys about the Vista fix. both me and Thibor are awaiting the fix avidly
  28. ifican

    ifican Network Guru Member

    I am so glad i remembered there was an issue, i fought this for 2 days and then finally it donned on me there was an issue i remembered reading about. So without further ado and further loss of hair, is there any new information on this one?
  29. Fredcombuese

    Fredcombuese Guest

    Does anyone knows if there will be an update for the WRTSL which is fully Vista-Compatible? Does anyone also knows the fixes in Thibor 17? I can´t find anything.

    Best Regards
  30. mw1001

    mw1001 Network Guru Member

    Looks like WRTSL54SL is dead to Linksys. One year has passed since this incompatibility was discovered.

    There isn't a official firmware fixing the insure. The samba version must be updated in firmware’s the source code, with wasn’t until now.

    I’m currently running DD-WRT plus optware to run a compatible version of samba. A lot of actions are needed (In special if you want user limitations) to make it work, but is possible.
    But I’m suffering a few random hooks when transferring large files from WRTSL’s HD to any WiFi connected computer. I have tried with several v24 betas and now with v24rc4 in combination with several samba version (including samba2). The router will hook only in this particular operation: large transfer from router’s HD to WiFi device.

    The strange thing is: I can transfer several gigs from/to wired computers to/from router. Will never hook!
    I also can transfer any amount of data from a networked PC over WiFi. The problem is only in the condition mentioned above (from WRTSL’s HD to WiFi computer).

    In resume, this combination (DD-WRT + optware + samba) will be compatible with Vista, but isn’t fully stable and a lot of procedures are required. My next attempt will be install an older DD-WRT (23sp2) and, if this doesn’t solve, will try openWRT.

    But is really frustrating the necessity of use a non default firmware to make a product bought this year (Q2) compatible with Vista! I have several Linksys routers, but this will be a relevant factor before consider buy another Linksys product.

    Sorry my terrible English :p

  31. jmranger

    jmranger LI Guru Member

    SL dead ?

    Carl & Simon,

    Do you still expect Linksys to release a new firmware for the SL, ever ?


  32. bigclaw

    bigclaw Network Guru Member

    Obligatory check to see if anything interesting is happening.

    Has anybody been using Vista and the WRTSL54GS together with any degree of success? The most promising solution was to

    1) Downgrade Vista to using NTLM authentication, and/or
    2) map the NAS directory as a network drive

    What was the problem with the above approach again?

    This is the catch-22. Because of this problem, I haven't upgraded to Vista. Because I haven't upgraded to Vista, I can't test the above approach myself. :)
  33. MarkInDavis

    MarkInDavis Network Guru Member

    Let vista wait. Believe me you aren't missing anything. My wife has an old XP laptop, I bought her a new one with fast core duo processor but it has Vista. She won't use it. It crawls. I've tried it myself and it is just slow. I have turned offf aeroglass and other snazzy features but it is still slower than the old XP machine.

    I mapped the network drive and don't have any issues accessing it with the vista machine, but I haven't done a lot with it.
  34. Toxic

    Toxic Administrator Staff Member

    well. thats a $65000 question. we ask, we ask, and we ask again. we ususally get the same replies. then main problem is Vista and tbh Vista should have added a fix, yet we see OEMs weakening again to the Microsoft empire. Hell, it took MS 6 months to release a file copying bug for Vista.

    I'll see if there is any news on this but dont hold you hold your breath.
  35. bigclaw

    bigclaw Network Guru Member

    I finally installed Vista Ultimate tonight. To my surprise, I didn't have to do No. 1 above. Somehow NTLMv2 is working for my Vista and WRTSL54GS. I'm not sure what's different in my case.

    I did have to map a network drive in order to see files. Also, I did have problem with Windows Media Player 11 trying to access media files. I didn't have a problem with realplayer and its rmvb files. Not sure what protocol WMP11 uses to access the files.

    Finally, it's very slow accessing the network drive, much slower than XP.
  36. RoadRanger

    RoadRanger LI Guru Member

    Anybody try Thibor 17RC3 with Vista?
  37. Toxic

    Toxic Administrator Staff Member

    Thibor was waiting for an update from linksys on the samaba issue with vista. I think he got tired of waiting.
  38. CoveredWagon

    CoveredWagon Guest

    Vista maps IP address not name

    I have Linksys version 2.07.2 on my WRTSL54GS and my Vista Home Premium laptop can map and use a drive using an admin account and the WRTSL54GS IP address but not using the Machine Name. My XP machine can use either IP address or Machine Name. All machines are using workgroups not domains. Behavior is the same when workgroups match as when they are different.

    I did a live chat and got 2.07.5 (2.07.2 was not available). I have not tried it yet. Hope the upgrade goes well as the only version I have to go back to is 2.06.0. Unless someone knows a way to backup the firmware currently on the device?
  39. DRTigerlilly

    DRTigerlilly LI Guru Member

    Could you share the firmware with us?
  40. hogrod

    hogrod Network Guru Member

    It would be nice to get this beta firmware somehow, after contacting linksys via live chat they claim it doesn't even exist and the only way to get the USB link working is to edit the registry in vista.

    I did find version 2.07.0 which is higher than the version on the actual product page(2.06.0) but its in a format that I have no idea how to use. maybe someone here could get it working and see if this fixes the vista issues.

    scroll down to where the WRTSL54GS you'll find 2.07.0

  41. chodaboy19

    chodaboy19 LI Guru Member

  42. hogrod

    hogrod Network Guru Member

    any other options

    Is there any hope to get the USB working properly in vista? looks like hyperWRT is pretty much hit the end of the road now, so does anybody know of another firmware that gets this working?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice