WRTSL54GS: Can't get it to recognize an Ext3-formatted disk.

Discussion in 'Cisco/Linksys Wireless Routers' started by meq123, Mar 20, 2006.

  1. meq123

    meq123 Network Guru Member

    I want to use a network disk to store backup files (mostly in the form of large Ghost files) and, as seems to be well-known now, the SL doesn't do this too well on FAT32 disks. Note: I have Tofu13c firmware loaded on it (so that NTP works!)

    So... I've tried a number of ways to format my USB disk (160GB) via ubunto (e.g. fdisk/cfdisk followed by mkfs.ext3) and later, I even took it to a friends house to use his copy of Partition Magic v8 to format it. In every case, the SL "sees" the disk, but doesn't see any partition on it. When I try to do a Share/Select Partition, nothing shows up.

    When I use the SL's own commands to erase/claim the disk, it reformats back to FAT32. (On my 160GB disk, the "full erase" took over 24 hours to finish!)

    What am I doing wrong? I saw the vincentfox had ext3 running on his (and said it cured some of the large file issues). Can anyone help me get there?

    For reference, this is one version of a set of commands that I tried from ubuntu:

    : fdisk /dev/sda
    --> Command: o
    --> Command: n (-> p, 1, <defaults>)
    --> Command: w
    : umount /dev/sda1
    : mke2fs -m 1 -F /dev/sda1
    : tune2fs -j /dev/sda1 -L netdsk -i 0
  2. Thibor

    Thibor Super Moderator Staff Member Member

    vincentfox uses openwrt on his SL
  3. vincentfox

    vincentfox Network Guru Member

    Yeah I haven't used HyperWRT yet just Linksys and OpenWRT. As soon as I get another SL to play with.

    I noticed the original Linksys firmware had reiserfs commands, did you carry those across Thibor? Reiser should work as well as Ext3 does.

    Do a cat /proc/filesystems to see what your kernel supports.

    I'm not sure if the problem actually lies in the kernel-level FAT stuff, or if it's something that is only triggered by Samba usage. The fact that Samba works better with non-FAT formats does seem indicative, but it is not conclusive. I keep meaning to hook up two hard-drives with FAT format and do some command-line copies and see if it generates any errors, just haven't gotten around to it.

    It's raining here, reduces my motivation levels....
  4. vincentfox

    vincentfox Network Guru Member

  5. meq123

    meq123 Network Guru Member

    Thanks a lot for the update, and continued investigation! PLEASE keep me/us informed with any further progress. Thank you. :bow:
  6. meq123

    meq123 Network Guru Member

    :cheering: O' vincentfox... You are king :thumb:

    From your comments here and in the other thread you referred-to, I formatted my hard drive as reiserfs and mounted it and verily it is good! Copied a 700Meg file and it started fine with an immediate progress bar window and completed with no weird errors! Hoorah!

    I am still running Tofu13c, and had one change to the commands you had stated - the addition of "-q" to the mkfs command, else it asks a "continue y/n" question and errors out.

    So for anyone else following this, my command list was as follows [Note: I had fdisk'd my drive already on another machine]:

    mkreiserfs -l netdsk /dev/scsi/host1/bus0/target0/lun0/part1 -q
    mkdir /foreign_shares/netdsk
    mount /dev/scsi/host1/bus0/target0/lun0/part1 /foreign_shares/netdsk

    So the open issue still is how to automount the disk.

    Finally, one more question, (Linux newbie alert) why use /foreign_shares as the mount directory instead of /mnt? Does it matter?

  7. vincentfox

    vincentfox Network Guru Member

    You know I have no idea why not to use /mnt.

    I just noticed that the Linksys firmware was referencing /foreign_shares so that's where I added mine.

    I don't recally this -q being required, but I used Thibor14.

    Glad to hear it's working out for ya!
  8. Thibor

    Thibor Super Moderator Staff Member Member

    Reiser is detected and mounted correctly now, i'll see if i can get ext2&3 working in the same fashion. i do still have the issue with Claim_Disk though, it will only work for FAT32
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice