WRTSL54GS ftp help, HyperWRT Thibor

Discussion in 'HyperWRT Firmware' started by msde, Nov 30, 2006.

  1. msde

    msde Guest

    I finally found a spare USB stick to try out FTP on my WRTSL54GS, and I've been running into trouble. I'm able to access the share via SMB and FTP locally, but I seem to be unable to access it from outside.

    I've enabled both the FTP Server and WAN FTP Access radio buttons in Storage/FTP Server configuration, and I've tried changing the port in case 21 was blocked. (Is the FTP Server needed, or is WAN FTP access enough? I don't need local FTP.)

    I've tried adding the port to the port forwarding rules. (Is that necessary, or is the router smart enough not to block that port?)

    Does anyone have any suggestions?

    I'm running "Firmware Version: v2.00.5, HyperWRT + thibor15c+grcore6"

    Thanks in advance!
  2. skilmer

    skilmer LI Guru Member

    I've got the same trouble. I have never been able to access the ftp from remote. I'm using the stock Linksys firmware, the newest one just released, and I still can not connect remote with ftp.
    What is the command to access it remote? Maybe I'm not doing it right.
  3. windage

    windage Network Guru Member

    ftp access from internet

    Ya I have the same trouble. I can get it to accept the login but won't open the file folder. I am assuming it's because ftp just doesn't use one port. eg:21 It needs to have several data ports open as well. I have used scp with good success and have given up on ftp.
  4. Thibor

    Thibor Super Moderator Staff Member Member

    perhaps there's a bug in grcore6 with regards to ftp usage. T16 is due out very soon and this has been addressed for it's release
  5. Toxic

    Toxic Administrator Staff Member

    what FTP client mode are you using guys? you should be using Passive mode on you FTP client and not active.

    skilmer as long as you ahev setup a share on the storage with a group, username/pwd you should be able to get this to work without any problems.

    adding the group guest should allow access without any prompt for username/password afaik. make sure your admin pwd is changed from default.
  6. skilmer

    skilmer LI Guru Member

    Ok I connected but I'm local now. I changed it to passive. I only have trouble when I'm remote.
    What would I have to type in the browser to get into it, or should I be using a ftp client.
  7. skilmer

    skilmer LI Guru Member

    Also another note.
    What if my internet provider blocks port 21. Can I change that to a port that is not blocked and have that work?
  8. Toxic

    Toxic Administrator Staff Member

  9. skilmer

    skilmer LI Guru Member

    I do not have a domain. Would I change the domain name with my address that my provider gives me?
  10. Toxic

    Toxic Administrator Staff Member

    ftp.yourdomain.com will be an IP address then if on the LAN it will be the LAN IP if your allowing users access over the internet then WAN IP address or domain name OR DDNS name.
  11. Bill_S

    Bill_S Network Guru Member

    Has anyone had the FTP server working, if so what is your secret? I think I have tried everything, set mode to passive on WS_FTP, used port 21 then tried using port 1021, put guest account in share access list, turned off firewall and unblocked all ports and filters on the router, setup port forwarding to port 21 then to port 1021. Nothing works, from the outside but I can FTP in from inside my network. I can also remotely log on to my router and I can access my PC from the outside using remote desktop. So I think my ISP is not blocking access.

    I did have it working using Thibor 15c but I moved the router to another location and now nothing. I loaded Thibor 16 and get the same results.

    Anybody have any suggestions?

  12. Thibor

    Thibor Super Moderator Staff Member Member

    1. You don't need port forwarding.
    2. make sure you have enabled access, i saw your other post, correct it by:
    nvram set ftp_share_access="2:admin:rw:guest:r" and group_users="admin:1:admin guest:1:guest"
    3. Make sure you're ftp'ing to the remote port and that it's enabled in the router. check by nvram get remote_ftp; 1 is enabled, and nvram get wanftp_port for the remote port.
    also make sure you have given access permissions to the user you are trying to use, if you give guest access, it's anonymous and no user/pass is required.
  13. grcore

    grcore Network Guru Member

    Remeber that if you set a forward for a particular port, then uncheck the enable button it will block that port specifically. remove any fwds you have set manually.

  14. Bill_S

    Bill_S Network Guru Member

    Ahhh guys, I am sorry to say that I don't understand what I am being told.

    Thibor are those Linux commands and if they are how do I enter them (using WINXP Pro SP2)?

    Grcore when you say remove any fwds manually other than unchecking them is there something else I need to do?

    Sorry for the lack of understanding, but thanks very much for your efforts.

  15. Thibor

    Thibor Super Moderator Staff Member Member

    you run those commands in a telnet window. to remove those unticked port forwards, in the help on the right hand side of the forwarding window, it says to enter 0 as the ip address and save, it will then be deleted.
  16. Bill_S

    Bill_S Network Guru Member

    Thanks Tibor, one more question. In the telnet session should I enter the command like this or do I break it up?

    nvram set ftp_share_access="2:admin:rw:guest:r" and group_users="admin:1:admin guest:1:guest"
  17. Bill_S

    Bill_S Network Guru Member

    Still cann't get in, what about the security settings, should the firewall be turned off. Right now I have the firewall on and the following boxes checked:

    Block Anonymous Internet Requests

    Filter Multicast

    Filter IDENT(Port 113)

    I can get in without any problems inside my network.

    Ahhh the mysteries of computing it really is an exact science.
  18. Thibor

    Thibor Super Moderator Staff Member Member

    do the 2 nvram commands as seperate commands, and finish them with "nvram commit" to save the vars to nvram. firewall should be ON. if you are filtering ident, untick the ident requests box in the ftp page, otherwise it'll take longer to connect from outside the network.
    you should also do nvram set nas_login="admin:admin:admin guest:guest:guest" too, and don't forget to do a nvram commit. or you COULD just reset to defaults as i've said before, considering you aren't technically proficient.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice