WRV200 Beta Firmware v1.0.33 Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Jun 14, 2007.

  1. Toxic

    Toxic Administrator Staff Member


    WRV200 Firmware 1.0.33 Release Note

    6/13/2007 (Beta Testing)

    Issues Fixed:
    1. Fixed the issue where the Web Admin Interface (with Remote Management enabled) will be locked out after the router is up for 5 to 7 days.
    2. Allow SIP Application Layer Gateway to be disabled/enabled on the Firewall->General page.
    3. Fixed an issue where the Syslog Daemon may stop working, when Syslog is enabled.
    4. Fixed an issue where the IPSec Key Lifetime cannot be changed.
    5. Fixed an issue that only the first 8 Port Forwarding entries can work.
    6. Fixed an issue that only the first 8 QoS Priority Queue entries can work.

    Known Issues:
    1. IPSec tunnels do not pass NetBIOS broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    2. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.

    Download the firmware here: http://www.linksysinfo.org/forums/downloads.php?do=file&id=57 or contact Linksys Tech Support
  2. ghost_zero5

    ghost_zero5 LI Guru Member

    Does anyone already know if this will finally fix the FTP/ICQ/VoIP-Troubles after some day of connection - maybe the SIP firewall part (at least for VoIP but the rest)?
  3. Toxic

    Toxic Administrator Staff Member

    and are you able to replicate your issue with 1.0.33 ?
  4. ghost_zero5

    ghost_zero5 LI Guru Member

    Haven't installed yet... will do so tomorrow...
  5. Sfor

    Sfor Network Guru Member

    I've been running this firmware version for a quite some time, already. It does work better than, in general.

    I saw no new bugs, so far. But, there are a few old bugs derived from the older firmware versions, however.

    - it does appear, router does a self reset, from time to time. I think this kind of behavior begun with firmware. But, the GUI and other router services seemed to be much more stable, from the same moment. The downside of it is the fact, the local LAN connection is breaking during the router reset. So, it is wise to form LAN with a separate LAN switch. The router self resets should not impact the LAN stability, that way.

    - the "Automatically adjust clock for daylight savings changes" function is not available for all GMT +01:00 time zones. It is necesary to switch the time zone to a GMT +02:00 time zone, during the summer.

    - it is not possible to ping the WRV200 through a IPSec VPN tunnel. All remote LAN devices but the remote router are responding. It is also not possible to use a remote WRV200 GUI through IPSec tunnel, as well. I'm not entirely sure if it is a bug, or a desired feature. As, it is not a desired feature, for me, certainly.

    - some SysLog entries are corrupted. It is not a frequent situation. But, it happens.

    - the cancel changes link does not work correctly. On the static IP setup page the timezone was not restored, after the "Cancel changes" link was used.
  6. ghost_zero5

    ghost_zero5 LI Guru Member

    TimeZone-Settings problem: If I set to GMT+1 (Amsterdam, Berlin, ..., Vienna)
    the automatically adjust to daylight savings time cannot be set and especially is UNSET.... Which means the routers time is going one hour behind...
    This was still set with v1.0.29 (hadn't installed 1.0.32) - of course I mad a factory reset after firmware upgrade that is why i had to reset it to gmt+1 after all... But wouldn't it be best to make that option changeable no matter what in any case?

    EDIT: Just saw it Sfor reported this already...
  7. Sfor

    Sfor Network Guru Member

    Well. This bug has a long story, already. This is a shortened version:

    At first, it was possible to turn the daylight saving on, with all GMT +01:00 time zones. But, the time correction was not working properly. And I reported it as a bug. Then the feature was disabled (instead of fixed).
  8. netgeek

    netgeek LI Guru Member

    AIM/Yahoo/ICQ/FTP Issue

    I for one can say that I am still having the problem with these clients where they will disconnect and require a reboot to have them working again.
  9. Sfor

    Sfor Network Guru Member

    I've encountered a problem with HTTP traffic. Pages were loading partly, or not at all. Router reboot solved the problem.
  10. CalledToConstruct

    CalledToConstruct LI Guru Member

    I've been wondering if the performance counters (bytes in/out) are exceeding their maximum range and therefore corrupting memory adjacent to their storage / or causing an overflow exception.

    It would certainly not happen if the router is restarting every few hours. However, if the problem can be resolved and a restart unnecessary, that would be greatly preferred.

    // Joe
  11. DerToob

    DerToob LI Guru Member

    I assigned a static IP for my Computer, but the DHCP Server does not tell XP any network settings. I had to assign manual settings to get in contact with the device again. Even rebooting did not solve the Problem...
  12. Sfor

    Sfor Network Guru Member

    Well, I'm a bit confused.

    If a static IP is selected in a computer, it uses DHCP, no longer. So, a computer with static IP can not get any other network settings through DHCP protocol.

    Only dynamic IP (DHCP) provides computer with all setting (I mean: IP, net mask, gateway IP, DNS servers IPs).

    But, perhaps, I did not understood your point.
  13. DerToob

    DerToob LI Guru Member

    My english isn´t perfect, so i think you didn´t understand, what i want to express ;-)

    I did not select static ip in network settings under Windows XP.

    But you can assign a static ip in the router settings.
    The DHCP server provides the specific mac adress with all settings including the ip, i reserved for it.
    Up to version 1.0.32 i had no problems, but in 1.0.33 it would not work.

    When i set up the TCP/IP settings by hand in network configuration with the specific ip i reserved, XP tells me, that the IP is still in use by another network device.
  14. Sfor

    Sfor Network Guru Member

    I'm using the "Assign Static IP" feature and everything workd fine, so far.

    It sounds, like you have another computer using the same IP in your network.

    Anyways, I'm unable to reproduce your problem, I'm afraid.
  15. fowen

    fowen Network Guru Member

    This is the same behavior that I have seen with a BEFSX41. I can ping and connect to all devices except for the IPSec endpoint.
  16. CalledToConstruct

    CalledToConstruct LI Guru Member

    I'm able to ping the WRV200 through the IPSec tunnel via it's local IP address (192.168.x.x) but I'm not able to access the GUI. I've not tried to ping the router via it's WAN IP while connected via the IPSec tunnel.

    It would be nice if it was a setting: Allow administration through tunnel [] Yes [] No

    // Joe
  17. Sfor

    Sfor Network Guru Member

    The pinging through the WAN works correctly, while devices are connected through IPSec VPN.

    I'm curious, why pinging through the IPSec VPN tunnel does not work for me. Can it be related to the tunnel settings?
  18. ghost_zero5

    ghost_zero5 LI Guru Member

    The FTP/ICQ Problem still isn't resolved...
    It still happens after some time (it never has been a specific time, it was always random, I don't think that has changed) that you can't connect to FTP anymore and loss connection to ICQ (although that one can be re-established but only for some seconds)... Only way to "fix" it, is to reboot the router...
    But I don't want to reboot the router every few days or hours...
    So my question is: When will this issue finally be solved?
  19. DerToob

    DerToob LI Guru Member

    I don´t know why, but changing the lease time to a different (new) time solved the problem after rebooting
  20. Sfor

    Sfor Network Guru Member

    Firmware upgrade takes some time. The adrenaline level goes up, while thinking about a power line failure.

    Doing an upgrade from Internet Explorer does have some advantages, as it displays a progress bar in the IE status bar. Firefox does not display a progress bar, so one starts thinking about possible troubles, resets and bricks with antennas.

    It would be good to see a progress bar in all browsers. Until then, doing upgrades with IE seems to be less stressful.
  21. Toxic

    Toxic Administrator Staff Member

    I must agree, most new official linksys WebGUIs do run better on MSIE than Firefox.

    I also find customising you AV package to ignore the routers WebGUI IP address speeds things up on the browser.
  22. Toxic

    Toxic Administrator Staff Member

    there is no feature to add a Domain name to the access rules. you could add a range of IP addresses, but thats all.
  23. ghost_zero5

    ghost_zero5 LI Guru Member

    The FTP/ICQ-Issue might be related to changing settings that don't require you to reboot... Although I am not sure of course but e.g. I just disabled VPN-IPSec-Tunnel A and a few minutes later ICQ and FTP wasn't working anymore until I rebooted the router...
    I don't know if that is the only reason for that problem to occur or if there are other things too or if it was just coincidence but maybe...
  24. srainess

    srainess LI Guru Member

    Cisco VPN Client & LOTR Online require reboot

    Cisco VPN client works sporatically until Router is rebooted.
    LOTR Online will freeze frequently until Router is rebooted.

    No change from last version.

  25. Sfor

    Sfor Network Guru Member

    I've been playing with the Static Routing settings in the Basic Settings - Advanced Routing screen. I looked in to the help section of this page. The help for the Interface drop down meny says:
    The problem is, there is no "Loopback" option available. I can select form "LAN & Wireless" and "Internet" options, only.
  26. Walrus78

    Walrus78 LI Guru Member

    Steve, i'm using the Cisco VPN Client with this firmware and i'm not having any problems at all. I'm using the 5.0 version of the vpn client. Is your transport over TCP or UDP? (i'm using UDP).
  27. ghost_zero5

    ghost_zero5 LI Guru Member

    It still occurs without adjusting settings too... It just happens sooner if you adjusted settings without router reboot...
  28. Baro

    Baro LI Guru Member

    I'm using Cisco VPN client 4.0.5 and I have a big issue. It disconnect after few hours and does not seem to be able to reconnect till I reboot the router. I'm using firmware version
  29. odessa11

    odessa11 Guest


    Automatic re-establish of PPTP (Keep Alive) connection is not working. Redial Period field is invisible (disabled?).
  30. srainess

    srainess LI Guru Member

    I will check version and post... Have to boot work laptop....
    BTW everyone... Since I'm being hosted by Dyndns, I have Dynamic DNS enabled. Every reboot puts in a request to update the DNS entry, which after a certain point is considered abusive by them. They blocked update until I fix.

    At least I believe this is the reason. Does anyone know if the update procedure checks to see if the external IP address has changed, or does it always put in an update request ?

    Just checked... Using 4.8 Cisco Client

  31. Baro

    Baro LI Guru Member


    I just encounterd this issue on

    I have a VPN tunnel between two WRV200 routers. Both have
    The tunnel is up, all devices in the remote network respond to pings, except the remote router itself.
  32. grimbeaver

    grimbeaver LI Guru Member

    Has anyone tested to see if this is fixed? I just installed a WRV200 at a client site and just ran into this. It also resulted in QuickVPN not being able to connect. I would rather not turn off remote management but I have to be able to keep QuickVPN connectivity up.

    Any opinions on if this fw is stable enough to install?

    Also how long is it usually between Beta and Release fw?
  33. Sfor

    Sfor Network Guru Member

    I do believe, the Web admin interface problems were fixed in the The router seems to reset itself keeping the Web interface working, now.
  34. deathscythebjorn

    deathscythebjorn Network Guru Member


    Did you hard reset the router after upgrading the firmware?
  35. Toxic

    Toxic Administrator Staff Member

    How long is a piece of string? there is no fixed date.
  36. grimbeaver

    grimbeaver LI Guru Member

    Especially when you are working with Cisco... they move our dates all the time at my work.
  37. ghost_zero5

    ghost_zero5 LI Guru Member

    Btw. I also would have something like a feature request regarding Wireless:
    1.) If I disable Wireless the Broadcast Enable or Disable should still get stored (that is always reseted to enabled afterwards)...
    2.) It would be great if you could also (in combination to whole Wireless) only disable certain SSIDs - without needing to remove the name....

    e.g.: I have some or at least one SSID that is not always active and that one should not broadcast SSID too, so this addresses both things...
  38. spejderen

    spejderen LI Guru Member

    WRV200 drops wireless on every reset in new Beta


    Since the "Fix" for the web GUI came I have had problems with the wireless being dropped and reconnected every 5-10 min. The router is at the moment useless for me since I can't browse without being dropped. :mad:

    When having 2 SSID's with 1 WEP and 1 WPA-PSk the router starts to ping the Pc's to death when the WEP SSID is being used.

    I upgraded the FW to 1.0.33 yesterday with no solution.

    I might start looking for another router... :mad:
  39. jtombre

    jtombre Guest

    The biggest issue that I have with the WRV200 is that it will rest it self all the time. Where no one is using it, or using it very lilttle it seems to work fine. You put any load on it and it will reboot. I can't believe this is not fixed in this rev.
  40. Toxic

    Toxic Administrator Staff Member

    when you say put ANY load on the WRV200 what type of load do you put on it? Can you replicate the issue on demand, and if so have you told linksys in how to exactly replicate the issue? without replication and specifics no one can fix any issues.
  41. Sfor

    Sfor Network Guru Member

    According to my observations, the WRV200 seems to reboot, when I'm starting my network, in the morning.

    There is almost no network traffic at night (except for SIP server registration), and I do generate some traffic when starting the network. Anyways, the effect is strongly unpredictable. I'm unable to replicate it on demand.
  42. srainess

    srainess LI Guru Member

    Ok... I am considering the same... I cant keep rebooting this thing just to make sure i get a valid connection. What would you replace this unit with ?
  43. TazUk

    TazUk Network Guru Member

    A couple of issues I've noticed with the 1.0.33 firmware, on the VPN Summary page it shows the status for my tunnel as T, (Try to connect to Remote Peer), even though it's up and working. I also seem to be having problems connecting to remote sites using PCAnywhere, some work some don't, this wasn't the case with the WRV54G I was previously using.
  44. srainess

    srainess LI Guru Member

    Curious... What made you switch from the WRV54G ?
  45. TazUk

    TazUk Network Guru Member

    The WRV54G lacks things like QOS, NAT-T, VLAN's, etc and I thought MIMO on the WRV200 would give me a better wireless signal.
  46. spejderen

    spejderen LI Guru Member

    replace unit

    Well I have talked to the support team from Linksys here in the DK and tehy belives the Unit is faulty and must be replaced. So I'll give it a go. If this don't solve the problems i'm looking for something else to do the job. Possibly a Dlink. I've had fine experiences with their eq before.

  47. Sfor

    Sfor Network Guru Member

    I was talking to a Linksys support agents about my problems with the router (mainly SysLog, clock, and WEB interface hangs). Finally, I was told to replace the unit, as well.

    They believed they do have a stable firmware, then. Well, they were wrong. The current firmware does not have those issues (at least for me). But it was almost a year, ago.
  48. srainess

    srainess LI Guru Member

    Ok... Yes the VLAN, and QOS was worth a shot. Have a friend who has the 54G though, and hasnt had any of the issues I'm having. Afraid to call support. Sometimes its like talking to a wall. Not sure what the warranty is on these things either... If they tell me to replace it at a cost, may just go for the 54G.
  49. srainess

    srainess LI Guru Member

    I know this may be a stupid question, but does a hard reset really make a difference, rather than just a power on/off ? I would hate to have to reset all the settings, if its just a precaution...
  50. Sfor

    Sfor Network Guru Member

    Yes, it does make a difference.

    At some older firmware revisions some default config data was not set, or set improperly. Also, new config fields are added during the firmware development. I had some problems because of not doing the factory defaults reset.
  51. DocLarge

    DocLarge Super Moderator Staff Member Member

    Think of "on/off" as merely sweeping the dust off the table whereas a "hard reset" is "scrubbing the entire house with a wire brush!" Everything gets cleaned!! :)

  52. srainess

    srainess LI Guru Member

    Will it wipe all current config information/settings (ssid, dhcp, local IP, etc) ?
  53. TazUk

    TazUk Network Guru Member

  54. Aeryn

    Aeryn Guest

    I now have Firmware Version: 1.0.13EU

    Can I safely use this new firmware. I remember braking an older Linksys AP because I used a US firmware on my EU(rope) model. How about the official firmwares on the Linksys site? They don't mention specific US/EU versions.

    Just want to be safe :)
  55. TazUk

    TazUk Network Guru Member

    I've used it on my EU WRV200 so it's safe :)
  56. Sfor

    Sfor Network Guru Member

    There was a change in my Internet WAN connection, a while ago. I had to change WAN settings from static IP to DHCP. The router was rebooting itself about once a week, on the static IP connection. Now the self reboots are much more frequent. In one case the router froze completely (no DHCP, HTTP, WEB UI) and I had to reset it by a power outage.

    Here is a description of a common router self reset event:

    I'm powering on one of my computers, then do some browsing through HTTP. Then I do power on another computer and I return to the first one leaving the second booting. While I'm browsing HTTP the Internet connection freezes for a minute or so. The second computer finished booting and it displays PM and POP3 connection error messages. I'm logging to the router WEB UI, and I can see it just rebooted itself.

    Looks like, the second computer does something to the router forcing it to reset itself. It could be a DHCP negotiation, or any other network traffic caused by a computer in a boot sequence.
  57. CalledToConstruct

    CalledToConstruct LI Guru Member

    I have been using FTP a lot lately, so the issue with the FTP passthrough freezing up has become much more apparent for me.

    The one thing I have seen consistently, however, is that it will freeze at the top of the hour. I don't have any other parameters to report as it happens (otherwise) at random: different ftp servers, different times during the day or night, different ftp clients, etc...

    The only consistent parameter is that it will freeze up on the hour. It won't freeze up at 9:30 or 8:55 or 4:28, but 1:00, 2:00 ... 9:00, 10:00, 12:00, etc...

    I hope this is helpful to the developers so they can get the issue resolved once and for all. :D

    // Joe
  58. MarkToo

    MarkToo LI Guru Member

    I hope this information is helpful as well... the unresolved FTP and SIP/VoIP issues have been a disappointment.

  59. ghost_zero5

    ghost_zero5 LI Guru Member

    Not to forget the ICQ-Problem (which should be related to the FTP-Problem because it happens at the same time the FTP problem occurs)...
  60. fdoibz

    fdoibz LI Guru Member

    I hope this information helps...
    I've noticed that if you change de local IP range to 10.0.0.x the FTP issue seems to be gone.
    I've been with this new IP range since last week, zero reboots and I can still login to external FTPs.
    Give it a try.
  61. mcannon-gso

    mcannon-gso LI Guru Member

    I have upgraded my WRV200 to 1.0.33 firmware.
    I did a hard reset and manually re-configured the router.

    The router seems to work fine with a couple of exceptions.

    I have set Static IP addresses in the "Assign Static IP" portion of the router.
    I have created "Access Restriction" for 2 of my computers.

    If the configuration is changed or the router rebooted during the restricted timeframe. These 2 computers can now get online. for some reason a reboot does not refresh the Access Restrictions to see if computers should be restricted or not..

    This seems like a bug unless someone can tell me if I am doing soemthing wrong..

    Also, I am using a VoIP device on it's own VLAN. Sometimes I receive some jitter during a phone call. Can someone tell me if disabling the DoS protection would disable SPI ? I know some adapters prefer not to have SPI enabled. I am using a Linksys PAP2T device..

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice