WRV200 FTP issues

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by mperry184, Dec 21, 2006.

  1. mperry184

    mperry184 LI Guru Member

    hi there

    after running for a day, we can no longer FTP without rebooting the router. i have upgraded the firmware to the latest version (1.0.24)

    does anyone have any suggestions on how to fix this

  2. Sfor

    Sfor Network Guru Member

    I have a similar problem. The FTP stopped working. After a router reset everything returned to normal. I have the 1.0.24-ETSI firmware, loaded.
  3. sparhawk

    sparhawk LI Guru Member

    That`s my problem too. No matter what QoS I attached, after running for a day or two FTP stopped working. After a router reboot problem is gone. I`m going crazy with that, because i`m connecting to many ftp servers very often, and for me it`s sth like reboot every day. That`s not the way it should be.

    Anyone has a way to fix it ?


    PS.Sorry for my English.

    I`m trying it now and I will post the results soon.
  4. Toxic

    Toxic Administrator Staff Member

    have any of you guys tried the v1.0.26 and confirm the problem still persists?
  5. sparhawk

    sparhawk LI Guru Member

    I tried yesterday the v.1.0.26 and problem still persist. Nothing has changed. The FTP stopped working after maybe 12 hours.
  6. Toxic

    Toxic Administrator Staff Member

    Thanks. is this an internal FTP or External FTP you are connecting too.

    I take it you are heavily using FTP over the 12hrs at a constant rate?

    What WAN connection do you have to the Net? Cable/ADSL pppoe static?

    sorry for all the questions but it may help identify the problem at hand.
  7. sparhawk

    sparhawk LI Guru Member

    If it can helps you to fix it that`s ok with me.

    It`s an external ftp connection. Well, I did few external connections to different servers, without success.

    Well, maybe not so heavily, I`m connecting very often to update some files, on few servers.
    I`ll try to see If this 12hrs has some meaning. I attached a reboot 2hrs ago, so I`ll check the connection after next 8-12hrs.

    It`s a cable/ADSL with static IP.
    I`m actually connecting to this router with Wireless, but I checked the cable connection, and problem is without any change.

    I`ll try Wireshark to see where the problem is (connection, authorization etc), and If you can help me HOW I can try to see syslogs or SNMP.
  8. Toxic

    Toxic Administrator Staff Member

    use wallwatcher for syslog reading
  9. mperry184

    mperry184 LI Guru Member

    ftp issue reply

    our ftp use is not heavy, and is with an external ftp location. we have a dynamic adsl connection into the office.

    i typically have to reset the router once a day for ftp to work properly.

    there does not appear to be any other internet connectivity issues beyond the ftp problem.

    we had/have an earlier linksys router which we upgraded to the WRV200. the earlier router did not have this issue.

    hope this helps.

  10. MarkToo

    MarkToo LI Guru Member

    Same issue for me using .26.

    Very light FTP usage, generally none at all... but, when I try to connect to external FTP servers I most often have to reboot the WRV200 before it will work.

    Hope this helps!

  11. ghost_zero5

    ghost_zero5 LI Guru Member

  12. mperry184

    mperry184 LI Guru Member

    the issue you are having does sound very similar ... other than its with icq.
  13. sparhawk

    sparhawk LI Guru Member

    No, This 12hrs is not a constant rate.

    It was not working after i don`t know maybe 14hrs, but it`s not a point the point is, that when I managed syslog and wireshark I was not able to see anything.

    Wireshark showed me sth like this:

    When I was enabling syslogs It was not working, but after save It`s just started to work. That was good for few minutes, and after that It`s not working. Next few saves finished without success.

    When I did nmap nmap -p21 -P0 somedomainnameftphost(ex.aaa.yoyo.pl)

    He did me an answer:

    Starting Nmap 4.20ALPHA11 ( http://insecure.org ) at 2007-01-05 03:08
    Interesting ports on v1.yoyo.pl (
    21/tcp open ftp

    Nmap finished: 1 IP address (1 host up) scanned in 0.407 seconds

    So he get IP address, so the problem is not in DNS.

    What the best, after that suddenly Everything starts to work good.

    Syslog shows me nothing. After some time I can say that my syslog reporting is not working. It`s saying that I`m restarting this process, but that`s all. After that there is a big silence.

    I don`t know what to say. Maybe sth is wrong with a memory, I don`t know. For me it`s sth with accepting or rejecting packets, and When i`m not using for a while (big while) it`s stop to work, after once he accept a ftp packet it starts to work.

    Is there any queue, that eth depends on it. He is dropping packets in some moment. And it`s not a DNS, because It`s resolving it allright. After He get an IP address he don`t know what to do next. Maybe he is dropping it at QoS queue or sth.

    I`ll check it for some time.
  14. sparhawk

    sparhawk LI Guru Member

    Now I don`t need to restart my WRV 200 to start work ftp.

    In the morning I checked the connection, and it refused my connection, but I did nmap:

    The State is filtered, which means that sth is with wirewall. After few seconds i did nmap second time, and what i`ve got

    State - open, strange...

    After that everything start to work without any problems.

    By the way I install nmap on Windows, and I`m using it under this system.

    After few minutes. It stops working. The Nmap state is filtered and It is not changing.

    Ok. For now, let`s say that. When I`m trying connect FTP it`s not working. I work around with this, and when I put some big file to download, or put some movement in internet connection, I can get the ftp. After stop downloading, and after stop doing anything in the internet I can connect to my ftp for few minutes. After that It`s not working
  15. ghost_zero5

    ghost_zero5 LI Guru Member

    OK. I now tried during my ICQ-Issue to connect to FTP and that was NOT possible too. So I believe even more that those issues have the same source, especially because after rebooting FTP worked again too...
  16. ghost_zero5

    ghost_zero5 LI Guru Member

    Well strange is that I didn't have the FTP/ICQ-Issue today. I don't know but before I had that problem every day... The only thing I did was enable and disable W-LAN on the router once (last night - I only enable W-LAN when I need it) but I didn't reboot it....

    But therefore I had the problem again today....
  17. sparhawk

    sparhawk LI Guru Member

    Ok. I`m using my router without reboot for a few days.

    Ftp normally is not working, but When I start to download a big file, and I get some constant bandwith to finish this, It starts to work. After download file, It`s working for a few minutes, and then It`s gone.
  18. mperry184

    mperry184 LI Guru Member

    ftp woes

    hi there

    did some tests based on your guys responses, and the ftp issues are occuring for me both on wireless and wired connections.
  19. tobias.b

    tobias.b LI Guru Member

    As a matter of fact, I think my "IPsec passthrough connection dying" problem maybe related to all this as well and may have the same internal reason. Even though it doesn't take 12hrs until it breaks (only 1-2hrs) and it can be fixed be resetting the PPPoE connection, but what I read here sounds familiar.

    BTW, I'm having the FTP problem as well of course ... :rolleyes: I use Server's Alive to monitor my public FTP server (checks are done every 5 minutes) and after a couple of hours SAlive (and a normal FTP client as well) can't connect any more ... VERY LIGHT traffic to the FTP server due to the nature of SAlive, so it's not related to that, but the connection is opened/closed every 5 minutes, maybe that's more important here.

    Ciao, Tobias
  20. ghost_zero5

    ghost_zero5 LI Guru Member

    No, I am using ICQ and there I have a steady connection and still get to this problem.
    Or if I am sleeping (turn PC off) it could happen that the next day I stand up this problem occurs...
    And it also happens just during the time I am online in ICQ. I just lose connection and can't re-establish...
  21. pcah

    pcah LI Guru Member

    Same Problem

    I am experiencing the same issues with ftp. I aslo seem to have the issue with VOIP protocols. Reboot resolved the issue temporarily.
  22. stephenrx7

    stephenrx7 LI Guru Member

    same here

    I'm experiencing the same issues with FTP. I am running the beta version of 1.0.24 with 2 IPSEC connections. One of my IPSEC connections goes down regularly too, and a reboot of the WRV200 is usually all it takes to resolve.
  23. pcah

    pcah LI Guru Member

    I have a case open with Linksys and they gave me the latest firmaware - still the same result. I pointed them to this forum illustrating the problems but ?????

    They tested a ftp site on their side and got the same problem, but they want more sites to test
  24. hall_n_a

    hall_n_a Guest

    I also have this problem.

    I have 8 webs I manage, and FTP is a daily tool. I recently bought the WRV200 because my old Linksys died. This problem is very irritating for me because I have to reboot the router (usually) at least once per hour. It will go longer if I'm tranferring large files, or if I keep refreshing the dir view from within my FTP client.

    I've even mapped port 21 to my internal static IP (didn't help) and have disabled everything 'extra' including the wireless portion.

    If this router had been purchased locally, it would have been returned already for a refund. I'm losing faith in Linksys products...this isn't my first bad experience lately with their hardware

  25. DocLarge

    DocLarge Super Moderator Staff Member Member

    And your comment accomplished what in the interim????

    Stand in line, pahtner... :)

    We can only test what's made available to us; Linksys can only distribute what they get from the board maker (Gemtek, in this instance). Therefore, there's no "foot shufflin'" til we have something to work with.

    Obviously, you're new to the fray... We've got folks who've been hanging in since we started posting/using this device last year. Although irritated, we're a patient bunch because through the efforts of the Linksys team (Toxic especially), we're moving beta files through "once every other month" as opposed to "one every two or three months" so our feet are "on fire" in that respect.

    When we know the next release date, everybody knows the date...

  26. tdijks

    tdijks LI Guru Member

    Well, i have the same problem

    Looks to me like this linksys router has it's own ftp parsing functionality which gets triggeren with connections going to port 21. There is probably some sort of bug / memory leak which makes it unusable after een certain amount of time / usage.

    Anyway, if the ftp you are connecting to is not on port 21 you won't have this problem.

    Thomas Dijks
  27. tdijks

    tdijks LI Guru Member


    isn't it possible to give us the ability to disable the ftp parsing functionality in the wrv200. I don't care if i can't use active mode.

    Thomas Dijks
  28. goodwyne

    goodwyne LI Guru Member

    The last message in this thread was more than a month ago. I assume there has been no movement on this? I'm using firmware version 1.0.29 and the problem still exists. I've been dealing with it for quite some time but just found this forum.

    I see everyone is quite patient and I've also been patient. At what point, however, should we expect some kind of solution? This has been a known problem for quite some time and it seems to me that a solution should be available by now. But that's just me.
  29. Sfor

    Sfor Network Guru Member

    Well, there in a newer firmware version available. It seems to work better in general.
  30. Toxic

    Toxic Administrator Staff Member


    v1.0.32.2 released 04-04-07

    I'm not saying it has fixed everything but some things were fixed.

    discussion of the new beta is here: http://www.linksysinfo.org/forums/showthread.php?t=52385
  31. My16paws

    My16paws LI Guru Member

    WRV200 FTP Problems

    Just to add my 2 cents worth. We have been having the FTP problems for about 1 year now. Ever time we call support, they do not even admit to this issue as a problem.

    Even when looking at the Firmware upgrade notes there is no mention of this problem as being fixed and/or an outstanding issue.

    It appears that Linksys/Cisco does not care about the users of this model, as I do not think that all of there models have this issue.

    I wonder if it is time to look at other companies offerings (NetGear/Dlink), not that the Linksys products are bad just at how they have treated there users.
  32. Sfor

    Sfor Network Guru Member

    Well. I can not say much good about the Linksys support, as well. But, my last contact with them was in the september 2006. After I found the linksysinfo.org portal I did not bother to play with the Linksys direct support again.

    The FTP issue seems to be a difficult one. Looks like it is not possible to reproduce it on demand. Right now the FTP works correctly for me. Perhaps the 1.0.33 firmware changed something, or I'm simply lucky.
  33. punnybones

    punnybones LI Guru Member

    I can confirm that the FTP problem still exists with the latest firmware (1.0.33 Beta). The same bug(?) also affects AIM/ICQ (Port 5190 in addition to 21.. Strange). Router reboot fixes the connectivity to these services temporarily, sometimes for a period of one hour, sometimes for a few days.

    I personally would really like to see this fixed.. really annoying!

    The router seems to drop the sent TCP SYN packets (or does not forward the corresponding SYN/ACK back to the workstation). Some probably useless info:

    > telnet ftp.fi.debian.org 21
    tcp 0 1 SYN_SENT

    > telnet ftp.fi.debian.org 80
    Connected to ftp.fi.debian.org.
    Escape character is '^]'.
    tcp 0 0 ESTABLISHED

    > gaim/aim on
    tcp 0 1 SYN_SENT

    > tcpdump host (sees only the initial SYN)
    > telnet 21
    14:51:54.416173 IP host2.35166 > ftp.fi.debian.org.ftp: S 3189631506:3189631506(0) win 5840 <mss 1460,sackOK,timestamp 108263047 0,nop,wscale 5>
  34. ghost_zero5

    ghost_zero5 LI Guru Member

    Jup that bug still exists...
    It also seems to occur more often if you adjust settings which doesn't need router reboot (but not only in that case, it just happens sooner then)...

    And I really would like to see this issue fixed soon...
  35. draught

    draught LI Guru Member

    i still have this problem too with beta 1.0.33!

    german linksys business support didnt know anything about this bug as i called them last week!
  36. fdoibz

    fdoibz LI Guru Member

    I hope this information helps...
    I've noticed that if you change de local IP range to 10.0.0.x the FTP issue seems to be gone.
    I've been with this new IP range since last week, zero reboots and I can still login to external FTPs.
    Give it a try.
  37. punnybones

    punnybones LI Guru Member

    I tried changing my LAN network from to (as suggested by fdoibz). No change in FTP/AIM behavior. Still getting blocked out after some amount of uptime.

    Firmware 1.0.33 beta/ 1.0.34 beta.

    EVERMIND2 LI Guru Member

    Im having the same issues (with the latest 34 beta)

    I am an Heavy PC user, I have to reset my router at least 2 times per day.
    Icq permanently gets disconnects, to open ftp I have to reset the router...

    I am very disapointed of linksys because of the wrv200 :thumbdown:
  39. CalledToConstruct

    CalledToConstruct LI Guru Member

    I am still encountering this issue with 1.0.34 beta... typically just once per 24 hour period (but not consistent).

    I found that I am able to 'restart' the ftp passthrough by performing a release / renew on my wan connection... however, within short order, all throughput began to drop and soon the router locked requiring a power cycle.

    Anyone else want to give that a try and see if it produces the same results?

    edit: A few days ago, I repeated this process to kick / restart the ftp passthrough. The router as well as the ftp traffic has been running fine since... well, until tonight... (at the moment, I'm downloading 48megs via an secure ftp session and the router https server has stopped responding). Once the ftp transfer(s) are complete, I'll try the GUI again and see what happens. I just thought it was interesting that after 24 hours, the ftp froze. I was able to restart it by release / renew on the wan connection and it has run for 4 or 5 days without incident.

    edit: After the ftp transfer finished, I was able to access the web GUI on the router without issue. The router is reporting an up-time of 5d 22h + and ftp is working fine. I guess, after a restart of the router and 24 hours, the ftp may freeze, but release / renew on the wan connection (which does not cause a restart) may be a (work-around / hack) cure.

    // Joe
  40. CalledToConstruct

    CalledToConstruct LI Guru Member

  41. MarkToo

    MarkToo LI Guru Member

    I'm glad that others are keeping this issue alive... I would like to know this:

    Is the "WRV200 FTP Issue" something that Linksys acknowledges as a problem and is actively working to resolve or not ?

    A response from anyone "in the know" would certainly be appreciated :) .

  42. CDDrury

    CDDrury LI Guru Member

    I'm having the same issue as everyone else but not every time. I have about 20 of these routers spread out at remote locations in my company, most of them work flawlessly 100% of the time and we constantly connect to our ftp server throughout the day to transfer small files. One store was giving me problems so I swapped out the router and it fixed the problem, but now I have 2 other routers doing the same thing. They all have the firmware.

    I still have 23 more stores to put routers into and I'm wondering if I should look elsewhere for a different router or if this problem will get fixed any time soon...Any help?
  43. mgc418

    mgc418 LI Guru Member

  44. mgc418

    mgc418 LI Guru Member

    sorry. found the above page. entered in the settings and saved. this did NOT cause the router to restart. as has been the normal fix. once saved, ftp worked again. we'll see what happens tomorrow.
  45. ghost_zero5

    ghost_zero5 LI Guru Member

    Even if that would solve the problem:
    1.) I would have to use port triggering for at least that port.
    2.) That problem also exists with ICQ and maybe other things then too (so I would at least need to trigger them too)...

    I mean: One possibility would be the trigger ALL ports but that isn't that good for various reasons... I wonder if that is even possible - I mean you surely can enter it but I wonder if the router might would have troubles with that.

    They should just fix this bug soon. I mean: This bug has been known now for quite some time now and it still doesn't seem like it will get fixed soon and it really is one of the most annoying ones....
    I mean otherwise the device is really good (especially if you consider the low price)...
    I really hope they will fix it with one of the next firmwares...
  46. Freds001

    Freds001 LI Guru Member

    Mounting list of people having this problem

    Well I just thought I'd chime in to say "Me too!". I've purchased this Router for a few customers of mine so they could connect remote sites via IPSec VPN and started to see this problem with the one I bought for myself.

    How can Linksys ignore such an out cry?

    Maybe we should all pick a day and time to call in to support about this issue? hehe. :wink:

  47. ghost_zero5

    ghost_zero5 LI Guru Member

    OK. I have tested this with the port triggering and it really works, also for ICQ - you only need to use port 5190 there...
    I waited until this problem occured... I enabled that port forwarding rules - everything works again - if I now disable it again, everything stops working again. If I do a release connection and renew connection then everything works too (but without that rule it will probably be just temporarily) - so adding the rule probably would be the best (I will wait and see what happens)...
  48. ArchCC

    ArchCC LI Guru Member

    I'll try this fix too... looks like it work, but not every time, my ICQ connections down not every 2min, but once at 2-3 hour and it's not help with eMule(down every ~1.5hour). =(
  49. ghost_zero5

    ghost_zero5 LI Guru Member

    1.) After the firmware upgrade did you reset the settings and set everything from the scratch (no loading of configuration file and such things but manually entering everything)?
    2.) You should try latest Beta Firmware too... Although Linksys says Beta, most of them were better than the latest official (here you could try two versions: v1.0.33 and v1.0.34) - at least regarding the WRV200.

    Regarding eMule: Did you enter the correct port?

    Although as said to you per PM, this is more or less a workaroung not an acutal solution - as it is a firmware bug, which needs to get fixed... So even with the newest beta firmware it might still not work correctly a.s.o.
  50. ArchCC

    ArchCC LI Guru Member

    1. Yep, I'll set all settings from begin after reset.
    2. Setup 1.0.34 look what happen =)

    eMule, yep I set ports for my favorite servers... but it's down with some periods as icq, so looks like this workaroung work but not perfect =)

    This topic about vpn birth at January but i don't see any words about admit this issue as a problem from administration =(
  51. Doodsaq

    Doodsaq LI Guru Member

    Good News

    Good news guys, I found a permanent fix for this:

    Step 1: http://www.netgear.com

    Step 2. Purchase Router

    Step 3. Install.

    Enjoy AIM/ICQ and FTP all you want.

    Seriously, I've had this problem for about a year now, and Linksys has been dragging their feet so bad I've finally gave up on them like I have given up on Norton.

    The company I work for sells a lot of Linksys routers, and we just ordered a shipment of Netgear routers. :biggrin:

    Unfortunately we had to stick about 10 customers with these POS Linksys routers, but we've already got calls/complaints about them. Farewell, and I wish Linksys well in it's future endeavours.
  52. Freds001

    Freds001 LI Guru Member

    It's sad really...

    We've have also installed this router at a few customer sites and now I'm going to have to replace them.

    I guess I don't understand what the big deal in fixing this problem is. They should be able to repro this pretty easily in my opinion.

  53. ArchCC

    ArchCC LI Guru Member

    Is this issue happen on all WRV200 or it's just few machines?
  54. ghost_zero5

    ghost_zero5 LI Guru Member

    Well: It either is all of them or nearly all of them...
    I had some e-mails with Linksys directly lately (although German part of it) and they say this problem does not exist and they don't have it with v1.0.34 on their two devices they use in their corporation ...
    Somehow I don't think this will get fixed if they don't even accept that this problem exist.
    My guess is that they might turn everything off at night or use them in combination with port triggering or port forwarding...
  55. T-Troll

    T-Troll LI Guru Member

    For me, it happens only under heavy loading.
  56. ghost_zero5

    ghost_zero5 LI Guru Member

    I guess I will soon start using the WRV200 as VPN-Client only and put my WRT54G before it (which should work normally)...
    Although: I really hate it that they don't seem to admit this problem exists at all... Of course, the port triggering works but not that completely well but better than without but still this workaround is not even completely what I want to use - at least not for FTP and ICQ, there are needs that are good to use for port forwarding but not in these cases...
  57. HughR

    HughR LI Guru Member

    Is this FTP through a tunnel?

    Is this FTP combined with NAPTing? FTP + NAPT is a bit of a mess (some of the packet payloads need to be inspected and rewritten). Passive FTP is easier to NAPT. Are you using passive FTP?

    Is this an FTP connection that you are trying to keep up for more than a day, or just an FTP connection that you are trying to initiate after the router has been up for more than a day? There are two parts to a connection that I want to know about separately: sessions (duration of FTP login) and transmissions (duration of a single file transfer command).

    Can you describe a minimal setup and test that you expect would demonstrate the problem? I have a WRV200 that I can put inside my LAN for testing (i.e. it would not be on the wild internet).

    Sorry if these answers are already in the thread -- I didn't read it all.
  58. LBSources

    LBSources LI Guru Member

  59. HughR

    HughR LI Guru Member

    I missed this until LBSources mentioned it again.

    In case that page goes away, here is what it suggests to solve the FTP issue (that I don't actually know the details of -- see my query above):

    He noticed that he could not connect to his FTP server using the normal port 21 but could with SFTP that uses port 22. [I presume that this problem only happened after sufficient router uptime, but he doesn't say so.]

    Fix: go to the WRV200's firewall configuration / Port Triggering page. Add a triggering rule:
    Application: ftp; Triggered Range: Start Port: 21; End Port: 21; Forwarded Range: Start: 21; End: 21; Protocol: Both; Enabled: yes

    I don't know exactly what this rule does. I would guess that the Application field is just a comment. The protocol field should just be TCP since FTP does not use UDP (unless I'm misremembering).

    The rule might be to enable dynamic port forwarding. In other words, when an outgoing packet is matched, it triggers the installation of a port-forwarding rule. This raises some questions in my mind.

    When does the forwarding rule expire? How long does the forwarding rule persist after traffic on the triggering port has ceased?

    Does this mean that only one machine behind the WRV200 can use FTP within a time period? This forwarding rule seems to forward ALL FTP control traffic to one particular machine on the LAN. Normally NAPT should do better: allowing any number of (passive) FTP clients simultaneously. But maybe the triggering-installed forwarding is more sophisticated than I'm guessing.

    Is the Trigger Range matching the local port number or the remote port number? Surely the remote port number, but this isn't explained.

    FTP client requests are sent to port 21, but actual data transfers don't use port 21. Does this fix suggest that the WRV200's problem is only on the control part of the protocol?

    Does this fix work with older firmware versions?

    This stuff sure would be easier to analyze if one could dive down into the router with a root shell (i.e. telnet or ssh into a CLI).

    I admit to being lazy and not actually refreshing my memory about how the FTP protocol actually works http://www.faqs.org/rfcs/rfc959.html.
  60. ghost_zero5

    ghost_zero5 LI Guru Member


    There is a new beta firmware that should especially and only be used with those who have those FTP/ICQ-Issues...
    As it is no sticky-thread, I thought I would mention it in here...

    I didn't get ICQ fixed by this... But FTP seems to work just fine (although ICQ was not working, FTP still was - after reboot both were working again; I put ICQ-Port back to port triggering now but not the FTP port)...
  61. CDDrury

    CDDrury LI Guru Member

    Still having problems with FTP

    Using the 1.0.36 firmware and still having trouble with FTP connecting. I have 43 of these routers out there and at any given time 1/2 of them are having connection issues. We do very light ftp transfers but connect every 10 minutes to see if there are any files to download. If I don't get a fix soon I'll have to go buy Netgear, and I really don't want to do that.
  62. SomeBozo

    SomeBozo Guest

    Same problem - Long time. When's it going to be fixed?

    I have had this problem with multiple units since buying them over a year ago. They have never worked properly.

    FTP stops working after from anywhere between 6 hours to 48 hours after a router reboot.

    You can clear the error by rebooting the router.

    Have spent over 30 hours troubleshooting and dealing with (email) tech support over some months - abandoned the pursuit some time ago, and put other routers in.

    Tech support says to me that I am the only one they have heard of with this problem.

    Know other that have pulled out and trashed these units. Just not worth the wasted time..
  63. WRV200: VPN Passthrough and AOL IM issues

    I am having similar issues with the WRV200. After about 12-30 hours, the VPN Passthrough and AOL IM stop working. A warm-reboot of the WRV200 fixes the problem, but rebooting every day is getting rediculous. It's very bad when I am working and the VPN Passthrough decides to stop working. I have tried firmware releases,, and 1.0.33 all with the same results. Each time I changed to the different firmware, I reset the router back to the factory defaults and manually reconfigured all of the settings. Same results with each firmware release. I have even purchased a second WRV200 with the exact same results (I have since returned it). I cant even remember how many wasted hours I have spent on the phone with Linksys support.
    I am also having issues with the QuickVPN on the WRV200. It works ok if I use a dialup ISP connection to the Internet, but if I have a high-speed connection I am unable to get connected (same laptop - same settings - several differnet high-speed connections).
    I have been dealing with these issues for almost 3 months. I am looking for a replacment of my WRV200 - I need the following features: multiple WLAN SSIDs; multiple VLANs; DDNS; inbound VPN (i.e.: QuickVPN); SDHCP - does anyone have any suggestions for an inexpensive solution if Linksys can't get the WRV200 working properly?
    Just prior to the WRV200, I used to use a Linksys WRT54GC for over a year - I never had any of the VPN Passthrough or AOL IM issues with that or any of the various routers I have used over the years (Linksys and D-Link).
  64. osko

    osko LI Guru Member

    Hi people,

    Using the 1.0.36 firmware and still having trouble with FTP connecting, I can clear the error by rebooting the router but is a disaster router!!!!. FTP stops working after from anywhere between 4 hours to 30 hours after a router reboot. Any ideas ?

    Thanks !!!
  65. sparhawk

    sparhawk LI Guru Member

  66. osko

    osko LI Guru Member

    Hi sparhawk, I have a same problem with port triggering, firmware version 1.0.36, any ideas ?

  67. sparhawk

    sparhawk LI Guru Member

    Well, I don`t know.

    I have a 1.0.34 of a firmware and with port triggering it`s working without problems.

    Are you sure with your port triggering ?

    I mean, that we need a strange think to do. We need to tell router, that, port 21 is port 21 on both TCP and UDP (for FTP service).
  68. CDDrury

    CDDrury LI Guru Member

    Tried that - still didn't work. Telling the router that port 21 is port 21 doesn't make any sense - port trigering is for when you are changing ports, not as a passthrough.
  69. BenCh

    BenCh Guest

    I just found this thread. Same problem here. Still no REAL solution? No posts in a few months, maybe it has been fixed? If so, PLEASE let me know. Have not tried the port forwarding thing. Scares me, since we have several users on the network. We need them all to be able to FTP whenever they need to. Guess I'll give it a try. Thanks.
  70. ArchCC

    ArchCC LI Guru Member

    Today they release firmware 1.0.38 Toxic say, that issue fixed there, but i am not test it yet...
  71. jmdrolet

    jmdrolet Guest

    WRV200 FTP issue second solutions

    I found played with a Lynksys support ingeneer that the MTU connection make a difference ... example the AUTO mode give me a 1692... and the ftp was not working.

    We change this to 1492 ... connection but no listing....

    1452 ... work 100% everytime.

    i'm using PPPoE connection here.
    the firmware is

    I hope this could help someone.

    btw someone as try to install DD-WRT on this device?
  72. HughR

    HughR LI Guru Member

    1692 is an unlikely number. 1500 is usual.

    Since you use PPPoE, you need to take a bit off the 1500. I forget the right amount. I seem to be using 1464.
    No. Nobody has come forward even with a rebuild of the released source. Third party firmware would be a much bigger step.
  73. tech_chica

    tech_chica Guest

    Got the firmware update

    After screaming at Linksys tech support (who said they were totally unaware of any problems including those cited in their own forums!), a corporate tech called me the next day. I asked for the firmware update v1.0.38 and it was emailed to me shortly after.
    I applied the update and the router has yet to lose ftp connectivity (Going on two weeks). Yea!
    Be sure to document your settings as you will need to reset everything to factory after applying the update (do not restore from a file), then configure again.
  74. HughR

    HughR LI Guru Member

    Good to hear. They are obliged to offer you the source code for the GPLed portion of the software. Could you ask for it? You can then make it available to us. I would very much like a copy.

  75. frost022

    frost022 Addicted to LI Member

    Hi Guysss... I see that the issue not be solved even FTP, but they said that to me happens when I leave the eMule or uTorrent, I have to reset the reouter each about 4 hs aprox.
    I know how to configure the WRV200 to work well with these p2p applications?
    I have 1 MB Adsl.

    Thank you
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice