WRV200 v1.0.20 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Sep 12, 2006.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    Ok we have an update on the WRV200 front. a new beta. v1.0.20

    The official changelog is as follows:

    WRV200 Firmware 1.0.20 Release Note


    1. Added System Up Time on the Status->Router page.
    2. Added AES-128, AES-192, and AES-256 in the Encryption drop-down menu on the VPN->IPSec VPN->Key Management page.
    3. Added "Both" in the drop-down of port forwarding rule to include both TCP and UDP in the Firewall->Port Forwarding page.
    4. Added 10 more Port-Forwarding entries.
    5. Added 10 more entries to the Application-based QoS page, when the QoS type is Priority Queue.
    6. Added the utilization information for the Static DHCP Client List, which can accept up to 20 entries.
    7. Added a checkbox for enabling Auto Daylight Savings.
    8. Support Unscheduled Automatic Power Saving Delivery (U-APSD). A checkbox was added in the Wireless->Basic Wireless Settings page for users to enable this feature.
    9. Support Inter-Access Point Protocol (IAPP) to improve the speed of de-association with the previous access point when wireless clients move from one access point to another.
    10. Changed the default values of IPSec SA Lifetime and IPSec ISAKMP Lifetime to 28800 and 3600 seconds, respectively.


    1. Fixed an issue that PPPoE connection fails to establish when the PPPoE username contains a # sign.
    2. Fixed an issue that QVPN Client cannot connect when it's behind WRV200 (NAT) and the remote gateway is WRV200.
    3. Fixed an issue that WRV200 will send irrelevant system buggy messages to syslog server.
    4. Fixed an issue that the routing table shows too slowly when user clicks on Setup->Advanced Routing->Show Routing Table.
    5. Fixed an issue that users can remotely log into the WRV200 by just typing IP address of the router when Remote Management is enabled on ports other than 8080.
    6. Fixed an issue that some WebUI pages will display incorrectly on Mozilla Firefox browser.
    7. Fixed an issue that Remote Management cannot work when WRV200 behind one or multiple NAT-devices.
    8. Fixed the issue that when the WAN connection is down, the Port-Forwarding page won't load correctly after users click Save Setting.
    9. Fixed an issue that the IPSec VPN page will pop up Java Script errors in the Internet Explorer.
    10. Fixed an issue that Web UI will crash when using remote management with https. The issue is also related to IPSec tunnel configuration.
    11. Improved the response time of Web UI when the first IPSec tunnel or VPN Client is being configured.
    12. Improved the accuracy of Manual Time. WRV200 will save the current time after users make configuration changes that require reboots.
    13. Fixed a timing issue where the system clock cannot follow NTP Server.
    Remark: WRV200’s system clcok will slow down after system booting and the system time cannot follow the NTP Server's adjustment.
    14. Fixed an issue that WRV200 sometimes transmits packets larger than the TCP Maximum Segment Size (MSS) when users access the WebUI via remote management.
    Remark: These over-sized packets will be dropped by intermediate servers or routers, causing problems in remote administration.
    15. Fixed an issue that ICMP packets cannot be forwarded to the DMZ host.
    16. Fixed a configuration issue of Port Forwarding when the WAN connection type is PPPoE.
    17. Fixed an issue that enabling or disabling IPSec Passthrough will affect the ongoing connection to the PPTP Server in the LAN of WRV200.
    18. Fixed an issue that assigning DHCP Static IP will cause the router not prompting users for username and password at login time.
    19. Router will apply most of the configuration changes immediately without rebooting. See the following for details.

    19a. Web pages applying configuration immediately:
    1) Setup
    1.1) Setup->Basic Setup->Static IP Table
    1.2) Setup->VLAN
    1.3) Setup->DDNS
    1.4) Setup->Advanced Routing (Except for changing operation mode)
    2) Wireless (All)
    3) Firewall (All)
    4) VPN (All)
    5) QoS (All)
    6) Administration
    6.1) Administration->Log
    6.2) Administration->Diagnostics
    7) Status (All)

    19b. Web pages requiring reboots for configuration change:
    1) Setup->Basic Setup
    2) Setup->MAC Address Clone
    3) Setup->Advanced Routing (reboot only when Operation Mode is changed)
    4) Administartion->Management
    5) Administartion->Factory Default
    6) Administartion->Firmware Upgrade


    1. Router may unexpectedly reboot when all traffic is coming from/to wireless hosts, i.e. when there is no traffic coming from/to the LAN ports, and there is a VPN tunnel with steady traffic.

    2. IPSec tunnels do not pass NetBIOS Broadcast packets. This will prevent users from searching computers by names on Windows Explorer.

    NOTE: there are other issues, those these are being addressed soon with another firmware sometime this month.

    watch this space....

    For the download check it out here:

  2. Toxic

    Toxic Administrator Staff Member

    Anyone finding other bugs within this firmware (v1.0.20 only) please post them here. make sure you do a full reset on your router after this upgrade and any bug found should be listed with exact instructions to replicate the issue.

  3. TazUk

    TazUk Network Guru Member

    Nice to see Linksys are fixing problems with the WRV200 a lot quicker than they did on the WRV54G :clap2:

    Thumbs up to Linksys and to Simon for pushing them along :poke: :thumbup:
  4. ifican

    ifican Network Guru Member

    I am happy to announce that .20 has fixed quickvpn. I run a very dilluted setup at home on purpose to test cross connectivity. I can happily attest that quickvpn is now working as it should. I now successfully ping, ssh and port forward through an internal router to a third router for remote access. If that is not a mouthful i dont know what is. I was getting ready to change out the wrv200 for a netscreen for other testing but i am happy to say that it will be staying in place for now as the vpn is working phenominally.
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Progress Is Officially Made!

    Sourceinfo could be forthcoming, but we can't make any guarantees on that as of yet...

    For the moment, everything we've (Toxic, Kspare, and myself) tested for Linksys has finally come to fruition. Recently, the final issue of the wrv200 failing to stealth ports when acting as the gateway router has been acknowledged by the firmware developers, to include our being told that the makers of the WRV200's board (Gemtek, which is a company in Taiwan) have now been able to reproduce the wireless vpn drop we've all been suffering from. As a result, a patch for that should be issued within the month, to include a firmware fix for the WRV200's port stealthing capability.

    Peops, things are now starting to happen. Our goal when initially embarking on testing the wrv200 more thoroughly for Linksys was to make sure this router doesn't suffer the early demise of the WRV54G and it looks like it won't anytime soon!

  6. csayers

    csayers LI Guru Member

    Safe upgrading of firmware on wrv200

    Can someone please tell me of any tricks or gotchas to avoid when upgrading the firmware on this thing? I bricked my last one and I want to avoid repeat.

    I have always pulled out the wan cable when doing upgrades as I have learned that this can cause problems. When I bricked the last unit, I forgot to do that.

    Should I hook the thing directly to the computer by lan? How long should one wait for the firmware to update? Does the webpage where you upgrade, automatically refresh when done?

    I must say that Linksys was very quick in dealing with my returned unit, once I insisted I was a knowledeable network tinkerer and not a run of the mill consumer. It still cost me time and shipping but the replacement unit was in my hands in a day and a half.

    My understanding is that the IPSEC VPN and wireless at the same time issue is still not resolved. I am getting the feeling from DocLarge that maybe you guys are talking about a wireless VPN to the router as opposed to my problem of having a point to point VPN to the office and using my Laptop on the wireles and having the unit reboot,

    Am I offbase or is the simultaneous point to point VPN and wireless use impossible still?

    It seems to me that this problem should have been the first to get fixed not the last as it is a major major flaw and basically makes the unit almost useless to me.

    Thank you for your help
  7. infrandom

    infrandom Guest

    Well I couldn't wait to get home to upgrade the firmware to .20. I have been trying everything to get QuickVPN working from my laptop at work. I installed the new version of QuickVPN and did a remote firmware upgrade of the .20 beta. I am now able to ping/VNC into my home desktop computer.

    As far as the upgrade, I waited until the firmware upgrade page timeout before trying to hit the router admin again. I don't know how many times I'd actually attempt to do that remote again though.

    Thanks Linksysinfo.org
  8. Toxic

    Toxic Administrator Staff Member

    csayers we have been told by our sources in Linksys that teh wireless/vpn issue is being addressed with a new wireless driver. however there are other bugs that need to be squashed as well. 1.0.20 has been out for a while as an Alpha firmware so there was never going to be a fix of the Wireless/VPN issue in this version.

    as to upgrading. i prefer to reset to factory defaults before and after an upgrade. upgrading can take some time, and i found with the WRV200 that it did return back to the upgrade page once firmware upgrade has finished, but this is dependant on TTL/Timeouts of your PCs Setup tbh. give it 5 minutes anyway.
  9. Toxic

    Toxic Administrator Staff Member

    We aim to please:) well sometimes.....
  10. svg1

    svg1 Network Guru Member

    Looks like its no longer beta . Its now listed on linksys download section.
  11. ccbadd

    ccbadd Network Guru Member

    I, for one, am quite impressed with how long it took to get the WRV200 to a fairly stable firmware. Once the Wireless + VPN problem is resolved, I will probably pick up a couple more to replace some BEFVP41's. I know that some people don't like the fact that with wireless uses the RALink radio but the coverage and speed I have seen makes me more then happy.
  12. DocLarge

    DocLarge Super Moderator Staff Member Member

    You figure once we started riding the developers like "Zoro" about the issues we were having during the testing phase, they'd eventually get tired us throwing "virtual eggs" at their coding and "kick that shizzel up a notch!" :)

  13. Walrus78

    Walrus78 LI Guru Member

    I hope no one uses the 0 byte zip file that is 1.0.20 right now and tries to make it the firmware :wink:

    Maybe I'm more patient than most because we are only testing deployment of the WRV200s(we are planning on getting 30 or more of these), but testing the 1.0.20 responds so much better than previous official releases I'm actually impressed. For the price of these units, once the problem with wirless+vpn is fixed these we be a steal! We don't even really need the wireless feature at the moment (it is just an added feature in our current situation). For ~$70, adding a vpn endpoint and wireless to connect back to our Cisco Concentrator for our small sites this will be a serious moneysaver.

    Back to topic, I just can't believe how much faster and more stable this responds over 1.0.12.
  14. cactusfazer

    cactusfazer Network Guru Member

    There is 3 days that i have put the 1.0.19 beta firmware.The IPSEC vpn (endpoint) work but not with the wifi.I have just trying to put the new release 1.0.20 for trying the wifi on the IPSEC but even if the VPN is etablish (STATE_QUICK_R2: IPsec SA established {ESP=>0xfd4bfd56 <0x6b938d5f xfrm=3DES_0-HMAC_MD5 NATD=none DPD=none}), wifi can't ping the other lan and the wired can't too !!! I have read that QuickVPN work well now but IPSEC work bad !
    I go back to the 1.0.19 and i hove ( a miracle) that linksys can resolve this ....
  15. Walrus78

    Walrus78 LI Guru Member

    I thought it was already discussed that the driver for the wireless is being replaced, but it was not set for this firmware release. It shouldn't have been expected be fixed in 1.0.19 or 1.0.20, but linksys does know about it already and it is supposed to be corrected in a later firmware release.
  16. leebob

    leebob LI Guru Member

    Loss of Manageability after .20 upgrade

    Has anyone had the problem of losing manageability of the WRV200 after the 1.20 upgrade? I have followed all of the suggestions in this forum and waited the specified times, but cannot reconnect to the device after making a change that requires a reboot (like static ip, or administration page items) unless I unplug and re-plug the power. The older 1.0.12 firmware did not have this issue... Any suggestions?

  17. ifican

    ifican Network Guru Member

    I kind of had the same issue initially, it did not seem to take correctly the first two times i flashed it, that or somehow i managed to interupt it by being impatient. However on the third try i just let it sit, and after what felt like forever, most probably 3 minutes or so it rebooted itself and all is well.
  18. leebob

    leebob LI Guru Member

    Well, I have reflashed the unit twice and that seems to work ok. The problem I am having specifically relates to making a change to any setting that requires a reboot after the flash. I have now been waiting 15 minutes and still cannot connect, yet the router is passing traffic as I am sending this note... If you go to the admin page and select reboot, how long does it take for your device to come back to you and must you open a new browser window?
  19. DocLarge

    DocLarge Super Moderator Staff Member Member


    is your wrv200 set to "obtain ip automatically" or "static ip?"
  20. leebob

    leebob LI Guru Member

    static ip. DHCP internally is also off---using W2k3 server for that...
  21. ifican

    ifican Network Guru Member

    I dont know let me hit it remotely, reboot it and see how long it takes to respond.
  22. ifican

    ifican Network Guru Member

    Ok reboot took about 35 second before it started responding to pings but the page did not refresh and come to think about it anytime i reboot like you say, i have to manually go back in. What i have found in the past is if you refresh the same page you are on that caused the reboot most times it will cause it to reboot again, so i have learned backout the page it is on just to the ip, instead of etc it works for me everytime.
  23. leebob

    leebob LI Guru Member

    no joy for me... I still cannot manage this flippin thing... Think I may have an expensive coaster now... Any other suggestions?
  24. cactusfazer

    cactusfazer Network Guru Member

    I know that wifi don't work with 1.0.19 but it just for say that in the 1.0.19, the IPSEC VPN work and in the 1.0.20, it didn't !
  25. Sfor

    Sfor Network Guru Member

    I've encountered a few problems while trying to tame the WRV200 device.

    1) Time Zone settings for Warshaw.

    I'm a Polish so I would like to use the Warshaw timezone settings with the router clock being set to the Warshaw time. Unfortunately the GMT+01:00 Warshaw time zone settings makes router to be late by an hour. The daylight saving feature does not work in case of this setting (So the time is set to GMT+01:00, instead of GMT+02:00 summer time). On the other hand the GMT+01:00 Brussels setting being next to the Warshaw setting works correctly. Since the summer time correction to GMT+:02:00 works for Brusseles, it should work for Warshaw being a bit more east from there. This bug is hurting my national pride, but it is not a dangerous one.

    2) System log troubles.

    I've heard, there was a log problem solved related to wireless communication. I'm suffering log problems. But, I've switched the wireless off.

    I do not have other program to receive system log entries than LogViever 1.14. Some of the log entries are corrupted. The logging stops very often for long time periods. All is back to normal after the router reset. And after a while the log refuses to work, again.

    I was unable to determine if this is a router issue, or the software I'm using. I tried two different routers with two different computers. One was running Windows 98, the other Windows 95.

    3) "Lockout" - Sudden loss of communication with certain router functions on one of the 4 LAN ports.

    The internet connection works fine. The LAN communication also works fine. But, in the same time the "lockout" affected computer or other device can not communicate with DHCP server or web server in the router.

    To make it work again it is enough to power on a computer with TCP/IP installed connected to any of the router's LAN ports. If the powered on computer does not use TCP/IP and NetBios is the only protocol installed, it gives nothing. Instead of powering on a computer I was able to reset the "lockout" situation by temporarily unpluging one of the ethernet cables connecting the router with any computer with TCP/IP installed on it.

    The reset of the "lockout" effect does not seem to propagate over ethernet switches. It has to be a direct connection with router's LAN port. If there is a computer connected with TCP/IP on it through an ethernet switch, powering off the switch or reconecting it to the router does the trick.

    Also, the reset of the "lockout" condition happens on connecting the ethernet cable back to the router. Disconection event does nothing.

    I can not reproduce the "lockout" effect on demand. It just happens from time to time. While "lockout" is in effect all LAN connections are working fine. All, computer related internet connections are working fine, as well (Including the lockout affected computer).

    I'm using a Linksys PAP2 VoIP adapter to do direct IP dials through my Internet provider WAN. Quite often, the port forwarding feature stops to pass the packets to the PAP2 from the WAN side. This condition is also cleared by "lockout" reset procedure I've described.

    I'm wondering if it is somehow related to the "failing to stealth ports when acting as the gateway router" issue DocLarge wrote about. Because, my router is set as a gateway. For some reason it does not want to pass internet connection, when set as a router. It was working fine with the router setting, before loading 1.0.20 firmware.
  26. mindhack

    mindhack LI Guru Member

    Issue setting the MTU

    I just received the WRV200 and was trying to configure everything and did not have any issues until I went to set the MTU to manual = 1500. I tried it under the shipped firmware 1.0.12 and it kept resetting to auto. I then updated to 1.0.20 and still have the same issue. :confused:

    Everything else works perfect.:rockon:
  27. Walrus78

    Walrus78 LI Guru Member

    I posted this in another thread, but just realized this is more appropriate in the 1.0.20 thread.

    Starting with Firmware 1.0.20, we've been unable to pass traffic through an ipsec vpn tunnel when the WRV200 is using a PPPoE connection. Now, in each situation, we got the inital WRV200, before putting any configuration in there, flashed it to 1.0.20 and we were able to replicate this problem. Reflashing it back down to 1.0.19 solved the problem in both cases. I noticed in the release notes that there were some fixes for PPPoE connections so I'm guessing Linksys changed something minor in there.

    And before anyone asks, yes - we did do a clear of the whole config before and after these firmware upgrades.

    Anyone else seeing this same problem? If it makes any difference, we are establishing tunnels to a Cisco 3005 VPN Concentrator. No issue with 1.0.19, but .20 makes the connection no longer work with PPPoE connections. We have been able to replicate this problem with 2 different WRV200s and 2 different sites. I'm hoping versions past 1.0.20 don't have this issue since we just got 15 of them for deployment. :biggrin:
  28. leebob

    leebob LI Guru Member

    PPTP Problem with WRV200

    I am having a problem making a VPN (PPTP) connection to outside hosts using firmware 1.0.9(installed default), 1.0.19 and 1.0.20 on the WRV200 when staticly assigned. When I make the connection to a Win2003 Server, the router resets within 5 seconds of making the connection. Any suggestions out there?

  29. DocLarge

    DocLarge Super Moderator Staff Member Member

    If you have syslog enabled, disable it, and try it again. Having the syslog log enabled is known to cause the router to reset...

  30. ccbadd

    ccbadd Network Guru Member

    I tried this firmware and I can not get most of the pages to load. I did a factory reset before and after I loaded the new firmware. When I go to the setup page, it only shows the header and sometimes the rest of the page, but none of the values are filled in and I can not change them as the router hangs when I try to save changes. I have tried with both IE6 and Firefox. I can get to the admin pages just fine so doing a factory reset and upgrade the firmware through the web gui works fine. Funny that no one else has had this problem. I did disable my AV also with no luck. I guess I will just wait for the next beta to see if that cures it.
  31. ifican

    ifican Network Guru Member

    On the syslog issue i have had it enabled for about a month now and have not seen any of this, but i have come across another issue that i have not seen mentioned.

    If nat-t is not globally enabled, quickvpn does not work.
  32. Steve Grimes

    Steve Grimes Guest

    WRV200 f/ware .20 ok for the UK?

    As of today the Linksys' UK downloads page is still showing .12 as the current firmware download whilst .20 is showing on the US-only site. I took delivery of a unit on Friday which shipped with f/ware .13-EU, and it is a 'bit unresponsive' for remote management to say the least. I wish I'd studied this site b4 ordering the unit, I know I'll be using it as a bible in future since I tend to spec Linksys for all of my small clients. Can you say if the .20 upgrade is safe to use on a WRV200 in the UK (NTL cable connection) for a point-to-point VPN connection or do I need to wait for Linksys to generate a -EU version of the upgrade?
  33. Sfor

    Sfor Network Guru Member

    I have bought the WRV 200 device in Poland. It had 1.0.13 EU firmware installed, as well. There is a polish version of the Linksys portal. But, there are no WRV 200 device on the supported devices list. Looks like Linksys is cutting corners on national support.

    The 1.0.13 EU firmware had a few bugs not present in the 1.0.12 and 1.0.20 firmware (like possibility to login without a password).

    I believe, there will be no different firmware versions for different countries. The UK page was not updated after the 1.0.12 firmware introduction. Because of the corner cutting in national support.
  34. linuxcluster

    linuxcluster LI Guru Member

    @ Steve Grimes

    I have successfully flashed my EU version with the 1.0.20 firmware (downloaded from the US website). No complaints yet, other than the usual stuff already posted in this and other threads.
  35. DerToob

    DerToob LI Guru Member

    I´m using PPPoE on Firmware 1.0.20, DHCP active, Syslog off, no VPN, factory reset

    - The router crashes on heavy traffic (LAN) in irregular time intervals, only pushing the reset button will help.

    - even the Web GUI is not reachable from time to time.

    - Switching HTTPS in the Administration menu to on causes a factory reset.

    I hope, 1.0.21 will run much more stable....
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice