WRV200 v1.0.21 Beta Firmware Released.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Oct 15, 2006.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    We have just got the green light to release 1.0.21 as a Beta for you guys.

    The file is available to download here: WRV200 v1.0.21 Beta Firmware

    The changelog is listed below.

    WRV200 Firmware 1.0.21 Release Note


    1. With remote management enabled, if a user makes three unsuccessful logon attempts, WRV200 will block the user's IP address for 180 seconds.


    1. Fixed the issue that IPSec tunnels cannot be established when the WAN connection type is PPPoE. This issue was found only on firmware 1.0.20.
    2. Fixed the issue that router may unexpectedly reboot when all traffic is coming from/to wireless hosts and there is a VPN tunnel with steady traffic.
    3. Stealth all ports on the firewall when DoS Prevention is enabled.


    1. IPSec tunnels do not pass NetBIOS Broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at
    2. When DoS Prevention is enabled, remote management over http will not work.
    3. When DoS Prevention is enabled, DDNS will not work.
    4. When DoS Prevention and Web Block are both enabled, TCP and UDP traffic will be blocked.
    5. PPTP (WAN connection type) will not work when the PPTP Server and the Gateway are different in the configuration.

    Please note this is a Beta firmware and should be treated carefully. it is possible it will contain bugs.

    Please say on topic with this thread.
  2. Toxic

    Toxic Administrator Staff Member

    In .21 some time ago I noticed DDNS was disabled when you saved the settings. however a reboot made DDNS work.
  3. kspare

    kspare Computer Guy Staff Member Member

    If you intend to use this router in production and don't *NEED* syslog this firmware will work very well. I've deployed 2 routers with customers where I previously had wrv54g's and they are VERY happy.

    Please ensure you reset your router to default settings BEFORE updating and update over the wire and not wireless.
  4. DerToob

    DerToob LI Guru Member

    Beta 1.0.21

    Having PPPoE, Syslog off, DHCP with two assigned static IP´s, Internet Block both enabled.

    The router still crashes on heavy internet traffic (using UDP and TCP) over the LAN.
  5. Sfor

    Sfor Network Guru Member

    Time Setting bug for "(GMT+01:00) Sarajevo, Skopie, Warsaw, Zagreb" timezone.
    The "Automatically adjust clock for daylight savings changes" option does not work. The summer time +1 hour correction is not working correctly.
  6. kspare

    kspare Computer Guy Staff Member Member

    What kind of traffic? Can you capture the last packets with etherreal before the router crashes? I have been able to run a full 10 megs of traffic over it and a full 3 megs via aes vpn without any problems. My test was a download of a single and multiple zip files.

    If you can capture the crash with ether real we can give this to linksys to diagnose the problem and help fix it.
  7. DerToob

    DerToob LI Guru Member

    I´m using a filesharing client to test the connectivity. I figured out that the problem maybe could be the UPnP feature, i´ve activated.

    Since i deactiveted it it seems to run perfectly.

    But i´ll try to reproduce the problem running with ether real...


    It´s not the UPnP... the router crashed a few seconds after i posted this thread...
  8. DocLarge

    DocLarge Super Moderator Staff Member Member

    Do you have syslog enabled? Kspare, Toxic, and myself have been telling this to people everytime they crash their router:

    DO NOT ENABLE SYSLOG for the time being. "ANY" syslog option checked will either:

    1) Crash the webgui (eventually)
    2) Crash the webgui, then cause the router to reset to default while maintaining your current settings, or crash "all the way" to "factory default" (you lose "everything")

    Out of habit, I always enabled syslog, and it wasn't until a short while ago that I stopped doing it (only because Toxic said his WRV200 never crashed like that due to never enabling syslog) that I was able to see syslog was the problem (Kpare mentioned it again above...)

    If you have a simple webgui crash, just unplug "all cables" to include the power cable and let the router sit for about 2 mins. Then, plug in the power, wait for wireless to engage and then log into the router's webgui. Once you're able to do that, then re-insert the WAN cable and all remaining LAN cables.

    Additionally, if you're going to be in the router's internal webgui, turn off all antivirus and whatever personal security firewall software you might be running (java is heavily used throughout this router).

    As Kpare has previously stated, the router runs fine without syslog (until it's fixed hopefully in the next release). For some of you running more than one router, if the WRV200 is your internal router and you're not too concerned about internal traffic, you can always monitor the gateway subnet for traffic and get along fine, should this be your course of action... :)

  9. ifican

    ifican Network Guru Member

    I think the crashing has to do with wireless and syslog running together. I have wireless turned off and syslog enabled ever since the realease of .20 and have not had a single crash. I have had to reboot because of the occasional ipsec lockup, but router throughput stayed up. I will wait until i get home later to update to .21 and see how it goes.
  10. Walrus78

    Walrus78 LI Guru Member

    .21 definitely clears up with PPPoE issue as reported and appears to be more stable than previous versions. I am still getting some lockups from time to time.
  11. Sfor

    Sfor Network Guru Member

    I had a reset to default situation with wireless turned off and the syslog turned on (1.0.20). After turning syslog off, there were no such a situation again.

    It is possible wireless communication is increasing possibility of the bad behavior, but it is not the source of it.
  12. DocLarge

    DocLarge Super Moderator Staff Member Member

    There is "no remaining issue" with wireless at this time from what the testgroup has seen... The resetting has been isolated to the syslog. 1.0.21 is the best firmware to date...
  13. Toxic

    Toxic Administrator Staff Member

    it is advised guy that you do a factory restore before upgrading, an the do another reset after, just to make sure the nvram is cleaned out correctly.

    I personally prefer pressing the reset button for 30 seconds over the factory reset in the web gui.
  14. marwaw

    marwaw LI Guru Member

    Wireless and vpn fixed !
    Pending items
    - still unable to connect sony psp
    - unable to configure to play Rome Total War (DMZ do not help) other routers (also linksys) works ok
  15. srainess

    srainess LI Guru Member

    I had the v20 crash, but not exactly sure if its just the router, or issue with router and cable modem. In Heavy traffic, newsgroup up/downloads, the router looses its IP Address, and can not get a new one until both router, and cable modem are reset. No problems with other linksys routers in this situation. Syslog off, as well as wireless.. I will test with v21.
  16. kspare

    kspare Computer Guy Staff Member Member

    For the people getting lockups, we need to get more information from you in order to fix this router. Linksys is VERY willing to fix it so if you can reproduce the problem please let us know exactly how to do this so we can pass the info along to linksys. As well if you can capture the packets with etherreal this is also alot of useful information.
  17. Toxic

    Toxic Administrator Staff Member

    you need to port forward a lot of ports for RTW apparently.

    this link should help.


    "Rome Total War requires you to forward the 3783,6515,6500,6667,13139,27750,27900,28900,29900-29901 ports. "
  18. DerToob

    DerToob LI Guru Member

    No, Syslog was not enabled at any time and i made a factory restore before and after the update ....

    But in the last 10 hours after the last crash the router works perfectly :confused: ...

    (maybe i should allways run etherreal in the background :wink: )

    ... the night is still long. We will see ...
  19. cyclonous_gt

    cyclonous_gt LI Guru Member

    Cannot download the beta firmware

    can anybody help me? why can't i download the beta firmware? when i click the url given it says i dont have permission to download the file
  20. cyclonous_gt

    cyclonous_gt LI Guru Member

    can anybody help me? why can't i download the beta firmware? when i click the url given it says i dont have permission to download the file
  21. Sfor

    Sfor Network Guru Member

    Another time related problem.

    The router is up for about 21 hours. The time was set automaticaly and correctly at the beginning. But, now it is late about 20 minutes.

    Looks like the automaticall time adjustment is done only at the start of the router. After that the router clock is not beeing adjusted. The internet connection was up the whole 21 hours, from the start of the router.

    The current time setting of the router are:
    Time Zone: (GMT+01:00) Brussels, Copenhagen, Madrid, Paris
    Automatically adjust clock for daylight savings changes - enabled
  22. DerToob

    DerToob LI Guru Member

    Etherreal log

    Got the last 90 seconds with etherreal before the router crashed again...

    what should i do with this file?
  23. Sfor

    Sfor Network Guru Member

    The same problem again.

    I have a PAP2 VoIP adapter in my LAN. It is set as a static IP device through the Static DHCP Client List. I'm using it to do direct IP dials through the WAN of my internet provider.

    Looks like the port forwarding stops working from time to time. The SIP packets are reaching the other PAP2 device im dialing, but the confirmation of the connection is not reaching my PAP2 device. Also, the the PAP2 device looses connection with SIP registrary server. In the same time I can access the router and the PAP2 WEB console from any LAN computer. So, LAN cable connections are working correctly.

    To make it work again I can:
    - reset the router
    - or to disconnect and then connect back one of the ethernet cables from the router LAN port
    - or to power on another computer in my LAN.

    The powering another computer on, or disconnecting an ethernet cable does not work if there is no TCP/IP communication through the computer or cable. If there is a NetBeui protocol only, it does nothing.

    The settings:
    Internet Connection Type: Static IP
    Local IP Address:
    Subnet Mask:
    Local DHCP Server: Enable
    Start IP Address:
    Number of Address: 100
    IP Address Range: 192 . 168 . 122 . 100~199
    Client Lease Time: 86400
    Manual DNS Setting: disabled
    Static DHCP Client List: for the PAP2 device MAC

    I've noticed Windows 95 computers can not renew IP lease, from time to time, when turned on. It could be related to a fact there was no valid entry in the DHCP Clients Table. Yet, the old Digitus router DHCP services worked fine in such a case.
  24. marwaw

    marwaw LI Guru Member

    i forward all necessary ports :). I'm sure that all ports are properly entered in the forward ports page. I check it.
  25. linuxcluster

    linuxcluster LI Guru Member

    EU Versions

    Just FYI for all EU version users of the WRV200. I have successfully flashed my unit with the .20 and .21 firmware. So far no unexpected happenings other than the already in this thread mentioned.
  26. DerToob

    DerToob LI Guru Member

    Etherreal logfile

    Maybe someone can use it:

    the last seconds before router crashed...

    Mulitcast and Anonymous internet Request Block enabled
    no VPN
    QoS disabled
    Remote Managment disabled
    UPnP enabled.

    Attached Files:

  27. Toxic

    Toxic Administrator Staff Member

    thatks for the file. btw what file sharing program are you using?
  28. DocLarge

    DocLarge Super Moderator Staff Member Member


    what is the firmware version you are using also?
  29. Sfor

    Sfor Network Guru Member

    My router is working without a reset for a little over 3 days, now. The built in clock is late 20 minutes for each day. So, now it is late 1 hour. The automaticall time setting just sets the time once, then the clock is not being synchronized with a time server.

    The Linksys PAP2 adapter had a few more breaks in communication with WAN. I was able to test it a bit better. The problem is not connected with port forwarding feature. Because, my responder does not receive the invite packet. Also, the adapter can not connect to the SIP registrary service.

    Still, the short disconnection of any active ethernet connection is resetting the "lockout" condition.

    Since the PAP2 adapter is a Static DHCP Client, I'm wondering if the Static DHCP could be the problem.
  30. DerToob

    DerToob LI Guru Member

  31. DerToob

    DerToob LI Guru Member

  32. Sfor

    Sfor Network Guru Member

    I have had another opportunity to observe a DHCP lease renew problem with Windows 95, again. So, I was able to gather more informations that way.

    Everything was working correcly for a few days. But today I did reset the router. So, the DHCP Clients Table was cleared, that way. Later I powered on another Windows 95 computer, and it was unable to renew the IP lease through DHCP. Then I started the WINIPCFG application, and I tried to renew the IP manually. And the renew procedure failed, again. I tried a few more times without a success. Then, I released the IP lease. After that I was able to renew the IP lease without a problem. The IP lease was added to the DHCP Clients Table, and everything started to work correctly, from now on.

    The DHCP server should be able to renew the lease without an entry. It should to make a new entry, and to renew the lease, in such a case. The only logical reason to deny a request would be a situation, when there is the same IP entry from a different computer, or there is a different computer with the same IP in the network, already.
  33. ncarbon

    ncarbon LI Guru Member

    VPN & Wireless

    May router has been up and running for 3 days without reboot. Mainly wireless connection with constant VPN with telnet applications. The new firmware has definitely taken my VPN frustrations out.

  34. markleby

    markleby Guest

    hi everyone,
    this is my first post here, does the 1.21 firmware fix the port forwarding ?
    I am currently on 1.0.12 and I've had to resort to enabling DMZ on my WRV200 :-(
    I downloaded and installed 1.20, but then couldn't get a VPN connection (ppoe both ends)
    so I went back to 1.0.12
  35. DocLarge

    DocLarge Super Moderator Staff Member Member

    Go with 1.0.21. PPPoE was addressed in this version...

  36. Walrus78

    Walrus78 LI Guru Member

    Completely agree with DocLarge. IPSEC VPN Tunnels do not work at all on 1.0.20 when using a PPPoE connection on either side. The tunnels are established but do not actually pass any traffic.
  37. marwaw

    marwaw LI Guru Member

    enabling dmz also not work for this game
  38. jsleung

    jsleung LI Guru Member

    I am having the same problem with both 1.0.20 and 1.0.21 firmware versions, where LAN clients could not have their DHCP leases renewed. I can only get an IP address assigned when the lease has expired, or if I manually release it. Rebooting the router does not help. Very frustrating.

    I have all XP boxes though (except for virtual machines, but I don't run them longer than a DHCP lease).
  39. EricChak

    EricChak Network Guru Member

    just got a new WRV200 and upgraded to 1.0.21 but found DDNS for Dyndns never work, 2 VPNs to 2 offices with wireless etc. seems no problem.
  40. ccbadd

    ccbadd Network Guru Member

    You need to disable DoS Prevention under the Firewall settings. I don't know yet if 1.0.23 is also affected by this problem but I will check later tonight.
  41. DocLarge

    DocLarge Super Moderator Staff Member Member

    I've got DDNS running right now "with" DOS enabled. I think it's a timer issue again... It took more than five minutes before DDNS actually started working...

  42. EricChak

    EricChak Network Guru Member

    upgraded to 1.0.23 now working fine for DDNS either enable or disable the DoS
  43. ccbadd

    ccbadd Network Guru Member

    I never got DDNS working with 1.0.21 while have DoS prevention enabled. I rebooted, waited DAYS, and no change. Also, 1.0.23 does not seem to have this problem. Maybe it was a timing thing as Toxic said his worked after a reboot, but I never had it enable until I turned of DoS prevention. Who knows, but I am pretty happy now.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice