WRV200 v1.0.24 (US) Beta Firmware Released.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Nov 7, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    This Firmware is Beta.


    We find that is is best to set router to Default settings before updating firmware, then reset again once firmware has been uploaded sucessfully. But please give it time to update the router before resetting the router for the second time.

    WRV200 Firmware 1.0.24 Release Note

    New Enhancements:
    1. With remote management enabled, if a user makes three unsuccessful logon attempts, WRV200 will block the user's IP address for 180 seconds.
    2. Add a configurable NTP Server in Setup->Time Setting.
    3. Add a SNMP through IPSec Tunnel feature in VPN->IPSec VPN->Global Options.
    4. Add two syslog messages, "WRV200 system restart" for system reboot and "WRV200 start user-called FACTORY DEFAULT procedure" for reset to factory default.

    Issues Fixed:
    1. Fixed the issue that IPSec tunnels cannot be established when the WAN connection type is PPPoE. This issue was found only on firmware 1.0.20.
    2. Fixed the issue that router may unexpectedly reboot when all traffic is coming from/to wireless hosts and there is a VPN tunnel with steady traffic.
    3. Stealth all ports on the firewall when DoS Prevention is enabled.
    4. PPTP (WAN connection type) will not work when the PPTP Server IP and the Default Gateway are different in the configuration.
    5. Fixed an issue that when PPTP is "Connect on Demand" and PPTP connection disconnects due to idle timeout, WRV200 does not try to re-establish the PPTP connection.
    6. Improved the clock accuracy by synchronizing the time with NTP Server periodically.
    7. Fixed an issue that the same DNS server was displayed in the Status->Router page with PPPoE WAN connection.

    Known Issues:
    1. If Syslog is enabled and the WAN connection is up, the Web UI may crash randomly.
    2. IPSec tunnels do not pass NetBIOS Broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    Download the firmware here: WRV200 v1.0.24 Beta Fimware
  2. linuxcluster

    linuxcluster LI Guru Member

    Firmware v1.0.24 (US) on EU Version

    Just FYI for all EU WRV200 owners: flashing the unit with the current .24 (US) build is possible and works great.
  3. Sfor

    Sfor Network Guru Member

    No IP based filtering in the firewall

    I ve been trying to stop all traffic with some IP. I found no other solution, then to route the traffic to a wrong address.

    Sadly, there is no IP based filtering in the firewall settings.
  4. Sfor

    Sfor Network Guru Member

    I've experienced a router crash, today.

    First, all http traffic seemed to work slow. Then, I was not able to connect any server. It seemed like the DNS stopped working. I was able to ping servers outside my network in the same time. Finaly, I have discovered the WRV200 web interface stopped responding. (After providing a correct password, the web interface page have not been loaded.)

    I disconnected the power adapter for a few seconds, and the router started to work correctly.
  5. ccbadd

    ccbadd Network Guru Member

    I had two units develop problems with the dns also. My fix was to enter the static dns entries into the dhcp server settings. Both units developed this problem within a couple of days of each other and a simple hard reboot did not fix it.
  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    The webgui crashing is still an ongoing issue. It's still being worked at this time...

  7. Sfor

    Sfor Network Guru Member

    I can confirm, the DNS lockout and the web gui crash happened after a few days of work.
  8. arrok

    arrok LI Guru Member

    Dissapointing issues

    Hi all.

    First of all I can confirm successful upgrading from 1.0.13EU firmware to newest 1.0.24US beta firmware.

    Unfortunately it didn't help. I still have several serious issues:
    1. After turning LOGging (through email or LOG server) I observe random hanging of WebUI. After 4 crashes today I stop counting. I add only information that it happens so often because of my 'Emule' client. Before that I saw this about once a week...

    2. I see in my 'Kiwi SysLog' utility:
    "2006-11-26 19:29:59 Local4.Info [New Connection] [Outgoing TCP Link] (TCP) Outgoing Source: Destination:81.<006>á"
    Output is VERY OFTEN truncated. It is 'Kiwi SysLog' issue?

    3. After turning on 'Administration->Management->Use https' I saw strange message about expired and different certificate. I've set up my router as I have certificate on '' (Mini Webservice Ltd). It
    must be an ERROR!

    4. After a few hours of activity (with emule) I can't log to my company's VPN network. Before that I can observe slower connection process. After that time I CAN'T connect. Turning OFF/ON device helps. This is repeatable through last 3 days. Without emule I observe this behaviour once in 2 weeks. This is CRITICAL for me! I simply can't normally do my work :((

    I'm dissapointed of this buggy software. It costs me hours of my investigation. Please help! :confused:
  9. Toxic

    Toxic Administrator Staff Member

    arrok the first 2 are already highlighted from day one untill a new firmware comes out. syslog and logging will crash the router.

    4. how many connections to your PC have you when running emule. it sounds like the emule program has taken up ALL bandwidth of the router. try using QOS and lowing the amount of connections to you PC.
  10. arrok

    arrok LI Guru Member

    Ad 1,2.
    I know. I read everything what is available (including DOCs in sources). But how can I know what is going on without ANY evidence or ANY detailed statistics on this device. I can't even observe how many connections firewall Denied and Why. That would be nice:) I know - it is not an expensive device. It is not a BIG router...

    Ad 4.
    About 100-200 connections - works almost stable.
    About 500-700 connections VPN stopped after about 2-4h.
    Bandwidth isn't problem:
    avg UPload: 4-5kB/s (available 32kB/s)
    avg DOWNload: 10-15kB (available 192kB/s)

    I'm doing this with premeditation! It is a great test for any network device:) This way I can see ANY bug about 5-10times faster. I don't want to be surprised with any of my devices in production environment.
  11. arrok

    arrok LI Guru Member

    Ad 4. I've reproduced 'stopping VPN' minutes ago. It was a problem probably with too many connections. I were disconnected and I can't connect newly through VPN, although I can read WWW... Interesting - why?

    I'm trying now to count - how many connections cause this issue. Recently I've mentioned connections. I count on: 'netstat -a' connections. Currently it is the only one computer in router network. Now I have 194 conn. and it is OK. Waiting...
    Seconds ago - dropped. 110 connections... I don't see any rule. Maybe any suggestions for further investigation? I'll help with pleasure!
  12. MarkToo

    MarkToo LI Guru Member

    2 issues I've experienced with .24

    My WRV200 has become much more stable as each version of beta firmware is released... but I'm still hoping that the work on the firmware will continue so this box will live up to its potential!

    Here are my latest two issues with the WRV200 (.24)

    1) I have been unable to access ftp sites at times (via FileZilla, IE7 or Firefox 1.5). A reboot of the WRV200 will clear this up.

    2) My Sunrocket (VoIP service like Vonage) adapter will loose the ability to connect to it's SIP server periodically. It takes a reboot of the WRV200 to fix this as well. (Never had this issue with the WRT54G or DLink DI-604).

    I am using the WRV200 as a client to connect to a Kentrox router at work. There is an Avaya IP Office telephone connected to Port 1 on the WRV200 (this is the purpose of the VPN to my workplace) and a Sunrocket adapter connected to Port 2. Port 3 is connected to my LAN.

  13. csayers

    csayers LI Guru Member

    re:Issues with .24

    I would like to add that I also have problems with my Dlink VTA losing SIP registration to my provider. The adapter seems to stop being able to register. This happens randomly as far as I can tell and rarely will it stay registered more than 24 hours.

    A reboot will allow it to register immediately. This is a fairly serious bug and I am quite good at nailing down causes, I am stumped as to how to narrow down the causes of this one.

    I also have a VPN to work and the tunnel seems very stable. My first guess is to disable the VPN and see if my VOIP adapter stays connected.

    Any hints would be appreciated
  14. tdnyrfan

    tdnyrfan LI Guru Member

    I had problems with keeping the connection with my VOIP Provider as well(Viatalk), I thought it was my PAP2 but it turned out to be that the WRV200 has SPI and it needs to be turned off for everything to work right.

    I changed over to the WRV54G, turned off SPI and everything is working like it should. We need to have an option to trun off SPI with the WRV200 for VOIP to work....it seems that way at least.
  15. ccbadd

    ccbadd Network Guru Member

    I use my WRV200 with a Packet8 BPA-410. I had to change the NAT-Traversal settings in the BPA to use ICE and all works fine. Hopefully other providers will implement ICE and remove the need for all the router configuration changes. ICE is just a method to determine the type of NAT and firewall that is being used and use the correct mappings of ports to get through.
  16. Sfor

    Sfor Network Guru Member

    I've been experiencing VoIP adapter (Linksys PAP) loosing SIP service registration, as well.

    With the 1.0.24 firmware it is a lot less frequent problem, than with the older firmware versions. Yet, it happens, still.

    I've tested two different solutions.
    1) Redirection of PAP2 SIP ports through port forwarding
    2) DMZ setting for the PAP2

    Both solutions are facing the same problem, when the lockout happens.
    - adapter is loosing the connection with the SIP service
    - direct IP calls through the router are not working
    - the web interface of the adapter is working correctly in the same time

    By the way, 1.0.24 is the official firmware available on the Linksys US site.

    Also, there is an european version 1.0.24-ETSI available on the UK Linksys site. According to the date it is a bit newer than the US version.
  17. Sfor

    Sfor Network Guru Member

    I had a SIP lockout a while ago. Here is what happend.

    I have a computer connected to the router LAN port 2. The PAP2 VoIP SIP adapter is connected to the LAN port 4 through a network switch along with another computer.

    - The SIP communication stopped working, and the PAP2 lost connections with both SIP servers.
    - I turned on the computer on the same LAN port 4. The internet access worked fine.
    - The SIP is still locked.
    - I plugged out the ethernet jack from the LAN port 2 of the router, then I plugged it back in.
    - The SIP communication was immediately restored.

    I could restart the router, but this trick is faster. The curious thing is, why the trick is working, at all.
  18. MarkToo

    MarkToo LI Guru Member

    That is a good question! :thumbup:

  19. docinthebox

    docinthebox LI Guru Member

    Could the forum admin please update the firmware 1.0.24 download link on the first page of this thread? The word "portal" needs to be removed from the URL to work. Thanks.
  20. kingvj

    kingvj Network Guru Member

    WRV200 1.0.26 Beta Firmware Is Here...!!!

    WRV200 1.0.26 Beta Firmware Is Here...!!!

    The release notes are as follows:



    1. Enhanced the security of QuickVPN by supporting self-generated certificate on the router. Several functions (buttons) were added to the Certificate Management section on the VPN Client Access page. Administrator can generate new certificate, export certificate for admin backup, export certificate for QuickVPN clients, and import certificate for admin. The router's certificate needs to be delivered to all QuickVPN users and placed in the install directory of QuickVPN Client, e.g. C:\Program Files\Linksys\Linksys VPN Client\. This way the QuickVPN client will only trust these certificates placed in its local directory and will not be deceived by a hacker in the middle to connect to a hostile computer. With QuickVPN Client v1.0.47, when the client encounters a certificate that is not trusted, the client will pop up an warning message, suggesting the user quit the connection attempt. The export and import functions can be used when the admin wants to reset the router to factory default, but does not want to re-distribute the certificate to all of the QuickVPN users.

    2. Added the support for SNMP MIB-II.
    3. Added an optional Service Name field in the PPPoE WAN configuration.
    4. Merged the Advanced Key Management pop-up into the IPSec VPN page.

    Issues Fixed:

    1. Removed the checkbox for enabling "SNMP Through IPSec Tunnel" and made the feature always enabled.
    2. Fixed the issue that the Web UI will crash after 30~40 minutes, if Syslog is enabled and the WAN connection is up.
    3. Fixed the issue with showing incorrect Current Time in the Status->Router page.

    Known Issues:
    1. IPSec tunnels do not pass NetBIOS broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    Btw, i DO have a copy of the 1.0.26 beta. File size is abt 6.5 MB.
  21. kingvj

    kingvj Network Guru Member

    WRV200 1.0.26 Beta Firmware Is Here...!!!

    ... and suprisingly, the release notes mention QuickVPN 1.0.47... I do hv 1.0.40 beta. The official is 1.0.39.. so, where is the 1.0.47?????
  22. Toxic

    Toxic Administrator Staff Member

    where did you get this "beta" from? afaik it is Alpha Firmware. QuickVPN v1.0.47 is undergoing tests.
  23. kingvj

    kingvj Network Guru Member

    From Linksys... i can post it for sure if i am given permission by you.
  24. Toxic

    Toxic Administrator Staff Member

    lol nah its ok. the firmware has now been given Beta Status and we have authority to distribute it now, with QuickVPN v1.0.47
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice