WRV200 v1.0.29 Beta Firmware

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Feb 8, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    A new Beta Firmware has been released. If you find any bugs please report them in full with how to replicate the issue. this helps identify the problem which then will allow a fix to be done.

    *** This firmware is BETA Firmware. ***


    WRV200 Firmware 1.0.29 Release Note 2/05/2006

    1. Enhanced the security of QuickVPN by supporting self-generated certificate on the router. Several functions (buttons) were added to the Certificate Management section on the VPN Client Access page. Administrator can generate new certificate, export certificate for admin backup, export certificate for QuickVPN clients, and import certificate for admin. The router's certificate needs to be delivered to all QuickVPN users and placed in the install directory of QuickVPN Client, e.g. C:\Program Files\Linksys\Linksys VPN Client\. This way the QuickVPN client will only trust these certificates placed in its local directory and will not be deceived by a hacker in the middle to connect to a hostile computer. With QuickVPN Client v1.1.0, when the client encounters a certificate that is not trusted, the client will pop up an warning message, suggesting the user quit the connection attempt. The export and import functions can be used when the admin wants to reset the router to factory default, but does not want to re-distribute the certificate to all of the QuickVPN users.
    2. Added the support for SNMP MIB-II.
    3. Added an optional Service Name field in the PPPoE WAN configuration.
    4. Merged the Advanced Key Management pop-up into the IPSec VPN page.

    Issues Fixed:
    1. Fixed a wireless dropout issue that requires users to reboot the router in order to regain wireless connectivity.
    2. Removed the checkbox for enabling "SNMP Through IPSec Tunnel" and made the feature always enabled.
    3. Fixed the issue that the Web UI will crash after 30~40 minutes, if Syslog is enabled and the WAN connection is up.
    4. Fixed the issue with showing incorrect Current Time in the Status->Router page.
    5. Fixed an issue that SIP ALG cannot handle SIP invite packet with Source port 5060 and Destination port 5060.
    6. Fixed an issue that System Uptime will display incorrectly after the the system is up for 24 hours.
    7. Corrected the Note in the Wireless->WDS page as the following. The WDS feature allows WRV200 to connect with up to 3 wireless repeaters that can be either WAP54GP or WAP54GPE.
    8. Fixed an issue with saving a static route in the Advanced Routing page.

    Known Issues:
    1. IPSec tunnels do not pass NetBIOS broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    you can get the firmware here: WRV200 v1.0.29 Beta Firmware
  2. Sfor

    Sfor Network Guru Member

    I've got a question.
    What the "SIP ALG" is?
  3. MarkToo

    MarkToo LI Guru Member

    Looking forward to trying it out! Hopefully FTP and VoIP issues will be addressed, but I don't see that in the notes (except perhaps "SIP ALG")...

  4. Toxic

    Toxic Administrator Staff Member

    Quote: SIP ALG is an Application Layer Gateway that does NAT Traversal for SIP protocol.
  5. mrkramer

    mrkramer LI Guru Member

    Its good that new firmware has been released. But still doesn't contain some things which should be in future - in my opinion.
    1. Extended firewall - this one have too few options
    2. Extended filtering - i want filter sites which contain some keywords, not only by URL string.
    3. I don't want use external soft for gather messages from router (logging). In my opinin this should be in router.
    Why some options are limited ?! I want enter more, but i can't !!!
    E.G. "Access restriction" have 8 possibilities, but i want enter more !
  6. Thibor

    Thibor Super Moderator Staff Member Member

    i think it's more important that they get the core features working reliably before adding to an already unstable platform and risk introducing yet more bugs to the mix.
  7. kspare

    kspare Computer Guy Staff Member Member

    We've asked for some other things. ie. Port mapping, and have been told they are still in the mode of debugging. Which means adding no more functionality until the current function set is working properly.

    Having said that, we're very close to a bug free firmware, so what you are asking for, assuming they can/will do it, isn't that far down the road.
  8. Sfor

    Sfor Network Guru Member

    Looks like the port forwarding function does not work correctly, if the router IP was changed to a different subnet.

    Port forwarding starts to work again after disabling, and then enabling the port forwarding rules, again.

    In other words, if there are some port forwarding rules, it could be necesary to disable then enable the rules, if the router IP changed.
  9. Sfor

    Sfor Network Guru Member

    About half on an hour after enabling the log in the router, the log viewer stopped receiving "New Connection" events. In less then hour "URL Detect" events stopped appearing as well. I do not believe it was ment to work that way.

    Also, there are no inbound traffic events. Only outbound traffic is reported.

    I think, the log needs some work, still.
  10. csayers

    csayers LI Guru Member

    SIP ATA working now?

    updated to .29 , Did not do full reset, kept all previous settings. I know I should do a factory reset but I didn't.

    I hooked up my ATA that has had problems disconnecting with previous firmware and so far no problems, about 12 hours now. If it can go two days without losing registration, I will consider this router as Excellent for my use.

    IPSEC VPN seems as solid as before. Don't know about QuickVPN.

    Crossing my fingering that the VOIP adapter stays registered.
  11. DocLarge

    DocLarge Super Moderator Staff Member Member

    The log is still one of the areas that's still being "debugged," as Kspare put it. The biggest issue right now was to stop the webgui from crashing wirelessly after a period of 45mins or longer, which was successful. Next thing on the list will be the syslog in a few weeks...

  12. netgeek

    netgeek LI Guru Member

    Instant Messengers still dropping connections

    I am still having the same problem that I had under 1.0.24, 1.0.26 where the router will drop Instant Messenger and FTP protocols after about 12 hours. This does not affect HTTP traffic which is strange and a reboot of the device clears things up. I hope they fix this issue soon. One other strange thing - I had to flash the device two times before it would obtain a WAN IP address. I reset the settings to Factory defaults before and after each flash.
  13. kspare

    kspare Computer Guy Staff Member Member

    We are aware of some issues with settings not being saved to the router, can you give us any idea of how to replicate the ftp/im traffic dropping? IE. How to make the router do this? Thats the first thing the developers will ask us. They need to see how/where it fails so they can fix.
  14. MarkToo

    MarkToo LI Guru Member

    No VoIP or FTP after 12 hours - DETAILS

    Ok... I installed 1.0.29 about 12 hours ago... now my VoIP device (SunRocket) is no longer connected and I can't surf to FTP sites.

    It doesn't take much to recreate the issue, just wait about 12 hours...

    Anyway, here's how my WRV200 is set up:

    Static WAN IP.

    Wireless on, G only, WPA-Personal, MAC address "permit" filtering with 2 addresses.

    IPSEC VPN is on, connected to a router at the office.

    Port based QOS set to "High" on LAN ports 1 & 2

    Port 1 has an Avaya IP telephone that connects to the office via the VPN... this always works well.

    Port 2 has a VoIP "SIP" adapter that connects to SunRocket (goes down after about 12 hours).

    Ports 3 and 4 have computers connected to them.

    All other settings are default I believe. (Happy to submit the config file of the WRV200 if that will help!)

    Let me know if you need any other information.

  15. Sfor

    Sfor Network Guru Member

    The 12 hours up time is not enough, I think. My router is up 24 hours, already. There were no VoIP problems, so far.

    Well. I'm having some FTP problems, on the other hand. But, I'm still investigating the case. Also, resetting the router does not clear the situation.

    I'm not sure what is happening, because the SysLog stops reporting the [New Connection] events during the FTP session. A new connection is made for every single file transfer. But, the SysLog reports only some of all connections made.

    Looks like the log operates in cycles. (Work cycle, stop cycle, work, stop, work, stop,.....).
  16. netgeek

    netgeek LI Guru Member

    1.0.29 Issues

    I leave the router up all the time and I have my IM Clients running over night. This morning while I was using my pc, I noticed the IM clients disconnect, I tried to re-connect, and I finally had to reboot the router to get it to work. My set up is a DHCP WAN IP address with Comcast cable. I have 2 SSID's and 2 VLANS, (PC's and more secure wireless SSID in VLAN 1, Less Secure wireless SSID in VLAN 2). I do not have VPN configured, I do have Wireless MAC address filtering, and Static DHCP set up on the router, not using QOS at this point. One thing of note is that I have a 10.x IP address set up for the LAN. When I upgraded to 1.0.26, I had to flash the firmware 2 times, before it would obtain a WAN IP address just like 1.0.29. I hope this gets sorted out soon.
  17. csayers

    csayers LI Guru Member

    VOIP adapter .029

    First I think MarkToo should make sure he does a full factory reset with the button in for 20 seconds and then put all settings back by hand.

    My VOIP adapter seems to be stable and is staying registered. still have not gone more than about 16 hours as I had to reboot for another reason. So far though it has not unregistered

    I have 1 IPSEC VPN Tunnel to the office very stable, VOIP adapter,

    Wireless G only, WPA personal
  18. Sfor

    Sfor Network Guru Member

    With older firmware versions, it took several days necesary to observe a single SIP lockout. Other time I had several lockouts in one day. I will be more certain the problem is gone after a week or two without a lockout condition. I do not believe the problem was related to the up time of the router.
  19. MarkToo

    MarkToo LI Guru Member

    You know... csayers has "caught me in the act" as it were :) I always set my WRV200 to factory defaults before upgrading the firmware. But, this is the first time in this WRV200 beta debugging "experience" that I thought I'd reset the router to factory defaults by using the web interface instead of the tried and true "20 second rule".

    So, to be a "good sport" I have now reset the router to factory defaults the old fashioned way (holding the button for 20 seconds). I have re-entered the router settings by hand and am now starting the clock on VoIP and FTP stability testing.

    Fingers crossed!

  20. Tom0964

    Tom0964 LI Guru Member

    VPN Problem between two WRV200 (WAN = PPPoE and Remote Security Gateway = FQDN both sides):

    If WAN connection is dropped by ISP (PPPoE) or if WAN connection ist lost by any other cause IPSEC VPN doesn't reconnect. If IPSEC tunnel settings are saved without any change the VPN works again for the next 24h (connection is dropped every 24h by ISP).

    This is what i see in the VPN log:

    034 [MON 14:28:04] "TunnelB" #1: [WRV200 Response:] ISAKMP SA (Main Mode) Initiation
    035 [MON 14:29:14] "TunnelB" #1: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    036 [MON 14:29:14] "TunnelB" #1: [WRV200 Response:] Please check your
    Remote Secure Gateway setting.
    037 [MON 14:30:24] "TunnelB" #2: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    038 [MON 14:30:24] "TunnelB" #2: [WRV200 Response:] Please check your Remote Secure Gateway setting.
    039 [MON 14:31:34] "TunnelB" #3: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    040 [MON 14:31:34] "TunnelB" #3: [WRV200 Response:] Please check your Remote Secure Gateway setting.
    041 [MON 14:32:44] "TunnelB" #4: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    042 [MON 14:32:44] "TunnelB" #4: [WRV200 Response:] Please check your Remote Secure Gateway setting.
    043 [MON 14:33:54] "TunnelB" #5: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel.
    044 [MON 14:33:54] "TunnelB" #5: [WRV200 Response:] Please check your Remote Secure Gateway setting.

    :mad: Any idea?

  21. DocLarge

    DocLarge Super Moderator Staff Member Member

    Is your ip address from your isp dynamic or static? Although I have a static ip, I still have a dynamic dns account from www.dyndns.org. You may want to give that a try by assigning your WAN ip to a dynamic dns address. I went through that with my WAG54G. A dynamic dns address seemed to work for me and stopped the "24hr" refresh that would inevitably end with my internet connection being dropped.

  22. MarkToo

    MarkToo LI Guru Member

    WRV200 1.0.29 VoIP & FTP Update

    Unfortunately, my last reset and re-entering of settings on the WRV200 (see post above) did not clear up the VoIP and FTP issues. This time the router went about 16 hours before the SIP device lost connectivity.

    DocLarge, you were having VoIP and FTP issues as well, weren't you? Have you had a chance to test with 1.0.29 yet?

  23. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    My sources tell me that the developers are working on a SIP ALG (application layer gateway) for the RV042. I can ask if there is a similar fix in the works for the WRV200.

    It is getting close to "show time" with this box isn't it? The developers have been working very closely with DocLarge, Toxic, Kspare, Thibor and a few others to make sure that issues are ironed out quickly. I doubt that other SOHO gear makers work that closely with their customers.

  24. DocLarge

    DocLarge Super Moderator Staff Member Member

    Not anymore. My VOIP and FTP worked fine in 1.0.24, but .25 and .26 broke it. I'm running 1.0.29 and everything works great! Again, I'm on an ADSL connection, so my performance may vary if you're a cable broadband user. FTP works with zero hassles; I was able to access all of my ftp folders from my "real" job, to include access my webmail. VOIP works fine as well.

    From my point of view, 1.0.29 is functioning fine in that respect. Now it's time to focus on another aspect of this router (VLAN).

    As Eric stated, not too many development teams work as close to the real users in the field as what's happening right now. We're not trying to cause a rift in the corporate structure, but if you've been watching for the past 6 months, the WRV200 is getting a facelift at least every 45 days and we've been lucky enough to be two steps from the factory room floor when the changes are made. You "will not" get that type of service from to many other companies (D-link, Netgear, SMC). Oh, don't let Eric's modesty fool you; his detail for security, among other things, is noted in this endeavor also...

    Welcome to a possible "new age" of Linksys where field inputs from guys like us make the difference in the end users functionality...

  25. TomSweet

    TomSweet LI Guru Member

    Are these other issues from Doc's long-running WRV200 What are the issues so far? or is a separate thread to discuss and suggest priorities for these other areas for improvement appropriate? Is such a discussion premature?

    Tom S.
  26. csayers

    csayers LI Guru Member

    MarkToo Voip Issues

    Hey Marktoo, maybe you could tell us what VOIP adapter and VOIP provider you are using, maybe someone here knows a trick to keep that puppy registered, or did you have this device behind a different router in the past with no issues?

    I still have not had my Voip adapter up longer than about 20 hours as I am fooling around with my asterisk on Linksys NSLU2, which by the way is up 24/7 behind the WRV200 with no issues in the past or present firmware.
  27. Sfor

    Sfor Network Guru Member

    Guys like us? ... Well... Yes. We were lucky, or desperate enough to find this forum. But, before I went here, I was trying to make WRV200 to work correctly using the Linksys online help. And guess what. They did not believe the WRV200 had some issues.

    And there were many issues. In september, one week after I bought two WRV200 devices, I was trying to get help with self reset to factory settings , VoIP, SysLog, System clock. The online help agents were not believing me. They were sure firmware is fine. So, there is a close relation with us, advanced users. But, the regular clients were buying unreliable equipment.

    If a client does not know the English language, than he has a problem. Because Polish language page does not have PAP2 and WRV200 support section to this day. And I bought PAP2 in Poland more than 2 years ago.

    I have two WRV200 for half of a year now. All I'm doing so far is loosing time on testing those devices. While I wanted a trustworthy solution 6 moths ago. I stongly doubt, I will buy any new Linksys router.

    Perhaps Open Source could speed things up. But, in order to use open sorce development, device has to be prepared for such a work. Open source developers need to know ways of bringing the device back to life after a firmware crash resulting in unability to upload other firmware. I was desperate enough to start digging through the source code provided. But, the loss of the warranty, and no informations about firmware crash recovery, stopped me from doing any experiments.
  28. Tom0964

    Tom0964 LI Guru Member

    Hi Jay,

    My ip adress is dynamic and i use ddns all the time on both sides. This is typicall for DSL by isp T-Com in germany. After 24hr refresh it takes a few minutes till ddns is updated with the new ip adress. This timeout could be the problem because now WRV200 doesn't reconnect the VPN and i have to save ipsec settings (without any change) to get it work again. Before fw 1.029 this issue appeared after a few hours (3-4 hrs i think, without dropped wan connection by my isp) and on both WRV200 ipsec settings have to be saved again to get vpn work. I think this is still a bug in fw 1.029.

  29. Waelder

    Waelder LI Guru Member

    i would like to see a "use dhcp" checkbox on the PPTP Configuration page.
    Its a requrirement at my internet Provider in Austria.
    and i have seen it on some screenshots of 54 devices

    Thanks Martin Forster
  30. Sfor

    Sfor Network Guru Member

    I was cloning the settings from one router to another using "Backup Configurations" and "Restore Configurations" feature. I did the hard reset on the router, then I loaded the CFG file. The browser displayed page not found, and the web interface was not accessible, any more.

    The new CFG file changed the router LAN IP. The DHCP client was working on the old subnet, while the router WEB interface was not accessible though the old router IP. So, it was not possible to reset router from the web interface.

    After powering off the router, everyting returned to normal, with the new CFG effective.

    I think router should reset itself, after loading a CFG file. This would enable the changes without a power off/on reset.
  31. Patricij

    Patricij Guest

    QuickVPN doesn`t work properly

    Problem with QuickVPN on WRV200 v1.0.29 Beta + QuickVPN v1.0.47 Beta.
    I am using PPPoE on ADSL.
    QuickVPN is conected but no data passthru.
    The message "The remote gateway is not responding" appears after 15-20min.
    I can`t ping Router LAN address or PC on the LAN from QuickVPN PC.

    Any idea, what is the problem?
  32. DocLarge

    DocLarge Super Moderator Staff Member Member

    This has been reported to the developers already. Chances are there might have to be a new firmware upgrade because you're definitely not alone in noticing that.

  33. Waelder

    Waelder LI Guru Member

    Firmware works for me i have the european version.
    ntp - notworking
    vpn passthrug for cisco ipsec vpn
    wireless lan with intel Centrino - sometimes i have a connectionloss with a immediate reconnect

    vpn - untested
    vlan - untested
    upnp -untested
    dmz - untested
    static and dynmaic routing - untested

  34. MarkToo

    MarkToo LI Guru Member

    Is FTP working correctly for everyone with 1.0.29 (especially after about 24 hours uptime)?

    Because it is still not working correctly for me...

    Thanks for your input.

  35. netgeek

    netgeek LI Guru Member

    Having the same problems


    I am still having problems with Instant Message and FTP traffic with 1.0.29. After about 12-18 hours the router must be rebooted to allow the traffic to pass again.
  36. joppefan

    joppefan LI Guru Member

    Still problem with VOIP and FTP!

    I just wanted to say that i also have to reset the router every day to get voip and ftp to work!
  37. MarkToo

    MarkToo LI Guru Member

    joppefan and netgeek,

    Thanks for responding... since DocLarge wasn't having issues anymore I just wanted to see if I was alone in this or not.

    So... it sounds like FTP and VoIP still need regular reboots of the WRV200 in order to function correctly.

  38. Toxic

    Toxic Administrator Staff Member

    guys can you give some more info on this?

    1. WAN Type (DHCP, PPPoE, Static)
    2. LAN setup. WRV200 gateway?
    3. FTP client.
    4. IM Client.
    5. Syslog enabled?
    6. is the ftp usage 24/7 ?
    7. p2p usuage?
  39. netgeek

    netgeek LI Guru Member

    My Info

    1. WAN Type (DHCP, PPPoE, Static) - Comcast Cable DHCP
    2. LAN setup. WRV200 gateway? - the WVR200 is plugged into the cable modem on the WAN port (Changed lan ip to 10.5.x.x)
    3. FTP client. Windows XP FTP Client
    4. IM Client. Trillian(AIM, Yahoo, ICQ), GAIM(AIM, Yahoo, ICQ), Yahoo IM Client
    5. Syslog enabled? No it is not
    6. is the ftp usage 24/7 ? no After the IM Client's disconnect I try the FTP client and it does not work either.
    7. p2p usuage? No I don't use p2p systems.
  40. MarkToo

    MarkToo LI Guru Member


    Thank you for your interest in this VoIP/FTP issue with the WRV200. Here is the information for my WRV200:

    Static WAN IP.

    Wireless on, G only, WPA-Personal, MAC address "permit" filtering with 2 addresses.

    IPSEC VPN is on, connected to a router at the office.

    Port based QOS set to "High" on LAN ports 1 & 2

    Port 1 has an Avaya IP telephone that connects to the office via the VPN... this always works well.

    Port 2 has a VoIP "SIP" adapter that connects to SunRocket (goes down after about 12 hours).

    Ports 3 and 4 have computers connected to them.

    Syslog is NOT turned on.

    FTP Clients: Filezilla, IE7

    FTP Usage: Minimal (just once in awhile when I need a file)

    P2P: No

    IM Client: MSN Messenger

    I would be happy to submit my config file if that helps.

  41. CalledToConstruct

    CalledToConstruct LI Guru Member

    I installed 1.0.29 a day or two after it was released (posted here) and it has been performing reasonably well. However, the last day or two, I've noticed a distinct delay in the response of the DHCP server (it is now to the point of me having to use ipconfig /renew a couple times to get an ip address upon reconnect). So, I tried to access the web ui, and no go. The browser will wait for a minute or two, then report that the connection timed out.

    Seems like there is an issue with high processor usage, or similar.

    1) I have a cable modem, DHCP WAN
    2) 1 wired port in use (which connects to a switch, then PC and NAS drive)
    3) not using ftp
    4) use trillian with 4 IM services... no problems there
    5) logging off (syslog not enabled)

    2 VLANs (1 wired port + 1 SSID + WAN = devices can see each other, 1 SSID + WAN = devices cannot see each other)
    1 VPN login, receives periodic use, connection stable

    I'm on a local road runner WAN; I see a lot of activity on the WAN port, even when not in use by us; which is typical of road runner from what I've read. To me, this says two things... the firewall is doing it's job... the firewall gets a lot of use.

    I hope this helps the developers in some way to determine the problem so it can be resolved in a future release. This is the second such occurrance since I upgraded to 1.0.29 Restarting the device seems to clear the condition for a period of time.

    // Joe

    [edit]: While attempting to enable the email alert, I discovered the last three characters of my admin password in the From: box. (it didn't occur to me that it was part of the password until later). I enabled the email alert, entered email addresses and saved changes. From that point forward, I was not able to log back into the router (invalid user name or password)... until I did a factory reset and reloaded my configuration file.

    My admin password at that point was 20 characters long.
  42. joppefan

    joppefan LI Guru Member

    1. WAN Type (DHCP, PPPoE, Static)

    2. LAN setup. WRV200 gateway?
    WRV200 is gateway and i have an airport express connected as a repeater (WDS)

    3. FTP client.
    Rapidweaver, Transmit, ftp in console (macos x)

    4. IM Client.
    iChat i have had some problems but havnt tested it with the new firmware will do that when FTP hangs next time(just rebooted)
    VOIP dies when FTP dies(i have tried with hardware phones and softwarephones)

    5. Syslog enabled?

    6. is the ftp usage 24/7 ?
    I upload things thruu ftp 4-5 times a week

    7. p2p usuage?
    about 1 gigbyte / week
  43. johsod

    johsod Guest

    Hi everyone,

    I have a few issues with wrv200 that I haven't seen mentioned. The first one seem to be a bug while the second one is more of a feature request.

    1. Clients quite often loose connection with the router. This problem seem to be due to low network load. I have two clients and they both show the same tendency. When the network load is low the clients loose the connection with the router. When putting some network load, the connection seem to be more stable.

    2. Portforwarding can only be done to the same network as the LAN interface reside on.

  44. Sfor

    Sfor Network Guru Member

    Well. I deployed second WRV200 in order to create a IPSec VPN connection, more than a week ago. The result is not a bad one, but I found some issues, still.

    1) FTP lockout.
    It happend a few times. The FTP client can not make a connection wit FTP server. Sometimes it can not connect at all, sometimes it can not create another data connection to transfer another file. Router reset clears the lockout.

    2) GUI crash and HTTP connection problems.
    This is a strange one. I saw it with the older firmware once, as well. Someone is doing ARP poisoning attacks in the WAN my routers are connected to. When attack was finished and one router regained connection, the other one had the GUI locked and HTTP traffic crashed. Strange thing is some sites were working, other not. Also HTTP connections were working slower than they should. In the same time the not affected router was working correctly. Reset solved the problem.

    Both routers are connected to ethernet 10/100 WAN with static IP
    There is a IPSec VPN tunnel formed between them.
    Both routers are using VoIP (PAP2) with port forwarding, without any problems.
    Wireless is off.
    SysLog is off.
    Ftp is used from time to time, only. (Windows 98 FTP.EXE client)
    No P2P.
    No QoS
    No VLAN
  45. Sfor

    Sfor Network Guru Member

    I've experienced another FTP lockout, today. This time it was connected with VoIP problem. I was unable to make any direct IP SIP connection. There was no answer from the SIP provider server on NAT keep alive packets, as well. The SIP lockouts I had with the older firmware were different than this one. So, it can be a result of a different cause.

    The VPN and HTTP was working correctly. Router reset cleared the problem.

    There was a large LAN traffic before the problem happened. I transferred more than 50GB through the network using NetBeui and Microsoft Networking.
  46. csayers

    csayers LI Guru Member

    SIP VOIP Problems continue

    The .29 firmware has not solved SIP deregistration. It seemed like it stayed up a long time when I first loaded .29 but it is clear that the same old problems persist.

    This really needs to get fixed. This is a common thing now days to have a VOIP adapter behind the firewall. Of Course a reboot fixes it for a while again.
  47. netlinker

    netlinker LI Guru Member

    OK, the user interface of my WRV200 is also no longer responding. VPN is still up and working fine.

    How do I restart this thing without sending someone to the wiring closet at a remote location?
  48. MarkToo

    MarkToo LI Guru Member

    Well, it's nice to know that I'm not alone with the FTP and VoIP issues :wink:

  49. ccbadd

    ccbadd Network Guru Member

    The FTP issue is about to cause me to pull one of my WRV200's. Are things working better with the 1.0.30 beta firmware?? I almost bought an RVL200 to replace it, but I don't have any confidence in the new Linksys products right now. Once they stabilize, I might get one.
  50. jimi2f

    jimi2f Guest

    I have 4 WRV200's and my problem with all of them is after a while (several days) I can no longer access the router thu the interface until I reboot the device. This is my biggest problem right now and netlinker is the first person posting here that I've seen with the same problem. Other people must be having this issue! How could I be having the problem with all four and it not be a common issue ? I'm using FW ver 10.24 now and have had the same problem with other versions. Also it doesn't matter weather I log in with https or http.
  51. Sfor

    Sfor Network Guru Member

    You should change the firmware to 1.0.29. It is much more stable, than the older firmware revisions. Besides, the SysLog feature was crashing the web user interface in the 1.0.24. The problem was fixed in the 1.0.26, as far as I remember.
  52. netlinker

    netlinker LI Guru Member


    - I flashed a brand new WRV200 with 1.0.29
    - cleared all the settings
    - set PPPOE
    - Wireless with WEP
    - one IPSEC VPN Tunnel

    and nothing else. Use is very moderate for just two days a week over the weekend (no FTP, File Sharing or VOIP). The router interface crashed during the week with absolutely no user traffic going on.
  53. Sfor

    Sfor Network Guru Member

    I also noticed the user interface crash in 1.0.29. But, it happened just once. And I think it could be somehow related to arp poisoning attacks on the WAN I'm connected to.
  54. DerToob

    DerToob LI Guru Member

    I´m using two WRV200 with .29 and i noticed the GUI crash on both of them..

    From time to time the VPN crashes, too. After restarting the tunnel it works fine for about one week and then the following error occurs:

    193 [Tue 16:07:59] "TunnelA"[2] xxx.xxx.xxx.xxx #17: responding to Main Mode from unknown peer xxx.xxx.xxx.xxx
    194 [Tue 16:07:59] "TunnelA"[2] xxx.xxx.xxx.xxx #17: transition from state STATE_MAIN_R0 to state STATE_MAIN_R1
    195 [Tue 16:07:59] "TunnelA"[2] xxx.xxx.xxx.xxx #17: STATE_MAIN_R1: sent MR1, expecting MI2
    196 [Tue 16:07:59] "TunnelA"[2] xxx.xxx.xxx.xxx #17: NAT-Traversal: Result using 3: no NAT detected
    197 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: transition from state STATE_MAIN_R1 to state STATE_MAIN_R2
    198 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: STATE_MAIN_R2: sent MR2, expecting MI3
    199 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: Main mode peer ID is ID_IPV4_ADDR: 'xxx.xxx.xxx.xxx'
    200 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: I did not send a certificate because I do not have one.
    201 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: transition from state STATE_MAIN_R2 to state STATE_MAIN_R3
    202 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: [WRV200 Response:] ISAKMP SA established
    203 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: STATE_MAIN_R3: sent MR3, ISAKMP SA established {auth=OAKLEY_PRESHARED_KEY cipher=oakley_3des_cbc_192 prf=oakley_sha group=modp1024}
    204 [Tue 16:08:00] "TunnelA"[2] xxx.xxx.xxx.xxx #17: Dead Peer Detection (RFC 3706): enabled
    205 [Tue 16:08:01] "TunnelA"[2] xxx.xxx.xxx.xxx #18: responding to Quick Mode {msgid:ec47a96d}
    206 [Tue 16:08:01] "TunnelA"[2] xxx.xxx.xxx.xxx #18: transition from state STATE_QUICK_R0 to state STATE_QUICK_R1
    207 [Tue 16:08:01] "TunnelA"[2] xxx.xxx.xxx.xxx #18: STATE_QUICK_R1: sent QR1, inbound IPsec SA installed, expecting QI2
    208 ERROR: "TunnelA"[2] xxx.xxx.xxx.xxx #18: pfkey write() of SADB_X_ADDFLOW message 155 for flow tun.101e@xxx.xxx.xxx.xxx failed. Errno 14: Bad address
    209 | 02 0e 00 09 00 17 00 00 00 00 00 9b 00 00 1e ab
    210 | 00 03 00 01 00 00 10 1e 00 00 00 00 00 00 00 02
    211 | ff ff ff ff 00 00 00 00 00 03 00 05 00 00 00 00
    212 | 00 02 00 00 57 4f ee e8 00 00 00 00 00 00 00 00
    213 | 00 03 00 06 00 00 00 00 00 02 00 00 58 82 58 a5
    214 | 00 00 00 00 00 00 00 00 00 03 00 15 00 00 00 00
    215 | 00 02 00 00 c0 a8 a0 00 7f ff 7c c8 00 00 00 00
    216 | 00 03 00 16 00 00 00 00 00 02 00 00 c0 a8 96 00
    217 | 7f ff 7d 36 00 00 00 00 00 03 00 17 00 00 00 00
    218 | 00 02 00 00 ff ff ff 00 38 38 2e 31 36 35 00 00
    219 | 00 03 00 18 00 00 00 00 00 02 00 00 ff ff ff 00
    220 | 00 00 00 00 00 00 00 00
    221 [Tue 16:08:11] "TunnelA"[2] xxx.xxx.xxx.xxx #18: discarding duplicate packet; already STATE_QUICK_R1
    222 [Tue 16:08:31] "TunnelA"[2] xxx.xxx.xxx.xxx #18: discarding duplicate packet; already STATE_QUICK_R1
    223 [Tue 16:18:44] forgetting secrets
    224 [Tue 16:18:44] loading secrets from "/etc/ipsec.secrets"
    225 [Tue 16:18:44] "TunnelA": deleting connection
    226 ERROR: "TunnelA": pfkey write() of SADB_X_DELFLOW message 158 for flow int.0@ failed. Errno 14: Bad address
    227 | 02 0f 00 0b 00 0e 00 00 00 00 00 9e 00 00 1e ab
    228 | 00 03 00 15 00 00 00 00 00 02 00 00 c0 a8 a0 00
    229 | 7f ff 7c c8 00 00 00 00 00 03 00 16 00 00 00 00
    230 | 00 02 00 00 c0 a8 96 00 7f ff 7d 36 00 00 00 00
    231 | 00 03 00 17 00 00 00 00 00 02 00 00 ff ff ff 00
    232 | 00 00 00 00 00 00 00 00 00 03 00 18 00 00 00 00
    233 | 00 02 00 00 ff ff ff 00 00 00 00 00 00 00 00 00
    234 [Tue 16:18:46] "TunnelA"[2] xxx.xxx.xxx.xxx: deleting connection "TunnelA" instance with peer xxx.xxx.xxx.xxx {isakmp=#17/ipsec=#0}
    235 [Tue 16:18:46] "TunnelA" #18: deleting state (STATE_QUICK_R1)
    236 | 02 04 00 03 00 0b 00 00 00 00 00 9f 00 00 1e ab
    237 | 00 03 00 01 75 8d 63 c8 00 01 00 00 00 00 00 00
    238 | ff ff ff ff 00 00 00 00 00 03 00 05 00 00 00 00
    239 | 00 02 00 00 58 82 58 a5 00 00 00 00 00 00 00 00
    240 | 00 03 00 06 00 00 00 00 00 02 00 00 57 4f ee e8
    241 | 00 00 00 00 00 00 00 00
  55. ghost_zero5

    ghost_zero5 LI Guru Member

    Just to mention it:
    I also still have my FTP and ICQ-IM-Issues (not working after some time; need router reboot afterwards to get it working again) with the new firmware (1.0.29 Beta).
    I did a setting reset before and after the firmware update and entered the settings afterwards manually...
  56. Sfor

    Sfor Network Guru Member

    Well. I witnessed another web UI crash in the WRV200. Everything was working fine. But, when I tried to enter the router web page the password prompt appeared, then the screen remained empty.

    I removed the power cord for a few seconds, then everything started to work correctly.

    So, the web UI does crash with no apparent reason.
  57. ghost_zero5

    ghost_zero5 LI Guru Member

    P.S.: I would like to see a possibility to change settings through telnet/ssh... Would be great to be able to change settings over command-line...

    Although first they should get rid of most of the bugs (and most annoying bugs like FTP/IM-Issues, WebUI-Crashes, VoIP,...)
  58. Tom0964

    Tom0964 LI Guru Member

    All i wish is a stable VPN between two WRV200 over PPPoE. I changed every possible feature in VPN menue but after ISP 24h dropdown the WRVs never reconnect. :-(
  59. Sfor

    Sfor Network Guru Member

    Summer time is back. All my computers switched to the summer time. But, the WRV200 is keeping the winter time.

    Poland is in (GMT +01:00) Sarajevo, Skopie, Warsaw, Zagreb time zone. But, the "Automatically adjust clock for daylight savings changes" checkbox is disabled for this and all other (GMT +01:00) time zones. So, it is necesary to select some (GMT +02:00) time zone in order to have the clock running the local Warsaw time. All other (GMT +01:00) time zones users with day light saving are in the same position, I believe.
  60. DocLarge

    DocLarge Super Moderator Staff Member Member


    as inconvenient as this may sound, try power cylcing the wrv200 every 72hrs or more/less and see how this helps. I've gotten into the habit of doing a power cycle every three days and it seems to keep things on the up and up. No, it's not ideal, but until the next firmware release in April, this should get you through :(

  61. HughR

    HughR LI Guru Member

    Do you know if they make changes between a beta and a release? If they don't, then I guess that the purpose of beta testing is to kill not-good-enough potential releases before they become official releases.

    I don't bother to look at the source code. Even though I might be able to find problems by reading it. The reason is probably that I'm lazy. But I tell myself that the reason is that by the time they release source, that version is stale. The reason is that they only release source when they make an official release.

    Perhaps you could suggest that they release the source code for the beta with the binary. Not only are they obliged to do this by the GPL, it might encourage some of us to give more timely feedback.
  62. Sfor

    Sfor Network Guru Member

    I've been thinking about looking at the source code myself, as well. But, there are more problems related than just the complication of such a task.
    - warranty will be lost if not an official firmware release will be loaded
    - there are no recovy procedure from an unsuccessfull firmware upgrade.

    In order to make a good GPL platform the device should offer the possibility of hardware firmware upgrade. So, it would be safe to test own firmware versions, with a possibility of recovering the device, if the software upgrade procedure fails.

    It's too dangerous to tweak the firmware, right now, I think.
  63. Loveland95

    Loveland95 LI Guru Member

    I also have two WRV200's running .29 code with a 100-mile (as the crow flys)VPN tunnel between them. I also notice problems with the web access but can't correlate it to anything I'm doing. I've resorted to purchasing a "Web Power Switch" that I use to cycle power remotely (from my Treo 650) through the Port Forwarding feature.

    Some time ago I noticed some questions about VLAN capabilities / usage. I'm less than excited about the feature, as my Quick VPN users still have access to everything, so I would suggest adding the VLAN access table to the VPN user registration / authentication.

    As for .29 code, as most of you, we've struggled with multiple prior releases, but .29 seems pretty solid. I hope Linksys continues to work on the WRV200 feature set while fixing bugs. Thanks.
  64. Jogonboch

    Jogonboch LI Guru Member

    I also had the problem with dropping IM connections with .29
    I could resolve the problem with turning of DoS prevention. Can anyone confirm this?
  65. bsemisch

    bsemisch LI Guru Member

    Is the firmware still available? I get an error: Invalid File ID

    I'm hoping this solves some issues with my ATA that loses its registration daily (using port 5060, among others).
  66. Sfor

    Sfor Network Guru Member

    You can download 1.0.29 and firmware versions from the linksys site.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice