WRV200 v1.0.34 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Aug 21, 2007.

  1. Toxic

    Toxic Administrator Staff Member

    WRV200 Firmware 1.0.34 Release Note

    8/20/2007 (Beta Testing)

    Issues Fixed:

    1. Fixed an issue with reconnecting a G2G IPsec tunnel when a remote gateway is identified by a DDNS domain name. With this fix, two WRV200 routers, both using DDNS for internet connection, can reliably reconnect a tunnel should a tunnel go down and WAN IP address changes.
    2. Fixed an issue that the Web Admin Interface is not accessible over IPSec tunnels.
    3. Fixed an issue with bandwidth guarantee for SIP in the Application-based QoS page (with Bandwidth Allocation enabled).
    4. Fixed an issue with NTP Daylight Saving Timezone.
    5. Fixed an issue that some corrupted log entries show up in syslog.
    6. Removed the reference to the Loopback Destination Interface in the Help page, since the router does not support it.

    Known Issues:
    1. IPSec tunnels do not pass NetBIOS broadcast packets. This may create a problem when users want to search computers by names or to browse the network neighborhood on Windows Explorer. Users can use a LMHOSTS file to work around this issue. More information can be found at

    2. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.

    Firmware is available from Linksys Tech Support or our own downloads section shortly. Please report any issues with this Beta in this thread giving as much detail as possible to replicate the issue. Posting "its broken" will not help fix an issue.
  2. Sfor

    Sfor Network Guru Member

    "Automatically adjust clock for daylight savings changes" function does not work with "GMT +01:00 Sarajevo, Skopje, Warsaw, Zagreb" time zone. It is necesary to switch the time zone to a GMT +02:00, during the summer.
  3. Sfor

    Sfor Network Guru Member

    The router does a self reset, when I'm powering on the second computer in my network, quite often. It is not a big problem, but it does not look "healthy".

    Here is a description of the effect:

    I'm powering on one of my computers, then do some browsing through HTTP. Then I do power on another computer and I return to the first one leaving the second booting. While I'm browsing HTTP the Internet connection freezes for a minute or so. The second computer finished booting and it displays PM and POP3 connection error messages. I'm logging to the router WEB UI, and I can see it just rebooted itself.

    Looks like, the second computer does something to the router forcing it to reset itself. It could be a DHCP negotiation, or any other network traffic caused by a computer in a boot sequence.
  4. Sfor

    Sfor Network Guru Member

    There is something wrong with passing DNS queries. I'm using the DHCP. If the DHCP sets the router as the DNS server, some queries are returning no server found. When I switch to "User Defined DNS Servers" to bypass the router DNS service, everything works fine.


    I've been resetting the router a few times by changing the DHCP User Defined DNS Servers settings. It appears, every next reset took a while longer. At the end router hanged. There were no DHCP service, nor WEB GUI access. And I had to power reset the device, in the end.
  5. Sfor

    Sfor Network Guru Member

    I'm unable to access the WRV 200 WEB GUI through IPSec VPN tunnel. Pinging does not work, as well.

    Can anyone confirm the fix works?
  6. DerToob

    DerToob LI Guru Member

    I can ping and access the WRV from both sides of the tunnel.
    https enabled, allow any ip
    System uptime is 4 days
  7. Sfor

    Sfor Network Guru Member

    You are using remote router access, then.

    What IP address you are using to access the router from remote location? Is it the WAN IP, or internal LAN IP?
  8. DerToob

    DerToob LI Guru Member

    Oh, now i understand your problem. Yes, that´s right. I access via internal LAN IP.

    I disabled remote router access a few minutes ago and i had no problems to acces via VPN again.
    Pinging works fine, also..
  9. Sfor

    Sfor Network Guru Member

    In my case it doesn't work.

    I have 2 WRV200 devices. One is running 1.0.33, the other one 1.0.34. There is an IPSec VPN tunnel between both networks.

    When I'm trying to ping the 1.0.34 router from the 1.0.33 network, I'm receiving a timeout result.

    Here are my Management page settings:

    Local Router Access
    Use HTTPS: Disabled
    Allow Wireless Web Access: Disabled

    VPN Summary:
    Remote Group:
    Local Group:
    Key Methods: AutoKeying
    Tunnel Status: C

    Remote Router Access
    Remote Management: Disabled

    1.0.33 LAN IP is
    1.0.34 LAN IP is
    Subnet Mask:

    Both routers WAN IP is DHCP assigned.
  10. DerToob

    DerToob LI Guru Member

    my settings are like yours...

    in order to reproduce your problem i switched

    "local router access - use https" from enabled to disabled..

    with the result, that i could only connect by using "https://" ???!
  11. Sfor

    Sfor Network Guru Member

    Here are my HTTPS switching on/off observations.

    Swithing the HTTPS on:
    Everything looks fine. The router reboots, the browser is redirected to the https page, every time, I think.

    Switching HTTPS off:
    In the first attempt - The browser does not reconnect after the router reset. It is necesary to enter the url, again.
    On the second attempt - The WEB GUI hanged. I can not connect to the router with http/https. Power reset solved the problem.

    I can not access the router WEB GUI through VPN tunnel, still (with and without HTTPS).

    -------------------------- Edit

    Switching the HTTPS to enabled does not work flawlessly, as well. After a reboot the password prompt appears, but it does not accept the password. After 5 tries an empty screen is displayed. If I refresh the page, the https page opens without a password prompt.

    I was able to make the WEB GUI hang, again. It took a few HTTPS enable/disable cycles. But I lost the count somewhere on the way. Again the the GUI HANG happened on HTTPS disable reboot. And, again I had to power reset the device.
  12. grimbeaver

    grimbeaver LI Guru Member

    I had the same problem with 1.0.33. Ended up downgrading the firmware and doing a reset to defaults, then only turned on services I needed. Still not sure what was wrong but since it takes out the WEB GUI it takes out the VPN access as well.
  13. CalledToConstruct

    CalledToConstruct LI Guru Member

    Since it was not listed in the 'issues resolved', I'm not surprised... however, ftp traffic still seems to hang after at least 24 hours of uptime (since last restart).

    // Joe

    (edit / update)

    Today, after another 24 hour period and an apparent FTP freeze, I tried something new... instead of restarting the router, I did a release / renew on my wan connection and the FTP traffic sprang back to life!

    I'm using: Connection Type: Automatic Configuration - DHCP, Blank Host Name, Domain Name: revelations, MTU: auto, Advanced Routing: (all default settings)

    At any rate, I hope this information is helpful.

    // Joe
  14. MarkToo

    MarkToo LI Guru Member

    Unfortunately, I have a static WAN IP address along with the "FTP issue" so I can't try this... Also, I notice there aren't too many posts about this issue anymore. Is the "FTP issue" even considered a valid issue by Linksys?

  15. srainess

    srainess LI Guru Member

    Still issues with Older Cisco VPN Client and others...

    Still have to reboot router right before using older CISCO VPN Client.
    Also, AIM, Ichat still require port triggering to work correctly (Other Linky's do not).

    LOTR Online still requires reboot, otherwise client hangs every so often.

    I know this may be the wrong section for this, but I will ask anyway..
    Is there a QuickVPN type client for a Mac running OS X ?


  16. CalledToConstruct

    CalledToConstruct LI Guru Member

    I'm guessing a lot of people have given up, just "deal with it" or have replaced the router.

    Although, I don't see it listed on the "known issues list". :(

    // Joe
  17. HughR

    HughR LI Guru Member

    How do you get it from Linksys Tech Support? Is it on their site (I don't see it)? Do you have to ask them for it?

    (I know that it is available from this site: http://www.linksysinfo.org/forums/downloads.php?do=file&id=64. Even so, I would like to get it from Linksys directly.)
  18. Sfor

    Sfor Network Guru Member

    As far as I know, the linksysinfo.org works closely with Linksys firmware programmers.

    To put it other way, linksysinfo.org is a Linksys beta testers and open firmware developers community.

    Beta firmware revisions are not available from Linksys support. The only way to get it is to become a beta tester.

    I can not find words to describe the Linksys support channels in relation to the WRV200 devices. They seem to know nothing, to me.
  19. HughR

    HughR LI Guru Member

    I want the source code for the beta. The GPL clearly requires that the distribution of the binary is only allowed if the source is distributed as well.

    Pushing this point at linksysinfo has been ineffective for a year. I get surly dismissal.

    I wish to get the beta from Linksys so that I can push Linksys for the source.

    Note that the WRV200 source code release for non-beta firmware only came after I pushed Linksys. I cannot claim that there was a causal relationship.
    I guess that I expect no more from most support organizations.

    I find that a community of knowledgeable users is usually much more helpful. Open source enables the community to be much more effective: instead of just inferring the behaviour from a black box, it is possible to examine the guts to discover and even fix the cause of problems.

    Even though much source code has been released for the WRV200, it is always behind what we are using. I guess that the point is that it only makes sense to work with the beta and not the last official release because the releases are obsolete.

    Recap of some things I've said in other postings:

    I wrote some of the IPsec code, so I might be useful in fixing it.

    The current version of Openswan (IPsec) is much advanced and bug-fixed over the one used in the WRV200.

    I bought the WRV200 because I needed a certain feature in a wireless router with IPsec. That feature was mentioned in the WRV200 manual. When I got the unit, that feature was disabled. When I asked support, they said that the manual would be fixed! I could easily add the feature back if I could rebuild the firmware.

    The WRV200 appears to be crappy enough (according to messages on linksysinfo.org) that I've never actually tried to use it -- I don't need yet another source of flakiness in my networking. I keep hoping that Linksys will get it right and the years drift by.

    Because source is never released for the latest firmware I am even less motivated to bother attempting to build my own. And nobody else has. I'm not interested in being alone in that kind of adventure.

    Is the WRV200 still a current product? Certainly it has not lived up to its potential and now I expect it is too late. I assume that the technical source of all the problems is within the firmware. Of course the blame sits squarely on Linksys.
  20. Sfor

    Sfor Network Guru Member

    Well. The fact is, the firmware is not maintained by Linksys. Linksys added a case and brand. Boards and firmware are made by other company.

    I was thinking about tweaking the firmware, as well. But the WRV200 does not have any "brick recovery routine". If the tweaked firmware fails, device will be useless.

    So, the open source development should begin with obtaining a proper "brick recovery routine". Then we will be able to test our creations without the risk of destroying the routers.
  21. HughR

    HughR LI Guru Member

    That is the case, as I understand it. But brand names are currency in todays world. By putting their name on it, they are putting there reputation on the line too. So they are responsible.
    The User Guide, Appedix A: "Common Problems and Solutions", #15 says if the firmware is screwed up, use the TFTP technique to attempt recovery.
    Unfortunately neither the TFTP program nor the pdf seem to be part of the firmware download (as claimed). So I don't know the procedure. I don't know how much of the firmware needs to be functional for this technique to work. There are some hints here http://forums.linksys.com/linksys/board/message?board.id=Wireless_Routers&message.id=35884 and here http://forums.linksys.com/linksys/board/message?board.id=Wireless_Routers&thread.id=34868.
  22. Sfor

    Sfor Network Guru Member

    Well. I tried the TFTP and... it does not work.

    Since it doesn't work with an operational WRV200, it should not work with a broken one, as well.

    This little experiments is a good proof to a few things I was saying before:
    - Linksys support knows nothing.
    - TFTP is a Linksys standard feature, but WRV200 was not developped by Linksys.
    - WRV200 does not have TFTP support

    ------ Edit
    The User Guide mentiones the TFTP firmware upgrade, indeed. I'll bet they just made a copy of some other router trobleshooting guide.

    As for the value of the Linksys brand name. It is not worth much, since Cisco is thinking about killing the Linksys brand.
  23. Jogonboch

    Jogonboch LI Guru Member


    I just upgraded to 1.0.34. VPN doesn't work as it should.
    I have a G2G VPN from my WRV200 to a BEFVP41 V2. With 1.0.29 it worked fine, but with the new firmware I geht invalid payload errors on both sides.
    Here is what the WRV writes in its log:

    113 [Wed 17:59:32] "TunnelA" #51: starting keying attempt 5 of at most 5
    114 [Wed 17:59:32] "TunnelA" #63: initiating Main Mode to replace #51
    115 [Wed 17:59:33] "TunnelA" #63: transition from state STATE_MAIN_I1 to state STATE_MAIN_I2
    116 [Wed 17:59:33] "TunnelA" #63: STATE_MAIN_I2: sent MI2, expecting MR2
    117 [Wed 17:59:34] "TunnelA" #63: I did not send a certificate because I do not have one.
    118 [Wed 17:59:34] "TunnelA" #63: transition from state STATE_MAIN_I2 to state STATE_MAIN_I3
    119 [Wed 17:59:34] "TunnelA" #63: STATE_MAIN_I3: sent MI3, expecting MR3
    120 [Wed 17:59:34] "TunnelA" #63: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    121 [Wed 17:59:34] "TunnelA" #63: received and ignored informational message
    122 [Wed 17:59:45] "TunnelA" #63: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    123 [Wed 17:59:45] "TunnelA" #63: received and ignored informational message
    124 [Wed 18:00:04] "TunnelA" #63: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    125 [Wed 18:00:04] "TunnelA" #63: received and ignored informational message
    126 [Wed 18:00:44] "TunnelA" #63: max number of retransmissions (2) reached STATE_MAIN_I3. Possible authentication failure: no acceptable response to our first encrypted message

    Of course I did a factory reset after the upgrade.
    The WRV has an ADSL-connection to the internet; the error reminds me in the problems an older version had with VPN tunnels over ADSL connections... may be this time it's something similar...
  24. TazUk

    TazUk Network Guru Member

    Have you tried changing the MTU ?
  25. HughR

    HughR LI Guru Member

    It would be good to see the logs from both sides. Bonus points if their clocks are synchronized.

    In fact, the side you quoted did not complain about an invalid payload. It said that the other side made such a complaint. Oh and that this side is ignoring the complaint (this side doesn't know what to do with a complaint -- that's why it ignores it).
    This last line means: I got an informational payload and I'm ignoring it.

    The type of the informational payload it received is "INVALID_PAYLOAD" which means that the other side is complaining. The complaint means that the other side sees a payload that is invalid.

    Since the complaint isn't specific enough, it would be really good to look at the log from the other side. It should contain a more specific diagnostic.
    This one means that a whole message was informational, and is being ignored (well, not totally: it reported on the informational payload contained therein).
    I don't imagine that this behaviour is changed by a WRV200 firmware upgrade. I would guess that they are not doing any tweaking to the code handling the IKE protocol.

    Notice that the last message suggests that your problem might be authentication. It might be right. That would probably make the informational messages a red herring. I cannot tell.

    It's been a few years since I wrote the code that generated these messages so I might be forgetting something important.
  26. HughR

    HughR LI Guru Member

    I just asked Linksys support for beta firmware. They had a skill-testing question "why?" (actually more like: "What problem are you experiencing that you hope new firmware would address?"). After apparently passing that test, they said that the latest beta that they have is 1.0.33.

    The support person thinks that firmware on linksysinfo.org is built by third parties. Correct for things like dd-wrt, but I think that this is wrong for WRV200 firmware at this time.

    Can anyone tell me how I could get the current beta from Linksys?
  27. Jogonboch

    Jogonboch LI Guru Member

    Ok - the clocks aren't synchronized.
    The problem is a little bit strange; some time after I worte my post the tunnel started working... without any change in the configurations. When I disconnect the tunnel in de GUI the reconnect a few minutes later works fine, too. I only get the problem when one of the routers reboot and then it takes a few minutes until the tunnel starts working (I think it's somewhere between 10 and 30 minutes).
    But I can access my VPN after some time anyway, I just have to wait a bit after a router reset (which hopefully won't happen very often).

    I didn't get the log from yesterday evening, the BEFVP41 overwrote the old log entrys this night... But I've restartet the WRV to see if the problem still occurs; here is what both routers wrote in their log this time (while it didn't work):


    000 [Thu 07:15:00] added connection description "TunnelA"
    001 [Thu 07:15:05] "TunnelA" #2: initiating Main Mode
    002 [Thu 07:15:05] "TunnelA" #2: [WRV200 Response:] ISAKMP SA (Main Mode) Initiation
    003 [Thu 07:15:06] "TunnelA" #2: transition from state STATE_MAIN_I1 to state STATE_MAIN_I2
    004 [Thu 07:15:06] "TunnelA" #2: STATE_MAIN_I2: sent MI2, expecting MR2
    005 [Thu 07:15:08] "TunnelA" #2: I did not send a certificate because I do not have one.
    006 [Thu 07:15:08] "TunnelA" #2: transition from state STATE_MAIN_I2 to state STATE_MAIN_I3
    007 [Thu 07:15:08] "TunnelA" #2: STATE_MAIN_I3: sent MI3, expecting MR3
    008 [Thu 07:15:08] "TunnelA" #2: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    009 [Thu 07:15:08] "TunnelA" #2: received and ignored informational message
    010 [Thu 07:15:18] "TunnelA" #2: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    011 [Thu 07:15:18] "TunnelA" #2: received and ignored informational message
    012 [Thu 07:15:38] "TunnelA" #2: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    013 [Thu 07:15:38] "TunnelA" #2: received and ignored informational message
    014 [Thu 07:16:18] "TunnelA" #2: max number of retransmissions (2) reached STATE_MAIN_I3. Possible authentication failure: no acceptable response to our first encrypted message

    BEFVP41 V2:
    2007-09-13 08:15:11 UDP from XXX.XXX.XXX.XXX:500 to YYY.YYY.YYY.YYY:500
    2007-09-13 08:15:11 IKE[51] Rx << MM_I1 : XXX.XXX.XXX.XXXSA, VID, VID, VID, VID, VID, VID
    2007-09-13 08:15:11 IKE[51] Tx >> MM_R1 : XXX.XXX.XXX.XXX SA
    2007-09-13 08:15:11 IKE[51] ISAKMP SA CKI=[cb46e16 aa909323] CKR=[4c631f74 fee0fafc]
    2007-09-13 08:15:11 IKE[51] ISAKMP SA 3DES / SHA / PreShared / MODP_1024 / 28800 sec (*28800 sec)
    2007-09-13 08:15:12 IKE[51] Rx << MM_I2 : XXX.XXX.XXX.XXX KE, NONCE
    2007-09-13 08:15:12 IKE[51] Tx >> MM_R2 : XXX.XXX.XXX.XXX KE, NONCE
    2007-09-13 08:15:13 IKE[51] **Check your ISAKMP Pre-share Key setting !
    2007-09-13 08:15:13 IKE[51] Tx >> Notify : INVALID-PAYLOAD-TYPE
    2007-09-13 08:15:23 IKE[51] **Check your ISAKMP Pre-share Key setting !
    2007-09-13 08:15:23 IKE[51] Tx >> Notify : INVALID-PAYLOAD-TYPE
    2007-09-13 08:15:44 IKE[51] **Check your ISAKMP Pre-share Key setting !
    2007-09-13 08:15:44 IKE[51] Tx >> Notify : INVALID-PAYLOAD-TYPE
  28. d1_blade

    d1_blade Guest

    Greetings to all.
    I have some problems from traffic. Activity on 80 port periodically vanishes, through an explorer nothing opens, but thus works and https ping icq torrent all this continues to work, and here 80 port is frozen. In what there can be a problem? At the ather providers it perfectly works my linksys WRV200 and with firmware and 1.0.34.
    Help please!
  29. HughR

    HughR LI Guru Member

    As you describe it, this is strange.

    I strongly suspect that this is in the wrong thread: that your problem isn't related to the version of the WRV200 firmware. There is a slight chance that the problem arises due to an improper update procedure: that you didn't do a factory reset and then re-enter your setup after flashing.

    I know nothing about the BEFVP41 V2 IPSEC software. The log you sent for it strongly suggests an authentication error (as I had suggested yesterday) "**Check your ISAKMP Pre-share Key setting !". This seems to be why it is sending the INVALID-PAYLOAD-TYPE notification.

    You say that eventually a connection can be made. You don't say which side initiated and with what policy. My guess: that it works when the BEFVP41 initiates.

    I don't know how certificates work on WRV200 -- I didn't write or use that code. But the message "I did not send a certificate because I do not have one" suggests that the WRV200 is trying to authenticate with something other than PSK. The BEFVP41 apparently thinks PSK is being used.

    • Start a new thread for this: I don't think that what you are experiencing relates to the topic of new firmware. (Of course if you are only going to post one more message (perhaps "I got it working") then it isn't worth starting a new thread.)
    • Synchronize clocks so that logs from different routers can be easily matched up. The hour setting isn't too important so it is OK to have the settings reflect different timezones.
    • If you didn't do it before, do a factory reset on the WRV200 and re-enter your settings
    • Make sure that the only policy for TunnelA on the WRV200 uses PSK [PreShared Key authentication] (that seems to be what the other side is expecting). If, in fact, you don't want to be using PSK, then fix the BEFVP41 settings.
    • Capture logs for successful negotiations too so that they can be compared with the logs from failing negotiations.
    With Openswan, it is possible to get a lot more logging. I have no idea if the WRV200 GUI makes the controls available. If we could rebuild the firmware, it would be easy to do this. Another example of why I want the beta source released.
  30. Sfor

    Sfor Network Guru Member

    I've been posting here about my problems with accessing a WRV200 WEB GUI through an IPSec VPN tunnel.

    I got my hands on a Linksys RV042, today. So, I was able to test the issue with some new hardware. I can acces the WRV200 WEB GUI through a tunnel between RV042 and WRV200 1.0.34.

    But, when I'm trying to do the same trick with a WRV200 1.0.33 to WRV200 1.0.34 tunnel, it does not work.

    I had no problem with accessing RV042 WEB interface from WRV200 1.0.33 through VPN tunnel. So, it's possible, the issue is visible only when making a tunnel between 1.0.33 and 1.0.34 WRV200 routers.


    Well that took care of my problems with accessing the router interface from a remote location. Now another poroblem emerged. How to wake up a computer through a VPN tunnel. WRV200 does not seem to have any function to do so.

    The workaround solution is to add an old SMC based router to the network. With the DHCP disabled it can be used as a WEB interface for sending wake up packets.

    But, it would be quite logical to add a proper tool to the WRV200 inerface. It should not be a hard task.

    ----------------------- Edit

    I do not know what happened. The connection from WRV200 1.0.33 to the 1.0.34 WEB UI is working now.
  31. Sfor

    Sfor Network Guru Member

    Weird. I've encountered another VPN access lock.

    I've got a LAN with 3 computers running Windows 98 connected to the WRV200 with 1.0.34 firmware. There is a VPN tunnel linking the LAN to a RV042 router.

    I was unable to access the RV042 web UI from one of my computers. It was not responding to pings, as well. In the same time, I had a connetion from the remaining two computers to RV042, and all computers were accessing and pinging local WRV200 without any problems.

    I launched continuous pinging to WRV200 and RV042 on the affected computer. Then I started to do experiments. I rebooted both routers, then the affected computer, without any effects on the RV042 connection. Then I tried to renew the DHCP IP lease. In this moment the connection to the RV042 started to work correctly.
  32. T-Troll

    T-Troll LI Guru Member

    About FTP/ICQ freeze and other...

    I recently discovered interesting thing.

    Seems like well-known FTP/ICQ bug is depends on switch part of the software, not router part.

    I use WRV200 as a gateway, it plugged in local network switch by LAN port.
    I meet FTP/ICQ bug from time to time, and find a way to resolve it without router reset - you can simple unplug network cable from WRV and plug it back (or restart switch in my case). Seems like the problem in LAN part of WRV, not WAN part. Hope it helps.

    Additionally, i discover another bug in 1.0.34 - i use 2 wireless SSIDs (in different VLANs), and then i restart router - all of them down - status shows they are enabled, but don't have any MAC address assigned. Additionally, this problem can appears from time to time with no known reason. My solution is disable wireless and enable it again.
  33. ghost_zero5

    ghost_zero5 LI Guru Member

    One question: Is it possible to use my old WRT54G(L) for internet and still use the WRV200 (that ICQ/FTP Bug really starts to annoy me lately; didn't had it that often than in the last few weeks) - for VPN and maybe DHCP too - only? It should work if I let IPSecs packets through - shouldn't it?
  34. Sfor

    Sfor Network Guru Member

    My ISP uses MAC to give IP through DHCP. If a new client is connected with unknown MAC the HTTP traffic is being redirected to a client registration site.

    Everything is working fine, when the router WAN is set to DHCP. But, if I change it to static IP strange phenomenon happens. From time to time the browser is redirected to the client registration site. The most probable cause is a query with a wrong source MAC, I think. Well, it could be ISP related problem, as well. But, the whole situation is strange enough to post it here.
  35. Sfor

    Sfor Network Guru Member

    I found the cause for unability to access the WRV200 WEB GUI through a VPN tunnel. The key factor is the VPN - VPN Passthrough - IPSec Passthrough setting.

    If disabled the WEB GUI does not respond through a VPN tunnel.

    I do not know if it is a bug or an intended feature. But, I did believe this setting should be effective with some LAN VPN host instead of the router built in VPN host.
  36. Doodsaq

    Doodsaq LI Guru Member

    Nice to see this doesn't fix any REAL problems at hand like the FTP issues.

    Nice work :cool:
  37. Sfor

    Sfor Network Guru Member

    Well. I do not have any FTP related problems.

    I switched to HTTP downloads, instead of the FTP. All other important transfers I do through a VPN.

    I'm using FTP from time to time, only. I experienced no router caused FTP lock for a few months.
  38. DerToob

    DerToob LI Guru Member

    Quick VPN Problem??

    WRV with 1.0.34 firmware

    I can´t access my network by using the QuickVPN Client (neither ver. 1.0.47 from Firmware 1.0.26 update, nor ver. 1.2.2beta)

    I tested it with firewall on and off. The Client says, that the tunnel is being established, but i can´t ping the router or any computer behind it and/or access remote desktop

    Doing "ipconfig /all" the wrv200 is listed as gateway next to the gateway i´m trying to connnect from.
    Someone can confirm this problem?
  39. HughR

    HughR LI Guru Member

    [off topic]
    I find it interesting that each place in your message where one would use an apostrophe (0x29), you have used an acute accent (0xb4). Maybe this is explained by http://www.cl.cam.ac.uk/~mgk25/ucs/apostrophe.html
  40. DerToob

    DerToob LI Guru Member

    Mhhh, you're right. I had never think about the difference it makes, yet.
    I'm using the acute accent instead of apostrophe because it is easier for me to type in (don't have to push "shift and #") I'm a little bit lazy :rolleyes:

    Edit: i've read the article you've linked... I think, i'm a typical german typing english *g*
  41. Sfor

    Sfor Network Guru Member

    I decided to play a bit with the WRV200 settings. When I was done I restored the configuration from a file. At this moment something strange happened. I do have the wireless switched off, but suddenly the wireless light went on then off again. Then the router rebooted by itself, and the sequence begun from the beginning.

    The router kept rebooting itself, turning the wireless on and off. I tried a short hardware reset, then a power reset, then a hardware factory defaults reset. Without a result. Finally I came to the idea something in the network is triggering the reset sequence. I diconnected the WAN and all LAN but one ports, then I initiated another harware factory defaults reset. The router reseted itself and DHCP started working, again. The strange thing is the settings were not changed to the defaults. Just to be sure I loaded the setting from the file again, and everything went right, this time. Then I conneced the WAN and the rest of the LAN cables.

    I added another switch to my LAN, just to protect it from loosing connections, when the router reboots itself. As, the router switch stops working during a router reset.

    Looks like the self reboot feature can be quite a pain, in some cases. It happend to me the router rebooted in a middle of a VOIP conversation, a few times, already. If there are some problems with the WAN gateway connection, the router reboots itself a few times a day.

    In the same time the other router with 1.0.33 firmware did not reboot itself for 6 days, already. It is connected to the same WAN, but it does not have as much work as 1.0.34 one (except for the VPN).
  42. Sfor

    Sfor Network Guru Member

    I switched a WRV200 device from gateway to router mode. Now I'm able to access the WEB gui through the WAN port IP without the remote management enabled.

    I'm not sure if this is a bug, or an inteneded feature.
  43. ielewap

    ielewap Guest

    Slowing Down

    My wrv200 after few days always slows down. Works as a gateway and only sends http to and fro. Can be anything done to make it work better ? Firmware latest available at this site.

  44. Hustadt

    Hustadt LI Guru Member


    i would like to upgrade my wrv200 firmware to 1.0.36 but i´m not able to find the link for download.
    I hope it could fix some issues with my vpn between a netgear fvg318 and the wrv200

    thanks for your help :)
  45. Sfor

    Sfor Network Guru Member

    I would suggest to look for the 1.0.37 or 1.0.38 beta firmware, instead.

    Linksys does not provide the beta firmware on public servers, any longer. You should ask the customer support in order to get the access to beta firmware revisions.
  46. malves

    malves LI Guru Member

    Bad advice. They no longer are letting anyone have it. We need a 3rd party to come to the rescue so we are not held hostage by short sighted policies.
  47. Sfor

    Sfor Network Guru Member

    This topis is no longer valid, as an official 1.0.39 firmware has been released.
  48. FORUM LINKSYS hardware

    I'm powering on one of my computers, then do some browsing through HTTP. Then I do power on another computer and I return to the first one leaving the second booting. While I'm browsing HTTP the Internet connection freezes for a minute or so. The second computer finished booting and it displays PM and POP3 connection error messages. I'm logging to the router WEB UI, and I can see it just rebooted itself.

    Looks like, the second computer does something to the router forcing it to reset itself. It could be a DHCP negotiation, or any other network traffic caused by a computer in a boot sequence.
  49. Sfor

    Sfor Network Guru Member

    Is there any reason to bring back an old and outdated thread by duplicating my post from the beginning of the same thread?

    Here is the post I wrote over a year ago:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice