WRV200 v1.0.37 Beta Firmware Released.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Dec 8, 2007.

Thread Status:
Not open for further replies.
  1. Toxic

    Toxic Administrator Staff Member

    WRV200 Firmware 1.0.37 Release Note 12/5/2007 (Beta Testing)

    Issues Fixed:

    1. Support NetBIOS broadcast over a Gateway-to-Gateway IPSec tunnnel. Now users can search computers by names or browse the network neighborhood on Windows Explorer.

    2. Fixed the problem that QuickVPN Client (Windows XP, 2000, or Vista) behind a NAT device cannot connect to WRV200.

    3. Fixed an issue with SIP ALG that times out NAT entry prematurely, causing incoming calls from internet not able to get in.

    Known Issues:

    1. There is a known issue with Windows XP SP2 Firewall - ICMP packets are always dropped by the Firewall when the Firewall is enabled. The issue will cause the QuickVPN Client not being able to establish a tunnel with the remote QuickVPN Server successfully. Microsoft has released a patch to fix this issue. Once you install the patch, the issue should be resolved.

    2. Windows Firewall needs to be enabled on Windows Vista in order for QuickVPN Client to function properly. This is due to the fact that IPSec service on Vista is disabled when Windows Firewall is disabled.

    3. QuickVPN Client v1.2.6 on Vista does not work properly when the Server Address is a DDNS domain name. This issue was fixed by QuickVPN Client v1.2.8 (under alpha testing).

    Plese ask Linksys Technical Support for this firmware
  2. Sfor

    Sfor Network Guru Member

    I'm unable to make direct IP calls with the SIP application layer gateway enabled. After establishing connection I can not hear my responder. In the same time my voice data are reaching the responder. So, it looks like my router is not passing the bounding SIP voice data to the SIP adapter in my network.

    During the upgrade procedure I've encountered a very strange situation. The router was programmed with 1.0.34. When I used the hardware reset switch to start the factory default restoration procedure, the router ignored it. No matter how long I was keeping the reset button pressed the router did nothing. The SysLog was not receiving any reset button related entries. A power reset cleared the situation. After that, the reset button was obeyed as it should to. And the router did the factory default routine. Then the firmware upgrade routine went without any further problems.
  3. DocLarge

    DocLarge Super Moderator Staff Member Member


    here are the factory procedures that I posted for WRVS4400N owners. It's been reported to the Linksys development team that the router does not reset when factory default is initiated:


    This behavior has also been reported regarding the WRV200 also...

  4. Sfor

    Sfor Network Guru Member

    I caused myself a few problems by connecting two routers with the same MAC to one ethernet switch, by a mistake. The effects were quite easy to predict, as the Internet access was not working correctly. One of those router was a WRV200.

    As the result the WRV200 was rebooting itself more often than once every hour. Still, I found no indication of the cause in the router log. Apparently there is some kind of watchdog system involved. It does check the WAN connection, somehow. When the connection fails the router reboots itself.

    This could explain quite frequent reboots of the router, when there are some problems related to the Internet access. I'm curious, what kind of connection testing the WRV200 watchdog system does. Sadly, there is nothing about the watchdog trigger event in the SysLog.
  5. RadioActiveMan

    RadioActiveMan LI Guru Member

    After switching from 1.0.34 to 1.0.37 my old router settings were not restorable. VPN from WRV200 to Netgear FVX538 with fixed IP works fine. SIP seems to be all right.
  6. pepemosca

    pepemosca LI Guru Member

    How about the FTP problem?
  7. Sfor

    Sfor Network Guru Member

    I can say nothing about the FTP problem, but my router is working whole 2 days without a single reboot. It looks like it is more stable than before, to me.

    But, the best improvement is the NetBIOS broadcast support, to me. The browsing over remote computers is lightning fast, now.
  8. pepemosca

    pepemosca LI Guru Member

    This was with the 1.0.37?
  9. Sfor

    Sfor Network Guru Member

    Yes, it was.

    The watchdog system was introduced in some early 1.0.3x firmware version, I think. I was keeping the WEB GUI working. But, the router started to reset itself quite often. So far, 1.0.37 looks very promissing.
  10. pepemosca

    pepemosca LI Guru Member

    Well, in that case: I'll try the 1.0.37 :)

    Hey, question: If you have the option to change the WRV200 to a WRT54GL, what will you do?
  11. Sfor

    Sfor Network Guru Member

    WRT54GL does not have IPSec VPN gateway function. So, it is useless to me. On the other hand I do not use wireless, at all. So, I'm not the right person to compare these two.

    According to my research the WRV200 is the cheapest device with the hardware IPSec VPN encode/decode acceleration.
  12. alb1us

    alb1us LI Guru Member

    Sorry to the developers, but all the firmwares sucks including this one.

    And I still have the same problem with my linksys pap2... It falls in each short while.

  13. Sfor

    Sfor Network Guru Member

    In what way does the PAP2 fall?

    Do you have the SIP application layer gateway enabled in the WRV200?

    Did you set the PAP2 IP as the DMZ host? Did you set port forwarding rules to route SIP traffic in the WRV200?
  14. Kphth

    Kphth LI Guru Member

    Requested Feature

    I'm not sure if I'm the only one who would benefit from this feature but I run this router in 5 restaurants and I bought it with the intent to utilize the multiple SSID's so my customers could use our wireless. But as I've thought it through I only want the public wireless available in the afternoon because at night I need the tables to turn. It would be great to be able to schedule one or all of the SSID's so I could have the wireless turn on in the morning and shut off at 5:00. Another needed feature would be if I could define QOS by SSID so I could limit the bandwidth used by a particular SSID.

    Just a thought…
  15. Sfor

    Sfor Network Guru Member

    Well. It is possible to block the internet acces for certain IP adresses. All your devices can have a static IP set, while the DHCP IP range can be blocked by a time related firewall access restriction rule.

    Such a protection is quite easy to break by a client with a static IP address. But, it should work.
  16. pepemosca

    pepemosca LI Guru Member

    I had the same problem: actually, the settings on my router hasn't been keept right.
    For example, the "Port Forwarding" names weren't saved :(

    But anything else: great!
  17. Sfor

    Sfor Network Guru Member

    According to the recommended firmware upgrade procedure a factory defaults reset should be done after upgrade. All the settings from old firmware are cleared that way. So, using the settings saved in the old firmware is not a very good idea.
  18. pepemosca

    pepemosca LI Guru Member

    Ok, good observation.

    Now, should I do a firmware update from .37 to .37 again? Or just do now (with the .37) a "reset to factory defaults"?

    I mean, doing this:
  19. Sfor

    Sfor Network Guru Member

    Just a reset to factory defaults should do the job.
  20. gyle

    gyle LI Guru Member

    Finally, the Daylight saving option for GMT+1 seems to be working.

    On the other hand, the DDNS remote peer for IPSec VPN behaves worse than it did with 1.0.34. I am using two WRV200 box and dyndns.org as DDNS provider. Side A has 1.0.37 and the status of the tunnel stays T forever, when side B has 1.0.34 and goes to status C after roughly 2 minutes.
  21. ArchCC

    ArchCC LI Guru Member

    My router work same like on old firmware. FPT, ICQ, eMule connections start down every few mins after 3 hour...

    Back to my asus router... see you all after new firware...
  22. pepemosca

    pepemosca LI Guru Member

    How's the problem with eMule?
  23. yawdib2

    yawdib2 LI Guru Member


    I have upgraded the wrv200 router from v1.0.24 to v1.0.37. Initially every thing seem ok but recently I have the router has been locking up. Not doing anything fancy, just plain gateway to 4 computers. When I reset the router everything seem to work for awhile. At first., thought the ISP was having problem, but during the time with no web access I could not access the router. I tried diffferent computers, same result. I do not know if anyone has experienced the same issue I .
  24. pepemosca

    pepemosca LI Guru Member

    I had that problem with 1.0.34... so far with the 1.0.37: everything goes right!
    or hope so! :halo:
  25. Sfor

    Sfor Network Guru Member

    Interesting. I decided to reboot the router from WEB GUI. Everything was working correctly, but I wanted to test if the router had something to do with IM connection problem. After doing the reset, the router WEB GUI stopped responding. Internet gateway stopped working. DHCP server died as well. After a power reset everything went back to normal.

    The IM problems were not related to the router, apparently. Router seems to be stable. But, I did encountered two strange events. Both happend during a SIP telephone call. Router rebooted itself a few times in round.

    I was able to capture just a few from the series of reboots, as the SysLog software was started during the event.
    Each sequence generates at least two entries:
    klogd: br0: topology change detected, propagating
    klogd: RTL865x Port 1 state=FWD

    It took about five sequences before the router started to work correctly.
  26. aneij

    aneij LI Guru Member

    WRV200 + firmware v 1.0.37 (beta) + Quickvpn v 1.2.8

    Since several months I try to use Quickvpn to connect via vpn to my wrv200 router. I tried al the firmware and quickvpn versions published so far but without success.

    I use XP and VISTA incl. patches...

    The latest Quickvpn utility has a better logging option so may be one of you has an idea how to solve this problem...

    The results in the log file are as follows:
    2007/12/19 08:26:57 [STATUS]OS Version: Windows Vista
    2007/12/19 08:26:57 [STATUS]Windows Firewall Domain Profile Settings: ON
    2007/12/19 08:26:57 [STATUS]Windows Firewall Private Profile Settings: ON
    2007/12/19 08:26:57 [STATUS]Windows Firewall Private Profile Settings: ON
    2007/12/19 08:26:57 [STATUS]One network interface detected with IP address
    2007/12/19 08:26:57 [STATUS]Connecting...
    2007/12/19 08:26:57 [STATUS]trying to connect to remote gateway with IP address:
    2007/12/19 08:27:02 [STATUS]remote gateway was reached...
    2007/12/19 08:27:02 [STATUS]Provisioning...
    2007/12/19 08:27:12 [STATUS]Success to connect!
    2007/12/19 08:27:12 [STATUS]Verifying Network...
    2007/12/19 08:27:15 [WARRING]Fail to ping the remote VPN Router!
    2007/12/19 08:27:16 [WARRING]Fail to ping the remote VPN Router!
    2007/12/19 08:27:17 [WARRING]Fail to ping the remote VPN Router!
    etc... (many times pinging)
  27. Sfor

    Sfor Network Guru Member

    I'm using IPSec VPN. It is not possible to ping the LAN IP of a WRV200 router through a VPN tunnel, if the IPSec passthrough option is disabled.
  28. aneij

    aneij LI Guru Member

    I opened the IPSec pass-trough but still without results.
    On this forum I also found restarting IPSec on VISTA can solve the problem but this in my case was not the solution as well.

    Anyone still ideas?:confused:
  29. mrdancer

    mrdancer LI Guru Member

    Wrv200 - Vpn

    I had installed 1.0.34 Version on 2 WRV200. Since month the VPN connection between this 2 routers was perfect. But since the update to 1.0.37 I can't connect this two routers anymore.
    They work with FQDN (dynamic ip). I have following message in the protocol.

    156 [Thu 13:45:02] packet from 80.xxx.xxx.xx:500: ignoring informational payload, type INVALID_PAYLOAD_TYPE
    157 [Thu 13:45:02] packet from 80.xxx.xxx.xx: received and ignored informational message

    Can someone help me?
  30. DerToob

    DerToob LI Guru Member

    I found two major problems:

    1. the vpn connection does not work anymore between my three wrv200 devices

    two of them using pppoe connection and fqdn, one pppoe with static ip.

    "TunnelB" #20: [WRV200 Response:] Remote peer has no tunnel entry to correspond to this tunnel."

    2. the router crashes under p2p traffic. Wallwatcher logs this message "<129>klogd: eth1:no buffer"
  31. jom1970

    jom1970 LI Guru Member

    WRV200 Firmware 1.0.37 Beta


    In this version of the firmware, is there possibel to change the username at the login ? like in the WAP200 Access point
  32. Sfor

    Sfor Network Guru Member

    It is not possible, as far as I know.
  33. masiulun0330

    masiulun0330 Guest

    Could anybody send me this firmware, it is because I did not have permission to download this firmware.
  34. pepemosca

    pepemosca LI Guru Member

    Me neither. Sorry... I'll be able to upload the file later at home. If you can wait...

    Maybe the forum admins can check the permission problem.
  35. f31@mail.ru

    f31@mail.ru Guest

    WRV200 Firmware 1.0.37 Beta

    IPSec VPN. It is not possible to ping the LAN IP of WRV200 router through a VPN tunnel, if the IPSec passthrough is disabled. ---> confirmation
  36. srainess

    srainess LI Guru Member

    FTP still not working

    Tried accessing NAS (via FTP) box from the outside, as well as FTP server. Can not connect with version 1.0.37. There seems to be more stability for streaming media though...

    Tried also to run Wallwatcher to see if I can see any incoming traffic. Doesnt look like the router sends incoming traffic messages... Is that true ???

  37. pepemosca

    pepemosca LI Guru Member

  38. Sfor

    Sfor Network Guru Member

    Yes, it is true. The WRV200 SysLog does not report any incoming traffic.
  39. CalledToConstruct

    CalledToConstruct LI Guru Member

    This seems to be the case, though, I have seen messages for packets that have been blocked (malformed or unsolicited) that were coming in-bound.

    // Joe
  40. chicharo

    chicharo Guest


    i can´t download please help me!!!:angry:
  41. Toxic

    Toxic Administrator Staff Member

  42. Sfor

    Sfor Network Guru Member

    Could you tell us, what was the reason for removing the file from the linksysinfo.org server?

    I've found the answer.

  43. Toxic

    Toxic Administrator Staff Member

    yep someone either here, at FSF or gpl-voilations.org decided to spoil the fun :) this means theoretically no one is allowed to distribute firmware without source code being supplied as well. its a pity but rules are rules. I would have prefered a "src code will be supplied on request" type of ruling, but I guess the FSF cannot change the law. out of 50,000 downloads (not all under gpl) the gpl-violators.org were the only ones requesting source code from me:) lol
  44. Sfor

    Sfor Network Guru Member

    To be true, the access to the code for the WRV200 is not good. The access to the source could speed up the development. But, still, the WRV200 is not a good platform for the GPL.
  45. Toxic

    Toxic Administrator Staff Member

    tbh I dont think anyone would want the source code to the wrv200 if you even paid them. it is far too buggy to be a stable platform to develope.
  46. Sfor

    Sfor Network Guru Member

    I would take a look at some faulty points, if the source would be available and if I would have a spare time. But, certainly, I would not load the tweaked firmware to the device.

    There is no bad flash recovery routine. So, it's far too dangerous to play with the device, because of that. If the flash chip would be in some sort of a socket, it would be possible to reflash it, or change to a different chip. Right now, I can not open the box, as I do not want to loose the warranty.
  47. pepemosca

    pepemosca LI Guru Member

    Toxic, your help here: How can I know that a new beta firmware is out?
    I can call Linksys, but when?

    Any ideas?

    This licencing problems is a sh*ty.
  48. srainess

    srainess LI Guru Member

    Yes... also interesting that on the list of events, DoS is listed which I would
    think would be from the outside.
  49. Toxic

    Toxic Administrator Staff Member

    if I hear of a new firmware being released I will post news of it here. just I am not aloud to distribute it since no source code is given.
  50. pepemosca

    pepemosca LI Guru Member

    Cool, thanks Toxic!
  51. Gallardo

    Gallardo Network Guru Member

    Hi guys!

    I have just tried to get the firmware from linksys but the live chat guy didn't know of that firmware. He told me that he has to talk to some people. I thinks that will take a long time and I'm not sure if I really get that firmware...
    So could anyone of you write me a PM or email me that firmware? that would be really great! Thanks in advance!

    greetz Gallardo
  52. srainess

    srainess LI Guru Member

    Ok.. I will just rant for a sec.... I've had this router for roughly 1.5 years... It has never worked correctly 'as stated'. I love the idea of being able to test patches, and there was always the hope that eventually everything would be right in the world. Now that those 'beta' versions will no longer be available easily, whats the point ? Whether it be VPN, FTP, or port forwarding issues, there has always been 'something'. Sure, Ive called tech support, and they have always told me to go back to the 'released' version. One of the earlier comments stated that the code is not 'stable'... Ok... but are we the only people seeing these issues ? Does the WRV54G have the same problems ? If not, will Linksys let me trade in the 200 for the 54G ? I actually just got fed up enough to buy one of the N routers (again from Linksys.. y oh y), and may just put a server in to do the VPN tunneling...

    Just a rant...

  53. pepemosca

    pepemosca LI Guru Member

    Check your PM.
  54. austingecko

    austingecko LI Guru Member

    Same here...

    Spoke with the tech rep after 45 minutes on hold and had no idea that the beta version even existed. someone please help! Got to get my hands on .37!!!

  55. andersoj

    andersoj LI Guru Member

    Firmware update

    I just had several chat interactions with Linksys folks. Version 1.0.35 was the latest I could shake out of them. My web gui lockup problems, consistent in across three router devices (one of them since returned) are competing with my PPPoE drop problems, consistent in 1.0.35, for my irritation. Tech support guys insist 1.0.35 is the latest...

  56. Toxic

    Toxic Administrator Staff Member

    thats funny man. 1.0.35 was released AFTER 1.0.36. 1.0.37 Beta was released approx 5th Dec 2008 and resided in the beta files area.

    I would ask another Tech support guy. that one sounds like he doesn;t know where to look.
  57. andersoj

    andersoj LI Guru Member

    Asked another Tech support person. They seem really cagey about releasing beta firmware... it seems like, once I'm already playing with .35, providing .37 would not be a big deal.

    They have suggested tweaking the MTU to 1492, 1428, and then 1400 to see if one of those settings resolves the dropped PPPoE connection issue. If not, then I'm to contact them back for the later firmware to try... test in progress now.

  58. Sfor

    Sfor Network Guru Member

    Your case proves what I've observed long time ago. The Linksys tech support crew have no information about the current development of the WRV200 firmware.

    Looks like the Gemtek does not fit the Linksys customer support system. As the Gemtek is the WRV200 dvelopper, as far as I know.

    It's difficult to say what the last change in the firmware development system will mean for us in the future. Apparently, the beta firmware versions will be available to the beta testers, only. To become a beta tester it is necesary to sign the Non-Disclosure Agreement.
  59. andersoj

    andersoj LI Guru Member

    FYI, the MTU experiments didn't work (same PPPoE drops, routinely after about 30-40 minutes each time). One more chat with LinkSys, one more "I'm not trained for this device, can you wait for another tech who is trained for this device?" (why don't they know this when I fill out the device information when requesting the chat?)

    The tech this time fairly quickly said they'd send the 1.0.37 update for me to try.

  60. Toxic

    Toxic Administrator Staff Member

    it proves tech support is still lacking in knowledge. not all tech support staff know about beta firmwares by the looks of it, but others do.

    I am only guessing this but it would appear this is the most possible procedure, Linksys development Team will forward request for a fix for an issue they can replicate. Gemtek will fix it, then forward a firmware for linksys to test. this is classed as an Alpha Firmware, which is internal only. once they can confirm the issue it was released for has been fixed, and the firmware is stable (though still may contain bugs) it is released as Beta firmware. this is passed to Tech support for them to issue as a fix for users that raise a similar issue that the fix is for.

    We at linksysinfo were able to put the Betas up for download for users without going to tech support, but since someone complained to the FSF that we had not supplied the Source code (and no one have ever asked me for it) for that beta firmware, we are now not allowed by their laws to distribute it.

    I would like to issue this statement.

    Out of 50,000 downloads and 170,000+ registered users from this site, not one person has ever asked me directly for any source code. makes a morcery of what FSF has forced tbh.

    they also state on their front page of the website:

    The Free Software Foundation (FSF), established in 1985, is dedicated to promoting computer users' rights to use, study, copy, modify, and redistribute modified computer programs. The FSF promotes the development and use of free software, particularly the GNU operating system, used widely in its GNU/Linux variant.

    however they have now failed to give the registered users of this site the right to user this firmware freely :)

    I will however distribute any firmware I can get the source code for. I will also inform Linksys users on this site about any new betas that I am aware of.
  61. Sfor

    Sfor Network Guru Member

    I found something strange about WRV200. I'm unable to ping through IPSec VPN tunnel using the WRV200 WEB GUI.

    Any local LAN device can ping the devices in the remote network. But, the WRV200 can not do it. On the other hand RV042 WEB GUI is able to ping through the tunnels. So, the inability to do the same from WRV200 looks like a sort of a bug, to me.
  62. pablito

    pablito Network Guru Member

    Actually that is normal behaviour per IPSEC. The endpoints are not supposed to be part of the tunnel itself. The packets are likely going out as the WAN interface which shouldn't be allowed over the tunnel. To do it on a straight linux IPSEC box you create a route that makes any calls to the other subnet coming from the WAN interface to appear as the internal interface. I don't see a way in the WRV to do that since it already has the basic route.

    Who is working on the code, Linksys or people over here? Mine has been o.k., the wireless is pretty crappy but the VPN has been stable.
  63. Sfor

    Sfor Network Guru Member

    Well, it is possible to ping devices through a tunnel from Linksys RV042 GUI. That's why I considered the inability to do the same with WRV200 as a bug.

    As far as I know, Gemtek is responsible for the WRV200 code. I do not know, if the Gemtek is owned by Linksys. It rather looks like a sort of cooperation, to me.

    The VPN tunnels are working quite well. But other router functions are not as good as the VPN is.
  64. austingecko

    austingecko LI Guru Member

    Someone PM me...please

    Someone PM me please. I need anything higher than 1.0.33 preferably 1.0.37. My unit is constantly dropping connections and the boss is beating down my door. Tried calling tech support AGAIN and after waiting an hour the person didn't even know about the beta firmware releases! SOMEONE HELP!!!
  65. Sfor

    Sfor Network Guru Member

    That's strange. I'm unable to access your forum account page, if your post is the last one.

    I had to add this message in order to be able to view your personal information. It looks like some forum engine bug, or something.
  66. guido331

    guido331 Network Guru Member

    I too am in need of the latest beta firmware (preferrably 1.0.37). I have two WRV200 routers at remote sites setup with IPSec VPNs to my RV082 and both WRV200s lock up every few days (no ping, web interface, internet access, etc). The only fix so far is to power-cycle the WRV200s, but that is proving to be increasingly annoying to the users at the remote sites.

    I called Linksys and they said they couldn't send the firmware because the person that has access to it was out sick or something like that.

    Please help!!
  67. Sfor

    Sfor Network Guru Member

    The problem with the forum member profile access happens only when I'm using IE. Everything seems to work fine with Firefox.
  68. Outbreaer

    Outbreaer Guest

  69. pepemosca

    pepemosca LI Guru Member

  70. Toxic

    Toxic Administrator Staff Member

    more than likely you have found one of the many bugs that MS refuses to fix on the way they handle web pages. maybe by MSIE v10 they might fix it:)
  71. sebberry

    sebberry LI Guru Member

    I'm using the WRV200 for home use since I share my internet connection with my roommate. The VLAN and multiple SSID features sealed the deal for me with this router, but it has been nothing but problems.

    I can't get SSID3 to work properly, I need to put in a dummy SSID and use SSID4 for my network, and even then my client machies don't connect to SSID4 half the time.

    Occasionally changing a wireless key on one SSID will add backslashes to the middle of another SSID's key. The router always goes to a blank page after making settings changes and not back to the page I was on. Needs a hard reset once or twice a week.

    Sadly, it doesn't look like the latest firmware at the beginning of this thread corrects these problems.

    Anybody have some tips?

  72. astoria

    astoria LI Guru Member


    I upgraded to this beta firmware version but i do not see any setting to switch netbios on (unlike i see in my RVS4000). I also cannot see the remote hosts w/out the LMHOSTS workaround. Am i missing anything?

    Any help would be appreciated.

  73. Sfor

    Sfor Network Guru Member

    It's a bit strange, but the NetBios network search works only between two WRV200 devices, for me. I can not use NetBios names trough a VPN tunnel between WRV200 and RV042 for unknown reasons.
  74. MAXX_MUR

    MAXX_MUR Guest

    please, send me this firmware version. maxx<@>kitm.ru
  75. pepemosca

    pepemosca LI Guru Member

    Check your PM.
  76. pepemosca

    pepemosca LI Guru Member

  77. Sfor

    Sfor Network Guru Member

    No there is no way to do it with just the WRV200.

    I added another router with the WOL function to my network, in order to take advantage of the WOL.
  78. pepemosca

    pepemosca LI Guru Member

    But will it work with http://www.dslreports.com/wakeup ?
    Port Forwarding the port UDP 9?
    And with the Port Triggering?

    I'm a newbie with this: will it work in Wi-Fi?
  79. Sfor

    Sfor Network Guru Member

    It depends on the hardware you are using. But in general, it should not work. As, the WOL packets are unroutable.

    In a standard network a powered off computer will ignore all the IP based traffic. Only packets adressed by a proper MAC address will be processed. Router will forget the MAC address of the powered off computer in about a minute.

    If a computer is connected directly through a DSL bridge the solution offered by the dslreports can work. In other case it should not.

    I do not know much about wi-fi. But, the network adapter has to be powered on, in order to receive a WOL package. I strongly doubt a wi-fi lan card will remain powered on, after the computer will be powered off.
  80. pepemosca

    pepemosca LI Guru Member

    Ok :frown1:
    Thanks for your small tutorial about WoL :)
  81. astoria

    astoria LI Guru Member

    netbios only betw 2 wrv200s

    Really??? so technically this shouldn't be marked as 'fixed' in this beta. I can't believe that i have another Linksys business device and it can't talk netbios with it (it works fine on the rvs4000 over to the wrv200)

  82. pablito

    pablito Network Guru Member

    I don't know about the netbios broadcast "feature" but IP is IP and you can do it over most nets and tunnels without the aid of the router. Instead of making the routers do the noisy broadcasts then use other ways that in my mind are a lot better anyway. If you have servers on either end then have them broadcast or share browse lists. Or use an lmhosts file. Or setup a WINS server and point to it. Or normal server to server configs. All depends on what you have and what works best but I've never turned on netbios broadcast at the router.

    The WRV's VPN is about the only I like about the router. At least it is stable compared to the wireless which is pretty horrible.
  83. astoria

    astoria LI Guru Member

    it is netbios over ipsec vpn

    to clarify it is netbios over ipsec vpn connections. The rvs4000 fully supports this, but this has been flagged as an issue which was supposed to be fixed in the 1.0.37 beta firmware for the wrv200. so my wins servers do see the machines on the other side, just cannot connect to them w/out lmhosts files. lmhosts files are ok for static machines where the ip address is well-known, but not for machines who get their ip address via dhcp.

    i was expecting to see an 'advanced' tab in the ipsec vpn tunnel definition with 'netbios broadcast' just as i do on the rvs4000. however i see no such option, hence my original question - am i missing something?
  84. sebberry

    sebberry LI Guru Member

    For my uses of this router, I don't need things like VPN, etc.. I just want my multiple SSID's to work properly. I my roommate uses one SSID, I use another and I have a shared one for guests.. Both mine and my roommate's are hidden, he can connect fine but I cannot with my two computers. SSID3 never works so I need a dummy SSID in there to populate the field and use #4 instead.

    Since it is a hidden SSID, I set my laptop and desktop up with all the required info (SSID name, key, etc...) and instead of connecting, it just pops up saying wireless networks are available, blah blah.

    Does the 1.0.37 firmware correct any of these issues or is this thing never going to do what it's supposed to do?

    Oh, and don't even get me started on my roomate's use of Azureus totally crashing any Linksys router I have owned to the point I can't even ping it...:mad:
  85. pablito

    pablito Network Guru Member

    That is what I don't understand. You shouldn't need netbios broadcast from the router if the server is sending the info or running WINS. My example is that I have a WRV200 at a house with VPN to the office behind a RV082. Another office VPNs in via an RV016. A 3rd house is behind a dlink VPN router. None have netbios broadcast but they can all see, browse, and connect to the servers behind the RV082. From behind the RV082 I can see and connect to anything I need at the remote sites. The servers are running samba if that helps since I can not only control who can connect but where I send browse lists. The remote users point to WINS at the main office and any remote servers share browse lists across VPN. Any user that puts in a name like \\server1 gets what they want. What doesn't work is a star/hub VPN setup but that is a config limitation of the RVs.

    I don't like the WRV200 for all the problems however VPN is working fairly well and no problem with server shares, printing etc in either direction.
  86. Sfor

    Sfor Network Guru Member

    I had an old Digitus DN-11005 router. It had a WINS server option in the DHCP server settings. Apparently there is nothing similiar in the WRV200. So, WRV200 can not be used to set WINS server address through the DHCP protocol.
  87. pablito

    pablito Network Guru Member

    oh yeah, no WINS option via DHCP on the 200. What I did was to manually set WINS at the client and let DHCP do the rest. This works very well for me across the VPN. I also set primary DNS at the DHCP server to the DNS across the VPN and put in a public DNS as secondary. This also takes care of the internal IPs that the private DNS server provides. With that the boss is happy working at home and works like he was at the office but on a slower link. I also extend his office phone over the VPN via SIP so he can take and make calls from either location with a single phone number. The 200 does this very well but I'm anxious to get better firmware to solve the other issues.
  88. moises2k

    moises2k Guest

    Hi, can anybody send me this firmware please?
    Thank you very much!
  89. Raquer

    Raquer Guest

    Please send me this new firmware

    Please anybody, send me this firmware version.
    Thank you.
  90. moffegreven

    moffegreven LI Guru Member

    Hey toxic could you please explain to me what Linksys firmware has to do with GNU and FSF?
    I mean Linksys firmware is not published under GNU is it?
    Hate to be comming with n00b questions but i just dont understand any of this BS
  91. Sfor

    Sfor Network Guru Member

    The WRV200 firmware is based on Linux. So, it has to be under GPL policy.

    The Linksys gives the access to the GPL code, except for the beta versions.
  92. moffegreven

    moffegreven LI Guru Member

    Thanks for the quick reply.
    But i still think this is pure BS and don't see the point in banning downloads, no one is ripping anybody of for gods sake, the only thing FSF achieved by doing this is convince me that they are a bunch of *****s. So if you are as angry as me do what i did, send an angry mail to:

    licensing@fsf.org or info@fsf.org not that i think it will change anything but you never know
  93. Toxic

    Toxic Administrator Staff Member


    I hope you asked them to clarify their 1st paragraph on their website.

    my understanding from this is you have the right to use the software, however since they have warned me and linksys about distribution, then they have given you (as the user) "no right" to use the firmware now, with or without the source code being made available, do they?

    it make no sense that a user cannot use it since they have stopped the distribution in the first place.
  94. loket

    loket LI Guru Member

    You can find login/pass to Linksys betafiles on google
    linksys+betafiles, third from the top :)

    Firmware 1.036 is the latest to Wrv200 on their server
  95. Sfor

    Sfor Network Guru Member

    Not true. There is 1.0.37 there, as well.
  96. loket

    loket LI Guru Member

    Yeeep it´s there :):confused:
  97. ibernal

    ibernal Guest

    Can someone send me the real link for download the firmware 1.0.37 pls?

    Thanks a lot
  98. richardppp

    richardppp Guest

    Access to firmware

    I've been battling the WRV200 for 2 weeks now, and have not been able to get quickVPN to connect to it from a Vista box (or any other, for that matter). I have got 1.0.24 firmware, have reset defaults and made minimal additions (eg adding a VPN user).
    On the vista box, I have turned the windows firewall on and off, enabled and disabled the Norton firewall and intrusion detection, etc etc and still quickVPN sticks on "Verifying Network".
    It works if I use quickVPN from the vista box when it is connected through the WRV200's wireless link, either to the LAN address or the WAN address.
    If a go to a public network and try to connect to the WRV200's WAN address, it sticks on "Verifying Network".
    The suggestion to use 1.0.37 sounds good, but the suggestion to use tech support isn't good. I'm in Australia, and all hours I'm awake, there's no "Level 2 support" people on (call back in 2 hours. I've done that 3 times, now it's time to go to bed).
    Any clues on how to get this sucker going. Sorry, my f key doesn't work.
  99. cfforce

    cfforce Guest

    Can anyone give me an adress for the latest firmware?
  100. Toxic

    Toxic Administrator Staff Member

    Tech Support
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice