WRV200 v1.0.37 Beta Firmware Released.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Toxic, Dec 8, 2007.

Thread Status:
Not open for further replies.
  1. HughR

    HughR LI Guru Member

    I tried to get betas from them long ago. They claimed no knowledge of them.
    I have several times expressed desire to have the GPL source for betas in this forum. For a long while I avoided asking you explicitly for the source because I felt that would put you offside with respect to the GPL. Eventually, I did ask: http://www.linksysinfo.org/forums/showpost.php?p=312614&postcount=47

    Note: I did not take this to the FSF or the SFLS.

    Although I strongly disagree with you about the GPL, I appreciate what you have done for this community.
  2. TomSweet

    TomSweet LI Guru Member

    Greetings Sfor, others,

    Wake-on-LAN traffic can also be generated on UDP 7 & 9, and is thus routable over the public internet. The usual filtering caveats apply since UDP 7 & 9 are IANA assigned to Echo and Discard. See the wikipedia article Wake-on-LAN. See also Intel's Wired for Management and Microsoft's Device Class Power Management Specifications for Network devices.

    Regarding wireless adapter support for Wake-On-LAN, my Intel 2200bg does not suppport it, but the 3945abg and later seem to according to Intel's Pro/Wireless overview page.
  3. Sfor

    Sfor Network Guru Member

    Well, apparently, I made a mistake by saying the WOL packets are not routable.

    However, more important problem is passing WOL packets through NAT. The targetted computer still has to be connected to the Internet directly, I think.
  4. pepemosca

    pepemosca LI Guru Member

    Later I'll check. Thanks!

    I have an Intel 3945ABG.
  5. aggietallboy

    aggietallboy LI Guru Member

    Week 2 Trying to get 1.0.37

    I came across this thread trying to solve my Ping Flood issue with the publicly available firmware.

    I have been trying since the 30th to get the 1.0.37 beta.

    Instead I got 1.0.35 from linksys the first time which introduced some new problems (but it did indeed solve the pesky ping flood!)

    New 1.0.35 problems:
    1) my dyndns account got shut off because it periodically renews the info, whether it changed or not; I have since fixed dyndns, but if I turn on update, it "abuses" DynDNS again.

    2) every hour on the hour, the wireless connection just drops (on 3 different machines)

    So I've been trying to get 1.0.37 which everyone here seems pretty satisfied with... It's now two weeks trying to get this dang thing, and I'm on chat with Linksys support (again) after being disconnected from the phone twice tonight.

    I've got the betafile website, but of course the password has changed, and now I'm going through hoops trying to get them to send the file via e-mail for the fifth time.

    If anyone can PM me, or otherwise forward 1.0.37 or the password to the betafile site I'd be truly grateful
  6. aggietallboy

    aggietallboy LI Guru Member

    Finally got the firmware!!

    And now I have a brick!

    I took my laptop in, hooked up the wired ethernet connection, disabled wireless -- all good.

    Open up the https:// connection to the router...


    Firmware update...






    I have no ip address...

    I still have no IP address...



    Follow all the reset/recover procedures anywhere out there (reset 10-30 sec, power 10-30 sec, reset 10-30 sec)


    Repeat all the reset/recover 60 seconds


    Set IP address manually.

    No ping response on previous IP or default IP (still no address from dhcp)

    Download setup utility.

    No response from linksys WRV200.

    So... now I have a brick, with a nice solid power LED, and no indication anywhere that it's working...

    Any suggestions most welcome!!
  7. pepemosca

    pepemosca LI Guru Member

    Sorry, I'd the same problem: And I took it back to the store in order to get a replacement.

    It's a sh*t* router.
  8. Sfor

    Sfor Network Guru Member

    The router should be reverted to the factory defaults before the firmware upgrade. The HTTPS is disabled by default. So, Aggietalboy did not used the proper safe firmware upgrade procedure.

    The hardware factory defaults routine lets to check the router before an upgrade. If it fails, the firmware upgrade can fail as well. Router should always be at the default config during the upgrade. WRV200 is quite unstable, so it is not possible to tell, if it works correctly in any particular moment.

    Once, I saved myself quite a lot of troubles, because the router ignored the factory defaults routine just before a firmware upgrade attempt. The power cycle solved the problem, then I did the defaults reset. Then when everything was working correctly I've upgraded the firmware. It is hard to tell, what could have happened if I would not revert it to the defaults. I would not have know about the router lockout and the firmware could be destroyed during an upgrade, in such a case.
  9. aggietallboy

    aggietallboy LI Guru Member

    Wow, set to factory defaults before performing the upgrade... seems quite asinine, but that's Linksys for ya.

    Well, I have another one to try it on, and hopefully that'll work there, meantime this one gets RMA'd
  10. alb1us

    alb1us LI Guru Member

    Can I post a link with the 1.0.37 firmware from other website?

  11. sebberry

    sebberry LI Guru Member

    Is anybody able to PM or email me the WRV200 1.0.37 beta firmware?
  12. dbrinkmann

    dbrinkmann LI Guru Member

    yeah.. this sucks, i really need to find 1.0.37

    is anybody seeding this on a torrent?
  13. sebberry

    sebberry LI Guru Member

    I reset my router's settings and re-flashed with the 1.0.32 and it some of my problems appear to have been fixed (ie, SSID 3 would not work). I am not a VPN user yet so I haven't tried that yet.

    My laptop and wireless desktops were having troubles connecting to the router but that also seems to have been resolved now. Blank pages on the router's configuration site still happen after saving settings changes however, or when it does a soft reboot after making setting changes.

    Now let's see if the thing will run for more than a week without requiring a reboot...

    EVERMIND2 LI Guru Member

    Could somebody please send me a dl link per PM

    Im still having the same old dumb connection problems and no FTP working...

  15. nheimler

    nheimler LI Guru Member

    Sigh...I just spent close to an hour in the chat que then to find out they want me to call their tech support. How frustrating is that. Being a computer tech I can understand the position they are in, but when you get a tech talking to another tech and having the tech walk your through everything you've already done that just gets even more frustrating. Not to diss them or anything. :) Is there someplace one can download this without all the hassles of being in que or on hold? Thanks!
  16. alb1us

    alb1us LI Guru Member

    FTP, VOIP and IRC

    Try this solution for FTP, VOIP and IRC It's working for me.

    Firewall > Port Triggering:
    FTP Triggered Range > Start 21 End 21 Forwarded Range > Start 21 End 21 Protocol > Both Enabled > Yes
    VOIP Triggered Range > Start 5060 End 5061 Forwarded Range > Start 5060 End 5061 Protocol > Both Enabled > Yes
    IRC Triggered Range > Start 6667 End 6669 Forwarded Range > Start 6667 End 6669 Protocol > Both Enabled > Yes

    Firewall > General
    SIP Application Layer Gateway: DISABLE


    EVERMIND2 LI Guru Member

    Sadly I still have my problems.

    If the Router runs over some time, I get connections problem with icq (somtimes it can't connect at all)
    The same issue with FTP (Passiv and Aktiv).
    The overall internet traffc, like http becommes very slow.
  18. cr0w21

    cr0w21 Guest

    I have 1.0.38

    After reading this thread, i was still unable to ftp so i ended up calling Linksys Technical Support and got 1.0.38. Supposedly it fixes the FTP problem. Just to let everyone know...Feedback will be left to see if it works
  19. christsc

    christsc LI Guru Member

    Hi Crow , do you mind to send the firmware to me ? my email is tanserchin@hotmail.com
  20. Toxic

    Toxic Administrator Staff Member

    AFAIK FTP uses TCP so you do not need to trigger both TCP and UDP.
  21. Toxic

    Toxic Administrator Staff Member

    If any user is still having FTP problems contact Linksys Tech Support. they do have a version that is suppose to fix ftp issues. v1.0.38. Available from Linksys Tech Support.

    EVERMIND2 LI Guru Member

    EDIT: Sorry didn't see your last post, I will try the new Firmware (maybe someone could send me a dl Link per PM)

    Anothere funny thing, it doesn't matter if the Traffic goes over WAN or over LAN.

    If I Stream Videos from one LAN Port to anothere the whole thing crashes... everything becomes slow (yes even the webinterface), or it doesn't work at all.
    As soon as I plug the streaming to a seperate switch the problem doesn't exsist.
  23. javierpedrido

    javierpedrido LI Guru Member


    I've contacted Linksys tech support and they say that they don't have any 1.0.38 firmware. 37 is the last beta according to them, 38 is in developement.
    Crow, does the 38 version fixes the ftp problem? can you send it to javier.5050@hotmail.com
    Thanks, Javier
  24. pepemosca

    pepemosca LI Guru Member

  25. HughR

    HughR LI Guru Member

    Could you ask them for the GPLed source code for 1.0.38? They are obliged to fulfill that request (due to the GPL). Then pass it on to us.

  26. Sfor

    Sfor Network Guru Member

    I was able to download the file. But, I found nothing about the changes in the 1.0.38 firmware. So, I see no reason to "flash" my router with it.
  27. javierpedrido

    javierpedrido LI Guru Member

    Sfor, EMEA customers don't get release notes :)
    Any comments from people who installed this firmware?
  28. alb1us

    alb1us LI Guru Member

    Sorry to ask.... but what does it mean EMEA customers?
  29. javierpedrido

    javierpedrido LI Guru Member

    Europe, Middle East and Africa = EMEA
    The firmware was in that folder in the linksys beta files site.
    I am going to install it tonight, 1.0.37 stops working fine after a few days. If 1.0.38 sucks even more, I will downgrade.
  30. xefiant

    xefiant Guest


    Can anyone give me the new firmware?
  31. Toxic

    Toxic Administrator Staff Member

    Linksys Technical Support. Go ask them.

    thread now closed since 1.0.38 is being discussed on .37 topic.
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice