WRV200 v1.0.38 Beta Firmware Released

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by alb1us, Feb 20, 2008.

  1. alb1us

    alb1us LI Guru Member

    The wrv200 v1.0.38 Beta Firmware is available thru Linksys Tech Support.

    Has someone the release notes?
  2. pepemosca

    pepemosca LI Guru Member

    Could someone post some link for the 1.0.38? Or send it to my via PM?

  3. alb1us

    alb1us LI Guru Member


    Did someone test the 1.0.38 firmware?
  4. Toxic

    Toxic Administrator Staff Member

    afaik ftp issue was fixed. i doubt much else had changed.
  5. Toxic

    Toxic Administrator Staff Member

    Just a quick reminder for people that will not read previous posts on this subject.

    You can get the 1.0.38 firmware from Linksys Technical Support. the fix is ONLY for ftp afaik, if you dont have an ftp issue, then this firmware is not needed.
  6. tripuri

    tripuri Guest

    Is anybody able to email me the WRV200 1.0.38 beta firmware?
  7. pepemosca

    pepemosca LI Guru Member

    Can someone post the release notes?

    Thank you!
  8. Sfor

    Sfor Network Guru Member

    There were no release notes file attached to the 1.0.38 firmware file.

    According to the available informations, this version was ment to correct the FTP problem, only.
  9. pepemosca

    pepemosca LI Guru Member

    Ok :)
  10. Toxic

    Toxic Administrator Staff Member

    Yes: Linksys Tech Support.
  11. Baro

    Baro LI Guru Member

    Is v1.0.38 a superset of v1.0.37?

    I mean, does it include thev1.0.37 fixes too?

    Thank you
  12. Toxic

    Toxic Administrator Staff Member

    Erm yes all firmwares work this way, did you honestly think they remove features for new versions? the only difference is it fixes some ftp issue (though i never seen any ftp issue with my setup)
  13. nheimler

    nheimler LI Guru Member

    I've been seeing quite a few people still having Vista issues with the VPN client even with the dot 37 release. It appears to be people using wireless or so it seems. Has anyone worked with Linksys' tech support regarding this particular issue in trying to get the wireless users working?
  14. alb1us

    alb1us LI Guru Member


    I can confirm that the ftp, sip and irc problems are still there.

    EVERMIND2 LI Guru Member

    My router is running much better with the Firmware 38, not all problems are gone but everything seems to run much smoother and I had no total disconnects until now.
  16. RadioActiveMan

    RadioActiveMan LI Guru Member

    To solve the SIP Problem: I give my Voip Telephone a fixed IP. It works perfectly for me.
  17. christsc

    christsc LI Guru Member

    any one can help me? my case is like this...

    3 units of WRV200 , wish to set up vpn tunnel with ipsec but all using DDNS .
    2 branch need to link to HQ and what are the setting i need to do so that they are all link up ?

    thanks in advance...

  18. Toxic

    Toxic Administrator Staff Member

    Chris I would recommend you take a look at the Video that Doclarge has done here: http://www.linksysinfo.org/forums/downloads.php?do=file&id=12

    this will give you an idea of how to setup a VPN. if you want to setup three router but have one as the HQ then setup 2 VPN tunnels on the HQ router and one tunnel on each of the remote sites point to the HQ router.

    make sure that the LAN IP of each router is different.
  19. christsc

    christsc LI Guru Member

    hi toxic...

    thanks for your reply, i need to setup with dynamic IP gateway... any idea ?
    example xxx.dyndns.org and yyy.dyndns.org to HQ.dyndns.org

  20. vpnuser

    vpnuser LI Guru Member

    The WRV200 user guide (on linksys.com) has config examples in the Appendix E for your scenario.
  21. christsc

    christsc LI Guru Member

    actually what i did from branch A to HQ is successful but branch B to HQ keep showing status T for the tunnel status. any one face this b4 ?
  22. kactus

    kactus Guest

    my WRV200 still hangs 2-3times a day

    have to reboot. no VPN, no FTP, no mass downloads. with 1.0.38, no improvement from 1.0.24.

    this is the biggest rubbish ever seen.

    anyone here experience the same?
  23. Sfor

    Sfor Network Guru Member

    My WRV200 did the same. But, I've added another cheap router as the Internet gateway leaving WRV200 as VPN gateway. So, my WRV200 hangs just about once a week now.

    The interesting thing is the second WRV200 in my posession placed in a different location is much more reliable. It's quite possible, some routers are faulty and are unstable because of the hardware problem, while others are working much better.

    The problem is to distinguish the faulty router from the faulty firmware. As the firmware is not perfect, as well.
  24. Toxic

    Toxic Administrator Staff Member

    have you registered 2 DDNS accounts with www.dyndns.org?
  25. CalledToConstruct

    CalledToConstruct LI Guru Member

    I was running on 1.0.36 for the last month or so and it has been (mostly) stable. I did, however, continue to have problems with the FTP dropout and I've not been able to VPN in. :|

    Now, I've updated to 1.0.38 (yesterday) and it has been stable and the connection has been responsive. The web ui seems to respond a bit faster as well (though this could be my imagination ;) ) I'll continue to monitor and report back if either of the above issues are resolved.

    Is there any chance they'll make 1.0.38 a full release so we can get the latest sources? (hint, hint linksys - do the right thing, release it officially!)

    // Joe
  26. javierpedrido

    javierpedrido LI Guru Member


    My router WRV200 has been working fine with 1.0.38 for 5d:18h:57m:0s.
    That's an all time record for that piece of crap
  27. Toxic

    Toxic Administrator Staff Member

    Hey! I dunno whether to congratulate you, or just laugh :)
  28. christsc

    christsc LI Guru Member

    hi toxic,

    i have registered 3 account from Dyndns.

  29. christsc

    christsc LI Guru Member

    wow.. not that bad i think. so far so good. just lack of some vpn issue here.

  30. CalledToConstruct

    CalledToConstruct LI Guru Member

    Just wanted to report in that I am now able to VPN (I'm using quickvpnplus) with 1.0.38 where I was previously getting connected, but only "Request timed out" when pinging and no access to any ip address on the host lan.

    As for stability, I was getting some drop outs on the wireless (wireless reported that it had reconnected a couple times for no reason). I turned off the WMM for all the SSIDs and that seemed to stablize the wireless connection(s).

    I've only had it running for < 24hours, so who knows what the future holds! :O

    // Joe
  31. dbrinkmann

    dbrinkmann LI Guru Member

    holy crap

    well... i am cautiously optimistic then... going to be loading up this firmware in a few hours... i have never had success with VISTA quickvpn or quickvpn+, XP works fine.
  32. dbrinkmann

    dbrinkmann LI Guru Member

    no dice, no vpn from vista on quickvpn or quickvpn+ with the Microsoft and without the Microsoft registry changes for a NAT. I saw on another post that there was some other newly discovered issue with vista? i am just thru with vista...
  33. Toxic

    Toxic Administrator Staff Member

    do you have your firewall enabled on vista?
  34. nheimler

    nheimler LI Guru Member

    I'm curious why the firewall has to be on for the Linksys VPN software to work on Vista? I'm running Vista with SP1 btw in my case. As an admin that's the first thing I do on our networks is turn off the firewall that and the firewall causes thing issues with other things we do when turned on. Either that or I have to tweak the heck outta the stupid Windows firewall in order to get things working. I saw that it's because of the IPSEC service, but when I look the IPSEC service is running even with it turned off. Can someone explain this further? Just doesn't make sense to me other than people saying to turn on the firewall. Thanks!
  35. DocLarge

    DocLarge Super Moderator Staff Member Member

    There was a patch at one point that was issued by Microsoft that allowed quickvpn to run without the firewall being turned off (this was posted in one of the earlier quickvpn notes if I'm not mistaken).

    In the beginning, it was necessary to turn windows firewall off because it was blocking 443. The current version of MS firewall "should" allow quickvpn communication; at least it did with 2000/XP. Vista, as you see, is a creature that still needs "taming." :)
  36. sebberry

    sebberry LI Guru Member

    Toxic, just thought I'd let you know that Linksys no longer provides email support, and my recent experience has been that they have long wait times on the phones. A few times I haven't even been able to get through to the queue, they just cut the call off and it is frustrating going through about 8 menu levels of pressing 1 and 2...

    That's probably why people keep asking "where can I get the firmware". :)

    Is anyone else having wireless connection problems? Everyone seems to only be talking about Quick VPN, FTP, etc... Connecting to one of my wireless SSIDs is sketchy at best.

  37. tmeyer

    tmeyer LI Guru Member

    WRV200 FTP just stops

    I am having the FTP problem with my WRV200, Software Version

    It just stops talking on FTP every so often, sometimes many times in one day, sometimes it works for several days.

    A re-boot fixes the problem until the next time.

    I have read in these forums that there is a beta firmware fix for this. Where can I get that fix?

  38. Toxic

    Toxic Administrator Staff Member

    read the initial post. Linksys Technical Support has it Ask them and they will send you it.

    BTW this is the 3rd time in this thread I have sated that, and the forth time overall that it is mentioned in this thread, can people not read?
  39. nheimler

    nheimler LI Guru Member

    Toxic...this is why people are frustrated as I've been down this road and it just makes you want to give up or find someone that might be able to send you the firmware they are after. I've been disappointed with Linksys since trying to fix some of these issues with this router.

    On a side topic...the 1.0.38 version I have seen seems to be the most stable so far of the betas (have yet to reboot the stupid thing since installing it when it came out). The only issue I'm still having is that you cannot connect through a wireless connection (with Vista) using the VPN software. A hard wired connection works just fine though. I have yet to see any resolution to this and I've seen a few people comment on this.
  40. Toxic

    Toxic Administrator Staff Member

    email is a very easy customer option but is very time consuming for support staff since most customers do not give enough information or just expect a reply within minutes. trying to reply to 1000's email a day is not viable. Hell I even tell users Email support at linksysinfo is not supported!

    nheimler are us using DHCP on your Wireless client? try setting a static IP on your client. just a thought.
  41. nheimler

    nheimler LI Guru Member

    I replied about this in another thread that this was being more talked about in that you had suggested this, but yes I'm using a static IP.
  42. nheimler

    nheimler LI Guru Member

    And we were talking about the long phone wait time due to email not being supported that was being the pain not email.
  43. tmeyer

    tmeyer LI Guru Member

    Firmware download link

    Yes, it is the third time, however, no where on the linksys tech support pages are any email addresses for contact, and the linksys download web page is down, and has been for a while. Not the greatest in customer support.

    All I am looking for is a link to the firmware so I can fix my 4 routers, that I bought at CompUSA :angry: right before they closed the doors.
  44. dckid

    dckid Guest

    This is really basic stuff and I know most people probably know it already but it took me ages to work it out so hopefully it will help someone.

    To get the WRV200 firmware

    Go to the linksys site (assuming it is running) go to the tab which says support and select tech support from the drop down. Then go to Live Chat on the left hand side and ask the friendly support agent for the 1.0.38 firmware. I did this at 1am and it was quick and painless.

    Also I have read some people with OSX trying to mount the .img file and getting an error. It is not a Mac image file it is just a file with a .img extension. Don't click on it, go to your router ( or whatever) select Admin and Firmware upgrade and select the .img file to do the upgrade.
  45. pepemosca

    pepemosca LI Guru Member

    I have a problem I'm not sure I have read about it, like someone else has it.

    Sometimes, I try to go to some webpage and get an IE error saying the page is not available.
    I go to the router and try the "Diagnosis" ( and ping the same site... and I get ping response.

    So I reboot the router... and boom!
    Now I get the site just as it should be.

    Is this a regular problem?
    I haven't notice it on old firmwares (I now have the 1.0.38).

    Thanks in advance for your comments.
  46. Sfor

    Sfor Network Guru Member

    You can try to set user defined DNS servers in the DHCP section of the WRV200, or to set DNS server manualy in the computer you are browsing the web pages from.

    The WRV200 does seem to have some problems with processing or caching the DNS queries. It is better to send them directly to the DNS servers.

    I've found the WRV200 does seem to work slower than other routers. But, I did no tests to prove it. Anyways, an OvisLink Airlive IP-1000R router seems to be working much more smoothly, when comes to web pages browsing.
  47. pepemosca

    pepemosca LI Guru Member

    I see, great idea.
    I'll try and we will see.

    I still don't know why I bought this WRV200 insted the WRT54G (and variants WRT54GS, WRT54GL, and WRTSL54GS). Too much trouble with this router.
    I don't use the VPN.

    Thanks, I'll try.

  48. bsemisch

    bsemisch LI Guru Member

    I tried (and tried), but was told that they don't support the WRV200 or have access to the WRV200 firmware. The WRV200 is supported by another group. So, back to the 800# I guess.

    There goes the rest of my afternoon...:mad:
  49. bsemisch

    bsemisch LI Guru Member

    Update (2 things)...

    1) Found that following the phone menu options for business support (since WRV200 is a business router) will save many minutes of waiting in the other queue, only to be transferred. I think I pressed the following options after calling 800-546-5797... 1 English, 1- Tech Support, 3 - Business Products, 4- "other" business products

    2) Though the good news was that I wasn't on hold more than 2 minutes, the initial support tech had no idea about the firmware 1.0.38 and connected me with a tech in India. The 2nd tech confirmed it existed, but could not send it to me. Instead, a ticket was opened and I'll be getting an email and/or phone call from the support folks in Irving, CA.

    Wish me luck...
  50. pepemosca

    pepemosca LI Guru Member

    Check your PM.

  51. javierpedrido

    javierpedrido LI Guru Member

  52. CalledToConstruct

    CalledToConstruct LI Guru Member

    It seems to me that 1.0.38 is the most stable and functional version (there is hope!). Here's what I've had to do (though):

    1) I had to disable WMM on all SSIDs (else, my wireless clients would disconnect / reconnect every 15 or 20 minutes; plus, the router seemed to be less stable)

    2) Reset to Defaults after firmware upgrade (I know, this sounds obvious to most of us, but I had forgotten ... went straight in after upgrade and entered settings ... it was not stable ... so I saved settings ... reset to default and restored settings and now it is quite stable)

    3) The VPN is working again (stopped working with 1.0.36) but I do get about 3% - 7% dropped packets. Hopefully we will get another update with this fixed??

    // Joe
  53. toymaster458

    toymaster458 Network Guru Member

    Well you got LUCKY
    I first tried the WEB Chat route just to be told that they wish they could help me but they have a special department to assist with my needs and I need to call in.
    I then called in, mentioned the beta and was told that they have to troubleshoot my configuration first. This is all fine as long as the end result is the same but after a hour of working with their support I was hung up on.
    I then called back in after waiting for a half hour for a call back just to find out that my support ticket was never updated by the tech I was working with and had to start the whole process again from the begining. When I finely talked to a tech he logged in to my routers while I was on hold for a half hour just to have him come back and say I configured everything properly and it should be working. He then told me that I have to wait up to four hours for the development team to call me back.
    Well I started this whole process over 8 hours ago and been waiting for the development team to call me for the past 4 and half hours now.
    I am VERY dissapointed with Linksys Tech Support on this issue.
  54. toymaster458

    toymaster458 Network Guru Member

    Does anyone have a known good copy of the firmware I can get. Linksys has still yet to call me back and when I called in and put on hold for another hour they told me 24 to 48 hours for development to call me back.
  55. bsemisch

    bsemisch LI Guru Member

    Another Update...

    Believe it or not, I got a call from Linksys the next day and they emailed the firmware to me. Too bad there were not as fast as pepemosca. It seems to have fixed my SIP/voip problems, but now I loose my Internet connection daily and need to reboot (but keep dialtone, hmmm...)

    I'll follow the advice of CalledToConstruct and start from scratch. Honestly, I thought it would blow away my settings with the upgrade. I was so happy they were still there, I just went with it. If this doesn't work, I'm going to club this thing like a baby seal and put us both out of our mysery.

    BTW, *disabling* SIP Application Layer Gateway to get my VOIP to work seems counter-intuitive. But it seems to work and that's what the tech said to do. Is there a simple explanation?
  56. CalledToConstruct

    CalledToConstruct LI Guru Member

    Always, always, always... Factory Reset BEFORE ... AND ... AFTER upgrading firmware. Those are the instructions I read and have (almost) always followed. When I've (oops) forgotten to reset after, the router has run like carp. Factory reset and enter settings manually is the safest ... BEST ... ONLY way to go.

    I've even gone as far as to compile a list of MAC and IP addresses on my network (in the form of ##-##-##...## as well as ##:##:##...##) so I can simply copy and paste into the config screen (for wireless network access and static ip list).

    I found the same to be true for the Wireless Isolation (within SSID). Enabled seems to allow wireless clients to see each other, Disabled seems to keep wireless clients from seeing each other. (go figure)

    Has anyone else noticed issues with their wireless clients / connection bouncing every 5 to 10 minutes when WMM and U-APSD are enabled? I have two laptops with the Intel PRO/Wireless 2915ABG adapter... one stays connected regardless, but the other will drop connection for a half a second, then popup the "connected" message every so often.

    // Joe
  57. pepemosca

    pepemosca LI Guru Member

    Are you using WPA2? I had that problem when I used WPA2-Personal Mixed and my Intel 3945ABG.
    That's why I use WPA-Personal.
  58. kuvera

    kuvera LI Guru Member

    restart required

    I have upgraded my firmware to 1.0.38, and my FTP problems are gone, but there's a new one. When I start my computer in the morning, after more than 8 hours of inactivity, the router and thus the internet is unreachable. Every day, for the last 4 days. Do others experience this?
    Formerly it happened about once in every two weeks, until I installed firmware
    Can this be because I did not reset factory defaults before upgrading? Should I repeat the process?
  59. pepemosca

    pepemosca LI Guru Member

    Maybe. I don't have that problem.
    Try doing a "factory defaults" reset.
    Good luck.

  60. kuvera

    kuvera LI Guru Member

    I did the 1.0.38 firmware upgrade again. I still have to switch off+on in the morning to make it work. I have had this router for 1.5 years now, and it is the worst supported hardware I have ever had. So far I had to restart it because of the FTP problems, and now because of this inactivity problem. I have had enough.
  61. Csupa

    Csupa LI Guru Member

    pepemosca could you send me the 0.38 firmware, i have 6 wrv200s, some of them with ppoe connection and ddns.

  62. TomSweet

    TomSweet LI Guru Member

    I second this wholeheartedly. Yes, the multiple required reboots are an irritation, but there aren't as many as there used to be.

    No issue noted with an Intel PRO/Wireless 2200bg, using ProSet Wireless Version 10.x series releases were absolute junk with frequent hangs, disconnect/reconnect, and memory leaks. Release 11.5 is out now. There is a note about enabling U-APSD via registry changes in the Release Notes' Known Issues.
  63. Csupa

    Csupa LI Guru Member

    Thank You guys! This new firmware is working perfectly. You saved me! :)
  64. DerToob

    DerToob LI Guru Member

    I'm using three wrv200 devices.
    I updated two of them from 1.0.37 to .38, the third is running with 1.0.34

    Since than my VPN is not working anymore between firmware .38 and restarts every 2 minutes between .38 and .34

    One 1.0.38 wrv200 has static ip, the others dynamic.
  65. jwiedow

    jwiedow Guest

    I upgraded to beta firmware 1.0.38 29 days ago and my WRV200 has been up and running now for 29d:19h:10m:14s. This has addressed a major problem I had with VPN and HTTP dying requiring a cold boot every 5 days.

    This seems to be a fairly stable release so far.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice