WRV200 VPN "Initialization File is Corrupt"

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by CalledToConstruct, Jan 17, 2008.

  1. CalledToConstruct

    CalledToConstruct LI Guru Member

    For the last month or so, I've been unable to establish a working VPN connection to my WRV200. So, last night I was trying the QuickVPNPlus application downloaded from linksysinfo.org (Thanks admin!)

    Anyway, in the documentation for quickvpnplus, there is an explanation of how QuickVPN works... and I found the "login" URL:


    Using this as a diagnostic tool via the browser, I am able to see the response from the WRV200. The response (shown below) somewhat explains the error I receive back from quickvpnplus:

    [E] HttpSendRequest 12152 - The server returned an invalid or unrecognized response

    The router returns:

    version=1 msgtype=status status=-8 message=Initialization File is Corrupt HTTP/1.0 200 Ok Server: httpd Date: Thu, 17 Jan 2008 06:12:07 GMT Content-Type: text/html Connection: close version=1 msgtype=configuration conn quickvpn-1 presharedkey=blahblahblahblah rightsubnet=192.168.?.?/24 remotelanip=192.168.?.? dnsserver=192.168.?.? domain=linksys

    Now, here is where it gets weird... at least from my perspective... I figured "Initialization File is Corrupt" would be corrected by a Factory Default Reset (no luck there) or AT LEAST a reload of the firmware (I installed .32.2 downloaded from Linksys)... no luck there either.

    Soooo... I am hoping that someone can shed some light on the nature of this issue. Anyone know why the router would report "Initialization File is Corrupt" in the message? Is this what causes quickvpnplus to report "Invalid or Unrecognized Response"?

    Last note: QuickVPN usually does "connect", but no traffic passes to or from the VPN and I cannot ping the router once the VPN connection is "connected"... I've tried QuickVPN 1.0.10 (or similar) as well as QuickVPN 1.2.8

    Any help would be appreciated! Thanks!

    // Joe
  2. CalledToConstruct

    CalledToConstruct LI Guru Member

    Here is an update:

    After reading a bit further, I found that quickvpnplus needs the -F 2 option for the WRV200... which I had tried, but then ALSO, I needed to specify the name of the certificate (Cisco-Linksys, LLC)

    Now, I'm able to connect, but sadly, I'm not able to ping or access any machines on the other side of the connection.

    I am beginning to think that IPSEC has stopped working on my XP machine... so when I get a chance, I'll be copying the quickvpnplus application and configuration to another machine and giving that a try. I'll continue to report here in the hopes that someone else can benefit from my experience.

    // Joe
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice