WRV200 (What Are The Problems So Far?)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by DocLarge, May 29, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    I hope the MTU size was the fix you needed:)
  2. Toanoo

    Toanoo LI Guru Member

    I think it WAS the problem. Thank you again for guiding me because I didn't know that setting other than "Auto" would solve problems, I thought it would cause more problems so I didn't try to play with this parameter.

    The changes have been applied 1 hour ago, and no problem. I didn't test the wireless connected PCs, they're off and I'm a bit tired. I will test tomorrow but I think the problem of browsing is now a part of history :cool: !

    Finally this device works... Now it's time to play with it... :rolleyes:

  3. dewdo

    dewdo Guest

    I encoutered the same browsing troubles with the wrv200 and Toanoo an I talked about that. We have the same network configuration.
    When I change the MTU with 1492, it fixed this browsing trouble for my LAN and WLAN PCs. ^^
    So by now, I think we should recommend to turn your mtu on manual with your own value.
    Thanks for your help you guys !
  4. Toanoo

    Toanoo LI Guru Member

    Well well well...

    1492 is not our MTU, it's still a bit too high. I entered 1444 and it works better.

    It's not this topic's purpose to talk about MTUs, but to help the community and developers, I think we should notice that the automatic MTU detection *could be* defective on WRV200 (that's my opinion)...
  5. Toanoo

    Toanoo LI Guru Member

    Is anyone aware of WRV200's detailed specifications ? I'm curious and I would like to know which processor it uses, the amount of RAM, and other stuff... It's easy to find WRT54G's detailed specs but all we can find about WRV200 is that it's a grey wireless router with VPN and QoS possibilities, and its price. Nothing about the components included...

    Doc or Toxic, you may have an idea ?

  6. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    8 MB Flash, 32 MB RAM.
    built-in Realtek Controller / gateway-on-a-chip

    Information can be found in this thread:

  7. Toanoo

    Toanoo LI Guru Member

    Thanks ;-)
  8. John M

    John M Guest

    Is the WRV200 very stable? I need a vpn system that is extremely stable that can handle up to 5 users accessing networked data at a time. It sounds like this device has a lot of issues. If not this device what would you guys suggest?
  9. DocLarge

    DocLarge Super Moderator Staff Member Member

    How much money are you looking to spend? Yes, the WRV200 has been quite unstable, but, offcial firmware release sometime next week is expected to calm it down (finally). Should the firmware upgrade do its job, there'll be "a lot" of these units bought in the weeks to come.

    Although you're not hearing it, there's plenty of people watching this thread and waiting for others to buy it before they do. Fair enough... Linksys deserves to wait on customer choice because of "not" properly testing this thing before it hit the market.

    We'll see what the future holds for it as far as next week goes...

    Until then, I'd suggest the WRV54G with 2.37.13 firmware (found on this site) "if" you don't mind using quickvpn (yes, I said quickvpn; it's not a sinkhole waiting for hackers to fill it) IPSEC clients; this router also can form IPSEC vpn tunnels (50). There's also the option of third party clients such as greenbow vpn or ssh sentinel if you don't want to use quickvpn.

    Toxic's personal choice is the RV042. This router allows IPSEC clients (quickvpn) like the WRV54G and has the ability to form IPSEC vpn tunnels too "but" it also has on onboard PPTP server that allows you to connect microsoft vpn clients directly to it.

    Check out www.newegg.com and www.pagecomputers.com for good prices to find these units.

    By far, the WRV200 is the cheapest device around you're going to find that does VPN (plus all the extended features) for it's price.

  10. Walrus78

    Walrus78 LI Guru Member

    I know we are planning purchasing between 15-40 units of the WRV200 once the firmware gets stabilized. I hadn't read anything yet on the forums about another firmware release before 1.0.20 this month. Are there any details about the potential fixes in this new firmware release? Do you know if the using wireless and ipsec tunnel issue is slated to be fixed?

    I'm just on the edge of my seat for a release of these fixes since we are on the edge of deploying these in the new few weeks. Even without a new release I think we are still going to do it since the 1.0.20 resolved a lot of problems.
  11. RamHawk

    RamHawk LI Guru Member

    WRV200 Power and Firmware Issues

    First, let me say that I've experienced quite a few of the problems listed here in this forum and that I have definately been waiting for a firmware fix ever since I bought this in May 2006. I think a lot of the crap they fixed should have been in the original configuration. I mean, how many routers do they have out there? You would think the initial firmware would be much more stable that what it is. I just noticed the firmware is now up to .20 so I'm gonna go fix my router and see how well it does. Glad to see they added a few more port forwarding options. Heh, 5 custom just wasn't going to do it.

    I did notice a brand new issue this morning. At 6:30 am I lost internet connectivity. Examined all other hardware (cable modem, switch, etc) and it was all powered on... but my WRV200 was not showing ANY lights! Huh? My first thought was crap, the power supply went out or the router has died! I examined the power plug and it was inserted firmly and completly. So, I unplugged the power connector, waited about 5 secs, then plugged it back in. Viola! The router powered back on and all was well. Hmm... This a hardware issue? Firmware issue? Power supply issue?!? Again, I've never seen this issue before. Really weird. I have the router plugged into an APC SmartUPS along with my cable modem and switch. I looked in my cable modem log and it didn't show a power disruption. I looked in my APC monitor log and it didn't show any power outage or power spike/sag. Anyone else have this issue? I didn't see it listed in all the messages here.

    Nashville, TN
  12. RamHawk

    RamHawk LI Guru Member

    WRV200 and VoIP

    I have my BPG-510 VoIP adapter plugged directly into Port 4 on my router. I went into the firmware's QoS settings and enabled the Port-Based Qos for Port 4. What are the suggested settings for VoIP to have the priority of the router's bandwidth?

    If I am on the phone and I start a download or remote admin to a server then my calls break up. QoS (especially port-based) should keep the calls clear and inhibit the BW of the internet traffic from taking over the VoIP traffic... right? Any suggestions are definetly welcome!

    Nashville, TN
  13. ifican

    ifican Network Guru Member

    in theory that is correct, in practice however there are to many variables once packets destined for the internet leave your home. It could simply be that you are saturating your link so yes QoS is doing what it is suppose to on outbound traffic ( in my opinion home users in general dont need to worry about that) however the inbound traffic from your isp is unfiltered and just arrives when you request it. Http being the bursty beast that it is, loads downs your incomming pipe and Voip being the most time sensitive is going to have potential issues.
  14. Sfor

    Sfor Network Guru Member

    First I bought two of the WRV200 routers.
    They were acting a bit strange, so I loaded the 1.0.20 firmware. And, after a week I got scared. I wanted to make a stable IPSec connection between these two routers, in order to connect two locations sharing the same WAN. But, using this device as a router is missing it's purpose, right now.

    After one of the routers mysteriously did the factory default settings change by itself, I started to believe I should start looking for some other device, and to trash those two UFO things (Why UFO? They are grey. They have two antennas. And they do strange things to you. (The case should be a bit more round, I think)). Fortunately I "googled" here. So, I regained some of my faith. (Looks like the online help of the Linksys does not know the WRV200 is not a stable one)

    I'll start from the simplest thing

    1) Time Zone settings for Warshaw.

    I'm a Polish so I would like to use the Warshaw timezone settings with the router clock being set to the Warshaw time. Unfortunately the GMT+01:00 Warshaw time zone settings makes router to be late by an hour. The daylight saving feature does not work in case of this setting (So the time is set to GMT+01:00, instead of GMT+02:00 summer time). On the other hand the GMT+01:00 Brussels setting being next to the Warshaw setting works correctly. Since the summer time correction to GMT+:02:00 works for Brusseles, it should work for Warshaw being a bit more east from there. This bug is hurting my national pride, but it is not a dangerous one.

    2) System log troubles.

    The only way I found to view the router's system log is through the Linksys LogViever 1.14 software, I found on the CD in the router's box.
    I do not have other program to receive system log entries, but in case of this one some of the entries are corrupted. The logging stops very often for long time periods. All is back to normal after the router reset. And after a while the log refuses to work, again.

    I was unable to determine if this a router issue, or the software I'm using. I tried two different routers with two different computers. One was running Windows 98, the other Windows 95.

    I'll finish the list a bit later. The router starts doing some strange things again. I'll better watch what it is doing, now.
  15. RamHawk

    RamHawk LI Guru Member

    WRV200 Power Issues

    Well, my WRV200 router went dead again today at around lunch time. Internet / network was down all day until my wife got home and I could walk her through the reset. Again, no lights or activity. Unit was firmly plugged in. Unplugged, waited 5 secs, plugged back in and all was well. This is definately a problem and I will be calling tech support. I haven't had time to look in the logs to see if it recorded any type of activity or error message(s). :(

    Nashville, TN
  16. srainess

    srainess LI Guru Member

    Access Restrictions - Not like Other Linky's

    Not sure if its exactly a problem, but moved from another linksys (with voip).
    That Linksys let you put access restrictions on group of machines. I believe 5 in a list. The WRV200 :frown: is machine specific, and only 8 'rules'. This is way too restrictive. I need to limit access to certain machines after 10:00PM until 2PM the following day. I would have to create 2 rules for each machine this way.
  17. srainess

    srainess LI Guru Member

    AIM - Connection Drops

    Had this problem with earlier firmware quite frequently. AIM will stop, and say it cant connect. Only way to get connection back is to reboot router. Still happening with firmware 1.20, but not as frequent.

  18. ifican

    ifican Network Guru Member

    Been running IPsec vpn continuous for about 4 days, not much data going across but it has been stable. Interesting thing happened today, tunnel, internet, mail et all stayed active and working. However, could no long pptp through the router out to the world. Started looking at every other device then ended up on the wrv200. Tried logging in and discoverd the GUI would not come up. Logs didnt show anything out of the ordinary, so i rebooted it and everything including pptp and gui snapped right back into operation. Will keep an eye on this and see what transpires over the next several days to week.
  19. DocLarge

    DocLarge Super Moderator Staff Member Member

    This will happen again. Kspare, Toxic, and myself noticed this while we we're in the middle of testing the WRV200 for Linksys (should be mentioned further back in this post). Even though you lose connection to the GUI, you still have full availability of your internet connection. Tekai has promised that the new wireless patch (due out any day now) should take care of these issues.

    One question I do have though is are you using your wrv200 for strictly vpn "minus" http traffic? It's a well-known that you can't run IPSEC VPN and http simultaneously because it causes the router to reboot...

  20. Walrus78

    Walrus78 LI Guru Member

    Are you saying that with the current firmware you can't have users browse the web and have IPSEC VPN Tunnels created at the same time or the unit reboots? We've been testing it, and while we do get some random lockups, we haven't experienced this.

    I really hope this isn't true because we just got 15 of them to deploy today. We've been testing them for about a month and just really haven't seen this.
  21. ifican

    ifican Network Guru Member

    I am a bit to lazy to back and read the post in entirety however i believe if i remember right from reading it the first time, that he is saying you cannot run web traffic across the vpn, you can split tunnel it, and yes that is what i am doing with the occasional above symptoms. I have been monitoring this site and linksys for the new patch, hopefully it will be out soon.
  22. Walrus78

    Walrus78 LI Guru Member

    I wasn't able to quickly find the thread about http connections through a vpn, so maybe this is a known issue as well. Starting with Firmware 1.0.20, we've been unable to initally pass traffic through an ipsec vpn tunnel when the WRV200 is using a PPPoE connection. Now, in each situation, we got the inital WRV200, before putting any configuration in there, flash it to 1.0.20 and we were able to replicate this problem. Reflashing it back down to 1.0.19 solved the problem in both cases. I noticed in the release notes that there were some fixes for PPoE connections so I'm guessing Linksys changed something minor in there.

    And before anyone asks, yes - we did do a clear of the whole config before and after these firmware upgrades.

    Anyone else seeing this same problem? If it makes any difference, we are establishing tunnels to a Cisco 3005 VPN Concentrator. No issue with 1.0.19, but .20 makes the connection no longer work with PPPoE connections. We have been able to replicate this problem with 2 different WRV200s and 2 different sites.
  23. Toxic

    Toxic Administrator Staff Member

    it is a known issue and is fixed on the next release. (No date for this as yet)
  24. jcferrara

    jcferrara LI Guru Member

    wrv200 More than 1 VPN client resets to default settings

    I tested a WRV200 for 2 days with firmware. Everything seemed fine. Installed it in a client site and connected to it. Called one of the remote users and remotely installed QVPN x.40 on their PC and connected to WRV200 while I was connected. We lost all connectivity. Now, my client was down completely... I drove to his office and checked out the device and found it completely reset itself to factory default settings.

    Long story short... I uploaded the config back to the router and the same thing happened 2 more times.

    Anyone got a recommendation for a proven SOHO wireless VPN router?

    Thanks in advance.
  25. Walrus78

    Walrus78 LI Guru Member

    Thanks for getting back to me on this Toxic. I couldn't find anything on the forums about this.
    (but i could have easily missed)

    You guys must totally have the inside scoop. :) Here's to hoping the next firmware release is soon.
  26. ifican

    ifican Network Guru Member

    I run an ipsec vpn and quickvpn from several different locations back to the 200 and have yet to experience anything like this. Now reading over your post are you saying there were 2+ quickvpn's drop the connection?
  27. jcferrara

    jcferrara LI Guru Member

    2+ QuickVPN connections reset the device back to factory default settings. This happened 3 times total.
  28. Sfor

    Sfor Network Guru Member

    I was not using VPN, but the reset to default happened to me, as well.
    Wireless off.
    Syslog on.
    VPN off.
    IPSec off.
  29. Toxic

    Toxic Administrator Staff Member

    THE PROBLEM IS SYSLOG read to posts.
  30. DocLarge

    DocLarge Super Moderator Staff Member Member

    THIS JUST IN!! WRV200 Alpha 1.0.21 Firmware

    Toxic, Kspare, and myself have just gotten the new alpha firmware for the WRV200 (1.0.21) and the vpn over wireless problem has been resolved!!! Yes sir, get your orders ready, because the WRV200 is looking like it may be the business router it was originally advertised as being!!

    Before any of you ask, NO, we're not putting the firmware out until we finish thrashing it. Preliminary tells us it's going to be fine, but we're just making sure... Toxic and I already had a session where he connected his WRV200 (Firmware 1.0.21) to my WRV54G (Firmware 2.39.2e) and downloaded from my ftp server (through vpn), chatted with me over VOIP, opened up helluvwebpages, and the router didn't crash!!! Kspare also confirmed he can hit CNN with IE7 and Firefox without crashing.

    Here's some of the remaining things we asked to be fixed that have been taken care of in this new firmware release:

    - wireless+vpn
    - vpn over PPPoE
    - brute-force login attack
    - firewall ports not stealthed

    We'll keep you posted...

  31. srainess

    srainess LI Guru Member

    AIM - Connection Drops - Update

    Able to resolve the AIM Connection drops. Not sure why, but if I turn on
    triggering of port 5190 (AIM), I stop losing connections. This shouldn't be the case though, as I did not have this problem with previous models
  32. jcferrara

    jcferrara LI Guru Member

    Thank you for the input but syslog isn't enabled on this router.
  33. marwaw

    marwaw LI Guru Member

    my problems

    Existing problems (version 1.20)
    1. its impossible to use wireless and vpn(ipsec) in the same time (each 5-10 min reset)
    2. sony psp can't connect to this router (i try all combinations)
  34. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    The one I had deployed at a client a few months ago...
    Went there yesterday to do some work....flashed firmware on the 200 to the version that came out in September...

    The excruciatingly long reboot times have been cut down..but it still seems to insist on rebooting at darned near any change you make to it (save settings)

    I can't get it to go to manually set MTU...soon as I do and type in 1492..click save....when screen reloads it's back to auto.

    I can't get DHCP reservation to work.
  35. DocLarge

    DocLarge Super Moderator Staff Member Member

    In case some of you missed it, alpha firmware 1.0.21 is being tested by a few forum members right now to include myself, Toxic, and kspare. The wireless + vpn has been resolved, amongst a few other things :)

    The only issue still present at this time is the syslog, which will occasionally lock up and reset the router to default ssid along with gui crashing. The positive is now you can actually hit the reset button and it will clear the problem.

    Stay tuned...

  36. dancer_pk

    dancer_pk Guest

    DC Master, Second DC and IPSEC with WRV200

    I have a DC in the Subnet and a Second DC in the Subnet - inbeetween I have a IPSEC Tunnel with WRV200 - this works nice. I can ping the pcs on both sites, and I have also access to the shares on the servers. BUT: If i open Active Directory and want to open Properties on the second server, the master DC can't be find? Do I have define filters?
  37. kspare

    kspare Computer Guy Staff Member Member

    make sure you have dns servers setup on each dc. and each dc is set to have and the other dc as dns servers...
  38. jnorthco

    jnorthco Guest

    Does anyone have any info on QoS settings on this router? I've tried firmwares 1.0.9, 1.0.20, and 1.0.21, I can't seem to get QoS to work. Port or Application based, it doesn't matter, I can get neither VOIP traffic nor SSH traffic to be prioritized.
  39. hawkman

    hawkman LI Guru Member

    Will the 1.0.21 firmware resolve issues of dropped wireless connections and the router getting into a state where it cannot be accessed over the web interface. Thanks.
  40. DocLarge

    DocLarge Super Moderator Staff Member Member

    Yes it will. There are still some lockup problems users encounter when running "syslog" from the WRV200. By far the most important improvement with this firmware is the fact that you can now do internet and wireless vpn again...

  41. hawkman

    hawkman LI Guru Member

    I tried the 1.0.21 and unfortunately it did not resolve the dropped 802.11 connections for me. I am running with two SSIDs (one WPA-PSK and one WEP128). When I backed off to a single SSID (WPA-PSK) on my WRV200 and plugged in my old AP to the WRV200 Ethernet switch (and used the WEP128 connection through my old AP) - my wireless connection has remained solid as a rock. While I can live with this short-term, I'd definitely prefer to utilze the WRV200 for both SSIDs and retire my old AP. Any suggestions?
  42. DocLarge

    DocLarge Super Moderator Staff Member Member

    Which connection are you losing; the WPA or the WEP, or do you lose "ALL" connectivity?

  43. ifican

    ifican Network Guru Member

    At the moment just patience. The firmware has come a long ways and still has a little bit to go. I am sure that it will eventually get there, but your guess is as good as mine as to when that will be.
  44. Sfor

    Sfor Network Guru Member

    I started to observe some strange communication problems when using FTP. Since it happened right after moving to the WRV200, it can be router related problem. Unfortunatelly my old router is no longer in my possession. So, I can not switch back to the old router, any more.

    I have two of the WRV200 for over a month, now. Luckily I did not installed the second router in the second LAN. I lost the faith into this project. So, I do not want to dig in deeper into it. Without a working syslog, fighting with firmware bugs will be a long and bumpy road. I have no more time to play with it, because toying with problems without proper tools is nothing other than a time loss.

    I'll get rid of both WRV200 routers, as soon as I'll find a satisfying replacement for them.
  45. mkhancock

    mkhancock LI Guru Member

    Can't connect to VPN using quickvpn

    Firstly I'm a novice.....hoep someone can help.

    I have installed a WRV200 with an ADSL modem (AM200) in my office & want to connect onto the office LAN from a laptop using quickvpn.

    The WRV200 is up & working OK - office LAN is connected to the internet using a static IP.

    The settings on the router are:

    SET UP
    Internet connection type: Static IP
    IP Address:
    Subnet mask:
    Default gateway: (Modem IP Address)
    Primary DNS:
    Secondary DNS:

    Local IP address:
    Subnet mask:

    When I try to connect from home using quickvpn I get a dialogue box pop up with CONNECTION ERROR & a number of possible reasons. I have a username & password set up in the VPN tab & can ping my static IP address (which is a 213.xxx.xxx.xxx number).

    Can anyone offer any advice?


  46. Toxic

    Toxic Administrator Staff Member

    since the WRV200 is behind the ADSL modem and you have an internal IP address, you need to port forward on the ADSL Modem ports:

    HTTPS (port TCP 443)
    IPSec (UDP 500)

    to the WRV200 WAN IP address i.ie

    pinging your static IP address is [pinging your ADSL modem and NOT the WRV200

    Can you set you ADSL in Bridge mode?
  47. mkhancock

    mkhancock LI Guru Member

    Thanks for the info Simon.

    The modem is set to RFCxxxx Bridged PPPoA (it's a BT broadband line). I'm unsure whether port forwarding is a feature of the AM200 (I assume it should be) so I'll nip into my office this morning & take a look.


  48. mkhancock

    mkhancock LI Guru Member

    I set up the two port forwards as suggested, and the first time I tried the quickvpn connected OK. I disconnected, and every time I have tried to connect since then it goes through the process fine upto the point where it says "verifying network". At this point it stalls for approx 5 minutes then pops up a dialogue box "the remote gateway is not responding. You will now be disconnected,please try again later.".

    I have rebooted the router without success.

    Any ideas?
  49. Toxic

    Toxic Administrator Staff Member

    delete the quick vpn user account and re enter it(in WRV200) I have known it to "hang" and not correctly disconnect.
  50. mkhancock

    mkhancock LI Guru Member

    Checked the status over my trusty logmein account and found that the router thought I was connected already, even though the quickvpn on my laptop was stalling.

    Disconnected, removed the user and tried to reinstate the user and was prompted to change the IP addresses on the local LAN to avoid conflicts with remote users! Perhaps this could be the problem? The first time I connected successfully I was using an internet connection from a mobile 3G card in my laptop, so my IP address was an unsual 10.xxx.xxx.xxx ish which is nothing like the 192.168.1.xxx on my office LAN.

    Does this make any sense?
  51. Toxic

    Toxic Administrator Staff Member

    You need to make sure your local IP address range is not the same ip subnet as the office IP address range.


    Local /
    Remote /

    try using / for your local LAN IP.
  52. mkhancock

    mkhancock LI Guru Member

    Would you believe that after approx 5 hrs of technical support from Linksys, they have realised that the WRV200 router VPN function is not compatible with their own modems. The Linksys modems (or modem routers as they infact are) have a NAT which cannot be turned off - the router doesn't like this. You have to have a simple modem that passes the static IP directly through to the router, otherwise the router thinks it's connected when infact the remote user is NOT connected.

    Had to return the whole lot to Linksys & have replaced with a Draytek all in one ADSL VPN Router. Configured first time & VPN connected first time using the VPN client that is built into XP.
  53. DocLarge

    DocLarge Super Moderator Staff Member Member


    I noticed that when I did a "shields up" check with my adsl2mue in bridge mode with my wrv200 behind it (I've even mentioned it to a linksys developer once or twice...)

    The main device I use in my configuration to get around that is the x-modem ce from www.adslnation.com . Here's some information about it:

    http://www.adslguide.org/hardware/reviews/2003/q3/xmodem.asp (ADSL Guide Review)

    http://www.adslnation.com/products/xmodem-m3.php (X-Modem CE Site Review)

    Both my WRV54G and WRV200 have run "perfectly" with this modem because it transfers the ISP assigned ip address "directly to router," therefore elliminating any NAT issues; in the end, my quickvpn and IPSEC tunnels run uninterrupted and without problems.

    Too bad you didn't know about this before hand :( you could have kept your wrv200 (great little box now that the firmware is becoming stable...)

  54. roland80

    roland80 LI Guru Member

    Problems with the web interface

    My WRV200 is running on firmware 1.0.23(us) and evertime is start amule, the web interface crashes. I also tried the newer 1.024(us) firmware but the problem was the same.
    After starting amule I am able to login into the web interface, but after a few seconds the web interface becomes inaccessable.
    But all the other router functionality seems to work normal.
    I run the web interface with ssl encryption (were the ssl certificate seems to be out of date).
    Does someone else have this problem?
  55. Toxic

    Toxic Administrator Staff Member

    roland80 when you upgraded did you reset the firmware to factory settings? yes?
  56. roland80

    roland80 LI Guru Member

    Thanks for your quick answer

    Yes is reseted the firmware to factory defults as recommended in the readme.

  57. DocLarge

    DocLarge Super Moderator Staff Member Member

    If you haven't done so, make sure you disable any firewall software and/or antivirus when you are in the router's web interface. The java scripting doesn't get along with firewall/antivirus software unfortunately.

    If you do this, you should be able to work. Once you've made the changes you need, re-enable your firewall and antivirus once you exit out of the webgui.

  58. ifican

    ifican Network Guru Member

    I believe this is the case with just about any soho device and the certificates are not dynamically updated. And yes it is the case with mine as well. As far as your AMule issue, p2p in generally will do some goofy things, it really sounds like once the program starts it sends a sequence that the router just does not like. My guess ultimately would be the program cause the router to stumble by making it write to a part of memory that is already being used. How or why i am not certain but its just what it feel like. Not that this is going to help very much, but i bet if you played with it enough, you can find out what setting on the router is cause it to act that way when you start the program. Could be just about anything, so if you are so inclined, turn off all option functions and try, then just keep adding things one at a time until you find the culprit.
  59. roland80

    roland80 LI Guru Member

    I am using linux without running a firewall.
    I think so too, it could be that a memory area is used that the web server uses too, and so the server crashes.
    I will try some different configurations of the WRV200 and maybe I can find the failure.

    Thank you for your hints.

  60. Sfor

    Sfor Network Guru Member


    I've been experiencing some FTP related problems, after I switched my router to WRV200. The problem was present with the 1.0.20 fimware, and it is still present with the newest 1.0.24.

    I'm using an FTP script to download a large amount of small files with MGET command. The FTP client is the Windows 9x built in FTP.EXE.

    The ftp client connects to the ftp server and starts to download files. During download of a few hundred small files it stops with an error condition. I tested it on 4 different computers and the result was always the same. When I connected one of the computers through a different router the problem dissapeared.

    The problem description:

    The normal ftp client output for each file looks like that:
    200 PORT command successful.
    150 Opening BINARY mode data connection.
    226 Transfer complete.
    ftp: 74989 bytes received in 4.01Seconds 18.70Kbytes/sec.

    Quite often at the beginning of the next file ftp client displays one of the error messages:

    500 Illegal address rejected.
    425 Can not create data connection: Operation timed out.
    425 Can not create data connection: Operation timed out.
    425 Can not create data connection: Operation timed out.
    (it enters a sort of endless loop in such a case)

    425 Can not create data connection: Connection refused.
    425 Can not create data connection: Connection refused.
    425 Can not create data connection: Connection refused.
    425 Can not create data connection: Connection refused.
    (it exits after a large number of those)

    Connection closed by remote host.

    200 PORT command successful.
    Połączenie przerwane przez zdalnego hosta.
    (translation from Polish language Windows version: Connection broken (or closed) by remote host)

    The script is interrupted by one of those error conditions with more than 90% probability. (Always at the beginning of a file.)
    The FTP server is always disconected if following ftp script commands are processed.
    If the ftp clients starts to receive data it will always downloads a full file. The problem occurs only before the ftp client receives the first part of a file.
    Sometimes a few hundred files are downloaded before the problem happens.
    I tried other ftp servers with the same results.

    The conclusions:

    I do not know exactly how the FTP protocol works, but I can imagine there is a problem during the file tranfer negotiation, or during making a connection to the ftp server. Since everything works fine with other non Linksys WRV200 router, I excluded other possible causes. Only the router related causes remained, I believe.
  61. DocLarge

    DocLarge Super Moderator Staff Member Member

    What's happening, SFOR?

    Haven't seen you on the boards in a while...

    I run an ftp server behind my WRV54G and it all runs fine. I'm using actual software (Ipswitch FTP Server) although I can get away with using DOS ftp command line too. Have you tried resetting the MTU on your wrv200?

  62. roland80

    roland80 LI Guru Member

    Problems with the web interface

    Now I found out were the problem with the crashing web interface comes from (while amule is running).
    It only happens if logging for DoS is enabled (the option with send log via e-mail).
    The problem appears with all firmwares is used (1.0.20, 1.0.23(us), 1.0.24(us)).
    I think the log gets full very fast an affects than the webserver.

  63. Sfor

    Sfor Network Guru Member

    I've been playing with every new firmware version. So, when I was ready to post something, a new firmware version was appearing and I had to test my problems with another firmware vesion.

    By the way. The clock in the 1.0.24 works good, now. And the "Automatically adjust clock for daylight savings changes" check box is disabled in case of many time zones. I will not be needing daylight saving time correction till spring. But, it will be a help, when the winter ends.
    I wonder if there are time servers returning the local corrected time, so it will be possible to go around lack of support for daylight saving using the newest "Assign Preferable Time Server" feature.

    I've just tested the FTP problem with DOS prevention disabled and MTU set to 1024. No change, I'm afraid. The download broke with 121'st file.

    The router is working with the WAN static IP setting. I wonder if it could have something to do with the problems, I'm experiencing.
  64. mhii

    mhii Guest

    I have been having major problems with this router since I purchased it several months ago. The Linksys website only has the firmware through version 1.0.20. Where I can find the later builds that everyone is referencing (i.e., 1.0.23 and 1.0.24)?
  65. ifican

    ifican Network Guru Member

    The download section of this site.
  66. hammondhui

    hammondhui Guest

    does anyone get the problem of PPPoE connection drop?

    I have the WRV200 connected through sbc dsl, and I already make "keep alive" enabled. But then from time to time, the connection will drop as I see my MSN messenger keeps disconnecting...

    And I have already upgrade the firmware to the .24 beta

    Can someone help please?
  67. patientzero

    patientzero LI Guru Member


    So I can't actually access my router via webclient or with the quickvpn utility. It gives me like a password error on the quickvpn and a bad request 401 when i try to firefox it... painful to ask, any ideas?

    Thanks in advance,
  68. Toxic

    Toxic Administrator Staff Member

    patientzero the webgui is accessible via a LAN IP addess or remote management . QuickVPN does not assign you a LAN IP address. so enable remoe management on the router (make sure pwd is log and different) and use a slightly different port then to access the router from a remote location using your webbrowser do the following.

  69. patientzero

    patientzero LI Guru Member

    I'm trying to (as this is the address *changed from x.x.x.1) Doing this i get a cannot establish connection message..
  70. patientzero

    patientzero LI Guru Member

    Ok so anyways I'm a retard, but I still cannot figure out why i can't http to my router to edit settings and stuff... I'm no guru and need some careful prodding, and would appreciate any extra help someone might offer to this extent!

    Thanks again,
  71. Sfor

    Sfor Network Guru Member

    There is a 1.0.24-ETSI firmware available on the Linksys UK page. I'm testing it right now, and I've got a feeling it is less stable than the US version.

    I was working with the US version for about two weeks, and the SIP connection failures were happering rarely (once every few days). The ETSI version gave me two SIP lockouts, just yesterday.
  72. LinkLogger

    LinkLogger Network Guru Member

    No inbound scans etc in logs

    I picked one of these up for testing and thus far I've noticed it doesn't log inbound scans etc. For example do a scan from grc.com and none of scans appear in the logs. I'm running the 1.0.25 firmware, and if I don't have it configured correctly (ie you see inbound scans, but I have everything selected in the log setup), then please let me know.

  73. Sfor

    Sfor Network Guru Member

    Where did you get the 1.0.25 firmware from?

    I've noticed the log does not report any denied inbound acces events, as well. But, since the log is causing the router to be unstable I kept it switched off.

    Has the 1.0.25 firmware the instability with log turned on corrected?
  74. yawdib2

    yawdib2 LI Guru Member

    T have the WRV200 with the latest firmware rev 24 .. ever since I have this router I have not been able to get any snmp messages. What free program ot there can I use to get snmp message from this device?
  75. DocLarge

    DocLarge Super Moderator Staff Member Member

  76. yawdib2

    yawdib2 LI Guru Member

    Thanks , program works as advertised.
  77. Loveland95

    Loveland95 LI Guru Member

    What date is this: 2007/0/21 6:45:40 (GMT -07:00) ?

    Looks like there's a bug with the Time syncing and translation ... :biggrin:

    Happy Holidays, whenever they are !

    WRV200 @ 1.0.24
  78. CalledToConstruct

    CalledToConstruct LI Guru Member

    Mixed review: Excellent features, .24 still buggy

    Thanks to linksysinfo and those who've posted regarding the progress of the WRV200. Based on the progress reports that I found here, I decided to finally replace my Belkin router with the WRV200. It arrived yesterday. :biggrin:

    Knowing the issues with the prior firmware versions, I immediately upgraded the unit to .24, then configured the WAN, LAN and Basic Wireless. Connected with both wired and wireless, good so far.

    While on the administration screen, I changed the password, applied the change, then discovered that the unit had reset to factory defaults. I reentered the config settings, changed the password (successfully) and began to set wireless security options. Unit reset to factory default again. Somewhere in there, I had to power cycle the unit twice to regain access to the web interface. I wasn't surprised, given the history of the device, so I continued...

    Then it occurred to me, I had upgraded the firmware in the "factory default" state (fresh out of the box), but I had not reset to factory default AFTER upgrading... so upon power cycle, I immediately reset to factory default, then configured the WAN, LAN and Basic Wireless, set the admin password, then wireless security. Everything went pretty smooth this time. The web interface did show a marked decrease in response time, but did not freeze up like before, nor did the unit reset to factory defaults.

    I have yet to establish a VPN connection, mainly due to the AlphaShield unit sitting between the WAN and the WRV200; hopefully I'll get that straightened out tomorrow. :D

    Since the initial configuration of the above mentioned features, I've had to either power cycle or reset the unit numerous times to keep the web interface responding in a timely manner. Otherwise, it is working well.

    // Joe

    [EDIT]: Sorry, I forgot to mention that the Web UI slow / unresponsive behaviour is with syslogging off.
  79. Sfor

    Sfor Network Guru Member

    There is a 1.0.26 firmware available. And, this is the first firmware the WEB UI of the router should not crash with Syslog feature enabled.

    Yet, the Syslog does not work right. It stops reporting new events, very often. There are reports about FTP and VoIP related problems, as well.

    I think the device is not ready to face the demands of a vital network component, still.
  80. netgeek

    netgeek LI Guru Member

    Does anyone have issues with Yahoo/Aim on the WRV200 Firmware 1.0.24, it seems that it works fine for about 5 hours, and then I the clients connect/disconnect/re-connect. This router will eventually be installed into small business as a VPN endpoint for the QuickVPN client. I experienced this same issue under 1.0.26. I reset to default config before and after flashing the firmware.
  81. Sfor

    Sfor Network Guru Member

    If disconnection of an active LAN port cable (just for a second) clears the lock condition, than it is the same problem as with the SIP connections.
  82. ghost_zero5

    ghost_zero5 LI Guru Member

  83. Sfor

    Sfor Network Guru Member

    Well, no.
    I mean to (hardware) disconnect an ethernet cable jack from one of the active LAN ports of the router. It seems to work in many cases of the SIP lockouts.

    Funny thing is it works with any LAN port the TCP communication is in action, not just the one the SIP communication is performed.
  84. netgeek

    netgeek LI Guru Member

    Yes, However Trillian and GAIM, both "Auto Reconnect" when an account is disconnected. When this problem occurs I see that the client connects/disconnects/re-connects over and over with approx 1min intervals.
  85. ghost_zero5

    ghost_zero5 LI Guru Member

    You mean to don't have a stable connection anymore... correct? Well... Yes, seems like my ICQ-Problem. And it also happened that I couldn't connect anymore too...
    You could try to use some FTP-Client and try to access some FTP-URL with it if you experience that AIM-Troubles... If you can't connect but after router-reboot you can (to the FTP-URL) then it probably is the same bug...
    Just to mention it: That bug is really anoying... Otherwise I think the WRV200 is a great product (good the log could be better but I don't need it that often)...
  86. netgeek

    netgeek LI Guru Member

    I will have to try an FTP client when I get home. I can still browse the internet via HTTP, when this condition exists.
  87. netgeek

    netgeek LI Guru Member

    I tried FTP'ing out and it would not connect, I tried the chat clients and they would not connect as well. I rebooted the WVR200 and all is well again for another 5 hours or so.
  88. ghost_zero5

    ghost_zero5 LI Guru Member

    Well... Seems to be the same problem and there are not that less people with this problem AND it is anoying...
    P.S.: I don't believe that Linksys never had this problem once. Therefore far too many are having that problem and also far too often...
  89. netgeek

    netgeek LI Guru Member


    I re-flashed to 1.0.26 twice in a row with clearing the config, and I have not had to reboot the router in 24hours and counting
  90. DocLarge

    DocLarge Super Moderator Staff Member Member

    I can now also confirm FTP is dead with 1.0.26. I was using 1.0.24 last night and ftp worked with "zero" problems; after flashing up, I'm now without :(

    I'll make sure to officially log this with the developers.

  91. ghost_zero5

    ghost_zero5 LI Guru Member

    Well: It also doesn't work after some time with 1.0.24 (I am still using that version and I also have that problems AND NOT just I)...
    And it is just the same with 1.0.26 ... Have you tried rebooting router... Afterwards it should work for some time again and then it would be dead again...

    AND NOT just FTP, but also ICQ and as I read here AIM... Same for them...
    Just look "WRV200 FTP-Issues"-Thread: http://www.linksysinfo.org/forums/showthread.php?t=50470

    P.S.: Could you tell us when this will be fixed approximately?
  92. netgeek

    netgeek LI Guru Member


    Well it seams that 1.0.26, just increases the ammount of time before thing go bad for me. It seems that it happens just about 24 hours or so.
  93. rgausman

    rgausman Guest

    First I want to say what great work you guys have been doing. Hats off...

    I have been testing WRV200 with firmware v1.0.24. Currently testing G2G VPN connection with wireless off. I just turned on syslog function. I notice under 'Administration->Management' page that the 'Remote Management IP Address' range when set to 'xxx.xxx.xxx.2 ~ .128' it pops up an error message 'Please input correct IP range, Start IP can not be larger than End IP' when saving.

    If I change the range to to '.2 ~ 99', it will save and reboot. If I change to to '.2 ~ 199', it will pop up the range error message. If I change to to '.99~ 100', it will also pop up the range error message. If I change the range to to '.100 ~ 254', it will save and reboot.

    Looks like a simple fix. Can you pass onto developement team. Thanks
  94. stromhu

    stromhu Guest

    Shouldn't it (WRV200) be better ?

    I've recently bought an wrv200 router, the first one just died.. the other one that i got instead works but not well. Compared to my Dlink DI-624 the Wrv200 reaches about 50% as long as the dlink?? And all browsing on internet and downloads goes really slowly with the wrv200. When using wireless connection it works really bad. I have the 1.13 firmware but because i live in europe i cant use every firmware uppdate :thumbdown: . Hard to know wich firmware to use and how to get the router to work properly??

  95. Any ideas if the same thing is true of the DLink 320T. I've read on a different message board that the DLink 320T also just forwards the Public IP Address on to the router/pc connected to it, such as the WRV200, but wanted to see if anyone else has tried this out.

    Any ideas?
  96. Tom0964

    Tom0964 LI Guru Member

    Why not? I do! :biggrin: Currently 1.026 in use, location: Germany
  97. Sfor

    Sfor Network Guru Member

    The european version of the firmware is available at the UK Linksys site.

    I'm using the US version, as well. There could be a problem with wireless radio channel range being out of the legal range in Europe. But, there should not be more differences than that, I think.
  98. bonez05

    bonez05 Guest

    I'm having the same problem. No AIM connection and No FTP until I restart. Both work for several hours then go down.

    AIM 6.0 works though. They must have figured out some way around.
  99. gwoolverton

    gwoolverton LI Guru Member

    Can't upgrade firmware

    I installed firmware 1.0.24 and it's giving trouble. I cannot get to the screen that allows me to upload a new firmware because when I click on the Administration link/tab, a blank screen comes up. ( I tried this from several computers using several browsers after several reboots. No luck; I can't get into the Administration screen to then click on the firmware upload screen.

    Can someone post the exact URL to the firmware page so I can try to pull it up directly?

    Also, I tried Linksys's TFTP.exe program (Windows GUI) to force in a new firmware remotely, but it cannot locate the device. Can someone post a link to instructions for this tool? Or any ideas on alternatives.

    Thanks in advance.

  100. wylieinc

    wylieinc LI Guru Member

    I upgraded to 1.0.26 beta and it is running well - so far.
    I have about 5 WRV200s in the field. Some work well and some have issues.
    I was having an issue with port forwarding and this update fixed it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice