WRV54G 2.25.2 Firmware unstable

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by dms, Jun 18, 2004.

  1. dms

    dms Guest

    My WRV54G has worked well for 6 months as a "wired-only" router. Last week I attempted to set up the wireless portion of its service. ( I have done this many times with other wireless routers). Several features did not work correctly,
    1.) "G-Only" mode would not connect at all to Linksys G network cards, or Linksys G PC cards that work flawlessly elsewhere. It only works in "Both mode"
    2.) when I turn WEP on, DHCP quits working, turn it back off, DHCP works fine?

    Based on these problems, I downloaded firmware rev 2.25.2 hoping that maybe these issues had been resolved. No fix to above issues, and now the router fails nearly everyday! When it fails, sometimes it shows no IP address from ISP ie, all fields blank or zero's, sometimes IP looks just finne, but router will not communicate with internet. Everytime, a power cycle will NOT fix the problem, only way to fix is to go to Status page and renew IP, then router works fine for another day or so.

    I would like to return to the 2.03 version of the firmware so that the router is at least reliable as a wired router. and then will have to decide whether to replace or just add an AP.

    PS, I have been waited over 6.5 hrs for Linksys Live support with absolutely no response. Then 2 days for e-mail response, and still no reply.
  2. Mark1

    Mark1 Guest

    I am having similiar troubles with the addition of:

    1) the router is now 'mysteriously' rebooting the cable modem. I have reset factory defaults to no avail. Reloading the firmware did not work; the last ditch effort has been to press the reset button on the back of the unit. For now, that seems to have solved the cable modem recycling problem.

    2) the DHCP license appears to be revoked long before the stated WAN IP Expires time on the status page. Pressing Release DHCP then Renew DHCP manually restores the IP. What a pain!

    BTW, my wireless has been working successfully in mixed mode with WEP enabled.
  3. gaogi

    gaogi Network Guru Member

    For #2, you need to check your WEP key. If you entered the wrong WEP key, the wireless card can still associate to the AP, but the AP won't pass any traffic to it, including DHCP requests.

    Make sure you are using the same type of WEP key on both sides, i.e., 64-Bit, 128-Bit, HEX or ASCII.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice