WRV54G and QuickVPN (and eventually WRT54G)

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by kpenn, Dec 1, 2005.

  1. kpenn

    kpenn Network Guru Member

    I have been looking at this site (and a few others) for a week or so now while I have been trying to get my QuickVPN configuration to work. I haven't been having much luck, though.

    I have tried to read relevant posts from this forum, but although I think I have followed the directions there and in the QuickVPN checklist, things aren't working.

    First, the picture:

    (my WinXP boxes) -> WRV54G -> DSL modem -> [internet] <- DSL modem <- WRT54G <- my laptop (for testing)

    The router: I have firmware 2.37; I have MTU set to auto (I tried manual at 1450 and 1350, and they didn't seem to work); I have 4 accounts created in the QuickVPN section; the router subnet is ; IPSec and PPTP passthrough enabled; remote administration enabled. I do have DHCP enabled; I could turn it off if that makes the difference. I downloaded 2.37 from linksys.com last week -- if 2.38 from this site makes a difference, I will try that today. I didn't see it on linksys.com, so didn't realize it was available until reading an article here. Oh, I have a static IP from my ISP, and I don't have any ports forwarded. Firewall is on, but I did try it with firewall off once.

    on the client (test laptop, same as what clients will be using):
    I don't have any firewall turned on, I don't have any other VPN software (that I know of!), ipsec is running (and I upgraded it from the SP2 tools). I tried putting the laptop in the DMV on the WRT54G, but that didn't seem to make a difference. [I have also tried using my laptop from a local hotspot -- same response.] In both cases, the IP is 192.168.1. subnet. I also have netscape windows up, to check my router configs or this forum or other places.

    At this point, I get various messages, then the "verifying network" box for 1-2 minutes, then it says it's going to disconnect, try later.

    I have two (sets of) questions:

    1) Have people gotten QuickVPN working behind Linksys WRT54G routers to WRV54G? Is this going to only work with QuickVPN, or could I try other VPN software as well?

    2) "What am I doing wrong?" it's not a good question, but I am not sure what to ask about. Hm, one area, though -- am I not supposed to have any other network connections open? If so, how do I close them all down?

    Thanks for any things to try at all. Oh, that includes other ways to test -- like if people have gotten this working at Starbucks, I can go there. Any definite way to find out if it is a client or server config problem would be appreciated, then I can start on the side that isn't work.
  2. kpenn

    kpenn Network Guru Member


    I ungraded to firmware 2.38.6, figuring that I could back it out. (It was a great upgrade, much better than the one to 2.37 where I had to reload everything.) Then I had a friend try QuickVPN from his Win2K box. Worked, just like that!

    So tomorrow, I will try again with the laptop, and see if the firmware makes a difference. If not, I will also try a different account/pw, as some people have indicated that accounts can just "go south".

    I would appreciate any help on the general set up and on the WRT54G issues.

  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    If you have my quickvpn guide, that should get you through a lot of previously discovered "rough patches" prior to some sort of documentation.

    If you're friend connected, there's a good chance his laptop configuration had something to do with (nothing conflicting with quickvpn). Try and see what your friend has loaded on his...

  4. kpenn

    kpenn Network Guru Member

    I've used the great guides already, and was still having problems. I *think* the problem was the firmware, since I just now connected from the hotspot using my laptop. I did do a pw change just before connecting (using remote admin of the router), so that may have been an issue also, but I don't think so.

    I did find out something -- I have a "limited" user account on the laptop, and that was getting the "incorrect pw, wrong network address, etc" box right away. I didn't change a thing except went to a user with admin access - and that worked. So somewhere in Windows XP Pro SP2, limited users can't do *something* that is needed for QuickVPN. (Doc, can you put that in the guide? It may help a few people.)

    I can ping the router but nothing else, and I can't get to shares yet, but I am willing to work on that (hopefully). Thanks for all the comments in this forum to help me along the way.
  5. DocLarge

    DocLarge Super Moderator Staff Member Member


    I've heard of this before (and forgotten all about it). If I remember correctly, users with "less" than administrative/power users privileges had problems using quickvpn withe the WRV54G. Still, if memory serves me correct, I believe someone figured out how to get around that.

    I'll have to look back through the forums to see what the answer once.

    Do you share this laptop, or is it a company laptop that only gives you basic user rights? Also, people behind the WRT54G have been able to use quickvpn.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice