WRV54G Hardware Rev.

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by bulletspunge, Mar 8, 2006.

  1. bulletspunge

    bulletspunge Network Guru Member

    Mine is always locking up and was wondering if hardware revision .02 is the latest.

    Seems as thought mine alwas needs to have the DHCP address released and renewed and then all is fine for a day.

  2. TazUk

    TazUk Network Guru Member

    I have a rev 02 as well but no lookup problems, what firmware version are you running?
  3. StThomas

    StThomas Guest

    WRV54G Locking Up

    I too am having trouble with the WRV54G locking up. Doesn't even last a day. I am set up with a VPN tunnel into the office. Could that be an issue?

    What seems particularly strange is that I can at times be perfectly functional including the VPN connection but at the same time cannot get into the WRV device through IE and the device's IP address. That just hangs.

    I have the latest firmware loaded from the Linksys site.

    Is there a solution to this?
  4. TazUk

    TazUk Network Guru Member

    Re: WRV54G Locking Up

    Well that was released back in 2004 so is far from the latest one around ;)
  5. kingvj

    kingvj Network Guru Member

    Ensure that the VPN Gateway option is disabled, when the VPN tunnel option is enabled.

    Ensure that you have 2.39.2 to check if resolves the issue, so that we can bang linksys again if it doesnt...:)
  6. JonAlthoff

    JonAlthoff Network Guru Member

    What's this about firmware 2.39.2?
    I've pretty much given up on my WRV54G and now just use it as an access point. I have a BEFVP41v2 for my VPN tunnels. If I can get 2.39.2 I'll load it and test it. I'll look around in the mean time.
  7. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Someone on dslreports posted that they had 2.39.2 The mod invited them to post the link and nothing's been heard since.

    For some interesting reading, check out the thread that DocLarge has started in this forum w.r.t. getting Linksys to get their thumb out and come out with firmware that addresses the various issues that we have all (you included) been remarking on for far too long.

    I know you were plugged into the WRV54G group on Yahoo! for the longest time and posted some very good FAQs on how to get IPSec VPN Clients (non-QuickVPN) to connect successfully to the WRV54G. Perhaps in reading Doc's thread you can offer some insights based on your own dealings with Linksys?


  8. DocLarge

    DocLarge Super Moderator Staff Member Member


    long time...

    Personally, Dave Warner (a.k.a. "TVOS") and myself were able to get quickvpn up and running "consistently" after we knocked heads together for the better part of 4 months (we've been doing the quickvpn thing for almost a year now), to which the "Quickvpn Setup Guide" was born. I've owned 2 WRV54G's and I've "always" been able to make quickvpn work with the "original" file (just used it again last night to successfully connect to NickelCW's WRV54G), to include run vpn tunnels through the ipsec PPTP server. Unfortunately, the first one is bricked because of that 2.38 bullshit; the best firmware right now is beta 2.37.13 and I swear by it until we get an new release...

    What pisses me of is I had to buy another router (SMCBR18VPN) in order to use third party vpn clients from behind the WRV (I basically had to hang the WRV off of the SMC). Yeah, it worked; I could use quickvpn successfully in this configuration, "BUT I'D RATHER DO IT USING THE WRV54G BY ITSELF!!

    Believe it or not, Linksys doesn't see anything wrong with the WRV54G. One person has even commented "We haven't had any complaints about its performance." I'll post some information pertaining to this in another thread...

  9. JonAlthoff

    JonAlthoff Network Guru Member

    I've pretty much given up on my WRV54G. I have a BEFVP41 and the WR54G is just an Access Point now. It works perfectly for that! I don't have much use for QuickVPN or even Greenbow for the most part for now. I mainly use mine to connect site to site. My location to a BEFVP41 or even a Netgear... FVS318. I've got like 40 tunnels plus. I got tired of always having to disable/enable the tunnels or making a change in the tunnels, saving it and then changing it back again. My BEFVP41 version 2 give me far less problems that the WRV54G does. No one seems to have this problem or complain about it. My trouble partially was due to DNS names changing and the WRV54G not updating them correctly. I'm not too sure about some of the other problems. Not much point in contacting Linksys so I just sit and wait. If there is a new firmware available I'll gladly load it and see what happens.

    There is also some mention of a 2.38.7 out.
  10. chris547

    chris547 Network Guru Member

    It might be possible to restore your wrv54g by purchasing a old 3.3v mobile phone cable ( I used a siemens C25 lead). You need to open the box, connect the phone cable to serial connectors and look at the openixp and openwrt webpages, in particular how to load firmware via serial and how to restore original Linksys firmware. It's quite hard to really brick a wrv54g, to really brick it you need to take the bootloader out and Linksys firmware doesn't usually change the bootloader.

    On the Linksys NSLU2 which also uses the redboot boot loader it's possible to access it via a normal ethernet lead connected between your pc and the unit. Unfortunately I can't seem to access it via this way on the WRV54g. You might want to ask Linksys support how to access Redboot to restore a broken download on the WRV54g.
  11. DocLarge

    DocLarge Super Moderator Staff Member Member


    I don't think I'd ask linksys to pee on my house if it was on fire much less trust them to unbrick my box...

    I still can't believe it bricked on me. I've got it sitting open on my dining room table looking for a point of entry. The only approach I've had on my mind is approaching it like a bricked wrt54g, but somebody said that wouldn't work...

  12. chris547

    chris547 Network Guru Member

    Well if you've got the wrv placed with the antenna aligned on the bottom right with the ethernet ports facing you, you might want to start at the bottom 9 connections on the left. That's the serial connection for the unit, 3.3v as mentioned so you need to modify a old mobile phone lead before you connector the wrv to a pc.

    This site provides nice pictures and instructions. http://www.phj.hu/wrv54g/
  13. kingvj

    kingvj Network Guru Member

    hey.. i do hv the 2.39.2 and tried to upload it to the mod but it kept rejecting the rmt file (restrictions eh). i renamed it to pdf and wasnt still able to upload it.

    what do i do now?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice