WRV54G reboots every 8 minutes

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by kipcole9, Oct 9, 2006.

  1. kipcole9

    kipcole9 LI Guru Member

    I am a long time happy Linksys customer - right up until I bought my 7th router, the WRV54G.

    From installation time it has show a tendency to reboot every 8-12 minutes. Linksys support has been of no help - eventually saying "sorry, we can't help". In desparation I bought a second unit to try (I do need a wireless VPN router) and it was DOA.

    I appreciate I am not alone in having issues with this thing. I have tried every piece of different firmware (2.39.2, 2.37.13, 2.37EU) I can find. The syslog appears littered with messages that just look like bad programming (some examples below).

    I have been very happy with my travel routers, my ADSL modem,with my wrt, with access points and other devices - but this "business series" router requires, in my opion, careful qualification for your needs before purchase.

    Of course if you've any good ideas, thoughts or suggestions they would be most welcome - I'm not giving up yet.



    Sample log messages:

    Daemon.Error Oct 9 07:52:59 2006 singapore-router ipf_check_interface:306: WRV54GFW-CONF: Failed ioctl (SIOCADDDV - No such device) on dev 'ips0'

    Daemon.Error Oct 9 07:52:53 2006 singapore-router Vendor buffer is <Vendor information which is to be written to the vendor section and read from it later on. Test information only, change it according to your needs>

    Daemon.Error Jan 1 00:00:04 2003 singapore-router esyscall_et_end:95: fd 5 op 16: failed operation: Invalid argument

    Kernel.Error Jan 1 00:00:01 2003 singapore-router initrd (0xc01b1000 - 0xc01b7000) extends beyond physical memory - disabling initrd

    Daemon.Error Oct 9 07:49:36 2006 singapore-router estream_write_efd:797: socket 8: failed write()
  2. DocLarge

    DocLarge Super Moderator Staff Member Member


    I just posted a snapshot of the status page of one of my remote WRV54G's that's running 2.37.13; it had an uptime of 1008hrs as of this morning. I have two more that have been running 2.37.13 for 20 mos with zero issues.

    At this point, have you considered it might be the unit itself?

  3. kipcole9

    kipcole9 LI Guru Member

    Yes, possibly the unit.. but replacement was DOA

    Which is why I bought a second one yesterday and it was DOA (power light continuous flashing, no http access to the unit, no IP addresses being provided). I tried to RMA today and it will be a week before I can get one from Linksys.

    I will report back after I get that unit and try again.

    What you are getting in uptime is what I expect. And why I'm still trying to get to the bottom of the issue, despite Linksys support deciding not to help or care.

    Cheers, --Kip
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    The majority of Linksys techs have never seen a majority of the units they are there to help with. There's a standard "script" they follow (i.e,. have you turned it on? Is the ethernet cable firmly attached? Did you put the seat back down after you finished????); once your problem deviates from that they either try to get you to go over the script again, or have you RMA the device.

    When you get a new one, post back and we'll go from there :)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice