WRV54G to WRV54G VPN Problem with DSL Modem/Router

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by rplankenhorn, Sep 12, 2007.

  1. rplankenhorn

    rplankenhorn LI Guru Member

    I am completely confused with the problems that I am now having with my WRV54G to WRV54G vpn setup. I purchased both routers at about the same time and have one located at my home and another located at my house at school. I have setup both of these routers before to work flawlessly with the VPN configuration and I was able to ping all of the computers on the remote network. The problem is is that when it worked, I was using a cable internet connection at both locations and now my school house is behind a dsl modem/router. The dsl modem that I have is a HomePortal 1000HW. I have configured the modem to do DMZplus and now my router gets a public ip address instead of one from the DHCP server on the modem.

    Now the problem I am having is that I got both of the routers to show connected at the bottom of the VPN configuration but when I try and ping the remote gateway, it says it is unreachable. I have also tried using the included ping utility on the router webpage but it says the same thing. I have reset the router that I have locally to factory defaults and reconfigured everything and I still have the same problem.

    After doing all of those tests, I have concluded that it is probably the dsl modem at fault since this is the only thing that is different. Are there any configuration changes that I need to make to allow this to work? Any help would be much appreciated.
  2. TazUk

    TazUk Network Guru Member

    You could try reducing the MTU on the WRV54G connected to the DSL modem and see if that helps.
  3. rplankenhorn

    rplankenhorn LI Guru Member

    I thought about that and I retested the MTU from my end with the ping command. I have it set to 1492. If I got any lower then the packet is too fragmented. Thanks for the help though. I still haven't found a solution for this problem.
  4. DocLarge

    DocLarge Super Moderator Staff Member Member

    xDSL and "PPPoE/PPPoA" do "not" play well with the Linksys "ethernet" routers. My WRV54G hasn't worked for "damn" since I came over to London back in '04 because I was using a xDSL connection. Yeah, the vpn would run, but only for a few days before the lease (which was good for only 72hrs on an xDSL connection) dropped and I lost all connectivity to the internet.

    So, yes, I believe the problem is your DSL modem...but it's not hopeless. :)

    The workaround for you is to put your dsl modem in "bridge" mode if you haven't tried this approach already; once you do that, it will act like a dumb modem meaning your WRV54G will have to do all of the work. Don't worry, I've made my WRV54G work like this perfectly! The trick is once you bridge your modem, you now have to set the WRV54G for "PPPoE." Once you've done that, just enter in your username/password combination that your ISP gave you to connect to your dsl modem into the WRV54G fields instead. Once you do a restart, you should be fine...

    I was doing this a Linksys ADSL2MUE as my modem (I bridged it). The only downside was that the little bit of firewall that the 2MUE had was blocking some packets that came through which pretty much made using Quickvpn out of the question :( but the vpn tunnels still worked if I recall.

  5. rplankenhorn

    rplankenhorn LI Guru Member

    Thanks a lot for the reply. I was just talking with SBC today and they told me how to bridge it. I'm glad to hear that it works. I don't plan on using the QuickVPN anyway so it will work for me. I will post my solution if it works.
  6. rplankenhorn

    rplankenhorn LI Guru Member

    More Help or QuickVPN

    I was able to get the WRV54G vpn connection to work after I put the dsl router into bridged mode. Now I have the same problem again because my router reset itself and I didn't make a backup of the config with the PPPoE password stored. My roommate also has no idea what the password is and I don't think I can reset it because it could potentially break other stuff (according to my roommate).

    I would really like to find a solution where the router authenticates but the VPN still works or if I could figure out how to get QuickVPN to work from behind it, that would be great also. I think the reason why I am having problems with QuickVPN has to do with the non bridge mode of the DSL modem. I can connect just fine but when I go to ping the remote gateway, I get "Negotiating Network Security." I have seen this on other posts but it doesn't seem like any of those solutions, if any, pertained to my situation.

    Any help on either of these problems would be great.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice